123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135 |
- %global module_version 0.62
- %global RPM_version %(echo %{module_version} | %{__perl} -pi -e 's/(.*)/sprintf("%.4f", $1)/e')
- Name: perl-Test-Differences
- Version: %{RPM_version}
- Release: 1%{?_dist_release}
- Summary: Test strings and data structures and show differences if not OK
- Group: Development/Libraries
- License: GPL+ or Artistic
- URL: http://search.cpan.org/dist/Test-Differences/
- Source0: http://search.cpan.org/CPAN/authors/id/O/OV/OVID/Test-Differences-%{module_version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildArch: noarch
- BuildRequires: perl(Text::Diff) >= 0.35
- BuildRequires: perl(ExtUtils::MakeMaker)
- BuildRequires: perl(Test::More)
- BuildRequires: perl(Test::Pod)
- BuildRequires: perl(Test::Pod::Coverage)
- BuildRequires: perl(Capture::Tiny)
- Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
- %description
- When the code you're testing returns multiple lines, records or data
- structures and they're just plain wrong, an equivalent to the Unix
- diff utility may be just what's needed.
- %prep
- %setup -q -n Test-Differences-%{module_version}
- %build
- %{__perl} Makefile.PL INSTALLDIRS=vendor
- make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make pure_install PERL_INSTALL_ROOT=%{buildroot}
- find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
- find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
- chmod -R u+w %{buildroot}/*
- %check
- make test
- %clean
- rm -rf %{buildroot}
- %files
- %defattr(-,root,root,-)
- %doc Changes README
- %{perl_vendorlib}/Test/
- %{_mandir}/man3/Test::Differences.3pm*
- %changelog
- * Wed Nov 19 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 0.6200-1
- - updated to 0.62
- - built with perl 5.16.3
- - added BR: perl(Capture::Tiny)
- * Fri Mar 09 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5000-1
- - initial build for Vine Linux
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5000-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.5000-5
- - Perl mass rebuild
- * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5000-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.5000-3
- - 661697 rebuild for fixing problems with vendorach/lib
- * Thu Jul 08 2010 Iain Arnell <iarnell@gmail.com> 0.500-2
- - explicitly require perl(Text::Diff)
- * Tue Jun 29 2010 Paul Howarth <paul@city-fan.org> - 0.5000-1
- - Update to 0.500
- - Add support for all diff styles supplied by Text::Diff (CPAN RT#23579)
- - Add Build.PL
- - Convert to universally use Test::More instead of Test
- - Convert to modern Perl distribution.
- - Applied doc suggestion from CPAN RT#24297
- - Fix the { a => 1 } versus { a => '1' } bug (CPAN RT#3029)
- - Upstream dropped eg/ docs
- - Bump perl(Text::Diff) requirement to 0.35
- - BR: perl(Test::Pod) and perl(Test::Pod::Coverage) for extra test cover
- * Thu May 06 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.4801-5
- - Mass rebuild with perl-5.12.0
- * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.4801-4
- - rebuild against perl 5.10.1
- * Wed Aug 19 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4801-3
- - fix source url
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4801-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.4801-1
- - update to 0.4801
- * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.47-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-4
- - Rebuild for perl 5.10 (again)
- * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-3
- - rebuild for new perl
- * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-2.2
- - add BR: perl(Test::More)
- * Tue Oct 16 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 0.47-2.1
- - correct license tag
- - add BR: perl(ExtUtils::MakeMaker)
- * Sun May 14 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.47-2
- - Bumping release (repodata checksum inconsistency for previous release).
- * Mon May 01 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.47-1
- - First build.
|