123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246 |
- %bcond_with test
- %global gem_name asciidoctor
- %global mandir %{_mandir}/man1
- %define pre %nil
- %global gittag v%{version}%{pre}
- Summary: A fast, open source AsciiDoc implementation in Ruby
- Name: rubygem-%{gem_name}
- Version: 2.0.20
- Release: 1%{?_dist_release}
- Group: publishing
- Vendor: Project Vine
- Distribution: Vine Linux
- License: MIT
- URL: https://asciidoctor.org
- Source0: https://github.com/asciidoctor/asciidoctor/archive/%{gittag}/%{gem_name}-%{version}%{pre}.tar.gz
- BuildArch: noarch
- Requires: ruby(rubygems)
- BuildRequires: ruby-rubygems-devel
- BuildRequires: ruby(rubygems)
- %if %{with test}
- BuildRequires: rubygem(coderay)
- BuildRequires: rubygem(concurrent-ruby)
- BuildRequires: rubygem(erubi)
- BuildRequires: rubygem(haml)
- BuildRequires: rubygem(minitest)
- BuildRequires: rubygem(nokogiri)
- BuildRequires: rubygem(rouge)
- BuildRequires: rubygem(slim)
- BuildRequires: rubygem(tilt)
- %endif
- Provides: asciidoctor = %{version}
- %if 0%{?el6} || 0%{?el7}
- Provides: rubygem(%{gem_name}) = %{version}
- %endif
- %description
- A fast, open source text processor and publishing toolchain, written in Ruby,
- for transforming AsciiDoc markup into HTML 5, DocBook 4.5, DocBook 5.0 and
- custom output formats. The transformation from AsciiDoc to custom output
- formats is performed by running the nodes in the parsed document tree through a
- collection of templates written in a template language supported by Tilt.
- %package doc
- Summary: Documentation for %{name}
- Group: documentation
- Requires: %{name} = %{version}-%{release}
- BuildArch: noarch
- %description doc
- Documentation for %{name}
- %prep
- %autosetup -n %{gem_name}-%{version}%{pre} -p1
- # Include tests in the gem, they're disabled by default
- sed -i -e 's/#\(s\.test_files\)/\1/' %{gem_name}.gemspec
- # Fix shebang (avoid Requires: /usr/bin/env)
- sed -i -e 's|#!/usr/bin/env ruby|#!/usr/bin/ruby|' bin/%{gem_name}
- %build
- gem build %{gem_name}.gemspec
- #gem_install -n %{gem_name}-%{version}%{pre}.gem
- %if %{with test}
- %check
- pushd .%{gem_instdir}
- LANG=C.UTF-8 ruby -I"lib:test" -e 'Dir.glob "./test/**/*_test.rb", &method(:require)'
- popd
- %endif
- %install
- %{__rm} -rf %{buildroot}
- %gem_install -d %{buildroot}
- mkdir -p %{buildroot}%{_bindir}
- cp -a %{buildroot}%{gem_instdir}/bin/* \
- %{buildroot}%{_bindir}/
- mkdir -p %{buildroot}%{mandir}
- cp -a %{buildroot}%{gem_instdir}/man/*.1 \
- %{buildroot}%{mandir}/
- %files
- %{!?_licensedir:%global license %%doc}
- %dir %{gem_instdir}
- %exclude %{gem_cache}
- %exclude %{gem_instdir}/asciidoctor.gemspec
- %exclude %{gem_instdir}/man
- %exclude %{gem_instdir}/test
- %exclude %{gem_instdir}/features
- %license %{gem_instdir}/LICENSE
- %doc %{gem_instdir}/CHANGELOG.adoc
- %doc %{gem_instdir}/README.*
- %lang(de) %doc %{gem_instdir}/README-de.*
- %lang(fr) %doc %{gem_instdir}/README-fr.*
- %lang(ja) %doc %{gem_instdir}/README-jp.*
- %lang(zh_CN) %doc %{gem_instdir}/README-zh_CN.*
- %{gem_instdir}/data
- %{_bindir}/*
- %{gem_instdir}/bin
- %{gem_libdir}
- %{mandir}/*
- %{gem_spec}
- %files doc
- %doc %{gem_docdir}
- %changelog
- * Fri Oct 13 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.0.20-1
- - new upstream release.
- * Thu Jan 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.0.17-1
- - new upstream release.
- * Tue Oct 19 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.0.16-1
- - new upstream release.
- * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.0.12-2
- - initial build for Vine Linux.
- * Wed Jan 27 2021 Pavel Valena <pvalena@redhat.com> - 2.0.12-1
- - Update to asciidoctor 2.0.12.
- Resolves: rhbz#1893940
- * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.10-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
- * Wed Aug 19 2020 Vít Ondruch <vondruch@redhat.com> - 2.0.10-4
- - Replace build time Erubis dependency by Erubi.
- * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.10-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
- * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.10-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
- * Sun Sep 22 2019 Todd Zullinger <tmz@pobox.com> - 2.0.10-1
- - Update to Asciidoctor 2.0.10
- * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.8-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
- * Tue Mar 19 2019 Todd Zullinger <tmz@pobox.com> - 1.5.8-1
- - Update to Asciidoctor 1.5.8 (resolves CVE-2018-18385)
- * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.6.1-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
- * Sun Nov 18 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 1.5.6.1-5
- - Use C.UTF-8 locale
- See https://fedoraproject.org/wiki/Changes/Remove_glibc-langpacks-all_from_buildroot
- * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.6.1-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Wed May 23 2018 Vít Ondruch <vondruch@redhat.com> - 1.5.6.1-3
- - Enable entire test suite.
- * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.6.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Thu Aug 24 2017 Fabio Alessandro Locati <fale@fedoraproject.org> - 1.5.6.1-1
- - Update to Asciidoctor 1.5.6.1
- * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Mon Jun 05 2017 Vít Ondruch <vondruch@redhat.com> - 1.5.5-2
- - Fix FTBFS.
- * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.5-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- * Fri Oct 14 2016 Fabio Alessandro Locati <fale@fedoraproject.org> - 1.5.5-1
- - Update to Asciidoctor 1.5.5
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.4-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Tue Jan 05 2016 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.4-1
- - Update to Asciidoctor 1.5.4 (rhbz#1295758)
- - Use %%license macro
- - Drop unnecessary "-p" flag to cp during %%install ("-a" already preserves
- timestamps)
- * Mon Nov 02 2015 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.3-1
- - Update to Asciidoctor 1.5.3 (rhbz#1276851)
- - Drop Fedora 19 and 20 macros (these distros are EOL)
- * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Fri Dec 05 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.2-1
- - Update to Asciidoctor 1.5.2
- * Fri Sep 19 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.1-1
- - Update to Asciidoctor 1.5.1
- * Tue Sep 09 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-1
- - Update to Asciidoctor 1.5.0 final
- * Fri Jun 06 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-0.4.preview.7
- - Add %%{version} number to Provides: asciidoctor
- * Fri Jun 06 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-0.3.preview.7
- - Provide: asciidoctor
- https://github.com/asciidoctor/rubygem-asciidoctor-rpm/issues/5
- * Tue May 20 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-0.2.preview.7
- - Update to Asciidoctor 0.1.5.preview.7
- - Drop unused patch
- * Thu May 15 2014 Ken Dreyer <ktdreyer@ktdreyer.com> - 1.5.0-0.1.preview.6
- - Update to Asciidoctor 0.1.5.preview.6
- - Use HTTPS URLs
- - Support Minitest 5
- - Adjustments for https://fedoraproject.org/wiki/Changes/Ruby_2.1
- - Mark CHANGELOG, LICENSE, READMEs as %%doc
- - Remove Rakefile in %%prep
- - Remove Requires: /usr/bin/env
- * Sun Sep 22 2013 Dan Allen <dan.j.allen@gmail.com> - 0.1.4-1
- - Update to Asciidoctor 0.1.4
- * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Sat Jun 08 2013 Dan Allen <dan.j.allen@gmail.com> - 0.1.3-1
- - Update to Asciidoctor 0.1.3
- * Fri Mar 01 2013 Dan Allen <dan.j.allen@gmail.com> - 0.1.1-1
- - Initial package
|