rkhunter-vl.spec 16 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404
  1. Name: rkhunter
  2. Summary: A host-based tool to scan for rootkits, backdoors and local exploits
  3. Version: 1.4.6
  4. Release: 3%{?_dist_release}
  5. Group: admin-tools,security
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: GPLv2+
  9. URL: http://rkhunter.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/rkhunter/rkhunter-%{version}.tar.gz
  11. Source2: 01-rkhunter
  12. Source3: rkhunter.sysconfig
  13. Patch0: rkhunter-1.4.6-vineconfig.patch
  14. # libkeyutils is an actual legit library now, so this old check is a false positive.
  15. Patch1: rkhunter-1.4.6-drop-libkeyutils-check.patch
  16. # have ssh checks use the sshd.d directoy config files too.
  17. Patch2: rkhunter-1.4.6-ssh.d.patch
  18. # Fix grep/egrep changes
  19. Patch3: rkhunter-1.4.6-grep.patch
  20. BuildArch: noarch
  21. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  22. Requires: coreutils, binutils, findutils, grep
  23. Requires: e2fsprogs, procps, lsof, iproute, wget
  24. Requires: perl, perl(strict), perl(IO::Socket), mailx, logrotate
  25. Requires: kmod
  26. %description
  27. Rootkit Hunter (RKH) is an easy-to-use tool which checks
  28. computers running UNIX (clones) for the presence of rootkits
  29. and other unwanted tools.
  30. %prep
  31. %autosetup -p1
  32. %{__cat} <<'EOF' >%{name}.logrotate
  33. %{_localstatedir}/log/%{name}/%{name}.log {
  34. weekly
  35. notifempty
  36. create 640 root root
  37. }
  38. EOF
  39. %build
  40. # Nothing to be built
  41. %install
  42. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_bindir}
  43. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_sysconfdir}/{cron.daily,sysconfig,logrotate.d}
  44. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts
  45. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_pkgdocdir}
  46. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_mandir}/man8
  47. %{__mkdir} -m700 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}
  48. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db
  49. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/log/%{name}
  50. %{__mkdir} -m755 -p ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n
  51. %{__install} -m755 -p files/%{name} ${RPM_BUILD_ROOT}%{_bindir}/
  52. %{__install} -m644 -p files/backdoorports.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
  53. %{__install} -m644 -p files/mirrors.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
  54. %{__install} -m644 -p files/programs_bad.dat ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/
  55. %{__install} -m644 -p files/i18n/cn ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n/
  56. %{__install} -m644 -p files/i18n/en ${RPM_BUILD_ROOT}%{_var}/lib/%{name}/db/i18n/
  57. %{__install} -m644 -p files/CHANGELOG ${RPM_BUILD_ROOT}%{_pkgdocdir}
  58. %{__install} -m644 -p files/LICENSE ${RPM_BUILD_ROOT}%{_pkgdocdir}
  59. %{__install} -m644 -p files/README ${RPM_BUILD_ROOT}%{_pkgdocdir}
  60. %{__install} -m755 -p files/check_modules.pl ${RPM_BUILD_ROOT}%{_datadir}/%{name}/scripts/
  61. %{__install} -m644 -p files/*.8 ${RPM_BUILD_ROOT}%{_mandir}/man8/
  62. # Don't ship these unless we want to Require the perl modules
  63. #%{__install} -m750 -p files/filehashmd5.pl ${RPM_BUILD_ROOT}%{_prefix}/lib/%{name}/scripts/
  64. #%{__install} -m750 -p files/filehashsha1.pl ${RPM_BUILD_ROOT}%{_prefix}/lib/%{name}/scripts/
  65. %{__install} -m755 -p %{SOURCE2} ${RPM_BUILD_ROOT}%{_sysconfdir}/cron.daily/%{name}
  66. %{__install} -m644 -p %{name}.logrotate ${RPM_BUILD_ROOT}%{_sysconfdir}/logrotate.d/%{name}
  67. %{__install} -m640 -p files/%{name}.conf ${RPM_BUILD_ROOT}%{_sysconfdir}/
  68. %{__install} -m640 -p %{SOURCE3} ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/%{name}
  69. %clean
  70. %{__rm} -rf $RPM_BUILD_ROOT
  71. %files
  72. %defattr(-,root,root,-)
  73. %doc %{_pkgdocdir}/*
  74. %{_bindir}/%{name}
  75. %dir %{_datadir}/%{name}
  76. %{_datadir}/%{name}/scripts
  77. %{_sysconfdir}/cron.daily/%{name}
  78. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  79. %dir %{_var}/lib/%{name}
  80. %{_var}/lib/%{name}/db
  81. %ghost %{_var}/lib/%{name}/db/mirrors.dat
  82. %ghost %{_var}/lib/%{name}/db/programs_bad.dat
  83. %{_var}/lib/%{name}/db/i18n
  84. %dir %{_var}/log/%{name}
  85. %config(noreplace) %{_sysconfdir}/%{name}.conf
  86. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  87. %{_mandir}/man8/*
  88. %changelog
  89. * Wed Jun 19 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.6-3
  90. - imported Patch3 from rawhide to support grep >= 3.8.
  91. * Wed Mar 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.6-2
  92. - imported Patch1 and 2 from rawhide.
  93. * Mon May 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.6-1
  94. - updated to 1.4.6.
  95. - updated Patch0.
  96. * Wed Nov 12 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.4.2-1
  97. - update to 1.4.2
  98. * Thu Feb 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  99. - initial build for Vine Linux
  100. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-6
  101. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  102. * Sat Oct 06 2012 Kevin Fenzi <kevin@scrye.com> 1.4.0-5
  103. - Add /dev/md/autorebuild.pid to whitelist. Fixes bug #857315
  104. * Sat Aug 18 2012 Kevin Fenzi <kevin@scrye.com> 1.4.0-4
  105. - Add /var/log/pki-ca/system to whitelist for FreeIPA. Fixes bug #849251
  106. * Wed Aug 15 2012 Kevin Fenzi <kevin@scrye.com> 1.4.0-3
  107. - Fix /bin/ad false positive. Fixes bug #831989
  108. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.0-2
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  110. * Tue May 08 2012 Kevin Fenzi <kevin@scrye.com> - 1.4.0-1
  111. - Update to 1.4.0
  112. * Sun Apr 15 2012 Kevin Fenzi <kevin@scrye.com> - 1.3.8-15
  113. - Add workaround for /lib/java false positive. Fixes bug #806972
  114. * Wed Feb 8 2012 Kay Sievers <kay@redhat.com> - 1.3.8-14
  115. - modutils are for Linux 2.4 and no longer provided; depend on kmod
  116. * Fri Jan 27 2012 Kevin Fenzi <kevin@scrye.com> 1.3.8-13
  117. - Drop net-tools, no longer needed. Fixes bug #784803
  118. - Add /dev/shm/spice.* to whitelist. Fixes bug #784882
  119. * Fri Jan 06 2012 Kevin Fenzi <kevin@scrye.com> 1.3.8-12
  120. - Add /etc/.java to whitelist. Fixes bug #770972
  121. * Fri Nov 25 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-11
  122. - Add /usr/share/man/man5/.k5identity.5.gz to whitelisted hidden files.
  123. * Wed Oct 12 2011 Jim Pirzyk <jim+rpm@pirzyk.org> - 1.3.8-10
  124. - Update %files section so that some .dat files are marked %ghost
  125. * Fri Aug 05 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-9
  126. - Add patch to fix ALLOWPROCDELFILE config option. fixes bug #727524
  127. * Fri Jul 08 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-8
  128. - Fix typo
  129. * Fri Jul 08 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-7
  130. - Add patch to fix out of the box warning on rkhunter script.
  131. - Fixes bug #719270
  132. - Add etckeeper and tomboy files. Fixes bug #719265 and #719259
  133. * Tue Jun 21 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-6
  134. - Change ssh check back to 2 - bug #596775
  135. - Drop hard Requires on prelink. It will be used if present - bug #714067
  136. * Thu Apr 21 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-5
  137. - Add /dev/.mount to ALLOW_HIDDENDIR - bug #697599
  138. * Wed Apr 13 2011 Kevin Fenzi <kevin@scrye.com> - 1.3.8-4
  139. - Don't send warning emails anymore. They cause selinux issues and are not very helpful.
  140. - Fixes bug #660544
  141. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.8-3
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  143. * Tue Dec 07 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.8-2
  144. - Adjust config some - bug #596775
  145. * Fri Nov 26 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.8-1
  146. - Update to 1.3.8
  147. * Wed Nov 24 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-9
  148. - Drop /var/run as it's not used anymore - bug #656684
  149. * Wed Oct 06 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-8
  150. - Add patch to make rkhunter use unhide if installed - bug #636396
  151. * Sat Jun 05 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-7
  152. - Add ipsec.hmac exclude - bug #560594
  153. * Fri May 28 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-6
  154. - Add exclude for md-device-map - bug #596731
  155. - Supress ssh version check - bug #596775
  156. * Sat Mar 06 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-5
  157. - Change config to not specify XINETD_PATH - bug #560562
  158. * Sat Jan 23 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-4
  159. - Change email to just root instead of root@localhost - bug #553179
  160. - Add .k5login.5.gz to files whitelist - bug #553134
  161. * Tue Jan 05 2010 Kevin Fenzi <kevin@tummy.com> - 1.3.6-3
  162. - Add some more ssh hmac files to whitelist - bug #552621
  163. - Re-add /dev/.mdadm.map to whitelisted files - bug #539405
  164. * Tue Dec 01 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.6-2
  165. - Disable apps check by default - bug #543065
  166. * Sun Nov 29 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.6-1
  167. - Update to 1.3.6
  168. * Thu Nov 26 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-9
  169. - Add exception for /dev/.mdadm file - bug #539405
  170. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-8
  171. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  172. * Fri Jul 03 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-7
  173. - Add exception for software raid udev file - bug #509253
  174. * Sat Jun 06 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-6
  175. - Add /usr/bin/.fipscheck.hmac to ok files - bug #494096
  176. * Sun Mar 08 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-5
  177. - Fix typo in patch file
  178. * Wed Mar 04 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-4
  179. - Rework spec file
  180. - Add check for the new hmac ssh files
  181. * Thu Feb 26 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-3
  182. - Update cron job to include hostname (thanks Manuel Wolfshant)
  183. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.4-2
  184. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  185. * Fri Jan 02 2009 Kevin Fenzi <kevin@tummy.com> - 1.3.4-1
  186. - Update to 1.3.4
  187. - Use libdir as tmp dir - bug #456340
  188. * Sat Dec 13 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-6
  189. - Fix cron job sending as attachment - bug #472679
  190. - Fix cron job trying to send with colors - bug #475916
  191. * Wed Sep 03 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-5
  192. - Patch debug tmp file issue - bug #460628
  193. * Mon Jun 16 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-4
  194. - Fix cron script to only mail on warn/error - bug #450703
  195. - Fix conditional to account for fc10 rsyslog
  196. * Mon Apr 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-3
  197. - Change cron to run after prelink - bug #438622
  198. * Wed Mar 26 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-2
  199. - Move things to more standard locations for selinux - bug #438184
  200. - Add exception for pulseaudio file - bug #438622
  201. * Thu Feb 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.2-1
  202. - Update to 1.3.2
  203. - Fix cron script
  204. * Thu Feb 28 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.0-2
  205. - Use /etc/redhat-release for EPEL and /etc/fedora release for Fedora.
  206. - Add conditionals to support EPEL
  207. - Fix man page warning.
  208. * Sun Feb 03 2008 Kevin Fenzi <kevin@tummy.com> - 1.3.0-1
  209. - Revive package, clean up spec
  210. - Update to 1.3.0
  211. * Sat Mar 18 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-3
  212. - Made an RPM transparent change to move the sha1 canary check
  213. file out of CVS and into the external lookaside cache (whose
  214. filename changes with every new package release anyway...)
  215. * Fri Mar 17 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-2
  216. - Fixed architectural dependency during package creation eliminating
  217. use of _libdir configure macro (x86_64 /usr/lib64 mis-targeting)
  218. * Tue Mar 7 2006 Greg Houlette <tamaster@pobox.com> - 1.2.8-1
  219. - New package version release
  220. - reworked the .spec file to support optional dist tag
  221. - Updated the application check default patchfile (chunk failure)
  222. - Changed to SHA1 for optional message digest (canary check)
  223. - Added a couple of suggested skip entries to rkhunter.conf
  224. * Sat Jun 11 2005 Greg Houlette <tamaster@pobox.com> - 1.2.7-1
  225. - Added signature auto-updating to CRON scan (new script)
  226. - Removed BOOTSCAN pending rewrite to full SysV Init scan in background
  227. - Added the --append-log command line option
  228. - Added Date Stamping to output
  229. - Fixed bug in /etc/group missing report
  230. - New package version release
  231. * Sun Jan 2 2005 Greg Houlette <tamaster@tekarmory.com> - 0:1.1.9-1
  232. - New package version release
  233. - Added the --run-application-check command line option
  234. to listing in command help
  235. - Replaced 'Here' Doc editing of rkhunter.conf file
  236. with in-place Perl edit
  237. - tweaked rpmbuild -bb Autoclean
  238. * Fri Oct 15 2004 Greg Houlette - 0:1.1.8-0.fdr.1 (revisited)
  239. - Removed redundant buildrequires /bin/sh, coreutils and perl
  240. - Revise postun scriptlet
  241. - Added /usr/share/doc/rkhunter-1.1.8/ to files list
  242. * Mon Oct 11 2004 Greg Houlette - 0:1.1.8-0.fdr.1
  243. - Changed Release Tag to 0.fdr.1 (testing) for QA
  244. - Removed wget from dependencies
  245. - Hid (temporarily) the --skip-application-check command
  246. line option from being listed in help
  247. - Fixed the spec files list, again!
  248. * Fri Oct 8 2004 Greg Houlette - 0:1.1.8-0.fdr.0.2.beta2
  249. - Unified and disabled the md5 canary check in prep
  250. (check is now optional) removing the sha1 cross-check
  251. - Fixed the spec files list, adding the /var/rkhunter
  252. directory and the /usr/bin/rkhunter executable
  253. - Fixed missing dependencies (rkh uses runtime checks)
  254. - Disabled "auto-clean" for rpmbuild -bb
  255. - Changed Application version scan default to
  256. disabled awaiting backport fix in upstream sources
  257. - Fixed shared_man_search.patch, configuration files
  258. verify and added postun(install) cleanup
  259. * Fri Oct 1 2004 Greg Houlette - 0:1.1.8-0.fdr.0.1.beta1
  260. - More cosmetic patchwork
  261. - Changed Release Tag to beta1 (pre-release) for QA submit
  262. * Tue Sep 28 2004 Greg Houlette - 0:1.1.8-0.fdr.1
  263. - Removed hidden_search.patch (1.1.7) after it was
  264. merged into upstream source by Michael Boelen
  265. - Removed .spec file from md5 and sha1 file checks
  266. (it must be modifiable by Fedora QA release build)
  267. - Added BOOTSCAN description file to documentation
  268. - Restructured dynamic file creation ('Here' Docs)
  269. moving them to the "prep" stage so that *_ALL_*
  270. files are available prior to the "build" stage
  271. (for inspection purposes)
  272. - Added a /etc/sysconfig/rkhunter parameters file
  273. * Sun Aug 29 2004 Greg Houlette - 0:1.1.7-0.fdr.1
  274. - Cosmetic patchwork
  275. * Sat Aug 21 2004 Greg Houlette - 0:1.1.6-0.fdr.1
  276. - Moderate reworking of .spec file for packaging standards
  277. - Added md5 and sha1 file checks to prep procedure for source .rpm
  278. - Included an optional rc.local replacement for scan on boot (with full logging)
  279. * Tue Aug 10 2004 Michael Boelen - 1.1.5
  280. - Added update script
  281. - Extended description
  282. * Sun Aug 08 2004 Greg Houlette - 1.1.5
  283. - Changed the install procedure eliminating the specification of
  284. destination filenames (only needed if you are renaming during install)
  285. - Changed the permissions for documentation files (root only overkill)
  286. - Added the installation of the rkhunter Man Page
  287. - Added the installation of the programs_{bad, good}.dat database files
  288. - Added the installation of the LICENSE documentation file
  289. - Added the chmod for root only to the /var/rkhunter/db directory
  290. * Sun May 23 2004 Craig Orsinger (cjo) <cjorsinger@earthlink.net>
  291. - version 1.1.0-1.cjo
  292. - changed installation in accordance with new rootkit installation
  293. procedure
  294. - changed installation root to conform to LSB. Use standard macros.
  295. - added recursive remove of old build root as prep for install phase
  296. * Wed Apr 28 2004 Doncho N. Gunchev - 1.0.9-0.mr700
  297. - dropped Requires: perl - rkhunter works without it
  298. - dropped the bash alignpatch (check the source or contact me)
  299. - various file mode fixes (.../tmp/, *.db)
  300. - optimized the %%files section - any new files in the
  301. current dirs will be fine - just %%{__install} them.
  302. * Mon Apr 26 2004 Michael Boelen - 1.0.8-0
  303. - Fixed missing md5blacklist.dat
  304. * Mon Apr 19 2004 Doncho N. Gunchev - 1.0.6-1.mr700
  305. - added missing /usr/local/rkhunter/db/md5blacklist.dat
  306. - patched to align results in --cronjob, I think rpm based
  307. distros have symlink /bin/sh -> /bin/bash
  308. - added --with/--without alignpatch for conditional builds
  309. (in case previous patch breaks something)
  310. * Sat Apr 03 2004 Michael Boelen / Joe Klemmer - 1.0.6-0
  311. - Update to 1.0.6
  312. * Mon Mar 29 2004 Doncho N. Gunchev - 1.0.0-0
  313. - initial .spec file