readline-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369
  1. Summary: A library for editing typed in command lines.
  2. Summary(ja): Readline ライブラリ
  3. Name: readline
  4. Version: 8.2.10
  5. %global shortver %(echo %{version} | cut -d . -f 1-2)
  6. %global shortver_nodots %(echo %{shortver} | tr -d ".")
  7. Release: 1%{?_dist_release}
  8. Group: system
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv3+
  12. URL: https://tiswww.case.edu/php/chet/readline/rltop.html
  13. %global baseurl https://ftp.gnu.org/gnu/readline
  14. Source: %{baseurl}/readline-%{shortver}.tar.gz
  15. # upstream patches
  16. Patch1: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-001
  17. Patch2: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-002
  18. Patch3: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-003
  19. Patch4: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-004
  20. Patch5: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-005
  21. Patch6: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-006
  22. Patch7: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-007
  23. Patch8: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-008
  24. Patch9: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-009
  25. Patch10: %{baseurl}/readline-%{shortver}-patches/readline%{shortver_nodots}-010
  26. # fix file permissions, remove RPATH, use CFLAGS
  27. Patch100: readline-8.0-shlib.patch
  28. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root
  29. BuildRequires: sed
  30. BuildRequires: ncurses-devel
  31. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  32. %if %{build_compat32}
  33. %global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
  34. %endif
  35. %description
  36. The Readline library provides a set of functions that allow users to
  37. edit command lines. Both Emacs and vi editing modes are available. The
  38. Readline library includes additional functions for maintaining a list
  39. of previously-entered command lines for recalling or editing those
  40. lines, and for performing csh-like history expansion on previous
  41. commands.
  42. %description -l ja
  43. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  44. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  45. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  46. %package devel
  47. Summary: Files needed to develop programs which use the readline library.
  48. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  49. Group: programming
  50. Requires: readline = %{version}
  51. Requires: ncurses-devel
  52. %if %{build_compat32}
  53. Provides: pkgconfig(readline) = %{version}-%{release}
  54. %endif
  55. %description devel
  56. The Readline library provides a set of functions that allow users to
  57. edit typed command lines. If you want to develop programs that will
  58. use the readline library, you need to have the readline-devel package
  59. installed. You also need to have the readline package installed.
  60. %package -n compat32-%{name}
  61. Summary: A library for editing typed in command lines.
  62. Summary(ja): Readline ライブラリ
  63. Group: system,legacy
  64. Requires: %{name} = %{version}-%{release}
  65. %description -n compat32-%{name}
  66. The Readline library provides a set of functions that allow users to
  67. edit command lines. Both Emacs and vi editing modes are available. The
  68. Readline library includes additional functions for maintaining a list
  69. of previously-entered command lines for recalling or editing those
  70. lines, and for performing csh-like history expansion on previous
  71. commands.
  72. %description -n compat32-%{name} -l ja
  73. Readline ライブラリは、ユーザーがコマンドラインを編集する機能を提供します。
  74. Emacs と vi の編集モードが利用可能です。Readline ライブラリはさらに、
  75. これまで入力されたコマンドライン履歴を保持し、再利用する機能も備えています。
  76. %package -n compat32-%{name}-devel
  77. Summary: Files needed to develop programs which use the readline library.
  78. Summary(ja): Readline ライブラリを使うプログラムための開発用ライブラリ
  79. Group: programming,legacy
  80. Requires: %{name} = %{version}-%{release}
  81. Requires: %{name}-devel = %{version}-%{release}
  82. Requires: compat32-ncurses-devel
  83. %description -n compat32-%{name}-devel
  84. The Readline library provides a set of functions that allow users to
  85. edit typed command lines. If you want to develop programs that will
  86. use the readline library, you need to have the readline-devel package
  87. installed. You also need to have the readline package installed.
  88. %debug_package
  89. %prep
  90. %setup -q -n %{name}-%{shortver}
  91. %autopatch -p0 -m0 -M99
  92. %autopatch -p1 -m100
  93. %build
  94. %configure --with-curses --disable-install-examples
  95. make %{?_smp_mflags}
  96. %install
  97. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  98. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  99. make DESTDIR=$RPM_BUILD_ROOT install
  100. mkdir $RPM_BUILD_ROOT/%{_lib}
  101. mv $RPM_BUILD_ROOT%{_libdir}/libreadline.so.* $RPM_BUILD_ROOT/%{_lib}
  102. for l in $RPM_BUILD_ROOT%{_libdir}/libreadline.so; do
  103. ln -sf $(echo %{_libdir} | \
  104. sed 's,\(^/\|\)[^/][^/]*,..,g')/%{_lib}/$(readlink $l) $l
  105. done
  106. rm -rf $RPM_BUILD_ROOT%{_docdir}/readline
  107. rm -rf $RPM_BUILD_ROOT%{_datadir}/readline
  108. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  109. %clean
  110. [ "${RPM_BUILD_ROOT}" != "/" ] && %__rm -rf ${RPM_BUILD_ROOT}
  111. %files
  112. %defattr(-,root,root)
  113. %license COPYING
  114. %doc CHANGES NEWS README USAGE
  115. /%{_lib}/libreadline*.so.*
  116. %{_libdir}/libhistory*.so.*
  117. %{_infodir}/history.info*
  118. %{_infodir}/rluserman.info*
  119. %files devel
  120. %defattr(-,root,root)
  121. %doc examples/*.c examples/*.h examples/rlfe
  122. %{_includedir}/readline
  123. %{_libdir}/lib*.a
  124. %{_libdir}/lib*.so
  125. %{_libdir}/pkgconfig/*.pc
  126. %{_infodir}/readline.info*
  127. %{_mandir}/man*/*
  128. %if %{build_compat32}
  129. %files -n compat32-%{name}
  130. %defattr(-,root,root)
  131. /%{_lib}/libreadline*.so.*
  132. %{_libdir}/libhistory*.so.*
  133. %files -n compat32-%{name}-devel
  134. %defattr(-,root,root)
  135. %{_libdir}/lib*.a
  136. %{_libdir}/lib*.so
  137. %{_libdir}/pkgconfig/*.pc
  138. %endif
  139. %changelog
  140. * Mon Jun 17 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.10-1
  141. - new upstream release.
  142. * Fri Nov 18 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-2
  143. - droped "Provides:pkgconfig(readline)" from compat32.
  144. * Sun Nov 06 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.1-1
  145. - new upstream release.
  146. - updated to patchlevel 001.
  147. * Fri Jan 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1.2-1
  148. - updated to patchlevel 002.
  149. * Fri May 07 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1.1-1
  150. - updated to patchlevel 001.
  151. - dropped ldconfig scriptlets.
  152. * Thu Feb 25 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.1-1
  153. - new upstream release.
  154. - dropped Patch1-4.
  155. * Sat Sep 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0.4-1
  156. - updated to patchlevel 004.
  157. * Fri Aug 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0-1
  158. - new upstream release.
  159. - dropped all of official patches.
  160. - added Patch1.
  161. - dropped Patch9.
  162. - updated Patch10.
  163. * Sat Mar 21 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 6.3-1
  164. - new upstream release
  165. - update upstream patches (patch1-8)
  166. * Fri Dec 27 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.2-5
  167. - rebuild with VineSeed environment
  168. * Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 5.2-4
  169. - add upstream patches 13,14 (Patch13,14)
  170. * Fri Mar 5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.2-3
  171. - rebuilt with new toolchain
  172. - add Requires(post,pre): /sbin/ldconfig
  173. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2-2vl5
  174. - build with ncurses-devel
  175. - spec in utf8
  176. - move libncurses.so.* to %%_lib from %%_libdir
  177. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-1vl5
  178. - added upstream patches (patch8-12)
  179. * Fri Oct 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2-0vl1
  180. - new upstream release
  181. - update upstream patches (patch1-7)
  182. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 5.1-0vl1
  183. - new upstream release
  184. - update upstream patches (patch1-4)
  185. - add doc/*.{html,pdf} instead of doc/
  186. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.3-5vl3
  187. - s/Copyright/License/
  188. - add URL
  189. - update source URL
  190. - add PreReq: ldconfig
  191. - move outdated.patch (patch1) to patch10
  192. - add upstream patches (patch1-5)
  193. - add no_rpath.patch (patch11)
  194. * Fri Oct 28 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 4.3-5vl2
  195. - added compat32- packages for x86_64 architecture support
  196. - fixed %files section (TODO* has been removed)
  197. * Sat Mar 8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 4.3-5vl1
  198. - new upstream release 4.3
  199. - merged with rawhide package.
  200. * Wed Nov 20 2002 Tim Powers <timp@redhat.com>
  201. - rebuild in current collinst
  202. - BuildRequires autoconf only
  203. * Wed Aug 07 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-3
  204. - Fixed Esc-O-M stack overflow bug.
  205. * Mon Jul 22 2002 Phil Knirsch <pknirsch@redhat.com> 4.3-1
  206. - Updated to latest readline release 4.3
  207. * Thu Jul 11 2002 Phil Knirsch <pknirsch@redhat.com> 4.2a-7
  208. - Fixed problem with alpha build.
  209. * Wed Jul 10 2002 Phil Knirsch <pknirsch@redhat.com>
  210. - Fixed utf8 problem (originally observed in bash).
  211. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 4.2a-6
  212. - automated rebuild
  213. * Thu May 23 2002 Tim Powers <timp@redhat.com> 4.2a-5
  214. - automated rebuild
  215. * Wed Mar 20 2002 Trond Eivind Glomsrod <teg@redhat.com> 4.2a-4
  216. - Use autoconf 2.53, not 2.52
  217. * Mon Mar 4 2002 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-3
  218. - Rebuild
  219. * Mon Nov 26 2001 Matt Wilson <msw@redhat.com> 4.2a-2
  220. - removed the manual symlinking of .so, readline handles this by itself
  221. - call only %%makeinstall, not %%makeinstall install install-shared as
  222. this makes bogus .old files in the buildroot
  223. * Tue Nov 20 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2a-1
  224. - 4.2a
  225. * Tue Oct 2 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-4
  226. - Work around autoconf bug
  227. * Mon Oct 1 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-3
  228. - Don't use readline's internal re-implementation of strpbrk on systems
  229. that have strpbrk - the system implementation is faster and better maintained.
  230. * Tue Aug 7 2001 Bernhard Rosenkraenzer <bero@redhat.com> 4.2-2
  231. - Make sure headers can be included from C++ applications (#51131)
  232. (Patch based on Debian's with the bugs removed ;) )
  233. * Wed May 09 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  234. - update to 4.2 and adapt patches
  235. * Fri Apr 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  236. - change the paths listed for the header files in the man page to reflect
  237. the location changes from previous versions (#35073)
  238. - note that "on" is acceptable instead of "On" in the man page (#21327)
  239. * Thu Mar 8 2001 Preston Brown <pbrown@redhat.com>
  240. - fix reading of end key termcap value (@7 is correct, was kH) (#30884)
  241. * Tue Jan 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  242. - mark the man page as currently out-of-date (#25294)
  243. * Tue Sep 4 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl5
  244. - remove texi2dvi and texi2html from doc/
  245. * Fri Jun 29 2001 Jun Nishii <jun@vinelinux.org> 4.1-6vl4
  246. - added doc and examples
  247. * Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  248. - 4.1-6vl3
  249. - rebuilt for VineSeed
  250. * Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  251. - 4.1-6vl2
  252. - Oops, spec was written in SJIS...
  253. * Sat Dec 9 2000 Jun Nishii <jun@vinelinux.org>
  254. - 4.1-6vl1
  255. - got i18n patch from Kondara
  256. * Thu Sep 7 2000 Jeff Johnson <jbj@redhat.com>
  257. - FHS packaging (64bit systems need to use libdir).
  258. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  259. - summaries from specspo.
  260. * Wed Aug 2 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  261. - use "rm -f" in specfile
  262. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  263. - automatic rebuild
  264. * Mon Jun 5 2000 Jeff Johnson <jbj@redhat.com>
  265. - FHS packaging.
  266. * Tue Mar 21 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  267. - 4.1
  268. * Thu Feb 03 2000 Nalin Dahyabhai <nalin@redhat.com>
  269. - update to 4.0
  270. * Fri Apr 09 1999 Michael K. Johnson <johnsonm@redhat.com>
  271. - added guard patch from Taneli Huuskonen <huuskone@cc.helsinki.fi>
  272. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  273. - auto rebuild in the new build environment (release 4)
  274. * Sun Jul 26 1998 Jeff Johnson <jbj@redhat.com>
  275. - updated to 2.2.1
  276. * Wed May 06 1998 Prospector System <bugs@redhat.com>
  277. - translations modified for de, fr, tr
  278. * Wed May 06 1998 Cristian Gafton <gafton@redhat.com>
  279. - don't package /usr/info/dir
  280. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  281. - devel package moved to Development/Libraries
  282. * Tue Apr 21 1998 Cristian Gafton <gafton@redhat.com>
  283. - updated to 2.2
  284. * Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
  285. - spec file cleanups
  286. * Fri Oct 10 1997 Erik Troan <ewt@redhat.com>
  287. - added proper sonames
  288. * Tue Jul 08 1997 Erik Troan <ewt@redhat.com>
  289. - updated to readline 2.1
  290. * Tue Jun 03 1997 Erik Troan <ewt@redhat.com>
  291. - built against glibc