libnma-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190
  1. %bcond_with libnma_gtk4
  2. %global gtk3_version %(pkg-config --modversion gtk+-3.0 2>/dev/null || echo bad)
  3. %global gtk4_version %(pkg-config --modversion gtk4 2>/dev/null || echo bad)
  4. %global glib2_version %(pkg-config --modversion glib-2.0 2>/dev/null || echo bad)
  5. %global nm_version 1.10.0
  6. %global mbp_version 0.20190618
  7. %global old_libnma_version 1.8.27
  8. Name: libnma
  9. Summary: NetworkManager GUI library
  10. Version: 1.8.32
  11. Release: 1%{?_dist_release}
  12. Group: system
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. # The entire source code is GPLv2+ except some files in shared/ which are LGPLv2+
  16. License: GPLv2+ and LGPLv2+
  17. URL: https://gitlab.gnome.org/GNOME/libnma/
  18. %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
  19. Source0: https://download.gnome.org/sources/%{name}/%{shortver}/%{name}-%{version}.tar.xz
  20. Patch1: 0001-nm-applet-no-notifications.patch
  21. Requires: mobile-broadband-provider-info >= %{mbp_version}
  22. Conflicts: libnma < %{old_libnma_version}
  23. BuildRequires: gcc
  24. BuildRequires: NetworkManager-libnm-devel >= %{nm_version}
  25. BuildRequires: ModemManager-glib-devel >= 1.0
  26. BuildRequires: glib2-devel >= 2.32
  27. BuildRequires: gtk3-devel >= 3.10
  28. %if %{with libnma_gtk4}
  29. BuildRequires: gtk4-devel >= 3.96
  30. %endif
  31. BuildRequires: gobject-introspection-devel >= 0.10.3
  32. BuildRequires: gettext-devel
  33. BuildRequires: pkgconfig
  34. BuildRequires: meson
  35. BuildRequires: gtk-doc
  36. BuildRequires: iso-codes
  37. BuildRequires: gcr-devel
  38. BuildRequires: mobile-broadband-provider-info-devel >= %{mbp_version}
  39. %description
  40. This package contains the library used for integrating GUI tools with
  41. NetworkManager.
  42. %package devel
  43. Summary: Header files for NetworkManager GUI library
  44. Group: programming
  45. Requires: NetworkManager-libnm-devel >= %{nm_version}
  46. Obsoletes: NetworkManager-gtk-devel < 1.8.22
  47. Requires: libnma%{?_isa} = %{version}-%{release}
  48. Requires: gtk3-devel%{?_isa}
  49. Requires: pkgconfig
  50. Conflicts: libnma < %{old_libnma_version}
  51. %description devel
  52. This package contains header and pkg-config files to be used for integrating
  53. GUI tools with NetworkManager.
  54. %if %{with libnma_gtk4}
  55. %package gtk4
  56. Summary: Experimental GTK 4 version of NetworkManager GUI library
  57. Group: system
  58. Requires: gtk4%{?_isa} >= %{gtk4_version}
  59. Requires: mobile-broadband-provider-info >= %{mbp_version}
  60. Conflicts: libnma < %{old_libnma_version}
  61. %description gtk4
  62. This package contains the experimental GTK4 version of library used for
  63. integrating GUI tools with NetworkManager.
  64. %package gtk4-devel
  65. Summary: Header files for experimental GTK4 version of NetworkManager GUI library
  66. Group: programming
  67. Requires: NetworkManager-libnm-devel >= %{nm_version}
  68. Requires: libnma-gtk4%{?_isa} = %{version}-%{release}
  69. Requires: gtk4-devel%{?_isa}
  70. Requires: pkgconfig
  71. Conflicts: libnma < %{old_libnma_version}
  72. %description gtk4-devel
  73. This package contains the experimental GTK4 version of header and pkg-config
  74. files to be used for integrating GUI tools with NetworkManager.
  75. %endif
  76. %debug_package
  77. %prep
  78. %autosetup -p1 -n "%{name}-%{version}"
  79. %build
  80. %meson \
  81. -Dgcr=true \
  82. -Ddisable-static=true \
  83. -Dvapi=false \
  84. %if %{with libnma_gtk4}
  85. -Dlibnma_gtk4=true
  86. %else
  87. -Dlibnma_gtk4=false
  88. %endif
  89. %meson_build
  90. %install
  91. %meson_install
  92. %find_lang %{name}
  93. %check
  94. %meson_test
  95. %files -f %{name}.lang
  96. %{_libdir}/libnma.so.*
  97. %{_libdir}/girepository-1.0/NMA-1.0.typelib
  98. %{_datadir}/glib-2.0/schemas/org.gnome.nm-applet.gschema.xml
  99. %doc NEWS CONTRIBUTING
  100. %license COPYING
  101. %files devel
  102. %{_includedir}/libnma
  103. %{_libdir}/pkgconfig/libnma.pc
  104. %{_libdir}/libnma.so
  105. %{_datadir}/gir-1.0/NMA-1.0.gir
  106. %{_datadir}/gtk-doc
  107. %if %{with libnma_gtk4}
  108. %files gtk4
  109. %{_libdir}/libnma-gtk4.so.*
  110. %{_libdir}/girepository-1.0/NMA4-1.0.typelib
  111. %license COPYING
  112. %files gtk4-devel
  113. %{_includedir}/libnma
  114. %{_libdir}/pkgconfig/libnma-gtk4.pc
  115. %{_libdir}/libnma-gtk4.so
  116. %{_datadir}/gir-1.0/NMA4-1.0.gir
  117. %endif
  118. %changelog
  119. * Fri Aug 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.8.32-1
  120. - new upstream release.
  121. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.8.30-2
  122. - initial build for Vine Linux.
  123. * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.30-1.2
  124. - Second attempt - Rebuilt for
  125. https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  126. * Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.30-1.1
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  128. * Thu Jul 9 2020 Jérôme Parmentier <jerome@prmntr.me> - 1.8.30-1
  129. - Update to 1.8.30 release
  130. * Fri Mar 6 2020 Thomas Haller <thaller@redhat.com> - 1.8.28-1
  131. - Update to 1.8.28 release
  132. - move org.gnome.nm-applet.gschema.xml from network-manager-applet to here.
  133. - introduce wireless security dialogs
  134. * Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.8.26-4
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  136. * Thu Nov 14 2019 Lubomir Rintel <lkundrak@v3.sk> - 1.8.26-3
  137. - Clarify licensing
  138. - Add a missing mobile-broadband-provider-info provide
  139. * Fri Nov 08 2019 Lubomir Rintel <lkundrak@v3.sk> - 1.8.26-2
  140. - Fixes suggested in review by Matthew Krupcale (#1763285):
  141. - Add gcc BR
  142. - Fixed the libnma-gtk4 conditional
  143. - Made dependencies arch-specific where relevant
  144. - Dropped obsolete macros
  145. - Install license file with libnma-gtk4
  146. * Fri Oct 18 2019 Lubomir Rintel <lkundrak@v3.sk> - 1.8.26-1
  147. - Initial package split from nm-connection-editor