libmemcached-awesome-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. %bcond_with tests
  2. Name: libmemcached-awesome
  3. Summary: Client library and command line tools for memcached server
  4. Version: 1.1.4
  5. Release: 1%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: BSD
  10. URL: https://github.com/awesomized/libmemcached
  11. Source0: https://github.com/awesomized/libmemcached/archive/refs/tags/%{version}.tar.gz#/libmemcached-%{version}.tar.gz
  12. BuildRequires: bison
  13. BuildRequires: cmake
  14. BuildRequires: cyrus-sasl-devel
  15. BuildRequires: flex
  16. BuildRequires: libevent-devel
  17. BuildRequires: openssl-devel
  18. BuildRequires: python3-sphinx
  19. %if %{with tests}
  20. BuildRequires: memcached
  21. %endif
  22. Obsoletes: libmemcached < 1.0.19
  23. Provides: libmemcached = %{version}-%{release}
  24. Provides: libmemcached%{?_isa} = %{version}-%{release}
  25. %description
  26. libmemcached is a C/C++ client library and tools for the memcached server
  27. (http://memcached.org/). It has been designed to be light on memory
  28. usage, and provide full access to server side methods.
  29. It also implements several command line tools:
  30. memcapable Checking a Memcached server capibilities and compatibility
  31. memcat Copy the value of a key to standard output
  32. memcp Copy data to a server
  33. memdump Dumping your server
  34. memerror Translate an error code to a string
  35. memexist Check for the existance of a key
  36. memflush Flush the contents of your servers
  37. memparse Parse an option string
  38. memping Test to see if a server is available.
  39. memrm Remove a key(s) from the server
  40. memslap Generate testing loads on a memcached cluster
  41. memstat Dump the stats of your servers to standard output
  42. memtouch Touches a key
  43. %package devel
  44. Summary: Header files and development libraries for %{name}
  45. Group: programming
  46. Requires: %{name}%{?_isa} = %{version}-%{release}
  47. Requires: pkgconfig
  48. Requires: cyrus-sasl-devel%{?_isa}
  49. Obsoletes:libmemcached-devel < 1.0.19
  50. Provides: libmemcached-devel = %{version}-%{release}
  51. Provides: libmemcached-devel%{?_isa} = %{version}-%{release}
  52. %description devel
  53. This package contains the header files and development libraries
  54. for %{name}. If you like to develop programs using %{name},
  55. you will need to install %{name}-devel.
  56. %debug_package
  57. %prep
  58. %setup -q -n libmemcached-%{version}
  59. # drop test hanging in mock
  60. # and requiring some memcached build options
  61. rm test/tests/memcached/sasl.cpp
  62. rm test/tests/memcached/regression/lp_001-630-615.cpp
  63. # temporarily ignore with erratic failure
  64. rm test/tests/memcached/udp.cpp
  65. %build
  66. %cmake \
  67. %if %{with tests}
  68. -DBUILD_TESTING:BOOL=ON \
  69. %endif
  70. -DBUILD_DOCS_MAN:BOOL=ON \
  71. -DBUILD_DOCS_MANGZ:BOOL=OFF \
  72. -DENABLE_SASL:BOOL=ON \
  73. -DENABLE_DTRACE:BOOL=ON \
  74. -DENABLE_OPENSSL_CRYPTO:BOOL=ON \
  75. -DENABLE_HASH_HSIEH:BOOL=ON \
  76. -DENABLE_HASH_FNV64:BOOL=ON \
  77. -DENABLE_HASH_MURMUR:BOOL=ON \
  78. -DENABLE_MEMASLAP:BOOL=ON
  79. %cmake_build
  80. %install
  81. %cmake_install
  82. mv %{buildroot}%{_datadir}/%{name}/example.cnf support
  83. rm -r %{buildroot}%{_datadir}/doc/%{name}/
  84. %if %{with tests}
  85. %check
  86. %ctest
  87. %endif
  88. %clean
  89. rm -rf %{buildroot}
  90. %files
  91. %license LICENSE
  92. %doc AUTHORS *.md
  93. %{_bindir}/mem*
  94. %{_libdir}/lib*.so.*
  95. %{_mandir}/man1/mem*
  96. %exclude %{_libdir}/libp9y.a
  97. %files devel
  98. %doc example
  99. %doc support/example.cnf
  100. %{_datadir}/aclocal/ax_libmemcached.m4
  101. %{_includedir}/*
  102. %{_libdir}/lib*.so
  103. %dir %{_libdir}/pkgconfig
  104. %{_libdir}/pkgconfig/libmemcached.pc
  105. %dir %{_libdir}/cmake
  106. %{_libdir}/cmake/%{name}
  107. %exclude %{_libdir}/cmake/%{name}/p9y*
  108. %{_mandir}/man3/libmemcached*
  109. %{_mandir}/man3/libhashkit*
  110. %{_mandir}/man3/memcached*
  111. %{_mandir}/man3/hashkit*
  112. %changelog
  113. * Wed Mar 15 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.4-1
  114. - new upstream release.
  115. * Sat Dec 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.1-1
  116. - initial build.