libdb-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define __soversion_major 5
  3. %define __soversion %{__soversion_major}.3
  4. %define __tclversion 8.6
  5. %bcond_with java
  6. Summary: The Berkeley DB database library for C
  7. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  8. Name: libdb
  9. Version: 5.3.28
  10. Release: 13%{?_dist_release}
  11. Group: system
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. URL: http://www.oracle.com/database/berkeley-db/
  15. License: BSD and LGPLv2 and Sleepycat
  16. Source0: http://download.oracle.com/berkeley-db/db-%{version}.tar.gz
  17. Source1: http://download.oracle.com/berkeley-db/db.1.85.tar.gz
  18. # For mt19937db.c
  19. Source2: http://www.gnu.org/licenses/lgpl-2.1.txt
  20. Patch0: libdb-multiarch.patch
  21. # db-1.85 upstream patches
  22. Patch10: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.1
  23. Patch11: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.2
  24. Patch12: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.3
  25. Patch13: http://www.oracle.com/technology/products/berkeley-db/db/update/1.85/patch.1.4
  26. # other patches
  27. Patch20: db-1.85-errno.patch
  28. Patch22: db-4.6.21-1.85-compat.patch
  29. Patch24: db-4.5.20-jni-include-dir.patch
  30. # License clarification patch
  31. # http://devel.trisquel.info/gitweb/?p=package-helpers.git;a=blob;f=helpers/DATA/db4.8/007-mt19937db.c_license.patch;h=1036db4d337ce4c60984380b89afcaa63b2ef88f;hb=df48d40d3544088338759e8bea2e7f832a564d48
  32. Patch25: 007-mt19937db.c_license.patch
  33. #Adds missing constant to Optcodes.java and changes ClassReader.java to use it. This makes package to build with Java 8.
  34. Patch26: java8-fix.patch
  35. # memp_stat fix provided by upstream (rhbz#1211871)
  36. Patch27: db-5.3.21-memp_stat-upstream-fix.patch
  37. # fix for mutexes not being released provided by upstream (rhbz#1277887)
  38. Patch28: db-5.3.21-mutex_leak.patch
  39. # fix for overflowing hash variable inside bundled lemon
  40. Patch29: db-5.3.28-lemon_hash.patch
  41. # upstream patch adding the ability to recreate libdb's environment on version mismatch
  42. # or when libpthread.so is modified (rhbz#1394862)
  43. Patch30: db-5.3.28-condition_variable.patch
  44. # additional changes to the upstream patch to address rhbz#1460003
  45. Patch31: db-5.3.28-condition-variable-ppc.patch
  46. # downstream patch that adds a check for rpm transaction lock in order to be able to update libdb
  47. # FIXME: remove when able
  48. Patch32: db-5.3.28-rpm-lock-check.patch
  49. # downstream patch to hotfix rhbz#1464033, sent upstream
  50. Patch33: db-5.3.28-cwd-db_config.patch
  51. Patch34: libdb-5.3.21-region-size-check.patch
  52. # Patch sent upstream
  53. Patch35: checkpoint-opd-deadlock.patch
  54. Patch36: db-5.3.28-atomic_compare_exchange.patch
  55. # CDB race (rhbz #1099509)
  56. Patch37: libdb-cbd-race.patch
  57. # Limit concurrency to max 1024 CPUs (rhbz#1245410)
  58. # A fix for the issue should be in an upstream release already
  59. # https://community.oracle.com/message/13274780#13274780
  60. Patch38: libdb-limit-cpu.patch
  61. # rhbz#1608749 Patch sent upstream
  62. # Expects libdb-5.3.21-mutex_leak.patch applied
  63. Patch39: libdb-5.3.21-trickle_cpu.patch
  64. # cve-2019-2708 fixed by mmuzila
  65. Patch40: db-5.3.28_cve-2019-2708.patch
  66. # Prevents high CPU usage
  67. Patch41: db-5.3.28-mmap-high-cpu-usage.patch
  68. Patch42: libdb-1.85-c99.patch
  69. Patch43: libdb-c99.patch
  70. Patch44: libdb-configure-c99.patch
  71. Patch45: libdb-sqlite-c99.patch
  72. BuildRequires: perl libtool
  73. BuildRequires: tcl-devel >= %{__tclversion}
  74. %if %{with java}
  75. BuildRequires: java-devel >= 1:1.6.0
  76. %endif
  77. #BuildRequires: chrpath
  78. #Conflicts: filesystem < 3
  79. %description
  80. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  81. provides embedded database support for both traditional and
  82. client/server applications. The Berkeley DB includes B+tree, Extended
  83. Linear Hashing, Fixed and Variable-length record access methods,
  84. transactions, locking, logging, shared memory caching, and database
  85. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  86. used by many applications, including Python and Perl, so this should
  87. be installed on all systems.
  88. %package utils
  89. Summary: Command line tools for managing Berkeley DB databases
  90. Summary(ja): Berkeley DB データベースを管理するためのコマンドラインツール集
  91. Group: office
  92. Requires: %{name}%{?_isa} = %{version}-%{release}
  93. Obsoletes: db4-utils
  94. Provides: db4-utils
  95. %description utils
  96. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  97. provides embedded database support for both traditional and
  98. client/server applications. Berkeley DB includes B+tree, Extended
  99. Linear Hashing, Fixed and Variable-length record access methods,
  100. transactions, locking, logging, shared memory caching, and database
  101. recovery. DB supports C, C++, Java and Perl APIs.
  102. %package devel
  103. Summary: C development files for the Berkeley DB library
  104. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  105. Group: programming
  106. Requires: %{name}%{?_isa} = %{version}-%{release}
  107. Obsoletes: db4-devel
  108. Provides: db4-devel
  109. %description devel
  110. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  111. provides embedded database support for both traditional and
  112. client/server applications. This package contains the header files
  113. and libraries for building programs which use the Berkeley DB.
  114. %package devel-doc
  115. Summary: C development documentation files for the Berkeley DB library
  116. Summary(ja): Berkeley DB ライブラリの C 言語用開発ドキュメント
  117. Group: documentation
  118. Requires: %{name} = %{version}-%{release}
  119. Requires: %{name}-devel = %{version}-%{release}
  120. BuildArch: noarch
  121. %description devel-doc
  122. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  123. provides embedded database support for both traditional and
  124. client/server applications. This package contains the documentation
  125. for building programs which use the Berkeley DB.
  126. %package devel-static
  127. Summary: Berkeley DB static libraries
  128. Summary(ja): Berkeley DB 静的ライブラリ
  129. Group: programming
  130. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  131. %description devel-static
  132. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  133. provides embedded database support for both traditional and
  134. client/server applications. This package contains static libraries
  135. needed for applications that require static linking of
  136. Berkeley DB.
  137. %package cxx
  138. Summary: The Berkeley DB database library for C++
  139. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  140. Group: system
  141. Requires: %{name}%{?_isa} = %{version}-%{release}
  142. %description cxx
  143. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  144. provides embedded database support for both traditional and
  145. client/server applications. The Berkeley DB includes B+tree, Extended
  146. Linear Hashing, Fixed and Variable-length record access methods,
  147. transactions, locking, logging, shared memory caching, and database
  148. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  149. used by many applications, including Python and Perl, so this should
  150. be installed on all systems.
  151. %package cxx-devel
  152. Summary: C++ development files for the Berkeley DB library
  153. Summary(ja): Berkeley DB ライブラリの C++ 言語用開発ファイル
  154. Group: programming
  155. Requires: %{name}-cxx%{?_isa} = %{version}-%{release}
  156. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  157. %description cxx-devel
  158. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  159. provides embedded database support for both traditional and
  160. client/server applications. This package contains the header files,
  161. libraries, and documentation for building programs which use the
  162. Berkeley DB in C++.
  163. %package tcl
  164. Summary: The Berkeley DB library for tcl
  165. Summary(ja): tcl 用 Berkeley DB データベースライブラリ
  166. Group: system
  167. Requires: %{name}%{?_isa} = %{version}-%{release}
  168. %description tcl
  169. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  170. provides embedded database support for both traditional and
  171. client/server applications. This package contains the libraries
  172. for building programs which use the Berkeley DB in Tcl.
  173. %package tcl-devel
  174. Summary: Development files for using the Berkeley DB with tcl
  175. Summary(ja): tcl で Berkeley DB を利用するための開発ファイル
  176. Group: programming
  177. Requires: %{name}-tcl%{?_isa} = %{version}-%{release}
  178. %description tcl-devel
  179. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  180. provides embedded database support for both traditional and
  181. client/server applications. This package contains the libraries
  182. for building programs which use the Berkeley DB in Tcl.
  183. %package sql
  184. Summary: The Berkeley DB library for SQL
  185. Summary(ja): SQL 用 Berkeley DB データベースライブラリ
  186. Group: system
  187. Requires: %{name}%{?_isa} = %{version}-%{release}
  188. %description sql
  189. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  190. provides embedded database support for both traditional and
  191. client/server applications. This package contains the libraries
  192. for building programs which use the Berkeley DB in SQL.
  193. %package sql-devel
  194. Summary: Development files for using the Berkeley DB with sql
  195. Summary(ja): SQL で Berkeley DB を利用するための開発ファイル
  196. Group: programming
  197. Requires: %{name}-sql%{?_isa} = %{version}-%{release}
  198. %description sql-devel
  199. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  200. provides embedded database support for both traditional and
  201. client/server applications. This package contains the libraries
  202. for building programs which use the Berkeley DB in SQL.
  203. %if %{with java}
  204. %package java
  205. Summary: The Berkeley DB library for Java
  206. Summary(ja): Java 用 Berkeley DB データベースライブラリ
  207. Group: system
  208. Requires: %{name}%{?_isa} = %{version}-%{release}
  209. %description java
  210. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  211. provides embedded database support for both traditional and
  212. client/server applications. This package contains the libraries
  213. for building programs which use the Berkeley DB in Java.
  214. %package java-devel
  215. Summary: Development files for using the Berkeley DB with Java
  216. Summary(ja): Java で Berkeley DB を利用するための開発ファイル
  217. Group: programming
  218. Requires: %{name}-java%{?_isa} = %{version}-%{release}
  219. %description java-devel
  220. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  221. provides embedded database support for both traditional and
  222. client/server applications. This package contains the libraries
  223. for building programs which use the Berkeley DB in Java.
  224. %endif
  225. # compat32
  226. %package -n compat32-%{name}
  227. Summary: The Berkeley DB database library for C
  228. Summary(ja): C 言語用 Berkeley DB データベースライブラリ
  229. Group: system,legacy
  230. Requires: libdb = %{version}-%{release}
  231. %description -n compat32-%{name}
  232. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  233. provides embedded database support for both traditional and
  234. client/server applications. The Berkeley DB includes B+tree, Extended
  235. Linear Hashing, Fixed and Variable-length record access methods,
  236. transactions, locking, logging, shared memory caching, and database
  237. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  238. used by many applications, including Python and Perl, so this should
  239. be installed on all systems.
  240. %package -n compat32-%{name}-cxx
  241. Summary: The Berkeley DB database library for C++
  242. Summary(ja): C++ 言語用 Berkeley DB データベースライブラリ
  243. Group: system,legacy
  244. Requires: %{name}-cxx = %{version}-%{release}
  245. Requires: compat32-%{name} = %{version}-%{release}
  246. %description -n compat32-%{name}-cxx
  247. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  248. provides embedded database support for both traditional and
  249. client/server applications. The Berkeley DB includes B+tree, Extended
  250. Linear Hashing, Fixed and Variable-length record access methods,
  251. transactions, locking, logging, shared memory caching, and database
  252. recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
  253. used by many applications, including Python and Perl, so this should
  254. be installed on all systems.
  255. %package -n compat32-%{name}-devel
  256. Summary: C development files for the Berkeley DB library
  257. Summary(ja): Berkeley DB ライブラリの C 言語用開発ファイル
  258. Group: programming,legacy
  259. Requires: compat32-%{name} = %{version}-%{release}
  260. Requires: %{name}-devel = %{version}-%{release}
  261. Obsoletes: compat32-db4-devel
  262. Provides: compat32-db4-devel
  263. %description -n compat32-%{name}-devel
  264. The Berkeley Database (Berkeley DB) is a programmatic toolkit that
  265. provides embedded database support for both traditional and
  266. client/server applications. This package contains the header files,
  267. libraries, and documentation for building programs which use the
  268. Berkeley DB.
  269. %debug_package
  270. %prep
  271. %setup -q -n db-%{version} -a 1
  272. cp %{SOURCE2} .
  273. %patch0 -p1 -b .multiarch
  274. pushd db.1.85/PORT/linux
  275. %patch10 -p0 -b .1.1
  276. popd
  277. pushd db.1.85
  278. %patch11 -p0 -b .1.2
  279. %patch12 -p0 -b .1.3
  280. %patch13 -p0 -b .1.4
  281. %patch20 -p1 -b .errno
  282. popd
  283. %patch22 -p1 -b .185compat
  284. %patch24 -p1 -b .4.5.20.jni
  285. %patch25 -p1 -b .licensefix
  286. %patch26 -p1 -b .java8-fix
  287. %patch27 -p1 -b .memp_stat-fix
  288. %patch28 -p1
  289. %patch29 -p1
  290. %patch30 -p1
  291. %patch31 -p1
  292. %patch32 -p1
  293. %patch33 -p1
  294. %patch34 -p1
  295. %patch35 -p1
  296. %patch36 -p1
  297. %patch37 -p1
  298. %patch38 -p1
  299. %patch39 -p1
  300. %patch40 -p1 -b .cve-2019-2708
  301. %patch41 -p1
  302. %patch42 -p1
  303. %patch43 -p1
  304. %patch44 -p1
  305. %patch45 -p1
  306. cd dist
  307. ./s_config
  308. cd ..
  309. %build
  310. CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
  311. CFLAGS="$CFLAGS -DSHAREDSTATEDIR='\"%{_sharedstatedir}\"' -DSQLITE_ENABLE_COLUMN_METADATA=1 -DSQLITE_DISABLE_DIRSYNC=1 -DSQLITE_ENABLE_FTS3=3 -DSQLITE_ENABLE_RTREE=1 -DSQLITE_SECURE_DELETE=1 -DSQLITE_ENABLE_UNLOCK_NOTIFY=1 -I../../../lang/sql/sqlite/ext/fts3/"
  312. export CFLAGS
  313. # Build the old db-185 libraries.
  314. make -C db.1.85/PORT/%{_os} OORG="$CFLAGS"
  315. test -d dist/dist-tls || mkdir dist/dist-tls
  316. # Static link db_dump185 with old db-185 libraries.
  317. /bin/sh libtool --tag=CC --mode=compile %{__cc} $RPM_OPT_FLAGS -Idb.1.85/PORT/%{_os}/include -D_REENTRANT -c util/db_dump185.c -o dist/dist-tls/db_dump185.lo
  318. /bin/sh libtool --tag=LD --mode=link %{__cc} -o dist/dist-tls/db_dump185 dist/dist-tls/db_dump185.lo db.1.85/PORT/%{_os}/libdb.a
  319. # Update config files to understand aarch64
  320. #for dir in dist lang/sql/sqlite lang/sql/jdbc lang/sql/odbc; do
  321. # cp /usr/lib/rpm/config.{guess,sub} "$dir"
  322. #done
  323. pushd dist/dist-tls
  324. %define _configure ../configure
  325. %configure -C \
  326. --enable-compat185 \
  327. --enable-dump185 \
  328. --enable-shared \
  329. --enable-static \
  330. --enable-tcl \
  331. --with-tcl=%{_libdir} \
  332. --enable-cxx \
  333. --enable-sql \
  334. --enable-test \
  335. --disable-rpath \
  336. --with-tcl=%{_libdir}/tcl%{__tclversion} \
  337. %if %{with java}
  338. --enable-java
  339. %endif
  340. # Remove libtool predep_objects and postdep_objects wonkiness so that
  341. # building without -nostdlib doesn't include them twice. Because we
  342. # already link with g++, weird stuff happens if you don't let the
  343. # compiler handle this.
  344. perl -pi -e 's/^predep_objects=".*$/predep_objects=""/' libtool
  345. perl -pi -e 's/^postdep_objects=".*$/postdep_objects=""/' libtool
  346. perl -pi -e 's/-shared -nostdlib/-shared/' libtool
  347. make %{?_smp_mflags}
  348. %if %{with java}
  349. # XXX hack around libtool not creating ./libs/libdb_java-X.Y.lai
  350. LDBJ=./.libs/libdb_java-%{__soversion}.la
  351. if test -f ${LDBJ} -a ! -f ${LDBJ}i; then
  352. sed -e 's,^installed=no,installed=yes,' < ${LDBJ} > ${LDBJ}i
  353. fi
  354. %endif
  355. popd
  356. %install
  357. rm -rf ${RPM_BUILD_ROOT}
  358. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}
  359. mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
  360. %makeinstall STRIP=/bin/true -C dist/dist-tls
  361. # XXX Nuke non-versioned archives and symlinks
  362. rm -f ${RPM_BUILD_ROOT}%{_libdir}/{libdb.a,libdb_cxx.a,libdb_tcl.a,libdb_sql.a}
  363. chmod +x ${RPM_BUILD_ROOT}%{_libdir}/*.so*
  364. # Move the header files to a subdirectory, in case we're deploying on a
  365. # system with multiple versions of DB installed.
  366. mkdir -p ${RPM_BUILD_ROOT}%{_includedir}/%{name}
  367. mv ${RPM_BUILD_ROOT}%{_includedir}/*.h ${RPM_BUILD_ROOT}%{_includedir}/%{name}/
  368. # Create symlinks to includes so that "use <db.h> and link with -ldb" works.
  369. for i in db.h db_cxx.h db_185.h; do
  370. ln -s %{name}/$i ${RPM_BUILD_ROOT}%{_includedir}
  371. done
  372. %if %{with java}
  373. # Move java jar file to the correct place
  374. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/java
  375. mv ${RPM_BUILD_ROOT}%{_libdir}/*.jar ${RPM_BUILD_ROOT}%{_datadir}/java
  376. %endif
  377. # Eliminate installed doco
  378. rm -rf ${RPM_BUILD_ROOT}%{_prefix}/docs
  379. # XXX Avoid Permission denied. strip when building as non-root.
  380. chmod u+w ${RPM_BUILD_ROOT}%{_bindir} ${RPM_BUILD_ROOT}%{_bindir}/*
  381. # remove unneeded .la files (#225675)
  382. rm -f ${RPM_BUILD_ROOT}%{_libdir}/*.la
  383. # remove RPATHs
  384. #chrpath -d ${RPM_BUILD_ROOT}%{_libdir}/*.so ${RPM_BUILD_ROOT}%{_bindir}/*
  385. # unify documentation and examples, remove stuff we don't need
  386. rm -rf docs/csharp
  387. rm -rf examples/csharp
  388. rm -rf docs/installation
  389. mv examples docs
  390. %files
  391. %defattr(-,root,root,-)
  392. %license LICENSE lgpl-2.1.txt
  393. %doc README
  394. %{_libdir}/libdb-%{__soversion}.so
  395. %{_libdir}/libdb-%{__soversion_major}.so
  396. %files devel
  397. %defattr(-,root,root,-)
  398. %{_libdir}/libdb.so
  399. %dir %{_includedir}/%{name}
  400. %{_includedir}/%{name}/db.h
  401. %{_includedir}/%{name}/db_185.h
  402. %{_includedir}/db.h
  403. %{_includedir}/db_185.h
  404. %files devel-doc
  405. %defattr(-,root,root,-)
  406. %doc docs/*
  407. %files devel-static
  408. %defattr(-,root,root,-)
  409. %{_libdir}/libdb-%{__soversion}.a
  410. %{_libdir}/libdb_cxx-%{__soversion}.a
  411. %{_libdir}/libdb_tcl-%{__soversion}.a
  412. %{_libdir}/libdb_sql-%{__soversion}.a
  413. %if %{with java}
  414. %{_libdir}/libdb_java-%{__soversion}.a
  415. %endif
  416. %files utils
  417. %defattr(-,root,root,-)
  418. %{_bindir}/db*_archive
  419. %{_bindir}/db*_checkpoint
  420. %{_bindir}/db*_deadlock
  421. %{_bindir}/db*_dump*
  422. %{_bindir}/db*_hotbackup
  423. %{_bindir}/db*_load
  424. %{_bindir}/db*_printlog
  425. %{_bindir}/db*_recover
  426. %{_bindir}/db*_replicate
  427. %{_bindir}/db*_stat
  428. %{_bindir}/db*_upgrade
  429. %{_bindir}/db*_verify
  430. %{_bindir}/db*_tuner
  431. %files cxx
  432. %defattr(-,root,root,-)
  433. %{_libdir}/libdb_cxx-%{__soversion}.so
  434. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  435. %files cxx-devel
  436. %defattr(-,root,root,-)
  437. %{_includedir}/%{name}/db_cxx.h
  438. %{_includedir}/db_cxx.h
  439. %{_libdir}/libdb_cxx.so
  440. %files tcl
  441. %defattr(-,root,root,-)
  442. %{_libdir}/libdb_tcl-%{__soversion}.so
  443. %{_libdir}/libdb_tcl-%{__soversion_major}.so
  444. %files tcl-devel
  445. %defattr(-,root,root,-)
  446. %{_libdir}/libdb_tcl.so
  447. %files sql
  448. %defattr(-,root,root,-)
  449. %{_libdir}/libdb_sql-%{__soversion}.so
  450. %{_libdir}/libdb_sql-%{__soversion_major}.so
  451. %files sql-devel
  452. %defattr(-,root,root,-)
  453. %{_bindir}/dbsql
  454. %{_libdir}/libdb_sql.so
  455. %{_includedir}/%{name}/dbsql.h
  456. %if %{with java}
  457. %files java
  458. %defattr(-,root,root,-)
  459. %{_libdir}/libdb_java-%{__soversion_major}*.so
  460. %{_datadir}/java/*.jar
  461. %files java-devel
  462. %defattr(-,root,root,-)
  463. %{_libdir}/libdb_java.so
  464. %endif
  465. %if %{build_compat32}
  466. %files -n compat32-%{name}
  467. %defattr(-,root,root)
  468. %{_libdir}/libdb-%{__soversion}.so
  469. %{_libdir}/libdb-%{__soversion_major}.so
  470. %files -n compat32-%{name}-cxx
  471. %defattr(-,root,root)
  472. %{_libdir}/libdb_cxx-%{__soversion}.so
  473. %{_libdir}/libdb_cxx-%{__soversion_major}.so
  474. %files -n compat32-%{name}-devel
  475. %defattr(-,root,root)
  476. %{_libdir}/libdb.so
  477. %endif
  478. %changelog
  479. * Fri Jul 05 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-13
  480. - imported Patch40-45 from rawhide.
  481. * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-12
  482. - imported Patch36-39 from rawhide.
  483. * Fri Dec 22 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-11
  484. - added Patch28-15.
  485. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-10
  486. - rebuilt with new toolchain.
  487. * Thu May 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-9
  488. - added Patch27.
  489. * Tue Dec 16 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-8
  490. - added compat32 subpackages
  491. * Sat Nov 1 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 5.3.28-7
  492. - updated Summary and Group
  493. * Thu May 22 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-6
  494. - added "Provides: db4-{utils,devel}".
  495. * Mon May 19 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.28-5
  496. - initial build for Vine Linux.
  497. * Sat Feb 22 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-4
  498. - Add some of the previous aarch64 bits back as the sub configure don't use the macro
  499. * Sun Jan 26 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.3.28-3
  500. - Fix configure macro usage for better aarch64 build fix
  501. * Wed Nov 06 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-2
  502. - Updated config files to allow build on aarch64 (#1022970)
  503. * Tue Oct 08 2013 Jan Stanek <jstanek@redhat.com> - 5.3.28-1
  504. - Added Sleepycat to the license list (#1013841)
  505. - Updated to 5.3.28 (#1013233)
  506. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-13
  507. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  508. * Tue May 28 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-12
  509. - add copy of lgpl-2.1.txt
  510. * Thu May 16 2013 Jan Stanek <jstanek@redhat.com> - 5.3.21-11
  511. - Fix missing debuginfo issue for utils subpackage
  512. * Thu May 9 2013 Tom Callaway <spot@fedoraproject.org> - 5.3.21-10
  513. - add license clarification fix
  514. * Wed Apr 03 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-9
  515. - Added sqlite compability CFLAGS (#788496)
  516. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-8
  517. - Cleaning the specfile - removed gcc-java dependecy other way
  518. * Wed Mar 27 2013 Jan Stanek <jstanek@redhat.com> 5.3.21-7
  519. - Removed dependency on obsolete gcc-java package (#927742)
  520. * Thu Mar 7 2013 Jindrich Novy <jnovy@redhat.com> 5.3.21-6
  521. - add LGPLv2+ and remove Sleepycat in license tag (#886838)
  522. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-5
  523. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  524. * Tue Nov 27 2012 Tom Callaway <spot@fedoraproject.org> - 5.3.21-4
  525. - fix license tag
  526. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.3.21-3
  527. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  528. * Sat Jul 14 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 5.3.21-2
  529. - Specify tag for libtool (fixes FTBFS # 838334 )
  530. * Thu Jul 5 2012 Jindrich Novy <jnovy@redhat.com> 5.3.21-1
  531. - update to 5.3.21
  532. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  533. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-5
  534. - move C++ header files to cxx-devel
  535. * Tue Jul 3 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-4
  536. - fix -devel packages dependencies yet more (#832225)
  537. * Sun May 6 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-3
  538. - package -devel packages correctly
  539. * Sat Apr 21 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-2
  540. - fix multiarch conflict in libdb-devel (#812901)
  541. - remove unneeded dos2unix BR
  542. * Thu Mar 15 2012 Jindrich Novy <jnovy@redhat.com> 5.3.15-1
  543. - update to 5.3.15
  544. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_3.html
  545. * Fri Feb 17 2012 Deepak Bhole <dbhole@redhat.com> 5.2.36-5
  546. - Resolves rhbz#794472
  547. - Patch from Omair Majid <omajid@redhat.com> to remove explicit Java 6 req.
  548. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-4
  549. - add filesystem guard
  550. * Wed Jan 25 2012 Harald Hoyer <harald@redhat.com> 5.2.36-3
  551. - install everything in /usr
  552. https://fedoraproject.org/wiki/Features/UsrMove
  553. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.36-2
  554. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  555. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.36-1
  556. - update to 5.2.36,
  557. http://download.oracle.com/otndocs/products/berkeleydb/html/changelog_5_2.html#id3647664
  558. * Wed Jun 15 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-2
  559. - move development documentation to devel-doc subpackage (#705386)
  560. * Tue Jun 14 2011 Jindrich Novy <jnovy@redhat.com> 5.2.28-1
  561. - update to 5.2.28
  562. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.25-2
  563. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  564. * Thu Feb 3 2011 Jindrich Novy <jnovy@redhat.com> 5.1.25-1
  565. - update to 5.1.25
  566. * Wed Sep 29 2010 jkeating - 5.1.19-2
  567. - Rebuilt for gcc bug 634757
  568. * Fri Sep 10 2010 Jindrich Novy <jnovy@redhat.com> 5.1.19-1
  569. - update to 5.1.19
  570. - rename -devel-static to -static subpackage (#617800)
  571. - build java on all arches
  572. * Wed Jul 7 2010 Jindrich Novy <jnovy@redhat.com> 5.0.26-1
  573. - update to 5.0.26
  574. - drop BR: ed
  575. * Thu Jun 17 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-2
  576. - add Requires: libdb-cxx to libdb-devel
  577. * Wed Apr 21 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-1
  578. - initial build
  579. * Thu Apr 15 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.2
  580. - remove C# documentation
  581. - disable/remove rpath
  582. - fix description
  583. - tighten dependencies
  584. - run ldconfig for cxx and sql subpackages
  585. * Fri Apr 9 2010 Jindrich Novy <jnovy@redhat.com> 5.0.21-0.1
  586. - enable sql
  587. - package 5.0.21