libcap-ng-vl.spec 7.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: An alternate posix capabilities library
  4. Name: libcap-ng
  5. Version: 0.8.5
  6. Release: 2%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPLv2+
  11. URL: http://people.redhat.com/sgrubb/libcap-ng/
  12. Source0: http://people.redhat.com/sgrubb/libcap-ng/%{name}-%{version}.tar.gz
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  14. BuildRequires: kernel-headers >= 2.6.11
  15. BuildRequires: libattr-devel
  16. %description
  17. Libcap-ng is a library that makes using posix capabilities easier
  18. %package devel
  19. Summary: Header files for libcap-ng library
  20. License: LGPLv2+
  21. Group: programming
  22. Requires: kernel-headers >= 2.6.11
  23. Requires: %{name} = %{version}-%{release}
  24. Requires: pkgconfig
  25. %description devel
  26. The libcap-ng-devel package contains the files needed for developing
  27. applications that need to use the libcap-ng library.
  28. %package python3
  29. Summary: Python3 bindings for libcap-ng library
  30. License: LGPLv2+
  31. Group: programming
  32. BuildRequires: python3-devel swig
  33. BuildRequires: python3-rpm-macros
  34. Requires: %{name} = %{version}-%{release}
  35. Provides: python3-capng = %{version}-%{release}
  36. %description python3
  37. The libcap-ng-python3 package contains the bindings so that libcap-ng
  38. and can be used by python3 applications.
  39. %package utils
  40. Summary: Utilities for analysing and setting file capabilities
  41. License: GPLv2+
  42. Group: admin-tools
  43. Requires: %{name} = %{version}-%{release}
  44. %description utils
  45. The libcap-ng-utils package contains applications to analyse the
  46. posix capabilities of all the program running on a system. It also
  47. lets you set the file system based capabilities.
  48. %package -n compat32-%{name}
  49. Summary: An alternate posix capabilities library
  50. Group: system,legacy
  51. Requires: %{name} = %{version}-%{release}
  52. %description -n compat32-%{name}
  53. Libcap-ng is a library that makes using posix capabilities easier
  54. %package -n compat32-%{name}-devel
  55. Summary: Header files for libcap-ng library
  56. Group: programming,legacy
  57. License: LGPLv2+
  58. Requires: %{name}-devel = %{version}-%{release}
  59. %description -n compat32-%{name}-devel
  60. The libcap-ng-devel package contains the files needed for developing
  61. applications that need to use the libcap-ng library.
  62. %debug_package
  63. %prep
  64. %setup -q
  65. %build
  66. %configure --with-python --with-python3
  67. make %{?_smp_mflags}
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. make DESTDIR="${RPM_BUILD_ROOT}" install
  71. # Remove a couple things so they don't get picked up
  72. rm -f $RPM_BUILD_ROOT%{_libdir}/libcap-ng.la
  73. rm -f $RPM_BUILD_ROOT%{_libdir}/libcap-ng.a
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/libdrop_ambient.la
  75. rm -f $RPM_BUILD_ROOT%{_libdir}/libdrop_ambient.a
  76. rm -f $RPM_BUILD_ROOT%{_libdir}/python?.?/site-packages/_capng.a
  77. rm -f $RPM_BUILD_ROOT%{_libdir}/python?.?/site-packages/_capng.la
  78. %check
  79. make check
  80. %clean
  81. rm -rf $RPM_BUILD_ROOT
  82. %files
  83. %defattr(-,root,root,-)
  84. %license COPYING.LIB
  85. %attr(0755,root,root) %{_libdir}/libcap-ng.so.*
  86. %attr(0755,root,root) %{_libdir}/libdrop_ambient.so.*
  87. %files devel
  88. %defattr(-,root,root,-)
  89. %attr(0644,root,root) %{_mandir}/man3/*
  90. %attr(0644,root,root) %{_mandir}/man7/*
  91. %attr(0644,root,root) %{_includedir}/cap-ng.h
  92. %attr(0755,root,root) %{_libdir}/libcap-ng.so
  93. %attr(0755,root,root) %{_libdir}/libdrop_ambient.so
  94. %attr(0644,root,root) %{_datadir}/aclocal/cap-ng.m4
  95. %{_libdir}/pkgconfig/libcap-ng.pc
  96. %files python3
  97. %defattr(-,root,root,-)
  98. %attr(755,root,root) %{python3_sitearch}/*
  99. %{python3_sitearch}/capng.py*
  100. %files utils
  101. %defattr(-,root,root,-)
  102. %doc COPYING
  103. %attr(0755,root,root) %{_bindir}/*
  104. %attr(0644,root,root) %{_mandir}/man8/*
  105. %if %{build_compat32}
  106. %files -n compat32-%{name}
  107. %defattr(-,root,root,-)
  108. %attr(0755,root,root) %{_libdir}/libcap-ng.so.*
  109. %files -n compat32-%{name}-devel
  110. %defattr(-,root,root,-)
  111. %attr(0755,root,root) %{_libdir}/libcap-ng.so
  112. %{_libdir}/pkgconfig/libcap-ng.pc
  113. %endif
  114. %changelog
  115. * Wed Jul 03 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.5-2
  116. - drop symlinks in /%%{_lib}/.
  117. * Mon Jun 17 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.5-1
  118. - new upstream release.
  119. * Thu Jun 15 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.3-1
  120. - new upstream release.
  121. * Wed Feb 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.8.2-1
  122. - new upstream release.
  123. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.10-1
  124. - new upstream release.
  125. * Tue Feb 27 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.7.9-1
  126. - new upstream release.
  127. - added compat32-* packages.
  128. - enabled python3 modules.
  129. * Sat Jan 04 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-2
  130. - rebuild with VineSeed environment
  131. * Mon Jan 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.3-1
  132. - new upstream release
  133. * Sun Oct 28 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.7.1-1
  134. - new upstream release
  135. * Mon Feb 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-2
  136. - rebuild with python-2.7.2
  137. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.6.6-1
  138. - initial build for Vine Linux
  139. * Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 0.6.6-1
  140. - New upstream release
  141. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.5-2
  142. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  143. * Wed Nov 03 2010 Steve Grubb <sgrubb@redhat.com> 0.6.5-1
  144. - New upstream release fixing 2.6.36 kernel header issue
  145. * Wed Jul 21 2010 David Malcolm <dmalcolm@redhat.com> - 0.6.4-4
  146. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  147. * Thu Jun 17 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-3
  148. - Only open regular files in filecap
  149. * Mon May 24 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-2
  150. - In utils subpackage added a requires statement.
  151. * Thu May 06 2010 Steve Grubb <sgrubb@redhat.com> 0.6.4-1
  152. - New upstream release fixing multi-threading issue
  153. * Wed Apr 28 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-2
  154. - filecap shows full capabilities if a file has any
  155. * Thu Mar 11 2010 Steve Grubb <sgrubb@redhat.com> 0.6.3-1
  156. - New upstream release
  157. * Tue Feb 16 2010 Steve Grubb <sgrubb@redhat.com> 0.6.2-4
  158. - Use global macro and require pkgconfig for devel subpackage
  159. * Fri Oct 09 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-3
  160. - Apply patch to retain setpcap only if clearing bounding set
  161. * Sat Oct 03 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-2
  162. - Apply patch correcting pscap and netcap acct detection
  163. * Mon Sep 28 2009 Steve Grubb <sgrubb@redhat.com> 0.6.2-1
  164. - New upstream release
  165. * Sun Jul 26 2009 Steve Grubb <sgrubb@redhat.com> 0.6.1-1
  166. - New upstream release
  167. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6-2
  168. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  169. * Mon Jun 29 2009 Steve Grubb <sgrubb@redhat.com> 0.6-1
  170. - New upstream release
  171. * Sun Jun 21 2009 Steve Grubb <sgrubb@redhat.com> 0.5.1-1
  172. - New upstream release
  173. * Fri Jun 19 2009 Steve Grubb <sgrubb@redhat.com> 0.5-1
  174. - New upstream release
  175. * Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.2-1
  176. - New upstream release
  177. * Fri Jun 12 2009 Steve Grubb <sgrubb@redhat.com> 0.4.1-1
  178. - Initial build.