lzo-vl.spec 7.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: lzo
  3. Summary: Data compression library with very fast (de)compression
  4. Summary(ja): 高速なデータ圧縮ライブラリ
  5. Version: 2.10
  6. Release: 3%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: GPLv2+
  11. URL: http://www.oberhumer.com/opensource/lzo/
  12. Source0: http://www.oberhumer.com/opensource/lzo/download/%{name}-%{version}.tar.gz
  13. Patch0: lzo-2.08-configure.patch
  14. Patch1: lzo-2.08-rhbz1309225.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: pkgconfig(zlib)
  17. %description
  18. LZO is a portable lossless data compression library written in ANSI C.
  19. It offers pretty fast compression and very fast decompression.
  20. Decompression requires no memory. In addition there are slower
  21. compression levels achieving a quite competitive compression ratio
  22. while still decompressing at this very high speed.
  23. %package minilzo
  24. Summary: Mini version of lzo for apps which don't need the full version
  25. Group: system
  26. %description minilzo
  27. A small (mini) version of lzo for embedding into applications which don't need
  28. full blown lzo compression support.
  29. %package devel
  30. Summary: Development files for the lzo library
  31. Summary(ja): lzo ライブラリの開発ファイル
  32. Group: programming
  33. Requires: %{name} = %{version}-%{release}
  34. Requires: %{name}-minilzo = %{version}-%{release}
  35. Requires: zlib-devel
  36. %description devel
  37. LZO is a portable lossless data compression library written in ANSI C.
  38. It offers pretty fast compression and very fast decompression.
  39. This package contains development files needed for lzo.
  40. %package -n compat32-%{name}
  41. Summary: Data compression library with very fast (de)compression
  42. Summary(ja): 高速なデータ圧縮ライブラリ
  43. Group: system,legacy
  44. %description -n compat32-%{name}
  45. LZO is a portable lossless data compression library written in ANSI C.
  46. It offers pretty fast compression and very fast decompression.
  47. Decompression requires no memory. In addition there are slower
  48. compression levels achieving a quite competitive compression ratio
  49. while still decompressing at this very high speed.
  50. %package -n compat32-%{name}-minilzo
  51. Summary: Mini version of lzo for apps which don't need the full version
  52. Group: system,legacy
  53. Requires: %{name}-minilzo = %{version}-%{release}
  54. %description -n compat32-%{name}-minilzo
  55. A small (mini) version of lzo for embedding into applications which don't need
  56. full blown lzo compression support.
  57. %package -n compat32-%{name}-devel
  58. Summary: Development files for the lzo library
  59. Summary(ja): lzo ライブラリの開発ファイル
  60. Group: programming,legacy
  61. Requires: compat32-%{name} = %{version}-%{release}
  62. Requires: %{name}-minilzo = %{version}-%{release}
  63. Requires: compat32-zlib-devel
  64. %description -n compat32-%{name}-devel
  65. LZO is a portable lossless data compression library written in ANSI C.
  66. It offers pretty fast compression and very fast decompression.
  67. This package contains development files needed for lzo.
  68. %debug_package
  69. %prep
  70. %setup -q
  71. %patch0 -p1 -z .configure
  72. %patch1 -p1 -z .rhbz1309225
  73. # mark asm files as NOT needing execstack
  74. for i in asm/i386/src_gas/*.S; do
  75. echo '.section .note.GNU-stack,"",@progbits' >> $i
  76. done
  77. %build
  78. %configure --disable-dependency-tracking --disable-static --enable-shared
  79. make %{?_smp_mflags}
  80. # build minilzo too (bz 439979)
  81. gcc %{optflags} -fpic -Iinclude/lzo -o minilzo/minilzo.o -c minilzo/minilzo.c
  82. gcc -g -shared -o libminilzo.so.0 -Wl,-soname,libminilzo.so.0 minilzo/minilzo.o
  83. %install
  84. rm -rf $RPM_BUILD_ROOT
  85. make install DESTDIR=$RPM_BUILD_ROOT
  86. rm $RPM_BUILD_ROOT%{_libdir}/liblzo2.la
  87. install -m 755 libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}
  88. ln -s libminilzo.so.0 $RPM_BUILD_ROOT%{_libdir}/libminilzo.so
  89. install -p -m 644 minilzo/minilzo.h $RPM_BUILD_ROOT%{_includedir}/lzo
  90. rm -rf %{buildroot}%{_docdir}/lzo
  91. %ifarch x86_64
  92. %check
  93. make check test
  94. %endif
  95. %files
  96. %license COPYING
  97. %doc AUTHORS ChangeLog NEWS README THANKS
  98. %{_libdir}/liblzo2.so.*
  99. %files minilzo
  100. %doc minilzo/README.LZO
  101. %{_libdir}/libminilzo.so.*
  102. %files devel
  103. %doc doc/LZOAPI.TXT doc/LZO.FAQ doc/LZO.TXT
  104. %{_includedir}/lzo
  105. %{_libdir}/lib*lzo*.so
  106. %{_libdir}/pkgconfig/lzo2.pc
  107. # compat32
  108. %if %{build_compat32}
  109. %files -n compat32-%{name}
  110. %{_libdir}/liblzo2.so.*
  111. %files -n compat32-%{name}-minilzo
  112. %{_libdir}/libminilzo.so.0
  113. %files -n compat32-%{name}-devel
  114. %{_libdir}/lib*lzo*.so
  115. %{_libdir}/pkgconfig/lzo2.pc
  116. %endif
  117. %changelog
  118. * Thu Jul 11 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10-3
  119. - rebuilt with current environment.
  120. * Sun Mar 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10-2
  121. - rebuilt with current environment.
  122. * Sat Dec 30 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.10-1
  123. - new upstream release.
  124. - updated Patch0.
  125. - imported Patch1 from rawhide.
  126. * Sat Dec 28 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.03-4
  127. - rebuild with VineSeed environment
  128. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.03-3
  129. - rebuilt with current VineSeed
  130. * Sat Jun 27 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.03-2
  131. - added compat32 package for x86_64 arch support
  132. * Fri Aug 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.03-1
  133. - initial build for Vine Linux
  134. * Thu May 1 2008 Lubomir Rintel <lkundrak@v3.sk> 2.03-1
  135. - New upstream release
  136. - Changed the license to GPLv2+
  137. * Wed Apr 2 2008 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-5
  138. - Fix configure failure with -Werror-implicit-function-declaration in CFLAGS
  139. - Add a minilzo subpackage which contains a shared version of minilzo, to be
  140. used by all applications which ship with their own copy of it (bz 439979)
  141. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.02-4
  142. - Autorebuild for GCC 4.3
  143. * Wed Aug 15 2007 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-3
  144. - Update License tag for new Licensing Guidelines compliance
  145. * Mon Aug 28 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-2
  146. - FE6 Rebuild
  147. * Wed Jul 26 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 2.02-1
  148. - New upstream release 2.02, soname change!
  149. * Mon Jul 24 2006 Hans de Goede <j.w.r.degoede@hhs.nl> 1.08-7
  150. - Taking over as maintainer since Anvil has other priorities
  151. - Add a patch to fix asm detection on i386 (bug 145882, 145893). Thanks to
  152. Carlo Marcelo Arenas Belon <carenas@sajinet.com.pe> for the initial patch.
  153. - Removed unused build dependency on nasm
  154. - Remove static lib
  155. - Cleanup %%doc a bit
  156. * Thu Mar 16 2006 Dams <anvil[AT]livna.org> - 1.08-6.fc5
  157. - Rebuild for new gcc
  158. * Tue Jan 17 2006 Dams <anvil[AT]livna.org> - 1.08-5.fc5
  159. - Bumped release for gcc 4.1 rebuild
  160. * Sun May 22 2005 Jeremy Katz <katzj@redhat.com> - 1.08-4
  161. - rebuild on all arches
  162. * Thu Apr 7 2005 Michael Schwendt <mschwendt[AT]users.sf.net>
  163. - rebuilt
  164. * Sun Apr 27 2003 Dams <anvil[AT]livna.org> 0:1.08-0.fdr.2
  165. - Typo un devel description
  166. - Added post and postun scriptlets
  167. - Added URL in Source0
  168. * Fri Apr 25 2003 Dams <anvil[AT]livna.org>
  169. - Initial build.