json-c-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define pkg_date 20230812
  3. Summary: A JSON implementation in C
  4. Name: json-c
  5. Version: 0.17
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: MIT
  11. URL: https://json-c.github.io/json-c/
  12. Source0: https://github.com/json-c/json-c/archive/json-c-%{version}-%{pkg_date}.tar.gz
  13. BuildRequires: cmake ninja
  14. %description
  15. JSON-C implements a reference counting object model that allows you to easily
  16. construct JSON objects in C, output them as JSON formatted strings and parse
  17. JSON formatted strings back into the C representation of JSON objects.
  18. %package devel
  19. Summary: Development files for json-c
  20. Group: programming
  21. Requires: %{name} = %{version}-%{release}
  22. Requires: pkgconfig
  23. %description devel
  24. This package contains the libraries and header files that are needed
  25. for writing applications that are using json-c.
  26. %package doc
  27. Summary: Documentation for json-c
  28. Group: documentation
  29. Requires: %{name} = %{version}-%{release}
  30. BuildArch: noarch
  31. %description doc
  32. This package contains documentation for json-c.
  33. %package -n compat32-%{name}
  34. Summary: A JSON implementation in C
  35. Group: system,legacy
  36. Requires: %{name} = %{version}-%{release}
  37. %description -n compat32-%{name}
  38. JSON-C implements a reference counting object model that allows you to easily
  39. construct JSON objects in C, output them as JSON formatted strings and parse
  40. JSON formatted strings back into the C representation of JSON objects.
  41. %package -n compat32-%{name}-devel
  42. Summary: Development files for json-c
  43. Group: programming,legacy
  44. Requires: compat32-%{name} = %{version}-%{release}
  45. Requires: pkgconfig
  46. %description -n compat32-%{name}-devel
  47. This package contains the libraries and header files that are needed
  48. for writing applications that are using json-c.
  49. %debug_package
  50. %prep
  51. %setup -q -n json-c-json-c-%{version}-%{pkg_date}
  52. %build
  53. %cmake \
  54. -DBUILD_SHARED_LIBS:BOOL=ON \
  55. -DBUILD_STATIC_LIBS:BOOL=OFF \
  56. -DCMAKE_BUILD_TYPE:STRING=RELEASE \
  57. -DCMAKE_C_FLAGS_RELEASE:STRING="" \
  58. -DDISABLE_BSYMBOLIC:BOOL=OFF \
  59. -DDISABLE_WERROR:BOOL=ON \
  60. -DENABLE_RDRAND:BOOL=ON \
  61. -DENABLE_THREADING:BOOL=ON \
  62. -G Ninja
  63. %cmake_build
  64. %install
  65. %{__rm} -rf $RPM_BUILD_ROOT
  66. %cmake_install
  67. %{__rm} -f $RPM_BUILD_ROOT%{_libdir}/*.la
  68. %check
  69. %ctest
  70. %clean
  71. %{__rm} -rf $RPM_BUILD_ROOT
  72. %files
  73. %defattr(-,root,root,-)
  74. %license COPYING
  75. %doc AUTHORS ChangeLog NEWS README*
  76. %{_libdir}/libjson-c.so.*
  77. %files devel
  78. %defattr(-,root,root,-)
  79. %dir %{_includedir}/json-c
  80. %{_includedir}/json-c/*
  81. %{_libdir}/libjson-c.so
  82. %{_libdir}/pkgconfig/json-c.pc
  83. %dir %{_libdir}/cmake/json-c
  84. %{_libdir}/cmake/json-c/*.cmake
  85. %files doc
  86. %defattr(-,root,root,-)
  87. %doc doc/html/*
  88. %if %{build_compat32}
  89. %files -n compat32-%{name}
  90. %defattr(-,root,root,-)
  91. %{_libdir}/libjson-c.so.*
  92. %files -n compat32-%{name}-devel
  93. %defattr(-,root,root,-)
  94. %{_libdir}/libjson-c.so
  95. %endif
  96. %changelog
  97. * Sat Jun 29 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.17-1
  98. - new upstream release.
  99. * Wed Oct 26 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.16-1
  100. - new upstream release.
  101. * Fri Sep 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.15-1
  102. - new upstream release.
  103. - dropped Patch1000: fixed in upstream.
  104. * Sat May 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.14-1
  105. - updated to 0.14.
  106. - added Patch1000 to fix CVE-2020-12762.
  107. * Tue Jan 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.13.1-1
  108. - updated to 0.13.1.
  109. * Sat Jan 17 2015 Daisuke SUZUKI <daisuke@vinelinux.org> 0.11-1
  110. - update to 0.11
  111. * Wed Nov 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.10-1
  112. - update to 0.10
  113. - update URL
  114. * Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-2
  115. - create compat32 sub packages
  116. * Fri Oct 07 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.9-1
  117. - initial build for Vine Linux