flac-vl.spec 9.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: flac
  3. Summary: FLAC - Free Lossless Audio Codec
  4. Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
  5. Version: 1.4.3
  6. Release: 1%{?_dist_release}
  7. Group: multimedia
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  11. License: BSD and GPLv2+
  12. URL: https://xiph.org/flac/
  13. Source: https://github.com/xiph/flac/archive/%{version}.tar.gz#/%{name}-%{version}.tar.gz
  14. BuildRequires: libogg-devel
  15. BuildRequires: automake autoconf libtool gettext-devel doxygen
  16. %ifarch %ix86
  17. # 2.0 supports symbol visibility
  18. BuildRequires: nasm >= 2.0
  19. %endif
  20. %description
  21. FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
  22. similar to MP3, but lossless.
  23. The FLAC project consists of:
  24. * the stream format
  25. * libFLAC - reference encoders and decoders in library form
  26. * flac - a command-line program to encode and decode FLAC files
  27. * metaflac - a command-line metadata editor for FLAC files
  28. %description -l ja
  29. FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
  30. MP3 に似ていますが、音質が劣化しません。
  31. FLAC プロジェクトは以下により構成されています。
  32. * ストリーム形式
  33. * libFLAC - リファレンスエンコーダ/デコーダを実装するライブラリ
  34. * flac - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
  35. プログラム。
  36. * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
  37. %package devel
  38. Summary: Development libraries and header files from FLAC
  39. Summary(ja): FLAC アプリケーション開発用ライブラリ及びヘッダファイル
  40. Group: programming
  41. Requires: %{name} = %{version}
  42. Requires: pkgconfig
  43. %description devel
  44. This package contains all the files needed to develop applications that
  45. will use the Free Lossless Audio Codec (FLAC).
  46. %description -l ja devel
  47. このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
  48. 開発するために必要なライブラリ及びヘッダファイルが含まれています。
  49. # compat32
  50. %package -n compat32-%{name}
  51. Summary: FLAC - Free Lossless Audio Codec
  52. Summary(ja): FLAC - フリーの可逆音声圧縮コーデック
  53. Group: system,legacy
  54. %description -n compat32-%{name}
  55. FLAC stands for Free Lossless Audio Codec. Grossly oversimplified, FLAC is
  56. similar to MP3, but lossless.
  57. The FLAC project consists of:
  58. * the stream format
  59. * libFLAC - reference encoders and decoders in library form
  60. * flac - a command-line program to encode and decode FLAC files
  61. * metaflac - a command-line metadata editor for FLAC files
  62. %description -n compat32-%{name} -l ja
  63. FLAC (Free Lossless Audio Codec) はフリーの可逆音声圧縮コーデックです。
  64. MP3 に似ていますが、音質が劣化しません。
  65. FLAC プロジェクトは以下により構成されています。
  66. * ストリーム形式
  67. * libFLAC - リファレンスエンコーダ/デコーダを実装するライブラリ
  68. * flac - FLAC ファイルのエンコード/デコードに使用するコマンドライン版
  69. プログラム。
  70. * metaflac - FLAC ファイルのコマンドライン版メタデータエディタ
  71. %package -n compat32-%{name}-devel
  72. Summary: Development libraries and header files from FLAC
  73. Summary(ja): FLAC アプリケーション開発用ライブラリ及びヘッダファイル
  74. Group: programming,legacy
  75. Requires: %{name}-devel = %{version}-%{release}
  76. Requires: compat32-%{name} = %{version}-%{release}
  77. Requires: compat32-pkgconfig
  78. %description -n compat32-%{name}-devel
  79. This package contains all the files needed to develop applications that
  80. will use the Free Lossless Audio Codec (FLAC).
  81. %description -n compat32-%{name}-devel -l ja
  82. このパッケージには FLAC (Free Lossless Audio Codec) を扱うアプリケーションを
  83. 開発するために必要なライブラリ及びヘッダファイルが含まれています。
  84. %debug_package
  85. %prep
  86. %define srcver %{version}%{?extraver:-%extraver}
  87. %setup -q -n %{name}-%{srcver}
  88. %build
  89. ./autogen.sh -V
  90. %configure \
  91. --disable-static \
  92. --disable-silent-rules \
  93. --disable-xmms-plugin \
  94. --disable-thorough-tests
  95. %make_build
  96. %install
  97. %make_install
  98. rm -rf ./htmldoc
  99. mv -f %{buildroot}%{_docdir}/flac ./htmldoc
  100. # remove unneeded files
  101. %{_bindir}/find %{buildroot} -name "*.la" -exec %__rm -f "{}" \;
  102. %check
  103. make check
  104. %files
  105. %license COPYING.*
  106. %doc AUTHORS README.md
  107. %{_bindir}/*
  108. %{_libdir}/*.so.*
  109. #{_mandir}/*/*
  110. %files devel
  111. %license COPYING.*
  112. %doc doc/html
  113. %{_includedir}/*
  114. %{_libdir}/*.so
  115. %{_libdir}/pkgconfig/*.pc
  116. %{_datadir}/aclocal/*.m4
  117. # compat32
  118. %if %{build_compat32}
  119. %files -n compat32-%{name}
  120. %license COPYING.*
  121. %doc AUTHORS README.md
  122. %{_libdir}/*.so.*
  123. %files -n compat32-%{name}-devel
  124. %{_libdir}/*.so
  125. %endif
  126. %changelog
  127. * Sat Jul 06 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.3-1
  128. - new upstream release.
  129. * Sun Apr 12 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
  130. - new upstream release.
  131. * Thu Feb 22 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.2-1
  132. - new upstream release.
  133. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-3
  134. - rebuilt with new toolchain.
  135. * Sat May 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.3.1-2
  136. - added compat32 subpackages
  137. * Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.1-1
  138. - new upstream release
  139. - remove old patches
  140. * Sat Jul 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.3.0-1
  141. - new upstream release
  142. - remove Patch1-6
  143. - add Patch1,2 from Fedora
  144. * Sun Sep 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-2
  145. - rebuilt with rpm-4.8.1 for pkg-config
  146. - added Patch1-6 from Fedora
  147. * Mon Jul 21 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
  148. - applied new versioning policy
  149. - spec in UTF-8
  150. * Sat Sep 22 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 1.2.1-0vl1
  151. - new upstream release
  152. - drop bmp-plugin.patch (patch1)
  153. - disable xmms plugin
  154. * Sat Aug 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  155. - new upsteram release
  156. - dropped Patch2 (merged into upstream)
  157. - do not build beepmp plugin
  158. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl7
  159. - rebuilt with new toolchain
  160. * Sun Oct 29 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl6
  161. - add '--disable-static' option to %%configure
  162. - remove *.la
  163. * Wed Jul 26 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl5
  164. - rebuild
  165. * Mon Mar 27 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.2-0vl4
  166. - --disable-asm-optimizations on ppc
  167. * Thu Feb 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl3
  168. - rebuild
  169. * Wed Feb 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl2
  170. - initialize flac_cfg.stream with NULL to avoid crashing (patch2)
  171. * Sun Feb 06 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl1
  172. - upstream release
  173. - update bmp-plugin.patch
  174. * Thu Feb 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.2-0vl0.0beta
  175. - upstream release
  176. - update bmp-plugin.patch
  177. * Fri Jan 14 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl5
  178. - fix typo
  179. * Sat Dec 18 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl4
  180. - move html docs to devel package
  181. * Wed Dec 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl3
  182. - add input plugin for beepmp based on for xmms (patch1)
  183. - BuildRequires: beepmp-devel >= 0.9.7
  184. - define build_*_plugin macros to build input plugin sub-packages
  185. - update description
  186. * Thu Nov 04 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl2
  187. - drop BuildRequires: zlib-devel (was required to build with id3lib)
  188. * Fri Oct 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl1
  189. - upstream release
  190. - drop (Build)Requires: id3lib(-devel)
  191. * Sun Aug 01 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.1-0vl0.1
  192. - 1.1.1-beta1
  193. - add BuildRequires: gtk+-devel, zlib-devel
  194. * Mon May 03 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl3
  195. - xmms-flac
  196. - enable to convert charset from/to EUC-JP-MS (Patch0)
  197. - Requires: glibc >= 2.3.3
  198. * Tue Apr 20 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl2
  199. - fix docs
  200. * Thu Apr 08 2004 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.1.0-0vl1
  201. - first build for Vine Linux
  202. * Mon Mar 31 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  203. - Rebuilt for Red Hat Linux 9.
  204. - Exclude .la files.
  205. - Updated description.
  206. * Tue Mar 11 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  207. - Fix nasm dep to be only for ix86.
  208. * Mon Jan 27 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  209. - Update to 1.1.0.
  210. * Sun Jan 5 2003 Matthias Saou <matthias.saou@est.une.marmotte.net>
  211. - Rebuilt against the latest id3lib for the xmms plugin.
  212. * Thu Oct 10 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  213. - Fixed location of include files, doh!
  214. * Sat Sep 28 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  215. - Rebuilt for Red Hat Linux 8.0.
  216. * Wed Sep 25 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  217. - Update to 1.0.4.
  218. - Removed obsolete build patch, the xmms plugin builds cleanly at last!
  219. * Thu Jul 4 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  220. - Update to 1.0.3.
  221. * Tue Apr 23 2002 Daniel Resare <noa@resare.com>
  222. - Fixed plugin build when flac is not already installed
  223. * Mon Apr 8 2002 Matthias Saou <matthias.saou@est.une.marmotte.net>
  224. - Replaced the hard-coded xmms input path with an expansion.
  225. - Fixed spec (License tag and redundant Group for devel package).
  226. - Fixed defattr for the xmms plugin.
  227. * Sat Apr 6 2002 Daniel Resare <noa@resare.com>
  228. - Update to 1.0.2.
  229. - Splitted out xmms plugin to a separate subpackage.
  230. * Tue Nov 20 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  231. - Update to 1.0.1.
  232. * Sun Oct 21 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  233. - Rebuilt for Red Hat 7.2 and added xmms dependency.
  234. * Thu Aug 16 2001 Matthias Saou <matthias.saou@est.une.marmotte.net>
  235. - Initial RPM release.
  236. - You cannot rebuild this SRPM easily if you want the xmms plugin.