coreutils-vl.spec 24 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765
  1. Summary: The GNU core utilities: a set of tools commonly used in shell scripts
  2. Summary(ja): GNU コアユーティリティ: シェルスクリプトで用いるツール集
  3. Name: coreutils
  4. Version: 9.5
  5. Release: 2%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPL
  10. URL: https://www.gnu.org/software/coreutils/
  11. Source0: https://ftp.gnu.org/gnu/%{name}/%{name}-%{version}.tar.xz
  12. Source101: coreutils-DIR_COLORS
  13. Source102: coreutils-DIR_COLORS.lightbgcolor
  14. Source103: coreutils-DIR_COLORS.256color
  15. Source105: coreutils-colorls.sh
  16. Source106: coreutils-colorls.csh
  17. # Vine sources
  18. Source1000: coreutils-8.10-ja.po
  19. # disable the test-lock gnulib test prone to deadlock
  20. Patch100: coreutils-8.26-test-lock.patch
  21. # require_selinux_(): use selinuxenabled(8) if available
  22. Patch105: coreutils-8.26-selinuxenable.patch
  23. # downstream changes to default DIR_COLORS
  24. Patch102: coreutils-8.32-DIR_COLORS.patch
  25. #df --direct
  26. Patch104: coreutils-df-direct.patch
  27. # (sb) lin18nux/lsb compliance - multibyte functionality patch
  28. Patch800: coreutils-i18n.patch
  29. #SELINUX Patch - implements Redhat changes
  30. #(upstream did some SELinux implementation unlike with RedHat patch)
  31. #Patch950: coreutils-selinux.patch
  32. # do not make coreutils-single depend on /usr/bin/coreutils
  33. %global __requires_exclude ^%{_bindir}/coreutils$
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. BuildRequires: gettext libtermcap-devel bison
  36. BuildRequires: texinfo >= 4.3
  37. BuildRequires: autoconf >= 2.58, automake >= 1.11.2
  38. BuildRequires: libcap-devel
  39. BuildRequires: libattr-devel
  40. BuildRequires: libacl-devel
  41. BuildRequires: gmp-devel
  42. # Require a C library that doesn't put LC_TIME files in our way.
  43. Conflicts: glibc < 2.2
  44. Provides: /usr/bin/cut
  45. Provides: /usr/bin/env
  46. Provides: fileutils = %{version}-%{release}
  47. Obsoletes: fileutils < %{version}-%{release}
  48. Provides: sh-utils = %{version}-%{release}
  49. Obsoletes: sh-utils < %{version}-%{release}
  50. Provides: stat = %{version}-%{release}
  51. Obsoletes: stat < %{version}-%{release}
  52. Provides: textutils = %{version}-%{release}
  53. Obsoletes: textutils < %{version}-%{release}
  54. Provides: mktemp = %{version}-%{release}
  55. Obsoletes: mktemp < %{version}-%{release}
  56. %description
  57. These are the GNU core utilities. This package is the combination of
  58. the old GNU fileutils, sh-utils, and textutils packages.
  59. %description -l ja
  60. このパッケージには GNU のコアユーティリティが収録されています。
  61. コアユーティリティ(coreutilsパッケージ)は従来の fileutils,
  62. sh-utils, textutils を統合したパッケージです。
  63. %debug_package
  64. %prep
  65. %autosetup -N
  66. # will be regenerated in the build directories
  67. rm -f src/fs.h
  68. # will be further modified by coreutils-8.32-DIR_COLORS.patch
  69. sed src/dircolors.hin \
  70. -e 's| 00;36$| 01;36|' \
  71. > DIR_COLORS
  72. sed src/dircolors.hin \
  73. -e 's| 01;31$| 00;31|' \
  74. -e 's| 01;35$| 00;35|' \
  75. > DIR_COLORS.lightbgcolor
  76. # apply all patches
  77. %autopatch -p1
  78. (echo ">>> Fixing permissions on tests") 2>/dev/null
  79. find tests -name '*.sh' -perm 0644 -print -exec chmod 0755 '{}' '+'
  80. (echo "<<< done") 2>/dev/null
  81. autoreconf -fiv
  82. # copy updated ja.po
  83. #mv po/ja.po po/ja.po.orig
  84. #cp -f %{SOURCE1000} po/ja.po
  85. %build
  86. export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -fpic"
  87. # Upstream suggests to build with -Dlint for static analyzers:
  88. # https://lists.gnu.org/archive/html/coreutils/2018-06/msg00110.html
  89. # ... and even for production binary RPMs:
  90. # https://lists.gnu.org/archive/html/bug-gnulib/2020-05/msg00130.html
  91. # There is currently no measurable performance drop or other known downside.
  92. CFLAGS="$CFLAGS -Dlint"
  93. # make mknod work again in chroot without /proc being mounted (#1811038)
  94. export ac_cv_func_lchmod="no"
  95. %{expand:%%global optflags %{optflags} -D_GNU_SOURCE=1 -DGNULIB_MBFILE }
  96. %configure --enable-largefile \
  97. --enable-install-program=arch \
  98. --enable-no-install-program=kill,uptime \
  99. --with-tty-group \
  100. DEFAULT_POSIX2_VERSION=200112 alternative=199209 || :
  101. %__make all %{?_smp_mflags}
  102. # XXX docs should say /var/run/[uw]tmp not /etc/[uw]tmp
  103. sed -i -e 's,/etc/utmp,/var/run/utmp,g;s,/etc/wtmp,/var/run/wtmp,g' doc/coreutils.texi
  104. %install
  105. rm -rf $RPM_BUILD_ROOT
  106. %__make DESTDIR=$RPM_BUILD_ROOT install
  107. # man pages are not installed with make install
  108. %__make mandir=$RPM_BUILD_ROOT%{_mandir} install-man
  109. # let be compatible with old fileutils, sh-utils and textutils packages :
  110. mkdir -p $RPM_BUILD_ROOT{/bin,%_bindir,%_sbindir,/sbin}
  111. for f in basename cat chgrp chmod chown cp cut date dd df echo env false \
  112. link ln ls mkdir mknod mktemp mv nice pwd rm rmdir sleep sort \
  113. stty sync touch true uname unlink
  114. do
  115. mv $RPM_BUILD_ROOT/{%_bindir,bin}/$f
  116. done
  117. # chroot was in /usr/sbin :
  118. mv $RPM_BUILD_ROOT/{%_bindir,%_sbindir}/chroot
  119. mkdir -p $RPM_BUILD_ROOT/etc/profile.d
  120. install -p -c -m644 %SOURCE101 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS
  121. install -p -c -m644 %SOURCE102 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.lightbgcolor
  122. install -p -c -m644 %SOURCE103 $RPM_BUILD_ROOT%{_sysconfdir}/DIR_COLORS.256color
  123. install -p -c -m644 %SOURCE105 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.sh
  124. install -p -c -m644 %SOURCE106 $RPM_BUILD_ROOT%{_sysconfdir}/profile.d/colorls.csh
  125. # These come from util-linux and/or procps.
  126. for i in hostname uptime kill ; do
  127. rm -f $RPM_BUILD_ROOT{%_bindir/$i,%_mandir/man1/$i.1}
  128. done
  129. %find_lang %name
  130. # Add the %%lang(xyz) ownership for the LC_TIME dirs as well...
  131. grep LC_TIME %name.lang | cut -d'/' -f1-6 | sed -e 's/) /) %%dir /g' >>%name.lang
  132. # (sb) Deal with Installed (but unpackaged) file(s) found
  133. rm -f $RPM_BUILD_ROOT%{_datadir}/info/dir
  134. %ifarch x86_64
  135. %check
  136. # this test will fail on non-real filesystem (overlayfs, etc.).
  137. perl -pi -e 's|^.*inotify-dir-recreate.*$|\\|' tests/local.mk
  138. make check %{?_smp_mflags}
  139. %endif
  140. %post
  141. if [ ! -L /bin ]; then
  142. for i in env cut; do
  143. if [ ! -e /usr/bin/$i ]; then
  144. ln -sf ../../bin/$i /usr/bin/$i
  145. fi
  146. done
  147. fi
  148. %triggerpostun -- coreutils < 9.5-2
  149. if [ ! -L /bin ]; then
  150. for i in env cut; do
  151. if [ ! -e /usr/bin/$i ]; then
  152. ln -sf ../../bin/$i /usr/bin/$i
  153. fi
  154. done
  155. fi
  156. %files -f %{name}.lang
  157. %defattr(-,root,root)
  158. %config(noreplace) %{_sysconfdir}/DIR_COLORS*
  159. %config(noreplace) %{_sysconfdir}/profile.d/*
  160. %license COPYING
  161. %doc ABOUT-NLS NEWS README THANKS TODO
  162. /bin/*
  163. %{_bindir}/*
  164. %{_libexecdir}/coreutils
  165. %{_infodir}/coreutils*
  166. %{_mandir}/man*/*
  167. %{_sbindir}/chroot
  168. %changelog
  169. * Sun Jul 07 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5-2
  170. - prepared for usrmerge.
  171. * Mon Jun 17 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.5-1
  172. - new upstream release.
  173. * Tue Sep 12 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.4-1
  174. - new upstream release.
  175. * Tue Oct 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0-1
  176. - new upstream release.
  177. - re-imported fedora patches.
  178. - dropped scriptlets.
  179. * Wed Mar 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.32-1
  180. - new upstream release.
  181. - updated all patches.
  182. * Fri May 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.25-1
  183. - update to 8.25
  184. - remove Patch1,102
  185. - import patches from fedora package
  186. - update Patch104,800
  187. - add Patch801,803,804
  188. * Sun Feb 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.23-1
  189. - update to 8.23
  190. - add Patch1 (coreutils-8.23-chroot-chdir.patch) from fedora
  191. - update Patch100,104,800
  192. - remove Requires: util-linux (BTS:2854)
  193. * Mon Jan 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 8.20-2
  194. - rebuild with VineSeed environment
  195. * Mon Nov 26 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 8.20-1
  196. - update to 8.20
  197. * Sat Apr 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-2
  198. - update ja.po
  199. - add BR: libcap-devel, gmp-devel, libattr-devel, libacl-devel
  200. * Sat Feb 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 8.10-1
  201. - update to 8.10
  202. * Mon Sep 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 6.11-2
  203. - rebuilt against curent toolchain
  204. - spec in UTF-8
  205. * Wed Apr 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 6.11-1
  206. - new upstream release
  207. - drop obsolete patches
  208. - import some patched from fedora-devel
  209. - add Obsoletes/Provides mktemp
  210. * Tue Jun 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.96-0vl1
  211. - new upstream release
  212. * Mon May 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.95-0vl1
  213. - new upstream release
  214. * Thu May 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 5.94-0vl1
  215. - new upstream release
  216. - drop opsolete patches
  217. - import some patches from FC
  218. * Sun Nov 13 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.2.1-40vl5
  219. - now readlink is kept as it is, since tetex-3.0 don't have readlink.
  220. * Sat Sep 17 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.2.1-40vl4
  221. - updated ja.po
  222. * Sat Feb 12 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl3
  223. - remove selinux related pam-module from /etc/pam.d/su
  224. * Fri Feb 11 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl2
  225. - update ja.po
  226. * Thu Feb 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 5.2.1-40vl1
  227. - initial build for Vine Linux
  228. - some modifications are merged from fileutils-4.1-10.1vl4
  229. - disable make check
  230. * Sat Feb 5 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-40
  231. - Undo last change (bug #145266).
  232. * Fri Feb 4 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-38
  233. - Special case for ia32e in uname (bug #145266).
  234. * Thu Jan 13 2005 Tim Waugh <twaugh@redhat.com> 5.2.1-37
  235. - Fixed zh_CN translation (bug #144845). Patch from Mitrophan Chin.
  236. * Tue Dec 28 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-36
  237. - Fix to only setdefaultfilecon if not overridden by command line
  238. * Mon Dec 27 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-35
  239. - Change install to restorecon if it can
  240. * Wed Dec 15 2004 Tim Waugh <twaugh@redhat.com>
  241. - Fixed small bug in i18n patch.
  242. * Mon Dec 6 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-34
  243. - Don't set fs uid until after pam_open_session (bug #77791).
  244. * Thu Nov 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-33
  245. - Fixed colorls.csh (bug #139988). Patch from Miloslav Trmac.
  246. * Mon Nov 8 2004 Tim Waugh <twaugh@redhat.com>
  247. - Updated URL (bug #138279).
  248. * Mon Oct 25 2004 Steve Grubb <sgrubb@redhat.com> 5.2.1-32
  249. - Handle the return code of function calls in runcon.
  250. * Mon Oct 18 2004 Tim Waugh <twaugh@redhat.com>
  251. - Prevent compiler warning in coreutils-i18n.patch (bug #136090).
  252. * Tue Oct 5 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-31
  253. - getgrouplist() patch from Ulrich Drepper.
  254. - The selinux patch should be applied last.
  255. * Mon Oct 4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-30
  256. - Mv runuser to /sbin
  257. * Mon Oct 4 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-28
  258. - Fix runuser man page.
  259. * Mon Oct 4 2004 Tim Waugh <twaugh@redhat.com>
  260. - Fixed build.
  261. * Fri Sep 24 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-26
  262. - Add runuser as similar to su, but only runable by root
  263. * Fri Sep 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-25
  264. - chown(1) patch from Ulrich Drepper.
  265. * Tue Sep 14 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-24
  266. - SELinux patch fix: don't display '(null)' if getfilecon() fails
  267. (bug #131196).
  268. * Fri Aug 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-23
  269. - Fixed colorls.csh quoting (bug #102412).
  270. - Fixed another join LSB test failure (bug #121153).
  271. * Mon Aug 16 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-22
  272. - Fixed sort -t LSB test failure (bug #121154).
  273. - Fixed join LSB test failure (bug #121153).
  274. * Wed Aug 11 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-21
  275. - Apply upstream patch to fix 'cp -a' onto multiply-linked files (bug #128874).
  276. - SELinux patch fix: don't error out if lgetfilecon() returns ENODATA.
  277. * Tue Aug 10 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-20
  278. - Added 'konsole' TERM to DIR_COLORS (bug #129544).
  279. * Wed Aug 4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-19
  280. - Added 'gnome' TERM to DIR_COLORS (bug #129112).
  281. - Worked around a bash bug #129128.
  282. - Fixed an i18n patch bug in cut (bug #129114).
  283. * Tue Aug 3 2004 Tim Waugh <twaugh@redhat.com>
  284. - Fixed colorls.{sh,csh} so that the l. and ll aliases are always defined
  285. (bug #128948).
  286. * Tue Jul 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-18
  287. - Fixed field extraction in sort (bug #127694).
  288. * Fri Jun 25 2004 Tim Waugh <twaugh@redhat.com>
  289. - Added 'TERM screen.linux' to DIR_COLORS (bug #78816).
  290. * Wed Jun 23 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-17
  291. - Move pam-xauth to after pam-selinux
  292. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  293. - rebuilt
  294. * Mon Jun 7 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-15
  295. - Fix ls -Z (bug #125447).
  296. * Fri Jun 4 2004 Tim Waugh <twaugh@redhat.com>
  297. - Build requires bison (bug #125290).
  298. * Fri Jun 4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-14
  299. - Fix selinux patch causing problems with ls --format=... (bug #125238).
  300. * Thu Jun 3 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-13
  301. - Change su to use pam_selinux open and pam_selinux close
  302. * Wed Jun 2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-12
  303. - Don't call access() on symlinks about to be removed (bug #124699).
  304. * Wed Jun 2 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-11
  305. - Fix ja translation (bug #124862).
  306. * Tue May 18 2004 Jeremy Katz <katzj@redhat.com> 5.2.1-10
  307. - rebuild
  308. * Mon May 17 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-9
  309. - Mention pam in the info for su (bug #122592).
  310. - Remove wheel group rant again (bug #122886).
  311. - Change default behaviour for chgrp/chown (bug #123263). Patch from
  312. upstream.
  313. * Mon May 17 2004 Thomas Woerner <twoerner@redhat.com> 5.2.1-8
  314. - compiling su PIE
  315. * Wed May 12 2004 Tim Waugh <twaugh@redhat.com>
  316. - Build requires new versions of autoconf and automake (bug #123098).
  317. * Tue May 4 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-7
  318. - Fix join -t (bug #122435).
  319. * Tue Apr 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-6
  320. - Fix 'ls -Z' displaying users/groups if stat() failed (bug #121292).
  321. * Fri Apr 9 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-5
  322. - Add ls -LZ fix
  323. - Fix chcon to handle "."
  324. * Wed Mar 17 2004 Tim Waugh <twaugh@redhat.com>
  325. - Apply upstream fix for non-zero seconds for --date="10:00 +0100".
  326. * Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-3
  327. - If preserve fails, report as warning unless user requires preserve
  328. * Tue Mar 16 2004 Dan Walsh <dwalsh@redhat.com> 5.2.1-2
  329. - Make mv default to preserve on context
  330. * Sat Mar 13 2004 Tim Waugh <twaugh@redhat.com> 5.2.1-1
  331. - 5.2.1.
  332. * Fri Mar 12 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-9
  333. - Add '-Z' to 'ls --help' output (bug #118108).
  334. * Fri Mar 5 2004 Tim Waugh <twaugh@redhat.com>
  335. - Fix deref-args test case for rebuilding under SELinux (bug #117556).
  336. * Wed Feb 25 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-8
  337. - kill(1) offloaded to util-linux altogether.
  338. * Tue Feb 24 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-7
  339. - Ship the real '[', not a symlink.
  340. * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-6
  341. - Apply Paul Eggert's chown patch (bug #116536).
  342. - Merged chdir patch into pam patch where it belongs.
  343. * Mon Feb 23 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-5
  344. - Fixed i18n patch bug causing sort -M not to work (bug #116575).
  345. * Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-4
  346. - Reinstate kill binary, just not its man page (bug #116463).
  347. * Sat Feb 21 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-3
  348. - Updated ls-stat patch.
  349. * Fri Feb 20 2004 Dan Walsh <dwalsh@redhat.com> 5.2.0-2
  350. - fix chcon to ignore . and .. directories for recursing
  351. * Fri Feb 20 2004 Tim Waugh <twaugh@redhat.com> 5.2.0-1
  352. - Patch ls so that failed stat() is handled gracefully (Ulrich Drepper).
  353. - 5.2.0.
  354. * Thu Feb 19 2004 Tim Waugh <twaugh@redhat.com>
  355. - More AFS patch tidying.
  356. * Wed Feb 18 2004 Dan Walsh <dwalsh@redhat.com> 5.1.3-0.2
  357. - fix chcon to handle -h qualifier properly, eliminate potential crash
  358. * Wed Feb 18 2004 Tim Waugh <twaugh@redhat.com>
  359. - Stop 'sort -g' leaking memory (i18n patch bug #115620).
  360. - Don't ship kill, since util-linux already does.
  361. - Tidy AFS patch.
  362. * Mon Feb 16 2004 Tim Waugh <twaugh@redhat.com> 5.1.3-0.1
  363. - 5.1.3.
  364. - Patches ported forward or removed.
  365. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com> 5.0-40
  366. - rebuilt
  367. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-39
  368. - Change /etc/pam.d/su to remove preservuser and add multiple
  369. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-38
  370. - Change is_selinux_enabled to is_selinux_enabled > 0
  371. * Tue Jan 20 2004 Dan Walsh <dwalsh@redhat.com> 5.0-37
  372. - Add pam_selinux to pam file to allow switching of roles within selinux
  373. * Fri Jan 16 2004 Tim Waugh <twaugh@redhat.com>
  374. - The textutils-2.0.17-mem.patch is no longer needed.
  375. * Thu Jan 15 2004 Tim Waugh <twaugh@redhat.com> 5.0-36
  376. - Fixed autoconf test causing builds to fail.
  377. * Tue Dec 9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-35
  378. - Fix copying to non xattr files
  379. * Thu Dec 4 2003 Tim Waugh <twaugh@redhat.com> 5.0-34.sel
  380. - Fix column widths problems in ls.
  381. * Tue Dec 2 2003 Tim Waugh <twaugh@redhat.com> 5.0-33.sel
  382. - Speed up md5sum by disabling speed-up asm.
  383. * Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-32.sel
  384. - Try again
  385. * Wed Nov 19 2003 Dan Walsh <dwalsh@redhat.com> 5.0-31.sel
  386. - Fix move on non SELinux kernels
  387. * Fri Nov 14 2003 Tim Waugh <twaugh@redhat.com> 5.0-30.sel
  388. - Fixed useless acl dependencies (bug #106141).
  389. * Fri Oct 24 2003 Dan Walsh <dwalsh@redhat.com> 5.0-29.sel
  390. - Fix id -Z
  391. * Tue Oct 21 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28.sel
  392. - Turn on SELinux
  393. - Fix chcon error handling
  394. * Wed Oct 15 2003 Dan Walsh <dwalsh@redhat.com> 5.0-28
  395. - Turn off SELinux
  396. * Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27.sel
  397. - Turn on SELinux
  398. * Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-27
  399. - Turn off SELinux
  400. * Mon Oct 13 2003 Dan Walsh <dwalsh@redhat.com> 5.0-26.sel
  401. - Turn on SELinux
  402. * Sun Oct 12 2003 Florian La Roche <Florian.LaRoche@redhat.de>
  403. - allow compiling without pam support
  404. * Fri Oct 10 2003 Tim Waugh <twaugh@redhat.com> 5.0-23
  405. - Make split(1) handle large files (bug #106700).
  406. * Thu Oct 9 2003 Dan Walsh <dwalsh@redhat.com> 5.0-22
  407. - Turn off SELinux
  408. * Wed Oct 8 2003 Dan Walsh <dwalsh@redhat.com> 5.0-21.sel
  409. - Cleanup SELinux patch
  410. * Fri Oct 3 2003 Tim Waugh <twaugh@redhat.com> 5.0-20
  411. - Restrict ACL support to only those programs needing it (bug #106141).
  412. - Fix default PATH for LSB (bug #102567).
  413. * Thu Sep 11 2003 Dan Walsh <dwalsh@redhat.com> 5.0-19
  414. - Turn off SELinux
  415. * Wed Sep 10 2003 Dan Walsh <dwalsh@redhat.com> 5.0-18.sel
  416. - Turn on SELinux
  417. * Fri Sep 5 2003 Dan Walsh <dwalsh@redhat.com> 5.0-17
  418. - Turn off SELinux
  419. * Tue Sep 2 2003 Dan Walsh <dwalsh@redhat.com> 5.0-16.sel
  420. - Only call getfilecon if the user requested it.
  421. - build with selinux
  422. * Wed Aug 20 2003 Tim Waugh <twaugh@redhat.com> 5.0-14
  423. - Documentation fix (bug #102697).
  424. * Tue Aug 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-13
  425. - Made su use pam again (oops).
  426. - Fixed another i18n bug causing sort --month-sort to fail.
  427. - Don't run dubious stty test, since it fails when backgrounded
  428. (bug #102033).
  429. - Re-enable make check.
  430. * Fri Aug 8 2003 Tim Waugh <twaugh@redhat.com> 5.0-12
  431. - Don't run 'make check' for this build (build environment problem).
  432. - Another uninitialized variable in i18n (from bug #98683).
  433. * Wed Aug 6 2003 Dan Walsh <dwalsh@redhat.com> 5.0-11
  434. - Internationalize runcon
  435. - Update latest chcon from NSA
  436. * Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com>
  437. - Re-enable make check.
  438. * Wed Jul 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-9
  439. - Don't run 'make check' for this build (build environment problem).
  440. * Mon Jul 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-8
  441. - Actually use the ACL patch (bug #100519).
  442. * Fri Jul 18 2003 Dan Walsh <dwalsh@redhat.com> 5.0-7
  443. - Convert to SELinux
  444. * Mon Jun 9 2003 Tim Waugh <twaugh@redhat.com>
  445. - Removed samefile patch. Now the test suite passes.
  446. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  447. - rebuilt
  448. * Wed May 28 2003 Tim Waugh <twaugh@redhat.com> 5.0-5
  449. - Both kon and kterm support colours (bug #83701).
  450. - Fix 'ls -l' alignment in zh_CN locale (bug #88346).
  451. * Mon May 12 2003 Tim Waugh <twaugh@redhat.com> 5.0-4
  452. - Prevent file descriptor leakage in du (bug #90563).
  453. - Build requires recent texinfo (bug #90439).
  454. * Wed Apr 30 2003 Tim Waugh <twaugh@redhat.com> 5.0-3
  455. - Allow obsolete options unless POSIXLY_CORRECT is set.
  456. * Sat Apr 12 2003 Tim Waugh <twaugh@redhat.com>
  457. - Fold bug was introduced by i18n patch; fixed there instead.
  458. * Fri Apr 11 2003 Matt Wilson <msw@redhat.com> 5.0-2
  459. - fix segfault in fold (#88683)
  460. * Sat Apr 5 2003 Tim Waugh <twaugh@redhat.com> 5.0-1
  461. - 5.0.
  462. * Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com>
  463. - Use _smp_mflags.
  464. * Mon Mar 24 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-2
  465. - Remove overwrite patch.
  466. - No longer seem to need nolibrt, errno patches.
  467. * Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com>
  468. - No longer seem to need danglinglink, prompt, lug, touch_errno patches.
  469. * Thu Mar 20 2003 Tim Waugh <twaugh@redhat.com> 4.5.11-1
  470. - 4.5.11.
  471. - Use packaged readlink.
  472. * Wed Mar 19 2003 Tim Waugh <twaugh@redhat.com> 4.5.10-1
  473. - 4.5.10.
  474. - Update lug, touch_errno, acl, utmp, printf-ll, i18n, test-bugs patches.
  475. - Drop fr_fix, LC_TIME, preserve, regex patches.
  476. * Wed Mar 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-21
  477. - Fixed another i18n patch bug (bug #82032).
  478. * Tue Mar 11 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-20
  479. - Fix sort(1) efficiency in multibyte encoding (bug #82032).
  480. * Tue Feb 18 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-19
  481. - Ship readlink(1) (bug #84200).
  482. * Thu Feb 13 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-18
  483. - Deal with glibc < 2.2 in %%pre scriplet (bug #84090).
  484. * Wed Feb 12 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-16
  485. - Require glibc >= 2.2 (bug #84090).
  486. * Tue Feb 11 2003 Bill Nottingham <notting@redhat.com> 4.5.3-15
  487. - fix group (#84095)
  488. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 4.5.3-14
  489. - rebuilt
  490. * Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com>
  491. - Fix rm(1) man page.
  492. * Thu Jan 16 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-13
  493. - Fix re_compile_pattern check.
  494. - Fix su hang (bug #81653).
  495. * Tue Jan 14 2003 Tim Waugh <twaugh@redhat.com> 4.5.3-11
  496. - Fix memory size calculation.
  497. * Tue Dec 17 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-10
  498. - Fix mv error message (bug #79809).
  499. * Mon Dec 16 2002 Tim Powers <timp@redhat.com> 4.5.3-9
  500. - added PreReq on grep
  501. * Fri Dec 13 2002 Tim Waugh <twaugh@redhat.com>
  502. - Fix cp --preserve with multiple arguments.
  503. * Thu Dec 12 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-8
  504. - Turn on colorls for screen (bug #78816).
  505. * Mon Dec 9 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-7
  506. - Fix mv (bug #79283).
  507. - Add patch27 (nogetline).
  508. * Sun Dec 1 2002 Tim Powers <timp@redhat.com> 4.5.3-6
  509. - use the su.pamd from sh-utils since it works properly with multilib systems
  510. * Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-5
  511. - Fix test suite quoting problems.
  512. * Fri Nov 29 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-4
  513. - Fix scriplets.
  514. - Fix i18n patch so it doesn't break uniq.
  515. - Fix several other patches to either make the test suite pass or
  516. not run the relevant tests.
  517. - Run 'make check'.
  518. - Fix file list.
  519. * Thu Nov 28 2002 Tim Waugh <twaugh@redhat.com> 4.5.3-3
  520. - Adapted for Red Hat Linux.
  521. - Self-host for help2man.
  522. - Don't ship readlink just yet (maybe later).
  523. - Merge patches from fileutils and sh-utils (textutils ones are already
  524. merged it seems).
  525. - Keep the binaries where the used to be (in particular, id and stat).
  526. * Sun Nov 17 2002 Stew Benedict <sbenedict@mandrakesoft.com> 4.5.3-2mdk
  527. - LI18NUX/LSB compliance (patch800)
  528. - Installed (but unpackaged) file(s) - /usr/share/info/dir
  529. * Thu Oct 31 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.3-1mdk
  530. - new release
  531. - rediff patch 180
  532. - merge patch 150 into 180
  533. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-6mdk
  534. - move su back to /bin
  535. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-5mdk
  536. - patch 0 : lg locale is illegal and must be renamed lug (pablo)
  537. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-4mdk
  538. - fix conflict with procps
  539. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-3mdk
  540. - patch 105 : fix install -s
  541. * Mon Oct 14 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-2mdk
  542. - fix build
  543. - don't chmode two times su
  544. - build with large file support
  545. - fix description
  546. - various spec cleanups
  547. - fix chroot installation
  548. - fix missing /bin/env
  549. - add old fileutils, sh-utils & textutils ChangeLogs
  550. * Fri Oct 11 2002 Thierry Vignaud <tvignaud@mandrakesoft.com> 4.5.2-1mdk
  551. - initial release (merge fileutils, sh-utils & textutils)
  552. - obsoletes/provides: sh-utils/fileutils/textutils
  553. - fileutils stuff go in 1xx range
  554. - sh-utils stuff go in 7xx range
  555. - textutils stuff go in 5xx range
  556. - drop obsoletes patches 1, 2, 10 (somes files're gone but we didn't ship
  557. most of them)
  558. - rediff patches 103, 105, 111, 113, 180, 706
  559. - temporary disable patch 3 & 4
  560. - fix fileutils url