cmake-vl.spec 8.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305
  1. # Set to bcond_without or use --with bootstrap if bootstrapping a new release
  2. # or architecture
  3. %bcond_with bootstrap
  4. # Set to bcond_with or use --without gui to disable qt4 gui build
  5. %bcond_with gui
  6. Name: cmake
  7. Summary: Cross-platform make system
  8. Summary(ja): クロスプラットフォームな Make システム
  9. Version: 3.29.5
  10. Release: 1%{?_dist_release}
  11. Group: programming
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: BSD
  15. URL: https://www.cmake.org/
  16. Source0: https://github.com/Kitware/CMake/releases/download/v%{version}/cmake-%{version}.tar.gz
  17. Source1: macros.cmake
  18. Source3: %{name}.attr
  19. Source4: %{name}.prov
  20. Source5: %{name}.req
  21. # Patch to fix RindRuby vendor settings
  22. # http://public.kitware.com/Bug/view.php?id=12965
  23. # https://bugzilla.redhat.com/show_bug.cgi?id=822796
  24. Patch100: %{name}-findruby.patch
  25. BuildRequires: curl-devel
  26. BuildRequires: expat-devel
  27. BuildRequires: gcc-gfortran
  28. BuildRequires: libarchive-devel
  29. #BuildRequires: libidn-devel
  30. BuildRequires: ncurses-devel
  31. BuildRequires: openssl-devel
  32. BuildRequires: zlib-devel
  33. BuildRequires: xz-devel
  34. BuildRequires: jsoncpp-devel
  35. %if %{with gui}
  36. BuildRequires: qt4-devel, desktop-file-utils
  37. %define qt_gui --qt-gui
  38. %else
  39. %define qt_gui --no-qt-gui
  40. %endif
  41. Provides: %{name}-filesystem%{?_isa} = %{version}-%{release}
  42. %global major_version %(echo %{version} | cut -d . -f 1)
  43. %global minor_version %(echo %{version} | cut -d . -f 2)
  44. %description
  45. CMake is used to control the software compilation process using simple
  46. platform and compiler independent configuration files. CMake generates
  47. native makefiles and workspaces that can be used in the compiler
  48. environment of your choice. CMake is quite sophisticated: it is possible
  49. to support complex environments requiring system configuration, pre-processor
  50. generation, code generation, and template instantiation.
  51. %package gui
  52. Summary: Qt GUI for %{name}
  53. Group: programming
  54. Requires: %{name} = %{version}-%{release}
  55. Requires(post): desktop-file-utils, shared-mime-info
  56. Requires(postun): desktop-file-utils, shared-mime-info
  57. %description gui
  58. The %{name}-gui package contains the Qt based GUI for CMake.
  59. %debug_package
  60. %prep
  61. %setup -q
  62. %autopatch -p1
  63. %build
  64. %{set_build_flags}
  65. ./bootstrap \
  66. --prefix=%{_prefix} \
  67. --datadir=/share/%{name} \
  68. --docdir=/share/doc/%{name} \
  69. --mandir=/share/man \
  70. %if 0%{?with_bootstrap}
  71. --no-system-libs \
  72. %else
  73. --system-curl \
  74. --system-expat \
  75. --system-jsoncpp \
  76. --system-zlib \
  77. --system-bzip2 \
  78. --system-liblzma \
  79. --system-libarchive \
  80. --no-system-librhash \
  81. %endif
  82. --parallel=`/usr/bin/getconf _NPROCESSORS_ONLN` \
  83. %{?qt_gui} \
  84. -- -DCMAKE_USE_SYSTEM_LIBUV=OFF
  85. # sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
  86. make VERBOSE=1 %{?_smp_mflags}
  87. %install
  88. rm -rf %{buildroot}
  89. make install DESTDIR=%{buildroot}
  90. find %{buildroot}/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  91. rm -rf %{buildroot}/usr/doc
  92. # RPM macros
  93. install -p -m0644 -D %{SOURCE1} %{buildroot}%{_rpmmacrodir}/macros.cmake
  94. sed -i -e "s|@@CMAKE_MAJOR_VERSION@@|%{major_version}|" %{buildroot}%{_rpmmacrodir}/macros.cmake
  95. touch -r %{SOURCE1} %{buildroot}%{_rpmmacrodir}/macros.cmake
  96. # RPM auto provides
  97. install -p -m0644 -D %{SOURCE3} %{buildroot}%{_prefix}/lib/rpm/fileattrs/%{name}.attr
  98. install -p -m0755 -D %{SOURCE4} %{buildroot}%{_prefix}/lib/rpm/%{name}.prov
  99. install -p -m0755 -D %{SOURCE5} %{buildroot}%{_prefix}/lib/rpm/%{name}.req
  100. %if %{with gui}
  101. # Desktop file
  102. desktop-file-install --delete-original \
  103. --dir=%{buildroot}%{_datadir}/applications \
  104. %{buildroot}/%{_datadir}/applications/CMake.desktop
  105. %endif
  106. rm -rf doc
  107. mv -f %{buildroot}%{_docdir}/%{name} ./doc
  108. %clean
  109. rm -rf $RPM_BUILD_ROOT
  110. %files
  111. %defattr(-,root,root)
  112. %doc CMakeLogo.gif README.* doc
  113. %doc Help
  114. %license Copyright.txt Licenses/*
  115. %config(noreplace) %{_rpmmacrodir}/macros.cmake
  116. %{_rpmconfigdir}/fileattrs/%{name}.attr
  117. %{_rpmconfigdir}/%{name}.prov
  118. %{_rpmconfigdir}/%{name}.req
  119. %{_bindir}/ccmake
  120. %{_bindir}/cmake
  121. %{_bindir}/cpack
  122. %{_bindir}/ctest
  123. %{_datadir}/%{name}/
  124. %{_datadir}/aclocal/cmake.m4
  125. %dir %{_datadir}/bash-completion
  126. %dir %{_datadir}/bash-completion/completions
  127. %{_datadir}/bash-completion/completions/*
  128. %exclude /usr/share/vim
  129. %exclude /usr/share/emacs
  130. %if %{with gui}
  131. %files gui
  132. %defattr(-,root,root,-)
  133. %{_bindir}/cmake-gui
  134. %{_datadir}/applications/CMake.desktop
  135. %{_datadir}/mime/packages/cmakecache.xml
  136. %{_datadir}/icons/hicolor/*/*/*
  137. %endif
  138. %changelog
  139. * Mon Jun 17 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.29.5-1
  140. - new upstream release.
  141. * Fri Nov 18 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.25.0-1
  142. - new upstream release.
  143. * Fri Oct 28 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.24.2-1
  144. - new upstream release.
  145. * Sat Nov 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.22.0-1
  146. - new upstream release.
  147. * Tue Aug 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.1-1
  148. - new upstream release.
  149. * Sun Mar 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.20.0-1
  150. - nre upstream release.
  151. - updated macros.req.
  152. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.19.6-1
  153. - updated to 3.19.6.
  154. - updated macros.cmake.
  155. * Thu Jul 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.18.0-1
  156. - updated to 3.18.0.
  157. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.15.3-1
  158. - updated to 3.15.3.
  159. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.10.1-1
  160. - updated to 3.10.1.
  161. - updated macros.cmake.
  162. - disabled gui.
  163. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-2
  164. - rebuild with gcc-5.4.0
  165. * Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
  166. - update to 3.5.2
  167. - add BuildRequires: xz-devel, jsoncpp-devel
  168. - remove old patches
  169. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  170. - update to 2.8.12.2
  171. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  172. - update to 2.8.12.2
  173. - add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
  174. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
  175. - rebuild with libarchive-3.1.2
  176. * Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
  177. - new upstream release
  178. - add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
  179. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
  180. - new upstream release
  181. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
  182. - new upstream release
  183. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
  184. - new upstream release
  185. - fixed desktop file warning
  186. * Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
  187. - rebuild with libarchive-3.0.4
  188. * Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
  189. - new upstream release
  190. - forced to link with libtinfo.so (ccmake)
  191. - used --system-libs again
  192. * Sat Jan 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
  193. - new upstream release
  194. - used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
  195. * Sun Sep 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
  196. - fixed typo (not --with-system-libs, but --system-libs)
  197. - added BR: curl-devel, expat-devel, zlib-devel
  198. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  199. - add BuildRequires: ncurses-devel
  200. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  201. - generate gui package
  202. - renamed module directory
  203. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  204. - new upstream release
  205. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  206. - rebuilt with new toolchain
  207. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  208. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  209. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  210. - new upstream release
  211. - added Vendor/Distribution tag
  212. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  213. - new upstream release
  214. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  215. - new upstream release
  216. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  217. - new upstream release
  218. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  219. - new upstream release
  220. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  221. - new upstream release
  222. - drop Patch100
  223. - use bootstrap script instead of configure
  224. - delete caches from %%doc
  225. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  226. - rebuilt with new toolchain
  227. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  228. - new upstream release
  229. - delete duped docs
  230. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  231. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  232. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  233. - source version up
  234. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  235. - initial build for Vine Linux