clang-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598
  1. %bcond_with test
  2. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  3. %define ver_suffix %(echo "%{version}" | cut -d . -f 1)
  4. %define _unpackaged_files_terminate_build 1
  5. # Documentation install path
  6. %global llvmdocdir() %{_docdir}/%1-%{version}
  7. %define _unpackaged_files_terminate_build 1
  8. Summary: A C language family front-end for LLVM
  9. Summary(ja): LLVM の C 言語フロントエンド
  10. Name: clang
  11. Version: 18.1.5
  12. Release: 1%{?_dist_release}
  13. Group: programming
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: NCSA
  17. URL: https://llvm.org/
  18. Source0: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
  19. Source1: https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
  20. # multilib fixes
  21. Source11: clang-config.h
  22. # Patches for clang
  23. Patch1: 0001-PATCH-clang-Make-funwind-tables-the-default-on-all-a.patch
  24. Patch2: 0003-PATCH-clang-Don-t-install-static-libraries.patch
  25. # Workaround a bug in ORC on ppc64le.
  26. # More info is available here: https://reviews.llvm.org/D159115#4641826
  27. Patch5: 0001-Workaround-a-bug-in-ORC-on-ppc64le.patch
  28. # RHEL specific patches
  29. # Avoid unwanted dependency on python-myst-parser
  30. Patch101: 0009-disable-myst-parser.patch
  31. %if %{without compat_build}
  32. # Patches for clang-tools-extra
  33. # See https://reviews.llvm.org/D120301
  34. Patch201: 0001-clang-tools-extra-Make-test-dependency-on-LLVMHello-.patch
  35. %endif
  36. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  37. BuildRequires: cmake
  38. BuildRequires: ninja
  39. BuildRequires: llvm-devel = %{version}
  40. BuildRequires: llvm-static = %{version}
  41. BuildRequires: libatomic
  42. BuildRequires: libxml2-devel
  43. BuildRequires: perl
  44. BuildRequires: ncurses-devel
  45. BuildRequires: python3
  46. BuildRequires: python3-devel
  47. Requires: llvm = %{version}-%{release}
  48. # clang requires gcc, clang++ requires libstdc++-devel
  49. Requires: libstdc++-devel
  50. # LLVM is not supported on PPC64
  51. # http://llvm.org/bugs/show_bug.cgi?id=3729
  52. ExcludeArch: ppc64
  53. %description
  54. clang: noun
  55. 1. A loud, resonant, metallic sound.
  56. 2. The strident call of a crane or goose.
  57. 3. C-language family front-end toolkit.
  58. The goal of the Clang project is to create a new C, C++, Objective C
  59. and Objective C++ front-end for the LLVM compiler. Its tools are built
  60. as libraries and designed to be loosely-coupled and extensible.
  61. %Package libs
  62. Summary: Runtime library for clang
  63. Summary(ja): Clang のランタイムライブラリ
  64. Group: system
  65. %description libs
  66. Runtime library for clang.
  67. %description libs -l ja
  68. Clang のランタイムライブラリです.
  69. %package devel
  70. Summary: Header files for clang
  71. Summary(ja): Clang のヘッダファイル
  72. Group: programming
  73. Requires: clang = %{version}-%{release}
  74. %description devel
  75. This package contains header files for the Clang compiler.
  76. %description devel -l ja
  77. Clang コンパイラのヘッダファイル集です.
  78. %package analyzer
  79. Summary: A source code analysis framework
  80. Summary(ja): ソースコード分析フレームワーク
  81. License: NCSA
  82. Group: programming
  83. Requires: clang = %{version}-%{release}
  84. # not picked up automatically since files are currently not instaled
  85. # in standard Python hierarchies yet
  86. Requires: python3
  87. %description analyzer
  88. The Clang Static Analyzer consists of both a source code analysis
  89. framework and a standalone tool that finds bugs in C and Objective-C
  90. programs. The standalone tool is invoked from the command-line, and is
  91. intended to run in tandem with a build of a project or code base.
  92. %package -n python3-clang
  93. Summary: Python3 bindings for clang
  94. Group: programming
  95. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  96. Requires: python3
  97. %description -n python3-clang
  98. Python3 bindings for clang
  99. %package tools-extra
  100. Summary: Extra tools for clang
  101. Group: programming
  102. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  103. %description tools-extra
  104. A set of extra tools built using Clang's tooling API.
  105. %debug_package
  106. %prep
  107. %setup -T -q -b 1 -n clang-tools-extra-%{version}.src
  108. %autopatch -m200 -p2
  109. # failing test case
  110. rm test/clang-tidy/checkers/altera/struct-pack-align.cpp
  111. pathfix%{python3_version}.py -i %{__python3} -pn \
  112. clang-tidy/tool/ \
  113. clang-include-fixer/find-all-symbols/tool/run-find-all-symbols.py
  114. %setup -q -n clang-%{version}.src
  115. %autopatch -M200 -p2
  116. # failing test case
  117. rm test/CodeGen/profile-filter.c
  118. pathfix%{python3_version}.py -i %{__python3} -pn \
  119. tools/clang-format/ \
  120. tools/clang-format/git-clang-format \
  121. utils/hmaptool/hmaptool \
  122. tools/scan-view/bin/scan-view \
  123. tools/scan-view/share/Reporter.py \
  124. tools/scan-view/share/startfile.py \
  125. tools/scan-build-py/bin/* \
  126. tools/scan-build-py/libexec/*
  127. sed -i -e 's/"i686-linux-gnu",/"i686-linux-gnu","i686-vine-linux","i686-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  128. sed -i -e 's/"x86_64-linux-gnu",/"x86_64-linux-gnu","x86_64-vine-linux","x86_64-vine-linux-gnu",/' lib/Driver/ToolChains/Gnu.cpp
  129. #sed -i -e 's/"ld"/"ld.gold"/' include/clang/Driver/ToolChain.h
  130. %build
  131. # lto builds with gcc 11 fail while running the lit tests.
  132. %define _lto_cflags %{nil}
  133. %ifarch s390 s390x %{arm} %ix86
  134. # Decrease debuginfo verbosity to reduce memory consumption during final library linking
  135. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  136. %endif
  137. %cmake \
  138. -GNinja \
  139. -DCLANG_DEFAULT_PIE_ON_LINUX=OFF \
  140. -DLLVM_PARALLEL_LINK_JOBS=1 \
  141. -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
  142. -DCMAKE_BUILD_TYPE=RelWithDebInfo \
  143. -DPYTHON_EXECUTABLE=%{__python3} \
  144. -DCMAKE_SKIP_RPATH:BOOL=ON \
  145. %ifarch %ix86
  146. -DCMAKE_C_FLAGS_RELWITHDEBINFO="%{optflags} -DNDEBUG" \
  147. -DCMAKE_CXX_FLAGS_RELWITHDEBINFO="%{optflags} -DNDEBUG" \
  148. %endif
  149. -DLLVM_CMAKE_DIR=%{_libdir}/cmake/llvm \
  150. %if 0%{?__isa_bits} == 64
  151. -DLLVM_LIBDIR_SUFFIX=64 \
  152. %else
  153. -DLLVM_LIBDIR_SUFFIX= \
  154. %endif
  155. -DCLANG_INCLUDE_TESTS:BOOL=OFF \
  156. -DLLVM_BUILD_UTILS:BOOL=ON \
  157. -DLLVM_EXTERNAL_CLANG_TOOLS_EXTRA_SOURCE_DIR=../clang-tools-extra-%{version}.src \
  158. -DLLVM_MAIN_SRC_DIR=%{_datadir}/llvm/src \
  159. \
  160. -DLLVM_TABLEGEN_EXE:FILEPATH=%{_bindir}/llvm-tblgen \
  161. -DLLVM_COMMON_CMAKE_UTILS=%{_datadir}/llvm/cmake \
  162. -DCLANG_ENABLE_ARCMT:BOOL=ON \
  163. -DCLANG_ENABLE_STATIC_ANALYZER:BOOL=ON \
  164. -DCLANG_INCLUDE_DOCS:BOOL=ON \
  165. -DCLANG_PLUGIN_SUPPORT:BOOL=OFF \
  166. -DLLVM_ENABLE_PLUGINS:BOOL=OFF \
  167. -DENABLE_LINKER_BUILD_ID:BOOL=ON \
  168. -DLLVM_ENABLE_EH=ON \
  169. -DLLVM_ENABLE_RTTI=ON \
  170. -DLLVM_BUILD_DOCS=ON \
  171. -DLLVM_ENABLE_SPHINX=OFF \
  172. -DLLVM_INCLUDE_TESTS:BOOL=OFF \
  173. -DCLANG_LINK_CLANG_DYLIB=ON \
  174. \
  175. -DCLANG_LINK_CLANG_DYLIB=ON \
  176. -DCLANG_BUILD_EXAMPLES:BOOL=OFF \
  177. -DBUILD_SHARED_LIBS=OFF \
  178. -DCLANG_REPOSITORY_STRING="Vine Linux %{version}-%{release}" \
  179. -DCLANG_DEFAULT_UNWINDLIB=libgcc
  180. %cmake_build
  181. %install
  182. rm -rf %{buildroot}
  183. %cmake_install
  184. # remove static libraries
  185. rm -fv %{buildroot}%{_libdir}/libclang*.a
  186. # Add clang++-{version} symlink
  187. ln -s clang++ %{buildroot}%{_bindir}/clang++-%{ver_suffix}
  188. # install clang python bindings
  189. mkdir -p %{buildroot}%{python3_sitelib}/clang/
  190. install -p -m644 bindings/python/clang/* %{buildroot}%{python3_sitelib}/clang/
  191. # install scanbuild-py to python sitelib.
  192. mv %{buildroot}%{_libdir}/{libear,libscanbuild} %{buildroot}%{python3_sitelib}
  193. mv -v %{buildroot}%{_includedir}/clang/Config/config{,-%{__isa_bits}}.h
  194. install -m 0644 %{SOURCE11} %{buildroot}%{_includedir}/clang/Config/config.h
  195. # TODO: Package html docs
  196. rm -Rvf %{buildroot}%{_docdir}/clang/html
  197. rm -Rvf %{buildroot}%{_datadir}/clang/clang-doc-default-stylesheet.css
  198. rm -Rvf %{buildroot}%{_datadir}/clang/index.js
  199. # remove git integration
  200. rm -vf %{buildroot}%{_bindir}/git-clang-format
  201. # remove editor integrations (bbedit, sublime, emacs, vim)
  202. rm -vf %{buildroot}%{_datadir}/clang/clang-format-bbedit.applescript
  203. rm -vf %{buildroot}%{_datadir}/clang/clang-format-sublime.py*
  204. rm -vf %{buildroot}%{_datadir}/clang/clang-format.el
  205. rm -vf %{buildroot}%{_datadir}/clang/clang-format.py*
  206. # remove diff reformatter
  207. rm -vf %{buildroot}%{_datadir}/clang/clang-format-diff.py*
  208. rm -f %{buildroot}%{_datadir}/clang/bash-autocomplete.sh
  209. rm -f %{buildroot}%{_datadir}/clang/clang-rename.el
  210. rm -f %{buildroot}%{_datadir}/clang/clang-rename.py
  211. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.el
  212. rm -f %{buildroot}%{_datadir}/clang/clang-include-fixer.py
  213. # Remove clang-tidy headers. We don't ship the libraries for these.
  214. rm -Rvf %{buildroot}%{_includedir}/clang-tidy/
  215. %if %{with test}
  216. %check
  217. %ctest check-clang
  218. %endif
  219. %clean
  220. rm -rf %{buildroot}
  221. %files
  222. %defattr(-,root,root,-)
  223. #doc %{llvmdocdir clang}/
  224. %{_bindir}/clang
  225. %{_bindir}/clang++
  226. %{_bindir}/clang-%{ver_suffix}
  227. %{_bindir}/clang++-%{ver_suffix}
  228. %{_bindir}/clang-cl
  229. %{_bindir}/clang-cpp
  230. %files libs
  231. %defattr(-,root,root,-)
  232. %{_libdir}/clang
  233. %{_libdir}/libclang.so.*
  234. %{_libdir}/libclang-cpp.so.*
  235. %files devel
  236. %defattr(-,root,root,-)
  237. #doc %{llvmdocdir clang-devel}/
  238. %{_libdir}/libclang.so
  239. %{_libdir}/libclang-cpp.so
  240. %{_includedir}/clang
  241. %{_includedir}/clang-c
  242. %dir %{_datadir}/clang/
  243. %{_libdir}/cmake/*
  244. %files analyzer
  245. %defattr(-,root,root,-)
  246. %{_bindir}/analyze-build
  247. %{_bindir}/intercept-build
  248. %{_bindir}/scan-build
  249. %{_bindir}/scan-build-py
  250. %{_bindir}/scan-view
  251. %{_libexecdir}/ccc-analyzer
  252. %{_libexecdir}/c++-analyzer
  253. %{_libexecdir}/analyze-c++
  254. %{_libexecdir}/analyze-cc
  255. %{_libexecdir}/intercept-c++
  256. %{_libexecdir}/intercept-cc
  257. %{_datadir}/scan-view
  258. %{_datadir}/scan-build
  259. %{_mandir}/man1/scan-build.1.*
  260. %{python3_sitelib}/libear
  261. %{python3_sitelib}/libscanbuild
  262. %files -n python3-clang
  263. %{python3_sitelib}/clang/
  264. %files tools-extra
  265. %{_bindir}/amdgpu-arch
  266. %{_bindir}/c-index-test
  267. %{_bindir}/clang*
  268. %exclude %{_bindir}/clang
  269. %exclude %{_bindir}/clang++
  270. %exclude %{_bindir}/clang-%{ver_suffix}
  271. %exclude %{_bindir}/clang++-%{ver_suffix}
  272. %exclude %{_bindir}/clang-cl
  273. %exclude %{_bindir}/clang-cpp
  274. %{_bindir}/diagtool
  275. %{_bindir}/find-all-symbols
  276. %{_bindir}/hmaptool
  277. %{_bindir}/modularize
  278. %{_bindir}/nvptx-arch
  279. %{_bindir}/pp-trace
  280. %{_bindir}/run-clang-tidy
  281. %{_datadir}/clang/clang-tidy-diff.py*
  282. %{_datadir}/clang/run-find-all-symbols.py*
  283. %changelog
  284. * Sat May 04 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 18.1.5-1
  285. - new upstream release.
  286. * Sat Oct 07 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.2-1
  287. - new upstream release.
  288. * Sat Sep 30 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 17.0.1-1
  289. - new upstream release.
  290. * Sun May 28 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 16.0.4-1
  291. - new upstream release.
  292. * Fri Dec 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.6-1
  293. - new upstream release.
  294. * Wed Oct 05 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.2-1
  295. - new upstream release.
  296. * Wed Sep 07 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 15.0.0-1
  297. - new upstream release.
  298. * Wed Jun 15 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 14.0.5-1
  299. - new upstream release.
  300. - dropped patch5.
  301. - updated Patch1.
  302. - imported Patch5-202 from rawhide.
  303. * Thu Feb 03 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.1-1
  304. - new upstream release.
  305. * Fri Oct 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 13.0.0-1
  306. - new upstream release.
  307. - refreshed patches.
  308. * Wed Aug 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.1-1
  309. - new upstream release.
  310. - refreshed patches.
  311. * Sat Apr 17 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 12.0.0-1
  312. - devided clang from llvm.
  313. - new upstream release.
  314. * Fri Oct 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-2
  315. - enabled to build utils.
  316. * Thu Oct 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 11.0.0-1
  317. - new upstream release.
  318. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.1-1
  319. - new upstream release.
  320. * Thu Apr 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-2
  321. - rebuilt with libffi-3.3.
  322. * Fri Mar 27 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.0-1
  323. - new upstream release.
  324. * Sun Dec 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.1-1
  325. - new upstream release.
  326. * Sun Sep 22 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-2
  327. - dropped all patches.
  328. - switched build-system to ninja.
  329. - switched python to python3.
  330. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.0.0-1
  331. - new upstream release.
  332. - added OpenMP.
  333. * Sun Dec 16 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.1-1
  334. - fixed %%files.
  335. * Wed Dec 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.0.0-1
  336. - new upstream release.
  337. - dropped Patch0, 4, 5, 100 and 200.
  338. - imported Patch3, 7, 12, 15, 100, 101, 102 and 400 from rawhide.
  339. - renamed a subpackage "llvm-libs".
  340. - added a subpackage "lld".
  341. * Tue Jan 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-2
  342. - added subpackages "llvm-static", "python-lldb" and "python-clang".
  343. * Mon Jan 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.1-1
  344. - new upstream release.
  345. - dropped Patch1 and 2: fixed in upstream.
  346. - imported Patch0, 3-5, 100 and 200 from rawhide.
  347. - disabled Patch1002: no longer needed?
  348. * Fri Aug 5 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.8.1-1
  349. - new upstream release.
  350. - switched to cmake.
  351. - disable ocaml binding as default.
  352. - updated Patch1000 and 1002.
  353. - disabled Patch1000 as default.
  354. - cleanup patches.
  355. * Thu Jun 30 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.6.2-2
  356. - rebuild with gcc-5.4.0
  357. * Sat Sep 5 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.2-1
  358. - new upstream release
  359. - added BR: ocaml-ctypes
  360. * Thu Jun 4 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.6.1-1
  361. - new upstream release
  362. - dropt Patch 1, 201 and 1001
  363. - updated Patch 1000
  364. * Tue Mar 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.5.1-1
  365. - updated to 3.5.1
  366. - added Patch1, 2, 100, 101, 200, 201 and 202 from Fedora
  367. - added clang-libs, lldb, lldb-devel and compat32-llvm-libs subpackage
  368. - obsoleted clang-doc
  369. - built with ocaml 4.02.1
  370. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-2
  371. - fix <BTS:2832>
  372. - fix configure option "--with-c-include-dirs"
  373. - update Patch1000: clang-3.5.0-driver-ld.gold.patch
  374. - update Patch1001: clang-3.5.0-driver-lib64.patch
  375. - update Patch1002: clang-3.5.0-driver-vine.patch
  376. * Tue Oct 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.0-1
  377. - update to 3.5.0
  378. - remove Patch11 (clang-hardfloat-hack.patch)
  379. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3-2
  380. - rebuild with libffi-3.0.13
  381. * Mon Oct 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 3.3-1
  382. - update to 3.3
  383. * Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-2
  384. - ld.gold (patch1000,1001)
  385. - add /%{_lib} to ld search path
  386. - add support *-vine-linux gcc (patch1002)
  387. * Fri Nov 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 3.1-1
  388. - update to 3.1
  389. * Tue Jan 24 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 3.0-1
  390. - updated to 3.0 release
  391. * Sun Jan 15 2012 NAKAMURA Kenta <kenta@vinelinux.org> - 2.9-3
  392. - added patch 2-4 to support -O4 link-time optimization
  393. * Fri Sep 9 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.9-2
  394. - disable -fno-var-tracking-assignments on ppc
  395. (seems like gcc-4.4.5 still doesn't support this)
  396. * Thu Aug 25 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9-1
  397. - new upstream release
  398. - add BR: libffi-devel
  399. - add R: libffi-devel to -devel
  400. * Sun May 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7-1
  401. - initial build for Vine Linux
  402. * Sun May 2 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-1
  403. - Update to final 2.7 release
  404. * Sun Mar 28 2010 Michel Salim <salimma@fedoraproject.org> - 2.7-0.1.pre1
  405. - Update to first 2.7 pre-release
  406. * Fri Sep 18 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.6.pre2
  407. - Update to 2.6 pre-release2
  408. - -devel subpackage now virtually provides -static
  409. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.5.pre1
  410. - Disable var tracking assignments on PPC
  411. * Wed Sep 9 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.4.pre1
  412. - Don't adjust clang include dir; files there are noarch (bz#521893)
  413. - Enable clang unit tests
  414. - clang and clang-analyzer renamed; no longer depend on llvm at runtime
  415. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.3.pre1
  416. - Package Clang's static analyzer tools
  417. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.2.pre1
  418. - PIC is now enabled by default; explicitly disable on %%{ix86}
  419. * Mon Sep 7 2009 Michel Salim <salimma@fedoraproject.org> - 2.6-0.1.pre1
  420. - First 2.6 prerelease
  421. - Enable Clang front-end
  422. - Enable debuginfo generation
  423. * Sat Sep 5 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-6
  424. - Disable assertions (needed by OpenGTL, bz#521261)
  425. - Align spec file with upstream build instructions
  426. - Enable unit tests
  427. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-5
  428. - Only disable PIC on %%ix86; ppc actually needs it
  429. * Sat Aug 22 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-4
  430. - Disable use of position-independent code on 32-bit platforms
  431. (buggy in LLVM <= 2.5)
  432. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5-3
  433. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  434. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-2
  435. - Remove build scripts; they require the build directory to work
  436. * Wed Mar 4 2009 Michel Salim <salimma@fedoraproject.org> - 2.5-1
  437. - Update to 2.5
  438. - Package build scripts (bug #457881)
  439. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-2
  440. - Patched build process for the OCaml binding
  441. * Tue Dec 2 2008 Michel Salim <salimma@fedoraproject.org> - 2.4-1
  442. - Update to 2.4
  443. - Package Ocaml binding
  444. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-2
  445. - Add dependency on groff
  446. * Wed Jun 18 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.3-1
  447. - LLVM 2.3
  448. * Thu May 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.2-4
  449. - fix license tags
  450. * Wed Mar 5 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.2-3
  451. - Fix compilation problems with gcc 4.3
  452. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.2-2
  453. - Autorebuild for GCC 4.3
  454. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-2
  455. - Fix review comments
  456. * Sun Jan 20 2008 Bryan O'Sullivan <bos@serpentine.com> - 2.1-1
  457. - Initial version