python3-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374
  1. # if you wanna test, add " --define '_run_test 1' " option to rpmbuild command
  2. %define run_test %{?_run_test:1}%{!?_run_test:0}
  3. %define libvers 3.5
  4. %define binsuffix 3.5
  5. %define python_lib %{_libdir}/python%{libvers}
  6. %define config_htmldir /var/www/html/python
  7. Summary: An interpreted, interactive, object-oriented programming language.
  8. Summary(ja): オブジェクト指向 Python3 インタプリタ
  9. Name: python3
  10. Version: 3.5.6
  11. Release: 2%{?_dist_release}
  12. License: PSF
  13. Group: Development/Languages
  14. URL: http://www.python.org/download/releases/%{version}
  15. Source0: http://www.python.org/ftp/python/%{version}/Python-%{version}.tar.xz
  16. Source1: https://docs.python.org/3.5/archives/python-%{version}-docs-html.tar.bz2
  17. Patch1: python-3.5.2-lib64.patch
  18. Patch2: python3-3.4.4-revert-makefile.patch
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. BuildRequires: gzip tar gcc-c++ pkgconfig sed findutils
  21. BuildRequires: bzip2-devel
  22. BuildRequires: expat-devel
  23. BuildRequires: gdbm-devel
  24. BuildRequires: glibc-devel
  25. BuildRequires: libdb-devel
  26. BuildRequires: libffi-devel
  27. BuildRequires: ncurses-devel
  28. BuildRequires: openssl-devel
  29. BuildRequires: readline-devel
  30. BuildRequires: sqlite3-devel
  31. BuildRequires: valgrind-devel
  32. BuildRequires: zlib-devel
  33. Requires: bzip2
  34. Requires: gdbm
  35. Requires: ncurses
  36. Requires: openssl
  37. Requires: readline
  38. Requires: sqlite3
  39. Requires: zlib
  40. Vendor: Project Vine
  41. Distribution: Vine Linux
  42. %description
  43. Python is an interpreted, interactive, object-oriented programming
  44. language. It incorporates modules, exceptions, dynamic typing, very high
  45. level dynamic data types, and classes. Python combines remarkable power
  46. with very clear syntax. It has interfaces to many system calls and
  47. libraries, as well as to various window systems, and is extensible in C or
  48. C++. It is also usable as an extension language for applications that need
  49. a programmable interface. Finally, Python is portable: it runs on many
  50. brands of UNIX, on PCs under Windows, MS-DOS, and OS/2, and on the
  51. Mac.
  52. %package devel
  53. Summary: The libraries and header files needed for Python development.
  54. Group: Development/Libraries
  55. Requires: %{name} = %{version}-%{release}
  56. %description devel
  57. The Python programming language's interpreter can be extended with
  58. dynamically loaded extensions and can be embedded in other programs.
  59. This package contains the header files and libraries needed to do
  60. these types of tasks.
  61. Install python-devel if you want to develop Python extensions. The
  62. python package will also need to be installed. You'll probably also
  63. want to install the python-docs package, which contains Python
  64. documentation.
  65. %package tkinter
  66. Summary: A graphical user interface for the Python scripting language.
  67. Group: Development/Languages
  68. Requires: %{name} = %{version}-%{release}
  69. Requires: tcl, tk, tix
  70. Requires: libX11, libxcb, libXau, libXdmcp
  71. BuildRequires: tcl-devel, tk-devel, tix
  72. BuildRequires: libX11-devel, libxcb-devel, libXau-devel, libXdmcp-devel
  73. %description tkinter
  74. The Tkinter (Tk interface) program is an graphical user interface for
  75. the Python scripting language.
  76. You should install the tkinter package if you'd like to use a graphical
  77. user interface for Python programming.
  78. %package tools
  79. Summary: A collection of development tools included with Python.
  80. Group: Development/Tools
  81. Requires: %{name} = %{version}-%{release}
  82. Requires: %{name}-tkinter = %{version}
  83. %description tools
  84. The Python package includes several development tools that are used
  85. to build python programs.
  86. %package docs
  87. Summary: Documentation for the Python programming language.
  88. Summary(ja): Python プログラミング言語のドキュメント
  89. Group: Documentation
  90. %description docs
  91. The python-docs package contains documentation on the Python
  92. programming language and interpreter. The documentation is provided
  93. in ASCII text files and in LaTeX source files.
  94. Install the python-docs package if you'd like to use the documentation
  95. for the Python language.
  96. %prep
  97. %setup -q -n Python-%{version}
  98. %if %{_lib} == lib64
  99. %patch1 -p1 -b .lib64
  100. %endif
  101. %patch2 -p1 -b .libpl
  102. %build
  103. ./configure \
  104. --prefix=%{_prefix} \
  105. --libdir=%{_libdir} \
  106. --enable-shared \
  107. --enable-ipv6 \
  108. --with-fpectl \
  109. --with-doc-strings \
  110. --with-pymalloc \
  111. --with-signal-module \
  112. --with-system-ffi \
  113. --with-threads \
  114. --with-valgrind \
  115. --without-ensurepip \
  116. %ifarch x86_64
  117. --with-universal-archs=64-bit \
  118. %endif
  119. CXX=g++;
  120. cat <<EOF >> Modules/Setup.local
  121. _socket socketmodule.c
  122. SSL=%{_prefix}
  123. _ssl _ssl.c \
  124. -DUSE_SSL -I%{_includedir} -I%{_includedir}/openssl \
  125. -L%{_libdir} -lssl -lcrypto
  126. EOF
  127. make %{?_smp_mflags}
  128. %if %{run_test}
  129. make test
  130. %endif
  131. %install
  132. [ -d "$RPM_BUILD_ROOT" -a "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  133. echo '[install_scripts]' >setup.cfg
  134. echo 'install_dir='"${RPM_BUILD_ROOT}%{_bindir}" >> setup.cfg
  135. mkdir -p $RPM_BUILD_ROOT%{python_lib}/lib-dynload
  136. make DESTDIR=$RPM_BUILD_ROOT LIBDIR=%{_libdir} install
  137. # if --with-wide-unicode at configure
  138. ln -s python%{libvers}m $RPM_BUILD_ROOT%{_includedir}/python%{libvers}
  139. # replace path in pydoc
  140. if [ ! -z "%{binsuffix}" ]
  141. then
  142. (
  143. cd $RPM_BUILD_ROOT%{_bindir}
  144. mv pydoc%{libvers} pydoc.old
  145. sed 's|#!.*|#!%{_bindir}/env python'%{libvers}'|' \
  146. pydoc.old > pydoc%{libvers}
  147. chmod 755 pydoc%{libvers}
  148. rm -f pydoc.old
  149. )
  150. fi
  151. # Tools
  152. echo '#!%{_bindir}/env python%{binsuffix}' > ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  153. echo 'import os, sys' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  154. echo 'os.execvp("%{_bindir}/python%{binsuffix}", ["%{_bindir}/python%{binsuffix}", "%{python_lib}/idlelib/idle.py"] + sys.argv[1:])' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  155. echo 'print "Failed to exec Idle"' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  156. echo 'sys.exit(1)' >> ${RPM_BUILD_ROOT}%{_bindir}/idle%{binsuffix}
  157. chmod 755 $RPM_BUILD_ROOT%{_bindir}/idle%{binsuffix}
  158. cp -a Tools $RPM_BUILD_ROOT%{python_lib}
  159. # make file lists
  160. rm -f mainpkg.files
  161. find "$RPM_BUILD_ROOT"%{python_lib} -type f |
  162. sed "s|^${RPM_BUILD_ROOT}|/|" |
  163. grep -v -e '/python%{libvers}/config$' -e '_tkinter.so$' >> mainpkg.files
  164. rm -f $RPM_BUILD_ROOT%{_prefix}/bin/2to3
  165. find "$RPM_BUILD_ROOT""%{_prefix}"/bin -type f -o -type l |
  166. sed "s|^${RPM_BUILD_ROOT}|/|" |
  167. grep -v -e '/bin/2to3%{binsuffix}$' |
  168. grep -v -e '/bin/pydoc%{binsuffix}$' |
  169. grep -v -e '/bin/smtpd.py%{binsuffix}$' |
  170. grep -v -e '/bin/idle%{binsuffix}$' >> mainpkg.files
  171. rm -f tools.files
  172. find "$RPM_BUILD_ROOT"%{python_lib}/idlelib \
  173. "$RPM_BUILD_ROOT"%{python_lib}/Tools -type f |
  174. sed "s|^${RPM_BUILD_ROOT}|/|" > tools.files
  175. echo %{_bindir}/2to3-%{binsuffix} >> tools.files
  176. echo %{_bindir}/pydoc%{binsuffix} >> tools.files
  177. ##echo %{_bindir}/smtpd.py%{binsuffix} >> tools.files
  178. echo %{_bindir}/idle%{binsuffix} >> tools.files
  179. # docs
  180. mkdir -p "$RPM_BUILD_ROOT"%{config_htmldir}
  181. (
  182. cd "$RPM_BUILD_ROOT"%{config_htmldir}
  183. bunzip2 < %{SOURCE1} | tar x
  184. )
  185. # fix the #! line in installed files
  186. find "$RPM_BUILD_ROOT" -type f -print0 |
  187. xargs -0 grep -l /usr/local/bin/python | while read file
  188. do
  189. FIXFILE="$file"
  190. sed 's|^#!.*python|#!%{_bindir}/env python'"%{binsuffix}"'|' \
  191. "$FIXFILE" >/tmp/fix-python-path.$$
  192. cat /tmp/fix-python-path.$$ > "$FIXFILE"
  193. rm -f /tmp/fix-python-path.$$
  194. done
  195. # check to see if there are any straggling #! lines
  196. find "$RPM_BUILD_ROOT" -type f | xargs egrep -n '^#! */usr/local/bin/python' \
  197. | grep ':1:#!' >/tmp/python-rpm-files.$$ || true
  198. if [ -s /tmp/python-rpm-files.$$ ]
  199. then
  200. echo '*****************************************************'
  201. cat /tmp/python-rpm-files.$$
  202. cat <<@EOF
  203. *****************************************************
  204. There are still files referencing /usr/local/bin/python in the
  205. install directory. They are listed above. Please fix the .spec
  206. file and try again. If you are an end-user, you probably want
  207. to report this to jafo-rpms@tummy.com as well.
  208. *****************************************************
  209. @EOF
  210. rm -f /tmp/python-rpm-files.$$
  211. exit 1
  212. fi
  213. rm -f /tmp/python-rpm-files.$$
  214. %post -p /sbin/ldconfig
  215. %postun -p /sbin/ldconfig
  216. %clean
  217. rm -fr $RPM_BUILD_ROOT
  218. %files -f mainpkg.files
  219. %defattr(-, root, root)
  220. %license LICENSE
  221. %doc Misc/ACKS Misc/HISTORY Misc/NEWS Misc/Porting Misc/README
  222. %attr(755,root,root) %dir %{python_lib}/
  223. %{_libdir}/libpython*
  224. %{_mandir}/man1/python%{libvers}.1*
  225. %{_mandir}/man1/%{name}.1*
  226. %files devel
  227. %defattr(-,root,root)
  228. %dir %{_includedir}/python%{libvers}m
  229. %{_includedir}/python%{libvers}m/*.h
  230. %{_includedir}/python%{libvers}
  231. %{_libdir}/pkgconfig/*.pc
  232. %files -f tools.files tools
  233. %defattr(-,root,root)
  234. %files tkinter
  235. %defattr(-,root,root)
  236. %{python_lib}/tkinter
  237. %{python_lib}/lib-dynload/_tkinter.*.so*
  238. %files docs
  239. %defattr(-,root,root)
  240. %{config_htmldir}/*
  241. %changelog
  242. * Sat Jan 26 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-2
  243. - rebuilt with new toolchain.
  244. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.5.6-1
  245. - new upstream release.
  246. - really rebuilt with openssl-1.1.1.
  247. * Fri Nov 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
  248. - rebuild with openssl-1.1.1
  249. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
  250. - new upstream release
  251. - update Patch1 (python-3.5.2-lib64.patch)
  252. * Sun Mar 27 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-2
  253. - rebuild with openssl-1.0.2g
  254. * Sat Feb 13 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.4-1
  255. - new upstream release
  256. - add Patch2 (python3-3.4.4-revert-makefile.patch)
  257. * Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.3-1
  258. - new upstream release
  259. * Sun Mar 22 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.4.2-2
  260. - rebuilt with readline 6.3
  261. - changed BuildRequires: tcl-devel, tk-devel instead of tcl, tk respectively
  262. - changed BuildRequires: libdb-devel instead of db4-devel
  263. * Sun Jan 11 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  264. - new upstream release
  265. - update Patch1 (python-3.4.2-lib64.patch)
  266. * Sun Sep 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-3
  267. - remove configure option "--enable-profiling"
  268. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-2
  269. - rebuild with libffi-3.0.13
  270. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.3-1
  271. - new upstream release
  272. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.2-1
  273. - updated python to 3.3.2
  274. * Sun Jan 6 2013 IWAI, Masaharu <iwai@alib.jp> 3.3.0-2
  275. - build with Tcl/Tk 8.5.7-1
  276. * Wed Oct 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.3.0-1
  277. - updated python to 3.3.0
  278. - update Patch1 (python-3.3.0-lib64.patch)
  279. - add BuildRequires: valgrind-devel
  280. * Sat Apr 16 2011 Shu KONNO <owa@bg.wakwak.com> 3.2-1
  281. - updated python to 3.2
  282. - updated python-*-docs-html to 3.2
  283. - dropt all patchs
  284. - added python-3.2b2-lib64.patch
  285. - referred to the review Python-3.2/Misc/RPM/python-3.2.spec
  286. * Fri Jan 14 2011 Shu KONNO <owa@bg.wakwak.com> 3.1.3-2
  287. - rebuilt with openssl-1.0.0c
  288. * Mon Nov 29 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.3-1
  289. - updated python to 3.1.3
  290. - added python-3.1.3-locale.patch
  291. - dropt python-3.1.2-lib64.patch
  292. - added python-3.1.3-lib64-*.patchs
  293. python-3.1.3-lib64-Makefile.patch
  294. python-3.1.3-lib64-setup.patch
  295. python-3.1.3-lib64-site.patch
  296. python-3.1.3-lib64-install.patch
  297. python-3.1.3-lib64-sysconfig.patch
  298. python-3.1.3-lib64-getpath.patch
  299. python-3.1.3-lib64-test_install.patch
  300. - added run_test macro to run unit test
  301. - added BR: libffi
  302. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-4
  303. - rebuilt with rpm-4.8.1 for pkg-config
  304. * Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-3
  305. - spec in utf-8
  306. * Sun Jun 20 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-2
  307. - added missings in BuildRequires, Requires
  308. * Fri Jun 18 2010 Shu KONNO <owa@bg.wakwak.com> 3.1.2-1
  309. - initial build for VineSeed