perl-DateTime-Format-Builder-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174
  1. # Note: Some tests for this package are disabled by default, as they
  2. # require network access and would thus fail in the buildsys' mock
  3. # environments. To build locally while enabling tests, either:
  4. #
  5. # rpmbuild ... --define '_with_network_tests 1' ...
  6. # rpmbuild ... --with network_tests ...
  7. # define _with_network_tests 1 in your ~/.rpmmacros
  8. #
  9. # Note that right now, the only way to run tests locally from a cvs sandbox
  10. # "make noarch" type scenario is the third one.
  11. %define real_version 0.80
  12. Name: perl-DateTime-Format-Builder
  13. # 0.80 in reality, but rpm can't get it
  14. Version: 0.8000
  15. Release: 1%{?_dist_release}
  16. Summary: Create DateTime parser classes and objects
  17. Group: Development/Libraries
  18. License: GPL+ or Artistic
  19. URL: http://search.cpan.org/dist/DateTime-Format-Builder
  20. Source0: http://search.cpan.org/CPAN/authors/id/D/DR/DROLSKY/DateTime-Format-Builder-%{real_version}.tar.gz
  21. BuildArch: noarch
  22. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  23. ## core
  24. BuildRequires: perl(Test::More)
  25. ## non-core
  26. BuildRequires: perl(Module::Build)
  27. BuildRequires: perl(Class::ISA)
  28. BuildRequires: perl(Class::Factory::Util)
  29. BuildRequires: perl(DateTime)
  30. BuildRequires: perl(DateTime::Format::Strptime)
  31. BuildRequires: perl(Params::Validate) >= 0.73
  32. # note -- listed as a BR but _not_ needed with Fedora perl
  33. #BuildRequires: perl(Task::Weaken)
  34. BuildRequires: perl(Test::Pod)
  35. ## For extended testing
  36. BuildRequires: perl(DateTime::Format::HTTP)
  37. BuildRequires: perl(DateTime::Format::Mail)
  38. BuildRequires: perl(DateTime::Format::IBeat)
  39. Provides: perl(DateTime::Format::Builder) = %{version}
  40. # for signature checking
  41. %{?_with_network_tests:BuildRequires: perl(Module::Signature) }
  42. # not explicitly picked up
  43. Requires: perl(DateTime::Format::Strptime)
  44. %{?perl_default_filter}
  45. %description
  46. DateTime::Format::Builder creates DateTime parsers. Many string formats of
  47. dates and times are simple and just require a basic regular expression to
  48. extract the relevant information. Builder provides a simple way to do this
  49. without writing reams of structural code.
  50. Builder provides a number of methods, most of which you'll never need, or at
  51. least rarely need. They're provided more for exposing of the module's innards
  52. to any subclasses, or for when you need to do something slightly beyond what
  53. is expected.
  54. %prep
  55. %setup -q -n DateTime-Format-Builder-%{real_version}
  56. cat << \EOF > %{name}-req
  57. #!/bin/sh
  58. %{__perl_requires} $* |\
  59. sed -e '/perl(DateTime::Format::HTTP)/d;/perl(DateTime::Format::IBeat)/d' \
  60. -e '/perl(DateTime::Format::Mail)/d'
  61. EOF
  62. %define __perl_requires %{_builddir}/DateTime-Format-Builder-%{real_version}/%{name}-req
  63. chmod +x %{__perl_requires}
  64. # digital signature checking. Not essential, but nice
  65. %{?_with_network_tests: cpansign -v }
  66. # POD doesn't like E<copy> very much...
  67. perl -pi -e 's/E<copy>/(C)/' `find lib/ -type f`
  68. # American English
  69. mv LICENCE LICENSE
  70. %build
  71. %{__perl} Makefile.PL INSTALLDIRS=vendor
  72. make %{?_smp_mflags}
  73. %install
  74. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  75. find %{buildroot} -type f -name .packlist -exec rm -f {} +
  76. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  77. %{_fixperms} %{buildroot}/*
  78. %check
  79. make test
  80. %files
  81. %defattr(-,root,root,-)
  82. %doc COPYING Artistic Changes AUTHORS CREDITS LICENSE README examples/ t/
  83. %{perl_vendorlib}/*
  84. %{_mandir}/man3/*.3*
  85. %changelog
  86. * Sun Jan 6 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.8000-1
  87. - initial build based on Fedora development package
  88. * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-10
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  90. * Wed Jun 20 2012 Petr Pisar <ppisar@redhat.com> - 0.8000-9
  91. - Perl 5.16 rebuild
  92. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-8
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  94. * Thu Jul 21 2011 Petr Sabata <contyk@redhat.com> - 0.8000-7
  95. - Perl mass rebuild
  96. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 0.8000-6
  97. - Perl mass rebuild
  98. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.8000-5
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  100. * Thu Dec 16 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-4
  101. - 661697 rebuild for fixing problems with vendorach/lib
  102. * Sun Dec 12 2010 Iain Arnell <iarnell@gmail.com> 0.8000-3
  103. - use perl_default_filter
  104. - clean up spec for modern rpmbuild
  105. * Fri May 14 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-2
  106. - add provides with rpm version for other packages
  107. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.8000-1
  108. - Mass rebuild with perl-5.12.0
  109. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 0.7901-5
  110. - rebuild against perl 5.10.1
  111. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7901-4
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  113. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7901-3
  114. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  115. * Tue Mar 4 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.7901-2
  116. - rebuild for new perl
  117. * Sat Jan 26 2008 Chris Weyl <cweyl@alumni.drew.edu> 0.7901-1
  118. - update to 0.7901
  119. - additional docs
  120. - some spec rework
  121. * Thu Aug 31 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-4
  122. - bump for mass rebuild
  123. * Tue Aug 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-3
  124. - bump for release & build, not in that order
  125. * Tue Aug 08 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-2
  126. - additional br's
  127. * Fri Aug 04 2006 Chris Weyl <cweyl@alumni.drew.edu> 0.7807-1
  128. - Initial spec file for F-E