123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271 |
- %bcond_with perl_Class_Method_Modifiers_enables_optional_test
- Name: perl-Class-Method-Modifiers
- Summary: Provides Moose-like method modifiers
- Version: 2.13
- Release: 1%{?_dist_release}
- Group: programming
- Vendor: Project Vine
- Distribution: Vine Linux
- License: GPL+ or Artistic
- URL: https://metacpan.org/release/Class-Method-Modifiers
- Source0: https://cpan.metacpan.org/authors/id/E/ET/ETHER/Class-Method-Modifiers-%{version}.tar.gz
- BuildArch: noarch
- BuildRequires: coreutils
- BuildRequires: findutils
- BuildRequires: make
- BuildRequires: perl >= 2:5.34.0
- BuildRequires: perl(ExtUtils::MakeMaker)
- BuildRequires: perl(strict)
- BuildRequires: perl(warnings)
- BuildRequires: perl(B)
- BuildRequires: perl(base)
- BuildRequires: perl(Carp)
- BuildRequires: perl(Exporter)
- BuildRequires: perl(File::Spec)
- BuildRequires: perl(if)
- BuildRequires: perl(Test::Fatal)
- BuildRequires: perl(Test::More)
- BuildRequires: perl(Test::Requires)
- %if 0%{!?perl_bootstrap:1} && %{with perl_Class_Method_Modifiers_enables_optional_test}
- BuildRequires: perl(CPAN::Meta)
- BuildRequires: perl(Moose)
- %endif
- Requires: perl >= 2:5.34.0
- Requires: perl(B)
- Requires: perl(Carp)
- Requires: perl(Exporter)
- %{?perl_default_filter}
- %description
- Method modifiers are a powerful feature from the CLOS (Common Lisp Object
- System) world.
- In its most basic form, a method modifier is just a method that calls
- '$self->SUPER::foo(@_)'. I for one have trouble remembering that exact
- invocation, so my classes seldom re-dispatch to their base classes. Very
- bad!
- 'Class::Method::Modifiers' provides three modifiers: 'before', 'around',
- and 'after'. 'before' and 'after' are run just before and after the method
- they modify, but can not really affect that original method. 'around' is
- run in place of the original method, with a hook to easily call that
- original method. See the 'MODIFIERS' section for more details on how the
- particular modifiers work.
- %prep
- %setup -q -n Class-Method-Modifiers-%{version}
- chmod -c -x t/*.t
- %build
- perl Makefile.PL INSTALLDIRS=vendor NO_PACKLIST=1 NO_PERLLOCAL=1
- make %{?_smp_mflags}
- %install
- make pure_install DESTDIR=%{buildroot}
- %{_fixperms} %{buildroot}
- %check
- make test
- %files
- %license LICENSE
- %doc Changes CONTRIBUTING README t/
- %{perl_vendorlib}/Class/
- %{_mandir}/man3/Class::Method::Modifiers.3*
- %changelog
- * Sun Nov 21 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.13-1
- - new upstream release.
- - built with perl-5.34.0.
- * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12-13
- - initial build for Vine Linux.
- * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-12
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
- * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-11
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Sat Jun 30 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-10
- - Perl 5.28 re-rebuild of bootstrapped packages
- * Thu Jun 28 2018 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-9
- - Perl 5.28 rebuild
- * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-8
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-7
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Wed Jun 07 2017 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-6
- - Perl 5.26 re-rebuild of bootstrapped packages
- * Mon Jun 05 2017 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-5
- - Perl 5.26 rebuild
- * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.12-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- * Wed May 18 2016 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-3
- - Perl 5.24 re-rebuild of bootstrapped packages
- * Sun May 15 2016 Jitka Plesnikova <jplesnik@redhat.com> - 2.12-2
- - Perl 5.24 rebuild
- * Sat Mar 05 2016 Petr Šabata <contyk@redhat.com> - 2.12-1
- - 2.12 bump, documentation fixes
- - %%license is now supported in EPEL too
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.11-7
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.11-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Wed Jun 10 2015 Jitka Plesnikova <jplesnik@redhat.com> - 2.11-5
- - Perl 5.22 re-rebuild of bootstrapped packages
- * Sat Jun 06 2015 Jitka Plesnikova <jplesnik@redhat.com> - 2.11-4
- - Perl 5.22 rebuild
- * Sun Sep 07 2014 Jitka Plesnikova <jplesnik@redhat.com> - 2.11-3
- - Perl 5.20 re-rebuild of bootstrapped packages
- * Fri Sep 05 2014 Jitka Plesnikova <jplesnik@redhat.com> - 2.11-2
- - Perl 5.20 rebuild
- * Thu Sep 4 2014 Paul Howarth <paul@city-fan.org> <paul@city-fan.org> - 2.11-1
- - Update to 2.11
- - Add documentation for modifying multiple methods at once (GitHub
- - Use %%license where possible
- * Fri Aug 29 2014 Jitka Plesnikova <jplesnik@redhat.com> - 2.10-3
- - Perl 5.20 rebuild
- * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.10-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Sun Mar 16 2014 Paul Howarth <paul@city-fan.org> <paul@city-fan.org> - 2.10-1
- - Update to 2.10
- - Remove erroneous perl 5.8 requirement
- - Support for handling lvalue methods
- - Convert to building with Dist::Zilla
- - Repository migrated to the github moose organization
- - Refresh configure_requires checking in generated Makefile.PL
- - New CONTRIBUTING file
- - Updated tests:
- - Compile test now only runs for authors
- - Check-deps test replaced by information-only report-prereqs test
- - Drop obsoletes/provides for old tests sub-package
- - Drop redundant Group tag
- - Classify buildreqs by usage
- - Make %%files list more explicit
- * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.03-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Fri Aug 02 2013 Petr Pisar <ppisar@redhat.com> - 2.03-2
- - Perl 5.18 rebuild
- * Fri Feb 15 2013 Iain Arnell <iarnell@gmail.com> 2.03-1
- - update to latest upstream version
- * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.00-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
- * Sat Jan 05 2013 Iain Arnell <iarnell@gmail.com> 2.00-1
- - update to latest upstream version
- * Sun Oct 28 2012 Iain Arnell <iarnell@gmail.com> 1.12-1
- - update to latest upstream version
- * Sat Oct 27 2012 Iain Arnell <iarnell@gmail.com> 1.10-1
- - update to latest upstream version
- * Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.09-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Fri Jun 22 2012 Petr Pisar <ppisar@redhat.com> - 1.09-2
- - Perl 5.16 rebuild
- * Tue Apr 03 2012 Iain Arnell <iarnell@gmail.com> 1.09-1
- - update to latest upstream version
- * Sun Jan 22 2012 Iain Arnell <iarnell@gmail.com> 1.08-3
- - drop tests subpackage; move tests to main package documentation
- * Tue Jan 17 2012 Iain Arnell <iarnell@gmail.com> - 1.08-2
- - rebuilt again for F17 mass rebuild
- * Fri Jan 13 2012 Iain Arnell <iarnell@gmail.com> 1.08-1
- - update to latest upstream version
- * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.07-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.07-2
- - Perl mass rebuild
- * Sun Mar 13 2011 Iain Arnell <iarnell@gmail.com> 1.07-1
- - update to latest upstream version
- - clean up spec for modern rpmbuild
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.05-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.05-3
- - 661697 rebuild for fixing problems with vendorach/lib
- * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.05-2
- - Mass rebuild with perl-5.12.0
- * Mon Mar 01 2010 Chris Weyl <cweyl@alumni.drew.edu> 1.05-1
- - update by Fedora::App::MaintainerTools 0.004
- - PERL_INSTALL_ROOT => DESTDIR
- * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 1.04-2
- - rebuild against perl 5.10.1
- * Fri Jul 31 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.04-1
- - auto-update to 1.04 (by cpan-spec-update 0.01)
- * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.02-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Mon Jun 08 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.02-1
- - auto-update to 1.02 (by cpan-spec-update 0.01)
- - altered br on perl(ExtUtils::MakeMaker) (0 => 6.42)
- * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.01-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.01-3
- - remove MM version qualifier (F-8's is older)
- * Mon Sep 08 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.01-2
- - bump
- * Sat Sep 06 2008 Chris Weyl <cweyl@alumni.drew.edu> 1.01-1
- - initial Fedora packaging
- - generated with cpan2dist (CPANPLUS::Dist::Fedora version 0.0.1)
|