libssh2-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: A library implementing the SSH2 protocol
  3. Summary(ja): SSH2 プロトコルを実装するためのライブラリ
  4. Name: libssh2
  5. Version: 1.8.2
  6. Release: 1%{?_dist_release}
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. Group: System Environment/Libraries
  10. License: BSD
  11. URL: http://www.libssh2.org/
  12. Source0: http://downloads.sourceforge.net/libssh2/%{name}-%{version}.tar.gz
  13. Patch1: 0001-scp-do-not-NUL-terminate-the-command-for-remote-exec.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  15. BuildRequires: openssl-devel
  16. BuildRequires: zlib-devel
  17. %description
  18. libssh2 is a library implementing the SSH2 protocol as defined by
  19. Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
  20. SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
  21. SECSH-DHGEX(04), and SECSH-NUMBERS(10).
  22. %package devel
  23. Summary: Development files for %{name}
  24. Summary(ja): %{name} の開発ファイル
  25. Group: Development/Libraries
  26. Requires: %{name} = %{version}-%{release}
  27. %description devel
  28. The %{name}-devel package contains libraries and header files for
  29. developing applications that use %{name}.
  30. %package docs
  31. Summary: Documentation for %{name}
  32. Summary(ja): %{name} のドキュメント
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}-%{release}
  35. %description docs
  36. The %{name}-docs package contains man pages and examples for
  37. developing applications that use %{name}.
  38. ## to build compat32 for x86_64 architecture support
  39. %package -n compat32-%{name}
  40. Summary: A library implementing the SSH2 protocol
  41. Summary(ja): SSH2 プロトコルを実装するためのライブラリ
  42. Group: System Environment/Libraries
  43. %description -n compat32-%{name}
  44. libssh2 is a library implementing the SSH2 protocol as defined by
  45. Internet Drafts: SECSH-TRANS(22), SECSH-USERAUTH(25),
  46. SECSH-CONNECTION(23), SECSH-ARCH(20), SECSH-FILEXFER(06)*,
  47. SECSH-DHGEX(04), and SECSH-NUMBERS(10).
  48. %prep
  49. %setup -q
  50. # scp: do not NUL-terminate the command for remote exec
  51. # https://bugzilla.redhat.com/show_bug.cgi?id=1489736
  52. # https://github.com/libssh2/libssh2/pull/208
  53. %patch1 -p1
  54. # Replace hard wired port number in the test suite to avoid collisions
  55. # between 32-bit and 64-bit builds running on a single build-host
  56. sed -i s/4711/47%{__isa_bits}/ tests/ssh2.{c,sh}
  57. # make sure things are UTF-8...
  58. for i in ChangeLog NEWS ; do
  59. iconv --from=ISO-8859-1 --to=UTF-8 $i > new
  60. mv new $i
  61. done
  62. %build
  63. %configure --disable-static --enable-shared
  64. make %{?_smp_mflags}
  65. %install
  66. rm -rf %{buildroot}
  67. make install DESTDIR=%{buildroot} INSTALL="install -p"
  68. find %{buildroot} -name '*.la' -exec rm -f {} +
  69. # clean things up a bit for packaging
  70. ( cd example && make clean )
  71. rm -rf example/simple/.deps
  72. find example/ -type f '(' -name '*.am' -o -name '*.in' ')' -exec rm -v {} +
  73. %check
  74. (cd tests && make check)
  75. %clean
  76. rm -rf %{buildroot}
  77. %post -p /sbin/ldconfig
  78. %postun -p /sbin/ldconfig
  79. %post -n compat32-%{name} -p /sbin/ldconfig
  80. %postun -n compat32-%{name} -p /sbin/ldconfig
  81. %files
  82. %defattr(-,root,root,-)
  83. %doc AUTHORS ChangeLog COPYING README NEWS
  84. %{_libdir}/*.so.*
  85. %files docs
  86. %defattr(-,root,root,-)
  87. %doc COPYING example/ docs/HACKING
  88. %{_mandir}/man?/*
  89. %files devel
  90. %defattr(-,root,root,-)
  91. %doc COPYING
  92. %{_includedir}/*
  93. %{_libdir}/*.so
  94. %{_libdir}/pkgconfig/libssh2.pc
  95. %if %{build_compat32}
  96. %files -n compat32-%{name}
  97. %defattr(-,root,root,-)
  98. %{_libdir}/*.so.*
  99. %endif
  100. %changelog
  101. * Thu Mar 28 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
  102. - new upstream release.
  103. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.0-1
  104. - new upstream release.
  105. - built with openssl-1.1.1.
  106. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-2
  107. - rebuilt with openssl 1.0.2g
  108. * Fri Feb 26 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.7.0-1
  109. - new upstream release with security fixes
  110. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-1
  111. - new upstream reelase
  112. - add compat32 package
  113. * Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.7-1
  114. - new upstream release
  115. - fix %%files
  116. * Tue Sep 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0-1
  117. - initial build for Vine Linux
  118. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.0-4
  119. - rebuilt with new openssl
  120. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-3
  121. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  122. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  124. * Mon Feb 16 2009 Chris Weyl <cweyl@alumni.drew.edu> 1.0-1
  125. - update to 1.0
  126. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.18-8
  127. - rebuild with new openssl
  128. * Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.18-7
  129. - Autorebuild for GCC 4.3
  130. * Wed Dec 05 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-6
  131. - rebuild for new openssl...
  132. * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-5
  133. - bump
  134. * Tue Nov 27 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-4
  135. - add INSTALL arg to make install vs env. var
  136. * Mon Nov 26 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-3
  137. - run tests; don't package test
  138. * Sun Nov 18 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-2
  139. - split docs into -docs (they seemed... large.)
  140. * Tue Nov 13 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.18-1
  141. - update to 0.18
  142. * Sun Oct 14 2007 Chris Weyl <cweyl@alumni.drew.edu> 0.17-1
  143. - update to 0.17
  144. - many spec file changes
  145. * Wed May 23 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.2.20070506
  146. - Fix release tag
  147. - Move manpages to -devel package
  148. - Add Examples dir to -devel package
  149. * Sun May 06 2007 Sindre Pedersen Bjørdal <foolish[AT]guezz.net> - 0.15-0.20070506.1
  150. - Initial build