xxhash-vl.spec 7.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220
  1. Name: xxhash
  2. Summary: Extremely fast hash algorithm
  3. Version: 0.8.2
  4. Release: 3%{?_dist_release}
  5. Group: system,accessories
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. # The source for the library (xxhash.c and xxhash.h) is BSD-2-Clause
  9. # The source for the command line tool (xxhsum.c) is GPL-2.0-or-later
  10. License: BSD-2-Clause AND GPL-2.0-or-later
  11. URL: https://www.xxhash.com/
  12. Source0: https://github.com/Cyan4973/xxHash/archive/v%{version}/%{name}-%{version}.tar.gz
  13. BuildRequires: make
  14. BuildRequires: gcc
  15. BuildRequires: doxygen
  16. %description
  17. xxHash is an Extremely fast Hash algorithm, running at RAM speed
  18. limits. It successfully completes the SMHasher test suite which
  19. evaluates collision, dispersion and randomness qualities of hash
  20. functions. Code is highly portable, and hashes are identical on all
  21. platforms (little / big endian).
  22. %package libs
  23. Summary: Extremely fast hash algorithm - library
  24. Group: system
  25. License: BSD-2-Clause
  26. %description libs
  27. xxHash is an Extremely fast Hash algorithm, running at RAM speed
  28. limits. It successfully completes the SMHasher test suite which
  29. evaluates collision, dispersion and randomness qualities of hash
  30. functions. Code is highly portable, and hashes are identical on all
  31. platforms (little / big endian).
  32. %package devel
  33. Summary: Extremely fast hash algorithm - development files
  34. Group: programming
  35. License: BSD-2-Clause
  36. Requires: %{name}-libs%{?_isa} = %{version}-%{release}
  37. # By setting XXH_INLINE_ALL, xxhash may be used as a header-only library.
  38. # Dependent packages that use xxhash this way must BR this virtual Provide:
  39. Provides: %{name}-static = %{version}-%{release}
  40. %description devel
  41. Development files for the xxhash library
  42. %package doc
  43. Summary: Extremely fast hash algorithm - documentation files
  44. Group: documentation
  45. License: BSD-2-Clause
  46. BuildArch: noarch
  47. %description doc
  48. Documentation files for the xxhash library
  49. %debug_package
  50. %prep
  51. %setup -q -n xxHash-%{version}
  52. %build
  53. # Enable runtime detection of sse2/avx2/avx512 on intel architectures
  54. %ifarch %{ix86} x86_64
  55. %global dispatch 1
  56. # Some distribution variants build with -march=x86-64-v3.
  57. # See xxh_x86dispatch.c.
  58. %global moreflags_dispatch -DXXH_X86DISPATCH_ALLOW_AVX
  59. %else
  60. %global dispatch 0
  61. %global moreflags_dispatch %{nil}
  62. %endif
  63. %make_build \
  64. MOREFLAGS="%{__global_cflags} %{?__global_ldflags} %{moreflags_dispatch}" \
  65. DISPATCH=%{dispatch}
  66. doxygen
  67. %install
  68. %make_install PREFIX=%{_prefix} LIBDIR=%{_libdir}
  69. rm %{buildroot}/%{_libdir}/libxxhash.a
  70. %check
  71. make check
  72. make test-xxhsum-c
  73. %files
  74. %license cli/COPYING
  75. %doc cli/README.md
  76. %{_bindir}/xxh*sum
  77. %{_mandir}/man1/xxh*sum.1*
  78. %files libs
  79. %license LICENSE
  80. %doc README.md
  81. %{_libdir}/libxxhash.so.*
  82. %files devel
  83. %{_includedir}/xxhash.h
  84. %{_includedir}/xxh3.h
  85. %{_libdir}/libxxhash.so
  86. %{_libdir}/pkgconfig/libxxhash.pc
  87. %files doc
  88. %doc doxygen/html
  89. %changelog
  90. * Tue May 07 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.8.2-3
  91. - initial built for Vine Linux.
  92. * Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.2-2
  93. - Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
  94. * Sat Jul 22 2023 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.8.2-1
  95. - Update to version 0.8.2
  96. - Drop patch xxhash-epel7-ppc64le.patch
  97. - Use SPDX license identifiers
  98. * Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-6
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
  100. * Mon Jun 19 2023 Florian Weimer <fweimer@redhat.com> - 0.8.1-5
  101. - Enable building with -march=x86-64-v3 (#2215831)
  102. * Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-4
  103. - Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
  104. * Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-3
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
  106. * Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-2
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
  108. * Mon Nov 29 2021 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.8.1-1
  109. - Update to version 0.8.1
  110. - Drop patch xxhash-pkgconfig-version.patch (accepted upstream)
  111. - Fix compilation on RHEL 7 ppc64le (gcc 4.8)
  112. - The x86 dispatch code now enables sse2 and avx2 separately, it can now use
  113. sse2 on EPEL 7 without trying to use avx2 which is not supported by gcc 4.8
  114. - Add documentation package - doxygen mark-up was added
  115. * Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-4
  116. - Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
  117. * Thu Jun 10 2021 Benjamin A. Beasley <code@musicinmybrain.net> - 0.8.0-3
  118. - Add virtual Provide for xxhash-static in xxhash-devel
  119. * Thu Jan 28 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-2
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
  121. * Tue Jul 28 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.8.0-1
  122. - Update to version 0.8.0
  123. - Drop patches xxhash-compiler-warning-32-bit.patch (accepted upstream)
  124. and xxhash-pkgconfig.patch (issue fixed upstream)
  125. - Fix empty version in .pc file
  126. * Fri Jul 24 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.4-2
  127. - Fix libdir in pkg-config file
  128. * Sat Jun 27 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.4-1
  129. - Update to version 0.7.4
  130. - Enable runtime detection of sse2/avx2/avx512 on intel architectures
  131. - Fix compiler warning for 32 bit architectures
  132. * Fri Mar 06 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.3-1
  133. - Update to version 0.7.3
  134. - Drop patch xxhash-gcc10-altivec.patch (accepted upstream)
  135. * Fri Feb 07 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.2-3
  136. - Fix ppc64le build with gcc 10
  137. * Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.2-2
  138. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  139. * Wed Oct 09 2019 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.2-1
  140. - Update to version 0.7.2
  141. * Sat Aug 17 2019 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.1-1
  142. - Update to version 0.7.1
  143. * Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-2
  144. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  145. * Mon Mar 18 2019 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.0-1
  146. - Update to version 0.7.0
  147. * Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.5-3
  148. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  149. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.5-2
  150. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  151. * Thu Apr 19 2018 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.6.5-1
  152. - Update to version 0.6.5
  153. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.4-2
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  155. * Wed Jan 03 2018 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.6.4-1
  156. - Update to version 0.6.4
  157. - Drop previously backported patches
  158. * Thu Oct 19 2017 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.6.3-2
  159. - Correct License tag (command line tool is GPLv2+)
  160. - Adjust Source tag to get a more descriptive tarfile name
  161. * Wed Oct 18 2017 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.6.3-1
  162. - Initial packaging