hscolour-vl.spec 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182
  1. %define pkg_name hscolour
  2. %define pkg_version 1.24
  3. %define pkg_release 3%{?_dist_release}
  4. %define ghc_version 7.10.3
  5. %ifarch %{ix86}
  6. %define rpmarch i386
  7. %endif
  8. %ifarch x86_64
  9. %define rpmarch x86_64
  10. %endif
  11. Summary: A small Haskell script to colourise Haskell code
  12. Name: %{pkg_name}
  13. Version: %{pkg_version}
  14. Release: %{pkg_release}
  15. License: GPLv2
  16. Group: Applications/Text
  17. URL: http://hackage.haskell.org
  18. Source0: http://hackage.haskell.org/package/%{name}-%{pkg_version}/%{name}-%{pkg_version}.tar.gz
  19. BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
  20. BuildRequires: ghc
  21. BuildRequires: haskell-platform-base cabal-install
  22. BuildRequires: gmp-devel libffi-devel
  23. Vendor: Project Vine
  24. Distribution: Vine Linux
  25. Packager: ara_t
  26. %description
  27. hscolour is a small Haskell script to colourise Haskell code.
  28. It currently has six output formats: ANSI terminal codes
  29. (optionally XTerm-256colour codes), HTML 3.2 with font tags,
  30. HTML 4.01 with CSS, HTML 4.01 with CSS and mouseover annotations,
  31. XHTML 1.0 with inline CSS styling, LaTeX, and mIRC chat codes.
  32. %prep
  33. %{__rm} -rf ${RPM_BUILD_ROOT}
  34. %setup -q
  35. %build
  36. cabal configure \
  37. --prefix=%{_prefix} \
  38. --libsubdir=%{_libdir}/ghc-lib/%{name}-%{version} \
  39. --datasubdir=%{_docdir}/%{name}-%{version} \
  40. --docdir=%{_docdir}/%{name}-%{version}
  41. cabal build
  42. %install
  43. cabal copy --destdir=${RPM_BUILD_ROOT}
  44. cd ${RPM_BUILD_ROOT}%{_bindir}
  45. %{__ln_s} HsColour hscolour
  46. %clean
  47. %{__rm} -rf ${RPM_BUILD_ROOT}
  48. %files
  49. %defattr(-, root, root)
  50. %{_bindir}/
  51. %{_libdir}/ghc-lib/
  52. %{_datadir}/
  53. %changelog
  54. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 1.24-3
  55. - correct SPEC file
  56. * Sat Feb 20 2016 Toshiaki Ara <ara_t@384.jp> 1.24-2
  57. - rebuild under ghc-7.10.3 and haskell-platform-2015.7.10.3
  58. * Tue Feb 09 2016 Toshiaki Ara <ara_t@384.jp> 1.24-1
  59. - new package