glib2-vl.spec 25 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860861862863864865866867868869870871872873874875876877878879880881882883884
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. Summary: A library of handy utility functions.
  4. Name: glib2
  5. Version: 2.74.1
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: daisuke
  11. License: LGPLv2+
  12. URL: http://www.gtk.org
  13. %define shortver %(echo %{version} | cut -d. -f1-2)
  14. Source: https://download.gnome.org/sources/glib/%{shortver}/glib-%{version}.tar.xz
  15. Source2: glib2.sh
  16. Source3: glib2.csh
  17. BuildRoot: %{_tmppath}/glib-%{version}-root
  18. BuildRequires: dbus-devel
  19. BuildRequires: docbook-style-xsl
  20. BuildRequires: elfutils-libelf-devel
  21. BuildRequires: gamin-devel
  22. BuildRequires: libattr-devel
  23. BuildRequires: libffi-devel
  24. BuildRequires: libmount-devel
  25. BuildRequires: libxslt
  26. BuildRequires: meson
  27. BuildRequires: pcre2-devel
  28. BuildRequires: pkgconfig >= 0.14
  29. BuildRequires: python3-devel
  30. BuildRequires: zlib-devel
  31. Obsoletes: glib-gtkbeta
  32. # for gio-querymodules
  33. Requires(post,postun): libffi
  34. %description
  35. GLib is the low-level core library that forms the basis
  36. for projects such as GTK+ and GNOME. It provides data structure
  37. handling for C, portability wrappers, and interfaces for such runtime
  38. functionality as an event loop, threads, dynamic loading, and an
  39. object system.
  40. This package provides version %{shortver} of GLib.
  41. %package devel
  42. Summary: Development files for the GLib library
  43. Group: programming
  44. Requires: %{name} = %{version}
  45. Requires: pkgconfig >= 0.14
  46. Requires: libffi-devel
  47. Requires: zlib-devel
  48. Requires: python3
  49. Obsoletes: glib-gtkbeta-devel
  50. Conflicts: glib-devel <= 1.2.8
  51. %description devel
  52. The glib-devel package includes the header files for
  53. version %{shortver} of the GLib library.
  54. ## to build compat32 for x86_64 architecture support
  55. %package -n compat32-%{name}
  56. Summary: A library of handy utility functions.
  57. Group: system,legacy
  58. %description -n compat32-%{name}
  59. GLib is the low-level core library that forms the basis
  60. for projects such as GTK+ and GNOME. It provides data structure
  61. handling for C, portability wrappers, and interfaces for such runtime
  62. functionality as an event loop, threads, dynamic loading, and an
  63. object system.
  64. This package provides version %{shortver} of GLib.
  65. %package -n compat32-%{name}-devel
  66. Summary: Development files for the GLib library
  67. Group: programming,legacy
  68. Requires: pkgconfig >= 0.14
  69. Requires: compat32-%{name} = %{version}
  70. Conflicts: glib-devel <= 1.2.8
  71. %description -n compat32-%{name}-devel
  72. The glib-devel package includes the header files for
  73. version %{shortver} of the GLib library.
  74. %debug_package
  75. %prep
  76. %autosetup -p1 -n glib-%{version}
  77. %build
  78. %meson \
  79. -Dselinux=disabled \
  80. -Dman=true
  81. %meson_build
  82. %install
  83. rm -rf $RPM_BUILD_ROOT
  84. %meson_install
  85. ## glib2.sh and glib2.csh
  86. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  87. install -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  88. install -m 755 %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/profile.d
  89. #mkdir -p $RPM_BUILD_ROOT%{python_sitearch}
  90. #ln -sf %{_libdir}/gdbus-2.0/codegen $RPM_BUILD_ROOT%{python_sitearch}/codegen
  91. mkdir -p $RPM_BUILD_ROOT%{_libdir}/gio/modules
  92. touch $RPM_BUILD_ROOT%{_libdir}/gio/modules/giomodule.cache
  93. %if %{build_compat32}
  94. cp -p \
  95. %{buildroot}%{_bindir}/gio-querymodules \
  96. %{buildroot}%{_bindir}/gio-querymodules-32
  97. %endif
  98. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  99. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/lib*.{a,la}
  100. rm -f $RPM_BUILD_ROOT%{_libdir}/gio/modules/*.cache
  101. %find_lang glib20
  102. %clean
  103. rm -rf $RPM_BUILD_ROOT
  104. %transfiletriggerin -- %{_libdir}/gio/modules
  105. gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules &> /dev/null || :
  106. %transfiletriggerpostun -- %{_libdir}/gio/modules
  107. gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules &> /dev/null || :
  108. %transfiletriggerin -- %{_datadir}/glib-2.0/schemas
  109. glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  110. %transfiletriggerpostun -- %{_datadir}/glib-2.0/schemas
  111. glib-compile-schemas %{_datadir}/glib-2.0/schemas &> /dev/null || :
  112. %if %{build_compat32}
  113. %transfiletriggerin -n compat32-%{name} -- %{_libdir}/gio/modules
  114. gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules &> /dev/null || :
  115. %transfiletriggerpostun -n compat32-%{name} -- %{_libdir}/gio/modules
  116. gio-querymodules-%{__isa_bits} %{_libdir}/gio/modules &> /dev/null || :
  117. %endif
  118. %files -f glib20.lang
  119. %defattr(-, root, root)
  120. %license COPYING
  121. %doc AUTHORS NEWS README*
  122. %{_bindir}/gapplication
  123. %{_bindir}/gdbus
  124. %{_bindir}/gio
  125. #{_bindir}/gio-launch-desktop
  126. %{_bindir}/gio-querymodules
  127. %{_bindir}/glib-compile-schemas
  128. %{_bindir}/gsettings
  129. %{_libdir}/libglib-2.0.so.*
  130. %{_libdir}/libgthread-2.0.so.*
  131. %{_libdir}/libgmodule-2.0.so.*
  132. %{_libdir}/libgobject-2.0.so.*
  133. %{_libdir}/libgio-2.0.so.*
  134. %dir %{_libdir}/gio
  135. %dir %{_libdir}/gio/modules
  136. #%{_libdir}/gio/modules/giomodule.cache
  137. #%{_libdir}/gio/modules/lib*.so
  138. %{_libexecdir}/gio-launch-desktop
  139. %{_sysconfdir}/profile.d/*
  140. %dir %{_datadir}/bash-completion/completions
  141. %dir %{_datadir}/bash-completion
  142. %{_datadir}/bash-completion/completions/gapplication
  143. %{_datadir}/bash-completion/completions/gdbus
  144. %{_datadir}/bash-completion/completions/gio
  145. %{_datadir}/bash-completion/completions/gsettings
  146. %files devel
  147. %defattr(-, root, root)
  148. %{_bindir}/gdbus-codegen
  149. %{_bindir}/glib-compile-resources
  150. %{_bindir}/glib-genmarshal
  151. %{_bindir}/glib-gettextize
  152. %{_bindir}/glib-mkenums
  153. %{_bindir}/gobject-query
  154. %{_bindir}/gresource
  155. %{_bindir}/gtester
  156. %{_bindir}/gtester-report
  157. %{_libdir}/lib*.so
  158. #%{_libdir}/lib*.a
  159. #%{_libdir}/gdbus-2.0/codegen/*
  160. %{_libdir}/glib-2.0
  161. %{_libdir}/pkgconfig/*
  162. #%{python_sitearch}/codegen
  163. %{_includedir}/*
  164. %{_datadir}/aclocal/*
  165. %{_datadir}/glib-2.0
  166. %{_datadir}/gettext/its/gschema.its
  167. %{_datadir}/gettext/its/gschema.loc
  168. #%doc %{_datadir}/gtk-doc/html/*
  169. %doc %{_mandir}/man1/*
  170. %{_datadir}/gdb/auto-load%{_libdir}/libglib-2.0.so.*-gdb.py*
  171. %{_datadir}/gdb/auto-load%{_libdir}/libgobject-2.0.so.*-gdb.py*
  172. %dir %{_datadir}/bash-completion/completions
  173. %dir %{_datadir}/bash-completion
  174. %{_datadir}/bash-completion/completions/gresource
  175. %if %{build_compat32}
  176. %files -n compat32-%{name}
  177. %defattr(-, root, root)
  178. %{_bindir}/gio-querymodules-32
  179. %{_libdir}/libglib-2.0.so.*
  180. %{_libdir}/libgthread-2.0.so.*
  181. %{_libdir}/libgmodule-2.0.so.*
  182. %{_libdir}/libgobject-2.0.so.*
  183. %{_libdir}/libgio-2.0.so.*
  184. %dir %{_libdir}/gio
  185. %dir %{_libdir}/gio/modules
  186. %files -n compat32-%{name}-devel
  187. %defattr(-, root, root)
  188. %{_libdir}/lib*.so
  189. %{_libdir}/glib-2.0
  190. %endif
  191. %changelog
  192. * Tue Nov 01 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.74.1-1
  193. - new upstream release.
  194. * Fri Jul 29 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.72.3-1
  195. - new upstream release.
  196. * Fri Aug 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.68.4-1
  197. - new upstream release.
  198. - dropped Patch1: fixed in upstream.
  199. * Fri Aug 06 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.68.3-1
  200. - new upstream release.
  201. - imported Patch1 from upstream.
  202. * Sun Apr 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.68.1-1
  203. - new upstream release.
  204. * Tue Mar 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.68.0-1
  205. - new upstream release.
  206. - dropped ldconfig scriptlets.
  207. * Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.66.7-2
  208. - added triggers.
  209. * Fri Feb 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.66.7-1
  210. - new upstream release.
  211. * Sat Dec 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.66.4-1
  212. - new upstream release.
  213. * Mon Sep 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.66.0-1
  214. - new upstream release.
  215. * Wed Jul 29 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.4-1
  216. - new upstream release.
  217. * Sat May 30 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.3-1
  218. - new upstream release.
  219. * Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-2
  220. - rebuilt with libffi-3.3.
  221. * Sat Apr 11 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.64.2-1
  222. - new upstream release.
  223. * Fri Nov 01 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.62.2-1
  224. - new upstream release.
  225. * Sat Apr 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.3-1
  226. - new upstream release.
  227. * Sat Dec 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.58.2-1
  228. - new upstream release.
  229. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.55.0-1
  230. - new upstream release.
  231. - dropped Patch0: fixed in upstream.
  232. - added BR:libmount-devel.
  233. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.48.1-1
  234. - new upstream release
  235. - add BuildRequires: pcre-devel
  236. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-2
  237. - add Requires: libffi
  238. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.2-1
  239. - new upstream release
  240. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.46.1-1
  241. - new upstream release
  242. * Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.1-1
  243. - new upstream release
  244. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.44.0-1
  245. - new upstream release
  246. * Sun Mar 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.2-1
  247. - new upstream release
  248. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.1-1
  249. - new upstream release
  250. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.42.0-1
  251. - new upstream release
  252. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-2
  253. - rebuild with libffi-3.0.13
  254. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.40.0-1
  255. - new upstream release
  256. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.2-1
  257. - new upstream release
  258. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.38.1-1
  259. - new upstream release
  260. * Sun Aug 11 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.4-1
  261. - new upstream release
  262. - remove Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
  263. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.3-1
  264. - new upstream release
  265. - add Patch1 (glib-2.36.3-revert-g_file_set_contents.patch) from upstream
  266. * Sat May 18 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.2-1
  267. - new upstream release
  268. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.36.1-1
  269. - new upstream release
  270. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.3-1
  271. - new upstream release
  272. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.2-1
  273. - new upstream release
  274. * Tue Oct 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.1-1
  275. - new upstream release
  276. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  277. - new upstream release
  278. * Mon Jul 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.4-1
  279. - new upstream release
  280. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
  281. - new upstream release
  282. * Wed May 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  283. - new upstream release
  284. * Sat Apr 21 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  285. - new upstream release
  286. - add BuildRequires: python-devel
  287. - add Patch0 (glib-2.32.1-dconf-path.patch)
  288. * Wed Nov 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  289. - new upstream release
  290. * Sun Oct 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  291. - new upstream release
  292. * Wed Sep 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  293. - new upstream release
  294. - add Requires: libffi-devel, zlib-devel (-devel sub package)
  295. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.92-1
  296. - new upstream release
  297. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.18-1
  298. - new upstream release
  299. - remove Patch0,1
  300. * Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.16-1
  301. - new upstream release
  302. - Patch0: glib-2.29.16-fixes-bug-656387.patch
  303. - Patch1: glib-2.29.16-fixes-bug-656675.patch
  304. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.29.14-1
  305. - new upstream release
  306. - add BuildRequires: libffi-devel, dbus-devel
  307. * Sat Jun 18 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.8-1
  308. - new upstream release
  309. * Fri Apr 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.6-1
  310. - new upstream release
  311. * Sun Apr 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.5-1
  312. - new upstream release
  313. * Wed Mar 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.4-1
  314. - new upstream release
  315. * Sat Mar 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.3-1
  316. - new upstream release
  317. * Sun Mar 13 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  318. - new upstream release
  319. * Sat Feb 19 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
  320. - new upstream release
  321. * Sat Feb 12 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.0-1
  322. - new upstream release
  323. * Fri Dec 10 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-2
  324. - move the following files from glib2-devel to glib2 package
  325. (gdbus, gio-querymodules, glib-compile-schemas, gsettings)
  326. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
  327. - new upstream release
  328. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.0-1
  329. - new upstream release
  330. - fix Source (add URL)
  331. - fix %files to add /etc/bash_completion.d files
  332. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 2.24.2-2
  333. - build with rpm-4.8.1-1 for pkg-config file
  334. * Sat Aug 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.2-1
  335. - new upstream release
  336. * Tue May 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  337. - new upstream release
  338. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  339. - new upstream release
  340. - add BuildRequires: zlib-devel
  341. * Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.5-1
  342. - new upstream release
  343. * Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.4-1
  344. - new upstream release
  345. * Thu Jan 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.3-1
  346. - new upstream release
  347. * Sun Oct 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  348. - new upstream release
  349. * Thu Sep 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.0-1
  350. - new upstream release
  351. * Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.4-1
  352. - new upstream release
  353. * Tue Jun 09 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.3-1
  354. - new upstream release
  355. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-1
  356. - new upstream release
  357. * Sat Apr 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.1-1
  358. - new upstream release
  359. * Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.0-1
  360. - new upstream release
  361. * Sun Jan 18 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.18.4-1
  362. - new upstream release
  363. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.3-1
  364. - new upstream release
  365. * Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.2-1
  366. - new upstream release
  367. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-1
  368. - new upstream release
  369. * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
  370. - new upstream release
  371. * Mon Jul 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.4-1
  372. - new upstream release
  373. * Sat May 10 2008 NAKAMURA Kenta <kenta@vinelinux.org> 2.16.3-2
  374. - updated %%if %%{build_compat32} case related statements
  375. * Wed Apr 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.3-1vl5
  376. - new upstream release
  377. - removed lib*.la files from devel package
  378. * Sun Apr 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.2-1vl5
  379. - new upstream release
  380. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-1vl5
  381. - added %%{?_dist_release}
  382. - BuildRequires: gamin-devel
  383. * Tue Mar 11 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.16.1-0vl1
  384. - new upstream release
  385. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.6-0vl1
  386. - new upstream release
  387. * Wed Jan 9 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.5-0vl1
  388. - new upstream release
  389. * Wed Nov 14 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
  390. - new upstream release
  391. * Thu Oct 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.2-0vl1
  392. - new upstream release
  393. - removed BuildRequires: automake17
  394. * Thu Sep 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.1-0vl1
  395. - new upstream release
  396. * Sun Aug 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.0-0vl1
  397. - new upstream release
  398. * Wed Jul 18 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.13-0vl1
  399. - new upstream release
  400. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl2
  401. - rebuild with new environment
  402. * Thu May 03 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.12-0vl1
  403. - new upstream release
  404. * Thu Mar 15 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.11-0vl1
  405. - new upstream release
  406. * Mon Jan 08 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.7-0vl1
  407. - new upstream release
  408. * Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.6-0vl1
  409. - new upstream release
  410. * Thu Aug 31 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.3-0vl1
  411. - new upstream release
  412. * Wed Aug 16 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
  413. - new upstream release
  414. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
  415. - new upstream release
  416. * Mon Jun 26 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.3-0vl3
  417. - rebuild
  418. * Sun Jun 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl2
  419. - update glib2.{sh,csh}
  420. - add EUC-JP,CP932,UTF-8 to G_FILENAME_ENCODING
  421. * Fri Jun 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.3-0vl1
  422. - new upstream release
  423. * Sat Apr 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.2-0vl1
  424. - new upstream release
  425. * Thu Mar 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.1-0vl1
  426. - new upstream release
  427. * Sun Mar 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
  428. - new upstream release
  429. * Mon Feb 27 2006 Shu KONNO <owa@bg.wakwak.com> 2.8.6-0vl2
  430. - added compat32-* packages for x86_64 architecture support
  431. - chaged G_ATOMIC_X86_64 to I486 in config.h before making compat32
  432. * Sun Jan 29 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.6-0vl1
  433. - new upstream release
  434. * Thu Jan 12 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.5-0vl1
  435. - new upstream release
  436. * Wed Nov 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.4-0vl1
  437. - new upstream release
  438. * Tue Sep 27 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.2-0vl1
  439. - new upstream release
  440. * Tue Sep 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl3
  441. - fixed typo in glib2.csh
  442. * Sun Sep 18 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl2
  443. - update glib2.{sh,csh} to use G_FILENAME_ENCODING instead of
  444. G_BROKEN_FILENAMES.
  445. * Wed Aug 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.1-0vl1
  446. - new upstream release
  447. * Sat Aug 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-0vl1
  448. - new upstream release
  449. * Sat Aug 06 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.7-0vl1
  450. - new upstream release
  451. * Fri Aug 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.6-0vl1
  452. - new upstream release
  453. * Tue Aug 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.4-0vl1
  454. - new upstream release
  455. * Sun Jul 03 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.5-0vl1
  456. - new upstream release
  457. - add *.la to build arts (should be fixed in arts?)
  458. * Sat Apr 09 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
  459. - new upstream release
  460. * Fri Mar 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.3-0vl1
  461. - new upstream release
  462. * Sat Feb 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.2-0vl1
  463. - new upstream release
  464. * Mon Jan 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-0vl1
  465. - new upstream release
  466. * Sat Dec 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.8-0vl1
  467. - new upstream release
  468. * Mon Nov 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl2
  469. - rebuilt
  470. * Mon Oct 11 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.7-0vl1
  471. - new upstream release
  472. * Sat Aug 14 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.6-0vl1
  473. - new upstream release
  474. * Sun Aug 08 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.5-0vl1
  475. - new upstream release
  476. * Fri Jul 16 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.4-0vl1
  477. - new upstream release
  478. * Sat Jun 5 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-0vl1
  479. - new upstream release
  480. * Sat May 1 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-0vl1
  481. - new upstream release
  482. * Thu Mar 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
  483. - new upstream release
  484. * Wed Dec 24 2003 Tomoya TAKA <taka@vinelinux.org> 2.2.3-0vl2
  485. - rebuild with new toolchain
  486. * Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.3-0vl1
  487. - new upstream release
  488. * Tue Jun 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.2-0vl1
  489. - new upstream release
  490. * Mon Feb 10 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
  491. - new upstream release
  492. * Wed Dec 25 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
  493. - new upstream release
  494. * Fri Dec 13 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.4-0vl1
  495. - new upstream release
  496. - build for Vine Linux
  497. * Tue Aug 13 2002 Havoc Pennington <hp@redhat.com>
  498. - install glib2.sh and glib2.csh to set G_BROKEN_FILENAMES
  499. - blow away unpackaged files in install
  500. * Thu Aug 8 2002 Owen Taylor <otaylor@redhat.com>
  501. - Version 2.0.6
  502. - Remove fixed-ltmain.sh; shouldn't be needed any more.
  503. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  504. - automated rebuild
  505. * Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
  506. - 2.0.4
  507. * Thu May 23 2002 Tim Powers <timp@redhat.com>
  508. - automated rebuild
  509. * Wed Apr 24 2002 Havoc Pennington <hp@redhat.com>
  510. - rebuild in different environment
  511. * Mon Apr 15 2002 Owen Taylor <otaylor@redhat.com>
  512. - Fix missing .po files (#63336)
  513. * Wed Apr 3 2002 Alex Larsson <alexl@redhat.com>
  514. - Update to version 2.0.1
  515. * Fri Mar 8 2002 Owen Taylor <otaylor@redhat.com>
  516. - Version 2.0.0
  517. * Mon Feb 25 2002 Alex Larsson <alexl@redhat.com>
  518. - Update to 1.3.15
  519. * Thu Feb 21 2002 Alex Larsson <alexl@redhat.com>
  520. - Bump for rebuild
  521. * Mon Feb 18 2002 Alex Larsson <alexl@redhat.com>
  522. - Update to 1.3.14
  523. * Fri Feb 15 2002 Havoc Pennington <hp@redhat.com>
  524. - add horrible buildrequires hack
  525. * Thu Feb 14 2002 Havoc Pennington <hp@redhat.com>
  526. - 1.3.13.91 cvs snap
  527. * Mon Feb 11 2002 Matt Wilson <msw@redhat.com>
  528. - rebuild from CVS snapshot
  529. - use setup -q
  530. * Thu Jan 31 2002 Jeremy Katz <katzj@redhat.com>
  531. - rebuild
  532. * Tue Jan 29 2002 Owen Taylor <otaylor@redhat.com>
  533. - 1.3.13
  534. * Tue Jan 22 2002 Havoc Pennington <hp@redhat.com>
  535. - attempting rebuild in rawhide
  536. * Wed Jan 2 2002 Havoc Pennington <hp@redhat.com>
  537. - remove 64-bit patch now upstream, 1.3.12.90
  538. * Mon Nov 26 2001 Havoc Pennington <hp@redhat.com>
  539. - add some missing files to file list, langify
  540. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  541. - add temporary patch to fix GTypeFundamentals on 64-bit
  542. * Sun Nov 25 2001 Havoc Pennington <hp@redhat.com>
  543. - Version 1.3.11
  544. * Thu Oct 25 2001 Owen Taylor <otaylor@redhat.com>
  545. - Version 1.3.10
  546. * Tue Sep 25 2001 Owen Taylor <otaylor@redhat.com>
  547. - Version 1.3.9
  548. * Wed Sep 19 2001 Owen Taylor <otaylor@redhat.com>
  549. - Version 1.3.8
  550. * Fri Jul 20 2001 Owen Taylor <otaylor@redhat.com>
  551. - Make -devel package require main package (#45388)
  552. - Fix description and summary
  553. - Configure with --disable-gtk-doc
  554. * Wed Jun 20 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  555. - add some portability fixes needed at least on s390
  556. - copy config.{guess,sub} instead of calling libtoolize
  557. * Wed Jun 13 2001 Havoc Pennington <hp@redhat.com>
  558. - try a new glib tarball with Makefile changes to work around
  559. libtool linking to installed .la files
  560. - make -devel require pkgconfig
  561. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  562. - either libtool or the bad libtool hacks caused link
  563. against glib-gobject 1.3.2, rebuild
  564. * Tue Jun 12 2001 Havoc Pennington <hp@redhat.com>
  565. - 1.3.6
  566. - bad libtool workarounds
  567. * Fri May 04 2001 Owen Taylor <otaylor@redhat.com>
  568. - 1.3.5, rename to glib2
  569. * Fri Nov 17 2000 Owen Taylor <otaylor@redhat.com>
  570. - Final 1.3.2
  571. * Mon Nov 13 2000 Owen Taylor <otaylor@redhat.com>
  572. - Version 1.3.2pre1
  573. - Remove pkgconfig
  574. * Sun Aug 13 2000 Owen Taylor <otaylor@redhat.com>
  575. - Call 1.3.1b instead of snap... the snap* naming doesn't
  576. order correctly.
  577. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  578. - new snapshot with fixed .pc files
  579. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  580. - include .pc files in file list
  581. * Thu Aug 10 2000 Havoc Pennington <hp@redhat.com>
  582. - Include pkg-config
  583. - Upgrade to a glib CVS snapshot
  584. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  585. - rebuild to cope with glibc locale binary incompatibility
  586. * Fri Jul 14 2000 Owen Taylor <otaylor@redhat.com>
  587. - Remove glib-config.1 manpage from build since
  588. it conflicts with glib-devel. When we go to
  589. glib glib1.2 setup, we should add it back
  590. * Fri Jul 07 2000 Owen Taylor <otaylor@redhat.com>
  591. - Version 1.3.1
  592. - Move back to standard %{prefix}
  593. * Thu Jun 8 2000 Owen Taylor <otaylor@redhat.com>
  594. - Rebuild in /opt/gtk-beta
  595. * Tue May 30 2000 Owen Taylor <otaylor@redhat.com>
  596. - New version (adds gobject)
  597. * Tue Apr 25 2000 Owen Taylor <otaylor@redhat.com>
  598. - Don't blow away /etc/ld.so.conf (sorry!)
  599. * Mon Apr 24 2000 Owen Taylor <otaylor@redhat.com>
  600. - Snapshot RPM for Pango testing
  601. * Fri Feb 04 2000 Owen Taylor <otaylor@redhat.com>
  602. - Added fixes from stable branch of CVS
  603. * Thu Oct 7 1999 Owen Taylor <otaylor@redhat.com>
  604. - version 1.2.6
  605. * Fri Sep 24 1999 Owen Taylor <otaylor@redhat.com>
  606. - version 1.2.5
  607. * Fri Sep 17 1999 Owen Taylor <otaylor@redhat.com>
  608. - version 1.2.4
  609. * Mon Jun 7 1999 Owen Taylor <otaylor@redhat.com>
  610. - version 1.2.3
  611. * Thu Mar 25 1999 Michael Fulbright <drmike@redhat.com>
  612. - version 1.2.1
  613. * Fri Feb 26 1999 Michael Fulbright <drmike@redhat.com>
  614. - Version 1.2
  615. * Thu Feb 25 1999 Michael Fulbright <drmike@redhat.com>
  616. - version 1.2.0pre1
  617. * Tue Feb 23 1999 Cristian Gafton <gafton@redhat.com>
  618. - new description tags
  619. * Sun Feb 21 1999 Michael Fulbright <drmike@redhat.com>
  620. - removed libtoolize from %build
  621. * Thu Feb 11 1999 Michael Fulbright <drmike@redhat.com>
  622. - added libgthread to file list
  623. * Fri Feb 05 1999 Michael Fulbright <drmike@redhat.com>
  624. - version 1.1.15
  625. * Wed Feb 03 1999 Michael Fulbright <drmike@redhat.com>
  626. - version 1.1.14
  627. * Mon Jan 18 1999 Michael Fulbright <drmike@redhat.com>
  628. - version 1.1.13
  629. * Wed Jan 06 1999 Michael Fulbright <drmike@redhat.com>
  630. - version 1.1.12
  631. * Wed Dec 16 1998 Michael Fulbright <drmike@redhat.com>
  632. - updated in preparation for the GNOME freeze
  633. * Mon Apr 13 1998 Marc Ewing <marc@redhat.com>
  634. - Split out glib package