perl-Test-SubCalls-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125
  1. # define bootstrap for initial build
  2. %define perl_bootstrap 1
  3. Name: perl-Test-SubCalls
  4. Version: 1.09
  5. Release: 1%{?_dist_release}
  6. Summary: Track the number of times subs are called
  7. Group: Development/Libraries
  8. License: GPL+ or Artistic
  9. URL: http://search.cpan.org/dist/Test-SubCalls/
  10. Source0: http://www.cpan.org/authors/id/A/AD/ADAMK/Test-SubCalls-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  12. BuildArch: noarch
  13. BuildRequires: perl(Hook::LexWrap) >= 0.20
  14. BuildRequires: perl(Test::Builder::Tester) >= 1.02
  15. BuildRequires: perl(Test::Pod) >= 1.00
  16. BuildRequires: perl(Test::More) >= 0.60
  17. BuildRequires: perl(Class::Inspector)
  18. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  19. %if 0%{!?perl_bootstrap:1}
  20. # for improved tests
  21. BuildRequires: perl(Test::CPAN::Meta) >= 0.12
  22. # FIXME: Fedora's Pod::Simple is outdated
  23. # BuildRequires: perl(Pod::Simple) >= 3.07
  24. BuildRequires: perl(Pod::Simple)
  25. BuildRequires: perl(Test::Pod) >= 1.26
  26. BuildRequires: perl(Test::MinimumVersion) >= 0.008
  27. %endif
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. Packager: shaolin
  31. %description
  32. There are a number of different situations (like testing cacheing
  33. code) where you want to want to do a number of tests, and then verify
  34. that some underlying subroutine deep within the code was called a
  35. specific number of times.
  36. %prep
  37. %setup -q -n Test-SubCalls-%{version}
  38. %build
  39. %{__perl} Makefile.PL INSTALLDIRS=vendor
  40. make %{?_smp_mflags}
  41. %install
  42. rm -rf $RPM_BUILD_ROOT
  43. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  44. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  45. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  46. chmod -R u+w $RPM_BUILD_ROOT/*
  47. %check
  48. make test AUTOMATED_TESTING=1
  49. %clean
  50. rm -rf $RPM_BUILD_ROOT
  51. %files
  52. %defattr(-,root,root,-)
  53. %doc Changes LICENSE README
  54. %{perl_vendorlib}/Test/
  55. %{_mandir}/man3/*.3pm*
  56. %changelog
  57. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.09-1
  58. - initial build for Vine Linux
  59. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.09-7
  60. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  61. * Tue Jul 19 2011 Petr Sabata <contyk@redhat.com> - 1.09-6
  62. - Perl mass rebuild
  63. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.09-5
  64. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  65. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.09-4
  66. - 661697 rebuild for fixing problems with vendorach/lib
  67. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 1.09-3
  68. - Mass rebuild with perl-5.12.0
  69. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 1.09-2
  70. - rebuild against perl 5.10.1
  71. * Wed Oct 7 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.09-1
  72. - update to new upstream release
  73. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.08-3
  74. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  75. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.08-2
  76. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  77. * Mon Oct 05 2008 Ralf Corsépius <corsepiu@fedoraproject.org> - 1.08-1
  78. - Upstream update.
  79. - Activate AUTOMATED_TESTING.
  80. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.07-3
  81. - Rebuild for perl 5.10 (again)
  82. * Sat Jan 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.07-2
  83. - rebuild for new perl
  84. * Wed Dec 19 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.07-1
  85. - bump to 1.07
  86. - license fix
  87. * Fri May 12 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 1.06-1
  88. - Update to 1.06.
  89. * Tue Apr 25 2006 Jose Pedro Oliveira <jpo at di.uminho.pt> - 0.05-1
  90. - First build.