kdebindings-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679
  1. %define csharp 1
  2. %define falcon 0
  3. %define php 1
  4. %define ruby 1
  5. %define smoke 1
  6. %define java 0
  7. %define pykde4_akonadi 1
  8. %define pyqt4_version 4.7
  9. # Qt4 version auto-detection -- inagaki
  10. %define _qt4_version %(pkg-config --modversion --silence-errors Qt 2>/dev/null || echo 4.6.3)
  11. %define mono_dir %{_prefix}/lib/mono
  12. #if 0%{?ruby}%{?smoke}
  13. #define devel 1
  14. #endif
  15. %global ruby_lib %(ruby -rrbconfig -e 'puts Config::CONFIG["rubylibdir"]')
  16. %global ruby_arch %(ruby -rrbconfig -e 'puts Config::CONFIG["archdir"]')
  17. %global ruby_sitelib %(ruby -rrbconfig -e 'puts Config::CONFIG["sitelibdir"]')
  18. %global ruby_sitearch %(ruby -rrbconfig -e 'puts Config::CONFIG["sitearchdir"]')
  19. %global python_ver %(%{__python} -c "import sys ; print sys.version[:3]")
  20. %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")
  21. %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")
  22. Name: kdebindings
  23. Version: 4.5.0
  24. Release: 1%{?_dist_release}
  25. Summary: KDE bindings to non-C++ languages.
  26. Source: ftp://ftp.kde.org/pub/kde/stable/%{version}/src/kdebindings-%{version}.tar.bz2
  27. # http://techbase.kde.org/Policies/Licensing_Policy
  28. License: LGPLv2+
  29. Group: System Environment/Libraries
  30. URL: http://www.kde.org/
  31. # fix build with CMAKE_SKIP_RPATH - also needs sed line below
  32. # WARNING: This is a bunch of quick hacks to get this to build. Please do not
  33. # commit this upstream without further discussion.
  34. Patch1: kdebindings-4.3.75-no-rpath.patch
  35. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  36. BuildRequires: akonadi-devel >= 1.4.0
  37. BuildRequires: kdebase-workspace-devel >= %{version}
  38. # okular bindings
  39. BuildRequires: kdegraphics4-devel >= %{version}
  40. BuildRequires: kdelibs4-devel >= %{version}
  41. BuildRequires: kdepimlibs-devel >= %{version}
  42. # kdebindings does not support polkit-qt-1 yet
  43. %if %{?_dist_release} == "vl4" || %{?_dist_release} == "vl5"
  44. BuildRequires: polkit-qt-devel
  45. %endif
  46. BuildRequires: python-devel
  47. BuildRequires: PyQt4-devel >= %{pyqt4_version}
  48. BuildRequires: qimageblitz-devel
  49. BuildRequires: qscintilla-devel >= 2.4
  50. BuildRequires: soprano-devel
  51. %if %{csharp}
  52. BuildRequires: mono-core
  53. BuildRequires: mono-devel
  54. %endif
  55. %if %{falcon}
  56. BuildRequires: Falcon-devel >= 0.8.12
  57. %endif
  58. %if %{php}
  59. BuildRequires: php5-devel
  60. %endif
  61. %if %{ruby}
  62. BuildRequires: ruby-devel
  63. BuildRequires: ruby
  64. %endif
  65. %if %{java}
  66. # TODO: kross-java is a mess, not sure what it needs to build
  67. # CMakeLists.txt is also not portable (only gcj and i486 hardcoded)
  68. # -- mathstuf
  69. BuildRequires: java-1.6.0-openjdk-devel
  70. %endif
  71. Requires: kdelibs4 >= %{version}
  72. Conflicts: kdebindings < 4
  73. %description
  74. KDE bindings to non-C++ languages
  75. %package devel
  76. Summary: Development files for kdebindings.
  77. Group: Development/Libraries
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: kdelibs4-devel
  80. Conflicts: kdebindings-devel < 4
  81. %description devel
  82. Development files for the KDE bindings.
  83. Install kdebindings-devel if you want to develop non-KDE applications
  84. that talk to KDE.
  85. %package -n PyKDE4
  86. Summary: Python bindings for KDE4
  87. Summary(ja): KDE4 の Python バインディング
  88. Group: Development/Languages
  89. Requires: kdelibs4 >= %{version}
  90. Requires: PyQt4 >= %{pyqt4_version}
  91. %description -n PyKDE4
  92. %{summary}.
  93. %package -n PyKDE4-akonadi
  94. Summary: Akonadi runtime support for PyKDE4
  95. Group: Development/Languages
  96. Requires: PyKDE4 = %{version}-%{release}
  97. Requires: kdepimlibs-akonadi >= %{version}
  98. %description -n PyKDE4-akonadi
  99. %{summary}.
  100. %package -n PyKDE4-devel
  101. Group: Development/Libraries
  102. Summary: Files needed to build PyKDE4-based applications
  103. Requires: PyQt4-devel
  104. Requires: PyKDE4 = %{version}-%{release}
  105. Requires: PyKDE4-akonadi = %{version}-%{release}
  106. %description -n PyKDE4-devel
  107. %{summary}.
  108. # C# bindings
  109. %if %{csharp}
  110. %package -n kimono
  111. Group: Development/Languages
  112. Summary: C# bindings for KDE4
  113. Summary(ja): KDE4 の C# バインディング
  114. Requires: kdelibs4 >= %{version}
  115. Requires: qyoto = %{version}-%{release}
  116. Provides: kimono4 = %{version}-%{release}
  117. %description -n kimono
  118. %{summary}.
  119. %package -n qyoto
  120. Group: Development/Languages
  121. Summary: C# bindings for Qt4
  122. Summary(ja): Qt4 の C# バインディング
  123. Requires: qt4 >= %{qt4_version}
  124. Provides: qyoto4 = %{version}-%{release}
  125. %description -n qyoto
  126. %{summary}.
  127. %package -n qyoto-devel
  128. Group: Development/Libraries
  129. Summary: Development files for qyoto
  130. Requires: qyoto = %{version}-%{release}
  131. Requires: mono-devel
  132. Provides: qyoto4-devel = %{version}-%{release}
  133. %description -n qyoto-devel
  134. %{summary}.
  135. %endif
  136. # Ruby
  137. %if %{ruby}
  138. %package -n korundum
  139. Group: Development/Languages
  140. Summary: Ruby bindings for KDE4
  141. Summary(ja): KDE4 の Ruby バインディング
  142. Requires: kdelibs4 >= %{version}
  143. Requires: QtRuby = %{version}-%{release}
  144. Provides: korundum4 = %{version}-%{release}
  145. %description -n korundum
  146. %{summary}.
  147. %package -n korundum-devel
  148. Group: Development/Libraries
  149. Summary: Development files for korundum
  150. Requires: QtRuby-devel
  151. Requires: korundum = %{version}-%{release}
  152. Provides: korundum4-devel = %{version}-%{release}
  153. %description -n korundum-devel
  154. %{summary}.
  155. %package -n QtRuby
  156. Group: Development/Languages
  157. Summary: Ruby bindings for Qt4
  158. Summary(ja): Qt4 の Ruby バインディング
  159. Requires: qt4 >= %{qt4_version}
  160. Provides: QtRuby4 = %{version}-%{release}
  161. %description -n QtRuby
  162. %{summary}.
  163. %package -n QtRuby-devel
  164. Group: Development/Libraries
  165. Summary: Development files for QtRuby
  166. Requires: QtRuby = %{version}-%{release}
  167. Provides: QtRuby4-devel = %{version}-%{release}
  168. %description -n QtRuby-devel
  169. %{summary}.
  170. %endif
  171. %if %{php}
  172. %package -n php-qt
  173. Group: Development/Languages
  174. Summary: PHP bindings for Qt4
  175. Summary(ja): Qt4 の PHP バインディング
  176. Requires: qt4 >= %{qt4_version}
  177. Provides: php-qt4 = %{version}-%{release}
  178. %description -n php-qt
  179. %{summary}.
  180. %package -n php-qt-devel
  181. Group: Development/Libraries
  182. Summary: Development files for php-qt
  183. Requires: php-qt = %{version}-%{release}
  184. Provides: php-qt4-devel = %{version}-%{release}
  185. %description -n php-qt-devel
  186. %{summary}.
  187. %endif
  188. %package -n kross-python
  189. Group: Development/Languages
  190. Summary: Kross plugin for python
  191. Requires: kdelibs4 >= %{version}
  192. Provides: kross(python) = %{version}-%{release}
  193. %description -n kross-python
  194. Python plugin for the Kross archtecture in KDE4.
  195. %if %{ruby}
  196. %package -n kross-ruby
  197. Group: Development/Languages
  198. Summary: Kross plugin for ruby
  199. Requires: ruby
  200. Requires: kdelibs4 >= %{version}
  201. Provides: kross(ruby) = %{version}-%{release}
  202. %description -n kross-ruby
  203. Ruby plugin for the Kross archtecture in KDE4.
  204. %endif
  205. %if %{falcon}
  206. %package -n kross-falcon
  207. Group: Development/Languages
  208. Summary: Kross plugin for falcon
  209. Requires: Falcon >= 0.8.12
  210. Requires: kdelibs4 >= %{version}
  211. Provides: kross(falcon) = %{version}-%{release}
  212. %description -n kross-falcon
  213. Falcon plugin for the Kross archtecture in KDE4.
  214. %endif
  215. %prep
  216. %setup -q -n kdebindings-%{version}
  217. # do the no-rpath hack last, after the upstream backports (if any)
  218. #patch1 -p1 -b .no-rpath
  219. #sed -i -e 's!COMMAND generator!COMMAND ${PROJECT_BINARY_DIR}/generator/bin/generator${CMAKE_EXECUTABLE_SUFFIX}.shell!g' -e 's/WORKING_DIRECTORY/DEPENDS generator WORKING_DIRECTORY/g' smoke/*/CMakeLists.txt
  220. %build
  221. mkdir -p %{_target_platform}
  222. pushd %{_target_platform}
  223. unset QTDIR || : ; . /etc/profile.d/qt4.sh
  224. %cmake \
  225. -DCMAKE_BUILD_TYPE=release \
  226. -DDATA_INSTALL_DIR:PATH=%{_datadir}/kde4/apps \
  227. -DINCLUDE_INSTALL_DIR:PATH=%{_includedir}/kde4 \
  228. -DLIBEXEC_INSTALL_DIR:PATH=%{_libexecdir}/kde4 \
  229. -DPYTHON_LIBRARY=%{_libdir}/libpython%{python_ver}.so.1.0 \
  230. -DPYTHON_LIBRARIES=%{_libdir}/libpython%{python_ver}.so.1.0 \
  231. -DPYTHON_INCLUDE_PATH=%{_includedir}/python%{python_ver} \
  232. %if %{csharp}
  233. -DENABLE_QYOTO=ON \
  234. %else
  235. -DBUILD_csharp=OFF \
  236. %endif
  237. %if %{falcon}
  238. -DENABLE_KROSSFALCON=ON \
  239. %else
  240. -DBUILD_falcon=OFF \
  241. %endif
  242. %if %{php}
  243. -DENABLE_PHP-QT=ON \
  244. %else
  245. -DBUILD_php=OFF \
  246. %endif
  247. %if %{ruby}
  248. -DRUBY_SITE_LIB_DIR:PATH=%{ruby_sitelib} \
  249. -DRUBY_SITE_ARCH_DIR:PATH=%{ruby_sitearch} \
  250. -DCUSTOM_RUBY_SITE_LIB_DIR:PATH=%{ruby_lib} \
  251. -DCUSTOM_RUBY_SITE_ARCH_DIR:PATH=%{ruby_arch} \
  252. %else
  253. -DBUILD_ruby=OFF \
  254. %endif
  255. %if %{smoke}
  256. -DENABLE_SMOKE=ON \
  257. %else
  258. -DBUILD_smoke=OFF \
  259. %endif
  260. %if %{java}
  261. -DENABLE_KROSSJAVA=ON \
  262. %else
  263. -DBUILD_java=OFF \
  264. %endif
  265. -DCMAKE_SKIP_RPATH:BOOL=OFF \
  266. -DBUILD_perl=OFF \
  267. ..
  268. popd
  269. # -DRUBY_INCLUDE_PATH:PATH=%{ruby_arch} \
  270. # smp build not recommended (upstream)
  271. make -C %{_target_platform}
  272. %install
  273. rm -rf $RPM_BUILD_ROOT
  274. make install/fast DESTDIR=$RPM_BUILD_ROOT -C %{_target_platform}
  275. # HACK: fix multilb conflict, similar to PyQt4's http://bugzilla.redhat.com/509415
  276. rm -fv $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  277. mv $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py \
  278. $RPM_BUILD_ROOT%{_bindir}/pykdeuic4
  279. ln -s %{_bindir}/pykdeuic4 \
  280. $RPM_BUILD_ROOT%{python_sitearch}/PyQt4/uic/pykdeuic4.py
  281. # install pykde4 examples under correct dir
  282. #mkdir -p %{buildroot}%{_docdir}
  283. #rm -f %{buildroot}%{_datadir}/kde4/apps/pykde4/examples/*.py?
  284. #mv %{buildroot}%{_datadir}/kde4/apps/pykde4 %{buildroot}%{_docdir}/
  285. # bz#551534 - qyoto doesn't pull mono in
  286. %if %{csharp}
  287. find %{buildroot} -name \*.dll -not -type l | xargs chmod ugo+x
  288. %endif
  289. %clean
  290. rm -rf $RPM_BUILD_ROOT
  291. %post -p /sbin/ldconfig
  292. %postun -p /sbin/ldconfig
  293. %pre -n PyKDE4-devel
  294. if [ -d %{_bindir}/pykdeuic4 ]; then
  295. rm -rf %{_bindir}/pykdeuic4/
  296. fi
  297. %if %{csharp}
  298. %post -n qyoto -p /sbin/ldconfig
  299. %postun -n qyoto -p /sbin/ldconfig
  300. %endif
  301. %files
  302. %defattr(-,root,root)
  303. %doc AUTHORS ChangeLog COPYING NEWS README
  304. %if %{smoke}
  305. %{_libdir}/libsmoke*.so.*
  306. %endif
  307. %files devel
  308. %defattr(-,root,root)
  309. %if %{smoke}
  310. %{_bindir}/smoke*
  311. %{_includedir}/smoke.h
  312. %{_includedir}/smoke
  313. %{_includedir}/smokegen
  314. %{_libdir}/libcppparser.so
  315. %{_libdir}/libsmoke*.so
  316. %dir %{_libdir}/smokegen
  317. %{_libdir}/smokegen/*.so
  318. %{_datadir}/smokegen
  319. %endif
  320. %files -n PyKDE4
  321. %defattr(-,root,root,-)
  322. %doc COPYING
  323. %{python_sitearch}/PyKDE4
  324. %{python_sitearch}/PyQt4/uic/widget-plugins/kde4.py*
  325. %dir %{_datadir}/kde4/apps/pykde4
  326. %{_libdir}/kde4/kpythonpluginfactory.so
  327. %exclude %{python_sitearch}/PyKDE4/akonadi.so
  328. %files -n PyKDE4-akonadi
  329. %defattr(-,root,root,-)
  330. %{python_sitearch}/PyKDE4/akonadi.so
  331. %files -n PyKDE4-devel
  332. %defattr(-,root,root,-)
  333. %{_bindir}/pykdeuic4
  334. %{python_sitearch}/PyQt4/uic/pykdeuic4.py*
  335. %{_datadir}/kde4/apps/pykde4/examples/
  336. %{_datadir}/sip/PyKDE4
  337. %if %{csharp}
  338. %files -n kimono
  339. %defattr(-,root,root,-)
  340. %{_libdir}/kde4/kimonopluginfactory.so
  341. %{_libdir}/libakonadi-sharp.so
  342. %{_libdir}/libkhtml-sharp.so
  343. %{_libdir}/libkimono.so
  344. %{_libdir}/libktexteditor-sharp.so
  345. %{_libdir}/libnepomuk-sharp.so
  346. %{_libdir}/libphonon-sharp.so
  347. %{_libdir}/libplasma-sharp.so
  348. %{_libdir}/libqimageblitz-sharp.so
  349. %{_libdir}/libqscintilla-sharp.so
  350. %{_libdir}/libsoprano-sharp.so
  351. %{mono_dir}/qyoto/qimageblitz.dll
  352. %{mono_dir}/qyoto/akonadi.dll
  353. %{mono_dir}/qyoto/kde-dotnet.dll
  354. %{mono_dir}/qyoto/khtml-dll.dll
  355. %{mono_dir}/qyoto/ktexteditor-dotnet.dll
  356. %{mono_dir}/qyoto/nepomuk-dll.dll
  357. %{mono_dir}/qyoto/phonon.dll
  358. %{mono_dir}/qyoto/plasma-dll.dll
  359. %{mono_dir}/qyoto/qscintilla.dll
  360. %{mono_dir}/qyoto/soprano.dll
  361. %{mono_dir}/gac/akonadi
  362. %{mono_dir}/gac/kde-dotnet
  363. %{mono_dir}/gac/khtml-dll
  364. %{mono_dir}/gac/ktexteditor-dotnet
  365. %{mono_dir}/gac/nepomuk-dll
  366. %{mono_dir}/gac/phonon
  367. %{mono_dir}/gac/plasma-dll
  368. %{mono_dir}/gac/qscintilla
  369. %{mono_dir}/gac/soprano
  370. %{mono_dir}/gac/qimageblitz
  371. %{_datadir}/kde4/apps/plasma_scriptengine_kimono
  372. %{_datadir}/kde4/services/plasma-scriptengine-kimono-applet.desktop
  373. %{_datadir}/kde4/services/plasma-scriptengine-kimono-dataengine.desktop
  374. %files -n qyoto
  375. %defattr(-,root,root,-)
  376. %{_libdir}/libqtscript-sharp.so
  377. %{_libdir}/libqttest-sharp.so
  378. %{_libdir}/libqtuitools-sharp.so
  379. %{_libdir}/libqtwebkit-sharp.so
  380. %{_libdir}/libqyoto.so.*
  381. %{mono_dir}/qyoto/qt-dotnet.dll
  382. %{mono_dir}/qyoto/qtscript.dll
  383. %{mono_dir}/qyoto/qttest.dll
  384. %{mono_dir}/qyoto/qtuitools.dll
  385. %{mono_dir}/qyoto/qtwebkit.dll
  386. %{mono_dir}/gac/qt-dotnet
  387. %{mono_dir}/gac/qtscript
  388. %{mono_dir}/gac/qttest
  389. %{mono_dir}/gac/qtuitools
  390. %{mono_dir}/gac/qtwebkit
  391. %files -n qyoto-devel
  392. %defattr(-,root,root,-)
  393. %{_bindir}/csrcc
  394. %{_bindir}/uics
  395. %{_includedir}/qyoto
  396. %{_libdir}/libqyoto.so
  397. %{_libdir}/pkgconfig/*
  398. %endif
  399. %if %{ruby}
  400. %files -n korundum
  401. %defattr(-,root,root,-)
  402. %{_bindir}/krubyapplication
  403. %{ruby_lib}/KDE/
  404. %{ruby_lib}/akonadi/
  405. %{ruby_lib}/khtml/
  406. %{ruby_lib}/kio/
  407. %{ruby_lib}/ktexteditor/
  408. %{ruby_lib}/okular/
  409. %{ruby_lib}/phonon/
  410. %{ruby_lib}/qscintilla/
  411. %{ruby_lib}/solid/
  412. %{ruby_lib}/soprano/
  413. %{ruby_lib}/nepomuk/
  414. %{ruby_arch}/akonadi.so
  415. %{ruby_arch}/khtml.so
  416. %{ruby_arch}/kio.so
  417. %{ruby_arch}/korundum4.so
  418. %{ruby_arch}/ktexteditor.so
  419. %{ruby_arch}/okular.so
  420. %{ruby_arch}/phonon.so
  421. %{ruby_arch}/plasma_applet.so
  422. %{ruby_arch}/solid.so
  423. %{ruby_arch}/soprano.so
  424. %{ruby_arch}/nepomuk.so
  425. %{ruby_arch}/qscintilla.so
  426. %{_libdir}/kde4/krubypluginfactory.so
  427. %{_datadir}/applications/kde4/dbpedia_references.desktop
  428. %{_datadir}/kde4/apps/dbpedia_references
  429. %files -n korundum-devel
  430. %defattr(-,root,root,-)
  431. %{_bindir}/rbkconfig_compiler4
  432. %{_includedir}/qtruby/
  433. %exclude %{_libdir}/libqtruby4shared.so
  434. %files -n QtRuby
  435. %defattr(-,root,root,-)
  436. %{ruby_lib}/Qt/
  437. %{ruby_lib}/Qt*.rb
  438. %{ruby_lib}/qtscript/
  439. %{ruby_lib}/qttest/
  440. %{ruby_lib}/qtuitools/
  441. %{ruby_lib}/qtwebkit/
  442. %{ruby_arch}/qt*.so
  443. %{_libdir}/libqtruby4shared.so.2
  444. %{_libdir}/libqtruby4shared.so.2.0.0
  445. %files -n QtRuby-devel
  446. %defattr(-,root,root,-)
  447. %{_bindir}/rbqtapi
  448. %{_bindir}/rbrcc
  449. %{_bindir}/rbuic4
  450. %{_libdir}/libqtruby4shared.so
  451. %endif
  452. %if %{php}
  453. %files -n php-qt
  454. %defattr(-,root,root,-)
  455. %{_libdir}/php5/php_qt.so
  456. %files -n php-qt-devel
  457. %defattr(-,root,root,-)
  458. %{_bindir}/phpuic
  459. %endif
  460. %files -n kross-python
  461. %defattr(-,root,root,-)
  462. # unversioned library
  463. %{_libdir}/kde4/krosspython.so
  464. %if %{ruby}
  465. %files -n kross-ruby
  466. %defattr(-,root,root,-)
  467. %{_libdir}/kde4/krossruby.so
  468. %endif
  469. %if %{falcon}
  470. %files -n kross-falcon
  471. %defattr(-,root,root,-)
  472. %{_libdir}/kde4/krossfalcon.so
  473. %endif
  474. %changelog
  475. * Tue Aug 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.5.0-1
  476. - new upstream release
  477. * Sun Jul 4 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.5-1
  478. - new upstream release
  479. * Fri May 7 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  480. - new upstream release
  481. * Thu Apr 15 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.2-1
  482. - new upstream release
  483. * Tue Mar 9 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.1-1
  484. - new upstream release
  485. - added -DCMAKE_SKIP_RPATH:BOOL=OFF option to cmake
  486. (see https://bugs.kde.org/show_bug.cgi?id=214824)
  487. - built with new toolchain
  488. * Wed Nov 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.3-1
  489. - new upstream release
  490. * Thu Oct 29 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-4
  491. - merged 4.3.1-2 %changelog
  492. - re-define %%{mono_dir} to %{_prefix}/lib/mono (again)
  493. * Tue Oct 27 2009 Shu KONNO <owa@bg.wakwak.com> 4.3.2-3
  494. - use %%{_prefix}/lib for mono-dll (for x86_64)
  495. * Tue Oct 27 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.2-2
  496. - new upstream release
  497. - built with PyQt4-4.6
  498. * Sun Sep 06 2009 NAKAMURA Kenta <kenta@vinelinux.org> 4.3.1-2
  499. - define %%{mono_dir} to specify mono library install path
  500. * Sun Sep 6 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.1-1
  501. - new upstream release
  502. - fixed ruby modules installation path
  503. * Thu Aug 20 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.3.0-1
  504. - new upstream release
  505. - spilt sub package based on Fedora
  506. * Mon May 11 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.8-1
  507. - applied new versioning policy
  508. - added Patch1
  509. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=484191)
  510. * Fri Nov 23 2007 NAKAMURA Kenta <kenta@vinelinux.org> 3.5.8-0vl3
  511. - added --with-qt-libraries option
  512. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl2
  513. - rebuild for VineSeed
  514. * Mon Oct 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.8-0vl1
  515. - new upstream release
  516. * Mon Jun 25 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl2
  517. - rebuild for VineSeed
  518. * Thu May 31 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.7-0vl1
  519. - new upstream release
  520. - update Patch0
  521. - drop Patch1
  522. * Mon Jan 29 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.6-0vl1
  523. - new upstream release
  524. - add Patch1
  525. - add --enable-libsuffix option
  526. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl2
  527. - rebuild for VineSeed
  528. * Tue Oct 3 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.5-0vl1
  529. - new upstream release
  530. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl2
  531. - rebuild for VineSeed
  532. * Wed Aug 2 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.4-0vl1
  533. - new upstream release
  534. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl2
  535. - rebuild for VineSeed
  536. * Thu Jun 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.3-0vl1
  537. - new upstream release
  538. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl2
  539. - rebuild for VineSeed
  540. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.2-0vl1
  541. - new upstream release
  542. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl2
  543. - rebuild for VineSeed
  544. * Wed Feb 1 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.5.1-0vl1
  545. - new upstream release
  546. - renew BuildPrereq and build section
  547. - renew %%files
  548. - enable python
  549. - change spec to make main and devel package
  550. - add BuildPrereq: ruby ruby-devel
  551. - add Patch0 to install ruby-bindings under /usr/lib/ruby
  552. * Sun Mar 17 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-1vl1
  553. - build for VineSeed
  554. - disable python and mozilla
  555. - objprelink (i386 only)
  556. * Wed Nov 21 2001 Than Ngo <than@redhat.com> <bero@redhat.com> 2.2.2-1
  557. - 2.2.2
  558. - build kmozilla binding only on x86/alpha
  559. * Thu Aug 9 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-2
  560. - Make sure %%{name}-kmozilla isn't built on ia64
  561. * Mon Jul 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-0.cvs20010723.2
  562. - Move python bindings to separate package
  563. - Add perl bindings
  564. - Shut up rpmlint
  565. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  566. - 2.1
  567. * Sun Jan 28 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  568. - initial RPM