lvm2-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572
  1. %define brp-strip-shared /bin/true
  2. %define lvm_version 2.02.60
  3. %define device_mapper_version 1.02.43
  4. %define with_cluster 0
  5. Summary: Userland logical volume management tools
  6. Summary(ja): 論理ボリューム管理ツール
  7. Name: lvm2
  8. Version: %{lvm_version}
  9. Release: 1%{?_dist_release}
  10. License: GPL
  11. Group: System Environment/Base
  12. URL: http://sources.redhat.com/lvm2
  13. Source0: LVM2.%{lvm_version}.tgz
  14. BuildRoot: %{_tmppath}/%{name}-%{lvm_version}-%{release}-buildroot
  15. BuildRequires: libtermcap-devel
  16. BuildRequires: ncurses-devel
  17. BuildRequires: readline-devel
  18. Requires: device-mapper >= %{device_mapper_version}-%{release}
  19. Conflicts: lvm
  20. Obsoletes: lvm
  21. %define _exec_prefix /usr
  22. %description
  23. LVM2 includes all of the support for handling read/write operations on
  24. physical volumes (hard disks, RAID-Systems, magneto optical, etc.,
  25. multiple devices (MD), see mdadd(8) or even loop devices, see
  26. losetup(8)), creating volume groups (kind of virtual disks) from one
  27. or more physical volumes and creating one or more logical volumes
  28. (kind of logical partitions) in volume groups.
  29. %if %{with_cluster}
  30. # lvm2-cluster
  31. %package cluster
  32. Summary: Cluster extensions for userland logical volume management tools
  33. License: GPLv2
  34. Group: System Environment/Base
  35. Requires: lvm2 >= %{version}-%{lvm_release}
  36. Requires(post): chkconfig
  37. Requires(preun): chkconfig
  38. Requires(preun): device-mapper >= %{device_mapper_version}
  39. Requires(preun): lvm2 >= 2.02
  40. %description cluster
  41. Extensions to LVM2 to support clusters.
  42. %endif
  43. # device-mapper
  44. %package -n device-mapper
  45. Summary: Device mapper utility
  46. Version: %{device_mapper_version}
  47. Release: %{release}
  48. License: GPLv2
  49. Group: System Environment/Base
  50. URL: http://sources.redhat.com/dm
  51. Requires: device-mapper-libs = %{device_mapper_version}-%{release}
  52. %description -n device-mapper
  53. This package contains the supporting userspace utility, dmsetup,
  54. for the kernel device-mapper.
  55. # device-mapper-devel
  56. %package -n device-mapper-devel
  57. Summary: Development libraries and headers for device-mapper
  58. Version: %{device_mapper_version}
  59. Release: %{release}
  60. License: LGPLv2
  61. Group: Development/Libraries
  62. Requires: device-mapper = %{device_mapper_version}-%{release}
  63. Requires: device-mapper-libs = %{device_mapper_version}-%{release}
  64. %description -n device-mapper-devel
  65. This package contains files needed to develop applications that use
  66. the device-mapper libraries.
  67. %package -n device-mapper-libs
  68. Summary: Device-mapper shared library
  69. Version: %{device_mapper_version}
  70. Release: %{release}
  71. License: LGPLv2
  72. Group: System Environment/Libraries
  73. Obsoletes: device-mapper < 1.02.30-1
  74. %description -n device-mapper-libs
  75. This package contains the device-mapper shared library, libdevmapper.
  76. %prep
  77. %setup -q -n LVM2.%{lvm_version}
  78. %build
  79. %define _exec_prefix /
  80. %define _bindir /bin
  81. %define _sbindir /sbin
  82. %define _libdir /%{_lib}
  83. %configure --enable-static_link --enable-readline --enable-lvm1_fallback \
  84. --with-pool=internal --with-staticdir=/sbin \
  85. --with-user= --with-group= \
  86. --with-dmdir=device-mapper.%{device_mapper_version} \
  87. --with-usrlibdir=/usr/%{_lib} --with-usrsbindir=/usr/sbin \
  88. --with-device-uid=0 --with-device-gid=6 \
  89. --with-device-mode=0660 --enable-pkgconfig
  90. make DESTDIR=$RPM_BUILD_ROOT
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make install DESTDIR=$RPM_BUILD_ROOT
  94. install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/archive
  95. install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/backup
  96. install -m 0700 -d $RPM_BUILD_ROOT/etc/lvm/cache
  97. install -m 0700 -d $RPM_BUILD_ROOT/var/lock/lvm
  98. install -m 0600 /dev/null $RPM_BUILD_ROOT/etc/lvm/cache/.cache
  99. mkdir -p -m755 $RPM_BUILD_ROOT/etc/rc.d/init.d
  100. %if %{with_cluster}
  101. install scripts/clvmd_init_red_hat $RPM_BUILD_ROOT/etc/rc.d/init.d/clvmd
  102. install -m 0755 scripts/lvmconf.sh $RPM_BUILD_ROOT/sbin/lvmconf
  103. %endif
  104. mkdir -p $RPM_BUILD_ROOT/%{_libdir}
  105. mv $RPM_BUILD_ROOT/%{_lib}/libdevmapper.a* $RPM_BUILD_ROOT/%{_prefix}/%{_lib}/
  106. # temporarily changes file permissions so that brp-strip* succeeds
  107. find $RPM_BUILD_ROOT/sbin -type f -exec chmod 0755 {} \;
  108. chmod 0755 $RPM_BUILD_ROOT/%{_lib}/*.so.*
  109. chmod 0755 $RPM_BUILD_ROOT/%{_prefix}/%{_lib}/*.a.*
  110. %clean
  111. rm -rf $RPM_BUILD_ROOT
  112. %if %{with_cluster}
  113. %post cluster
  114. /sbin/chkconfig --add clvmd
  115. /sbin/lvmconf --lockinglibdir %{_libdir}
  116. %preun cluster
  117. if [ "$1" = 0 ]; then
  118. /sbin/chkconfig --del clvmd
  119. /sbin/lvmconf --disable-cluster
  120. fi
  121. %endif
  122. %post -n device-mapper-libs -p /sbin/ldconfig
  123. %postun -n device-mapper-libs -p /sbin/ldconfig
  124. %files
  125. %defattr(-,root,root,-)
  126. %doc COPYING COPYING.LIB INSTALL README VERSION WHATS_NEW
  127. %attr(555,root,root) %{_sbindir}/fsadm
  128. %{_sbindir}/lvchange
  129. %{_sbindir}/lvconvert
  130. %{_sbindir}/lvcreate
  131. %{_sbindir}/lvdisplay
  132. %{_sbindir}/lvextend
  133. %attr(555,root,root) %{_sbindir}/lvm
  134. %attr(555,root,root) %{_sbindir}/lvm.static
  135. %{_sbindir}/lvmchange
  136. %{_sbindir}/lvmdiskscan
  137. %attr(555,root,root) %{_sbindir}/lvmdump
  138. %{_sbindir}/lvmsadc
  139. %{_sbindir}/lvmsar
  140. %{_sbindir}/lvreduce
  141. %{_sbindir}/lvremove
  142. %{_sbindir}/lvrename
  143. %{_sbindir}/lvresize
  144. %{_sbindir}/lvs
  145. %{_sbindir}/lvscan
  146. %{_sbindir}/pvchange
  147. %{_sbindir}/pvck
  148. %{_sbindir}/pvcreate
  149. %{_sbindir}/pvdisplay
  150. %{_sbindir}/pvmove
  151. %{_sbindir}/pvremove
  152. %{_sbindir}/pvresize
  153. %{_sbindir}/pvs
  154. %{_sbindir}/pvscan
  155. %{_sbindir}/vgcfgbackup
  156. %{_sbindir}/vgcfgrestore
  157. %{_sbindir}/vgchange
  158. %{_sbindir}/vgck
  159. %{_sbindir}/vgconvert
  160. %{_sbindir}/vgcreate
  161. %{_sbindir}/vgdisplay
  162. %{_sbindir}/vgexport
  163. %{_sbindir}/vgextend
  164. %{_sbindir}/vgimport
  165. %attr(555,root,root) %{_sbindir}/vgimportclone
  166. %{_sbindir}/vgmerge
  167. %{_sbindir}/vgmknodes
  168. %{_sbindir}/vgreduce
  169. %{_sbindir}/vgremove
  170. %{_sbindir}/vgrename
  171. %{_sbindir}/vgs
  172. %{_sbindir}/vgscan
  173. %{_sbindir}/vgsplit
  174. %{_mandir}/man5/lvm.conf.5.gz
  175. %{_mandir}/man8/fsadm.8.gz
  176. %{_mandir}/man8/lvchange.8.gz
  177. %{_mandir}/man8/lvconvert.8.gz
  178. %{_mandir}/man8/lvcreate.8.gz
  179. %{_mandir}/man8/lvdisplay.8.gz
  180. %{_mandir}/man8/lvextend.8.gz
  181. %{_mandir}/man8/lvm.8.gz
  182. %{_mandir}/man8/lvmchange.8.gz
  183. %{_mandir}/man8/lvmdiskscan.8.gz
  184. %{_mandir}/man8/lvmdump.8.gz
  185. %{_mandir}/man8/lvreduce.8.gz
  186. %{_mandir}/man8/lvremove.8.gz
  187. %{_mandir}/man8/lvrename.8.gz
  188. %{_mandir}/man8/lvresize.8.gz
  189. %{_mandir}/man8/lvs.8.gz
  190. %{_mandir}/man8/lvscan.8.gz
  191. %{_mandir}/man8/pvchange.8.gz
  192. %{_mandir}/man8/pvck.8.gz
  193. %{_mandir}/man8/pvcreate.8.gz
  194. %{_mandir}/man8/pvdisplay.8.gz
  195. %{_mandir}/man8/pvmove.8.gz
  196. %{_mandir}/man8/pvremove.8.gz
  197. %{_mandir}/man8/pvresize.8.gz
  198. %{_mandir}/man8/pvs.8.gz
  199. %{_mandir}/man8/pvscan.8.gz
  200. %{_mandir}/man8/vgcfgbackup.8.gz
  201. %{_mandir}/man8/vgcfgrestore.8.gz
  202. %{_mandir}/man8/vgchange.8.gz
  203. %{_mandir}/man8/vgck.8.gz
  204. %{_mandir}/man8/vgconvert.8.gz
  205. %{_mandir}/man8/vgcreate.8.gz
  206. %{_mandir}/man8/vgdisplay.8.gz
  207. %{_mandir}/man8/vgexport.8.gz
  208. %{_mandir}/man8/vgextend.8.gz
  209. %{_mandir}/man8/vgimport.8.gz
  210. %{_mandir}/man8/vgimportclone.8.gz
  211. %{_mandir}/man8/vgmerge.8.gz
  212. %{_mandir}/man8/vgmknodes.8.gz
  213. %{_mandir}/man8/vgreduce.8.gz
  214. %{_mandir}/man8/vgremove.8.gz
  215. %{_mandir}/man8/vgrename.8.gz
  216. %{_mandir}/man8/vgs.8.gz
  217. %{_mandir}/man8/vgscan.8.gz
  218. %{_mandir}/man8/vgsplit.8.gz
  219. %dir /etc/lvm
  220. %ghost /etc/lvm/cache/.cache
  221. %config(noreplace) /etc/lvm/lvm.conf
  222. %dir /etc/lvm/backup
  223. %dir /etc/lvm/cache
  224. %dir /etc/lvm/archive
  225. %dir /var/lock/lvm
  226. %if %{with_cluster}
  227. %files cluster
  228. %defattr(-,root,root,-)
  229. %attr(755,root,root) /usr/sbin/clvmd
  230. %{_sbindir}/lvmconf
  231. %{_mandir}/man8/clvmd.8.gz
  232. /etc/rc.d/init.d/clvmd
  233. %endif
  234. %files -n device-mapper
  235. %defattr(-,root,root,-)
  236. %doc COPYING COPYING.LIB WHATS_NEW_DM VERSION_DM README INSTALL
  237. %attr(755,root,root) /sbin/dmsetup
  238. %attr(755,root,root) /sbin/dmsetup.static
  239. %{_mandir}/man8/dmsetup.8.gz
  240. %files -n device-mapper-devel
  241. %defattr(-,root,root,-)
  242. %attr(755,root,root) /%{_lib}/libdevmapper.so
  243. %{_prefix}/%{_lib}/libdevmapper.a*
  244. %{_includedir}/libdevmapper.h
  245. /usr%{_libdir}/pkgconfig/*.pc
  246. %files -n device-mapper-libs
  247. %attr(755,root,root) /%{_lib}/libdevmapper.so.*
  248. %changelog
  249. * Sun Feb 14 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.02.60-1
  250. - new upstream release
  251. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.48-1
  252. - new upstream release
  253. * Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.47-1
  254. - new upstream release
  255. * Wed Feb 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-2
  256. - add libdevmapper.a
  257. * Thu Jan 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.44-1
  258. - new upstream release
  259. - upstream merge of device-mapper and lvm2 source.
  260. - move all binaries to /sbin
  261. - move libraries to /%%{_lib}
  262. * Wed Oct 29 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.42-1
  263. - new upstream release
  264. * Sun Oct 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.41-1
  265. - new upstream release
  266. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.40-1
  267. - new upstream release
  268. * Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.39-1
  269. - new upstream release
  270. * Thu Jun 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.38-1
  271. - new upstream release
  272. * Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.35-1
  273. - new upstream release
  274. * Sat Dec 01 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.28-0vl1
  275. - new upstream release
  276. * Wed Nov 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.13-0vl1
  277. - new upstream release
  278. * Sat Aug 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.02.06-0vl1
  279. - initial build for Vine Linux
  280. * Tue Aug 1 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-3
  281. - require new libselinux to avoid segfaults on xen (#200783)
  282. * Thu Jul 27 2006 Jeremy Katz <katzj@redhat.com> - 2.02.06-2
  283. - free trip through the buildsystem
  284. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.02.06-1.2.1
  285. - rebuild
  286. * Tue Jun 6 2006 Stephen C. Tweedie <sct@redhat.com> - 2.02.06-1.2
  287. - Rebuild to pick up new nosegneg libc.a for lvm.static
  288. * Mon May 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.1
  289. - Reinstate archs now build system is back.
  290. - BuildRequires libsepol-devel.
  291. * Fri May 12 2006 Alasdair Kergon <agk@redhat.com> - 2.02.06-1.0
  292. - New upstream release.
  293. * Sat Apr 22 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.1
  294. - Exclude archs that aren't building.
  295. * Fri Apr 21 2006 Alasdair Kergon <agk@redhat.com> - 2.02.05-1.0
  296. - Fix VG uuid comparisons.
  297. * Wed Apr 19 2006 Alasdair Kergon <agk@redhat.com> - 2.02.04-1.0
  298. - New release upstream, including better handling of duplicated VG names.
  299. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2.1
  300. - bump again for double-long bug on ppc(64)
  301. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.02.01-1.2
  302. - rebuilt for new gcc4.1 snapshot and glibc changes
  303. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  304. - rebuilt
  305. * Fri Dec 2 2005 Peter Jones <pjones@redhat.com> - 2.02.01-1
  306. - update to 2.02.01
  307. * Tue Nov 8 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-4
  308. - add patch for xen block devices
  309. * Sat Oct 15 2005 Florian La Roche <laroche@redhat.com>
  310. - add -lselinux -lsepol to the static linking -ldevice-mapper requires it
  311. * Wed Sep 14 2005 Jeremy Katz <katzj@redhat.com> - 2.01.14-2
  312. - the distro doesn't really work without a 2.6 kernel, so no need to require it
  313. * Thu Aug 4 2005 Alasdair Kergon <agk@redhat.com> - 2.01.14-1.0
  314. - And a few more bugs fixes.
  315. * Wed Jul 13 2005 Alasdair Kergon <agk@redhat.com> - 2.01.13-1.0
  316. - Fix several bugs discovered in the last release.
  317. * Tue Jun 14 2005 Alasdair Kergon <agk@redhat.com> - 2.01.12-1.0
  318. - New version upstream with a lot of fixes and enhancements.
  319. * Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.1
  320. - Add /etc/lvm
  321. * Wed Apr 27 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-2.0
  322. - No longer abort read operations if archive/backup directories aren't there.
  323. - Add runtime directories and file to the package.
  324. * Tue Mar 22 2005 Alasdair Kergon <agk@redhat.com> - 2.01.08-1.0
  325. - Improve detection of external changes affecting internal cache.
  326. - Add clustered VG attribute.
  327. - Suppress rmdir opendir error message.
  328. * Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.3
  329. * Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.2
  330. * Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.1
  331. - Suppress some new compiler messages.
  332. * Tue Mar 08 2005 Alasdair Kergon <agk@redhat.com> - 2.01.07-1.0
  333. - Remove build directory from built-in path.
  334. - Extra /dev scanning required for clustered operation.
  335. * Thu Mar 03 2005 Alasdair Kergon <agk@redhat.com> - 2.01.06-1.0
  336. - Allow anaconda to suppress warning messages.
  337. * Fri Feb 18 2005 Alasdair Kergon <agk@redhat.com> - 2.01.05-1.0
  338. - Upstream changes not affecting Fedora.
  339. * Wed Feb 09 2005 Alasdair Kergon <agk@redhat.com> - 2.01.04-1.0
  340. - Offset pool minors; lvm2cmd.so skips open fd check; pvmove -f gone.
  341. * Tue Feb 01 2005 Alasdair Kergon <agk@redhat.com> - 2.01.03-1.0
  342. - Fix snapshot device size & 64-bit display output.
  343. * Fri Jan 21 2005 Alasdair Kergon <agk@redhat.com> - 2.01.02-1.0
  344. - Minor fixes.
  345. * Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.01-1.0
  346. - Update vgcreate man page. Preparation for snapshot origin extension fix.
  347. * Mon Jan 17 2005 Alasdair Kergon <agk@redhat.com> - 2.01.00-1.0
  348. - Fix metadata auto-correction. Only request open_count when needed.
  349. * Wed Jan 12 2005 Tim Waugh <twaugh@redhat.com> - 2.00.33-2.0
  350. - Rebuilt for new readline.
  351. * Fri Jan 7 2005 Alasdair Kergon <agk@redhat.com> - 2.00.33-1.0
  352. - pvcreate wipes ext label
  353. - several clvm fixes
  354. * Thu Jan 6 2005 Alasdair Kergon <agk@redhat.com> - 2.00.32-2.0
  355. - Remove temporary /sbin symlinks no longer needed.
  356. - Include read-only pool support in the build.
  357. * Wed Dec 22 2004 Alasdair Kergon <agk@redhat.com> - 2.00.32-1.0
  358. - More fixes (143501).
  359. * Sun Dec 12 2004 Alasdair Kergon <agk@redhat.com> - 2.00.31-1.0
  360. - Fix pvcreate install issues.
  361. * Fri Dec 10 2004 Alasdair Kergon <agk@redhat.com> - 2.00.30-1.0
  362. - Additional debugging code.
  363. - Some trivial man page corrections.
  364. * Tue Nov 30 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.3
  365. - Reinstate all archs.
  366. * Sun Nov 28 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.2
  367. - Try excluding more archs.
  368. * Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1.1
  369. - Exclude s390x which fails.
  370. * Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.29-1
  371. - Fix last fix.
  372. * Sat Nov 27 2004 Alasdair Kergon <agk@redhat.com> - 2.00.28-1
  373. - Endian fix to partition/md signature detection.
  374. * Wed Nov 24 2004 Alasdair Kergon <agk@redhat.com> - 2.00.27-1
  375. - Fix partition table detection & an out of memory segfault.
  376. * Tue Nov 23 2004 Alasdair Kergon <agk@redhat.com> - 2.00.26-1
  377. - Several installation-related fixes & man page updates.
  378. * Mon Oct 25 2004 Elliot Lee <sopwith@redhat.com> - 2.00.25-1.01
  379. - Fix 2.6 kernel requirement
  380. * Wed Sep 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.25-1
  381. - Fix vgmknodes return code & vgremove locking.
  382. * Fri Sep 17 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-2
  383. - Obsolete old lvm1 packages; refuse install if running kernel 2.4. [bz 128185]
  384. * Thu Sep 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.24-1
  385. - More upstream fixes. (Always check WHATS_NEW file for details.)
  386. - Add requested BuildRequires. [bz 124916, 132408]
  387. * Wed Sep 15 2004 Alasdair Kergon <agk@redhat.com> - 2.00.23-1
  388. - Various minor upstream fixes.
  389. * Thu Sep 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.22-1
  390. - Permission fix included upstream; use different endian conversion macros.
  391. * Thu Sep 2 2004 Jeremy Katz <katzj@redhat.com> - 2.00.21-2
  392. - fix permissions on vg dirs
  393. * Thu Aug 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.21-1
  394. - New upstream release incorporating fixes plus minor enhancements.
  395. * Tue Aug 17 2004 Jeremy Katz <katzj@redhat.com> - 2.00.20-2
  396. - add patch for iSeries viodasd support
  397. - add patch to check file type using stat(2) if d_type == DT_UNKNOWN (#129674)
  398. * Sat Jul 3 2004 Alasdair Kergon <agk@redhat.com> - 2.00.20-1
  399. - New upstream release fixes 2.6 kernel device numbers.
  400. * Tue Jun 29 2004 Alasdair Kergon <agk@redhat.com> - 2.00.19-1
  401. - Latest upstream release. Lots of changes (see WHATS_NEW).
  402. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com> - 2.00.15-5
  403. - rebuilt
  404. * Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-4
  405. - clone %description from LVM rpm
  406. * Wed May 26 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-3
  407. - vgscan shouldn't return error status when no VGs present
  408. * Thu May 06 2004 Warren Togami <wtogami@redhat.com> - 2.00.15-2
  409. - i2o patch from Markus Lidel
  410. * Tue Apr 20 2004 Bill Nottingham <notting@redhat.com> - 2.00.15-1.1
  411. - handle disabled SELinux correctly, so that LVMs can be detected in a
  412. non-SELinux context
  413. * Mon Apr 19 2004 Alasdair Kergon <agk@redhat.com> - 2.00.15-1
  414. - Fix non-root build with current version of 'install'.
  415. * Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.14-1
  416. - Use 64-bit file offsets.
  417. * Fri Apr 16 2004 Alasdair Kergon <agk@redhat.com> - 2.00.13-1
  418. - Avoid scanning devices containing md superblocks.
  419. - Integrate ENOTSUP patch.
  420. * Thu Apr 15 2004 Jeremy Katz <katzj@redhat.com> - 2.00.12-4
  421. - don't die if we get ENOTSUP setting selinux contexts
  422. * Thu Apr 15 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-3
  423. - Add temporary pvscan symlink for LVM1 until mkinitrd gets updated.
  424. * Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-2
  425. - Mark config file noreplace.
  426. * Wed Apr 14 2004 Alasdair Kergon <agk@redhat.com> 2.00.12-1
  427. - Install default /etc/lvm/lvm.conf.
  428. - Move non-static binaries to /usr/sbin.
  429. - Add temporary links in /sbin to lvm.static until rc.sysinit gets updated.
  430. * Thu Apr 08 2004 Alasdair Kergon <agk@redhat.com> 2.00.11-1
  431. - Fallback to using LVM1 tools when using a 2.4 kernel without device-mapper.
  432. * Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-2
  433. - Install the full toolset, not just 'lvm'.
  434. * Wed Apr 07 2004 Alasdair Kergon <agk@redhat.com> 2.00.10-1
  435. - Update to version 2.00.10, which incorporates the RH-specific patches
  436. and includes various fixes and enhancements detailed in WHATS_NEW.
  437. * Wed Mar 17 2004 Jeremy Katz <katzj@redhat.com> 2.00.08-5
  438. - Fix sysfs patch to find sysfs
  439. - Take patch from dwalsh and tweak a little for setting SELinux contexts on
  440. device node creation and also do it on the symlink creation.
  441. Part of this should probably be pushed down to device-mapper instead
  442. * Thu Feb 19 2004 Stephen C. Tweedie <sct@redhat.com> 2.00.08-4
  443. - Add sysfs filter patch
  444. - Allow non-root users to build RPM
  445. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  446. - rebuilt
  447. * Fri Dec 5 2003 Jeremy Katz <katzj@redhat.com> 2.00.08-2
  448. - add static lvm binary
  449. * Tue Dec 2 2003 Jeremy Katz <katzj@redhat.com>
  450. - Initial build.