libgda-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559
  1. %define major 5
  2. %define minor 0
  3. %define micro 3
  4. %define version %{major}.%{minor}.%{micro}
  5. %define __libtoolize :
  6. # Default provider build options (MySQL, Postgres & unixODBC)
  7. #
  8. # Package build options:
  9. # --with tds
  10. # --with db2
  11. # --with oracle
  12. # --without sqlite
  13. # --with sybase
  14. # --with mdb
  15. # --without ldap
  16. # --without mysql
  17. # --without odbc
  18. # --without postgres
  19. #
  20. %define FREETDS 0
  21. %define IBMDB2 0
  22. %define MYSQL 1
  23. %define ODBC 0
  24. %define ORACLE 0
  25. %define POSTGRES 1
  26. %define SQLITE 1
  27. %define SYBASE 0
  28. %define MDB 0
  29. %define LDAP 0
  30. %{?_with_tds:%define FREETDS 1}
  31. %{?_with_db2:%define IBMDB2 1}
  32. %{?_without_ldap:%define LDAP 0}
  33. %{?_with_mdb:%define MDB 1}
  34. %{?_with_oracle:%define ORACLE 1}
  35. %{?_without_sqlite:%define SQLITE 0}
  36. %{?_with_sybase:%define SYBASE 1}
  37. %{?_without_mysql:%define MYSQL 0}
  38. %{?_without_odbc:%define ODBC 0}
  39. %{?_without_postgres:%define POSTGRES 0}
  40. %define libver 5.0
  41. Summary: A (relatively small) database access library
  42. Name: libgda
  43. Version: %{version}
  44. Release: 1%{?_dist_release}
  45. Source: %{name}-%{version}.tar.xz
  46. URL: http://www.gnome-db.org/
  47. Group: System Environment/Libraries
  48. License: LGPL
  49. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  50. Summary(ja): 比較的小規模なデータベース接続ライブラリ
  51. Patch0: libgda-4.2.0-disable-mdb.patch
  52. Vendor: Project Vine
  53. Distribution: Vine Linux
  54. Packager: yasumichi
  55. BuildRequires: pkgconfig >= 0.8
  56. BuildRequires: intltool >= 0.35.5
  57. BuildRequires: glib2-devel >= 2.12.0
  58. BuildRequires: gtk3-devel
  59. BuildRequires: gobject-introspection-devel
  60. BuildRequires: libxml2-devel
  61. BuildRequires: libxslt-devel >= 1.0.9
  62. BuildRequires: db4-devel ncurses-devel
  63. BuildRequires: gamin-devel >= 0.1.8
  64. BuildRequires: libgcrypt-devel >= 1.1.42
  65. BuildRequires: gcr-devel
  66. BuildRequires: iso-codes
  67. %if %{FREETDS}
  68. BuildRequires: freetds-devel
  69. %endif
  70. %if %{MYSQL}
  71. BuildRequires: MySQL-devel
  72. %endif
  73. %if %{POSTGRES}
  74. BuildRequires: postgresql-devel
  75. %endif
  76. %if %{ODBC}
  77. BuildRequires: unixODBC-devel
  78. %endif
  79. %if %{SQLITE}
  80. BuildRequires: sqlite3-devel
  81. %endif
  82. %if %{MDB}
  83. BuildRequires: mdbtools-devel
  84. %endif
  85. %if %{LDAP}
  86. BuildRequires: openldap-devel
  87. %endif
  88. %description
  89. Libgda is a (relatively small) database access library:
  90. - a wrapper like ODBC but with more features to access several database
  91. engines
  92. - a meta data extractor (to know all about database objects in a common
  93. way)
  94. - comes with an SQL console application (like mysql, psql or sqlite3
  95. consoles)
  96. - relies on GLib, coded in C, its API is easy to use
  97. - at the moment supports SQLite, MySQL, PostgreSQL, MSAccess and Bdb, work
  98. is in progress for other database types (such as Firebird and Oracle) and
  99. to wrap JDBC for more wider usage.
  100. Build option is:
  101. --with mysql postgres sqlite
  102. --without tds ibmdb2 ldap mdb odbc oracle sybase
  103. %package devel
  104. Summary: Development libraries and header files for libgda.
  105. Group: Development/Libraries
  106. Requires: %{name} = %{version}
  107. Requires: glib2-devel >= 2.12.0
  108. Requires: libxml2-devel
  109. Requires: libxslt-devel >= 1.0.9
  110. %description devel
  111. This package contains the header files and libraries needed to write
  112. or compile programs that use libgda.
  113. #%package sharp
  114. #Summary: Mono bindings for libgda
  115. #Group: System Environment/Libraries
  116. #Requires: %{name} = %{version}-%{release}
  117. #Requires: mono-core
  118. #
  119. #%description sharp
  120. #This package contains the dll files needed to run (and compile) Mono
  121. #applications which use libgda.
  122. %if %{FREETDS}
  123. %package -n gda-freetds
  124. Summary: GDA FreeTDS Provider
  125. Group: System Environment/Libraries
  126. %description -n gda-freetds
  127. This package includes the GDA FreeTDS provider.
  128. %endif
  129. %if %{IBMDB2}
  130. %package -n gda-ibmdb2
  131. Summary: GDA IBM DB2 Provider
  132. Group: System Environment/Libraries
  133. %description -n gda-ibmdb2
  134. This package includes the GDA IBM DB2 provider.
  135. %endif
  136. %if %{MYSQL}
  137. %package -n gda-mysql
  138. Summary: GDA MySQL Provider
  139. Group: System Environment/Libraries
  140. %description -n gda-mysql
  141. This package includes the GDA MySQL provider.
  142. %endif
  143. %if %{ODBC}
  144. %package -n gda-odbc
  145. Summary: GDA ODBC Provider
  146. Group: System Environment/Libraries
  147. %description -n gda-odbc
  148. This package includes the GDA ODBC provider.
  149. %endif
  150. %if %{ORACLE}
  151. %package -n gda-oracle
  152. Summary: GDA Oracle Provider
  153. Group: System Environment/Libraries
  154. %description -n gda-oracle
  155. This package includes the GDA Oracle provider.
  156. %endif
  157. %if %{POSTGRES}
  158. %package -n gda-postgres
  159. Summary: GDA PostgreSQL Provider
  160. Group: System Environment/Libraries
  161. %description -n gda-postgres
  162. This package includes the GDA PostgreSQL provider.
  163. %endif
  164. %if %{SQLITE}
  165. %package -n gda-sqlite
  166. Summary: GDA SQLite Provider
  167. Group: System Environment/Libraries
  168. %description -n gda-sqlite
  169. This package includes the GDA SQLite provider.
  170. %endif
  171. %if %{SYBASE}
  172. %package -n gda-sybase
  173. Summary: GDA Sybase Provider
  174. Group: System Environment/Libraries
  175. %description -n gda-sybase
  176. This package includes the GDA Sybase provider.
  177. %endif
  178. %if %{MDB}
  179. %package -n gda-mdb
  180. Summary: GDA MDB Provider
  181. Group: System Environment/Libraries
  182. %description -n gda-mdb
  183. This package includes the GDA MDB provider.
  184. %endif
  185. %if %{LDAP}
  186. %package -n gda-ldap
  187. Summary: GDA LDAP Provider
  188. Group: System Environment/Libraries
  189. %description -n gda-ldap
  190. This package includes the GDA LDAP provider.
  191. %endif
  192. %prep
  193. %setup -q -n %{name}-%{version}
  194. %patch0 -p1 -b .mdb
  195. %build
  196. %if %{FREETDS}
  197. CONFIG="$CONFIG --with-tds"
  198. %else
  199. CONFIG="$CONFIG --without-tds"
  200. %endif
  201. %if %{IBMDB2}
  202. CONFIG="$CONFIG --with-ibmdb2"
  203. %else
  204. CONFIG="$CONFIG --without-ibmdb2"
  205. %endif
  206. %if %{MYSQL}
  207. CONFIG="$CONFIG --with-mysql"
  208. %else
  209. CONFIG="$CONFIG --without-mysql"
  210. %endif
  211. %if %{POSTGRES}
  212. CONFIG="$CONFIG --with-postgres"
  213. %else
  214. CONFIG="$CONFIG --without-postgres"
  215. %endif
  216. %if %{ODBC}
  217. CONFIG="$CONFIG --with-odbc"
  218. %else
  219. CONFIG="$CONFIG --without-odbc"
  220. %endif
  221. %if %{ORACLE}
  222. CONFIG="$CONFIG --with-oracle"
  223. %else
  224. CONFIG="$CONFIG --without-oracle"
  225. %endif
  226. %if %{SQLITE}
  227. CONFIG="$CONFIG --with-sqlite"
  228. %else
  229. CONFIG="$CONFIG --without-sqlite"
  230. %endif
  231. %if %{SYBASE}
  232. CONFIG="$CONFIG --with-sybase"
  233. %else
  234. CONFIG="$CONFIG --without-sybase"
  235. %endif
  236. %if %{MDB}
  237. CONFIG="$CONFIG --with-mdb"
  238. %else
  239. CONFIG="$CONFIG --without-mdb"
  240. %endif
  241. %if %{LDAP}
  242. CONFIG="$CONFIG --with-ldap"
  243. %else
  244. CONFIG="$CONFIG --without-ldap"
  245. %endif
  246. %configure $CONFIG --disable-static --disable-gtk-doc --with-libdir-name=%{_lib}
  247. make
  248. %install
  249. rm -rf $RPM_BUILD_ROOT
  250. #makeinstall LIBGDA_DTDDIR=%{buildroot}%{_datadir}/libgda/dtd
  251. make install DESTDIR=$RPM_BUILD_ROOT
  252. #fixup mono / sharp related files install
  253. #mkdir -p %{buildroot}/%{_datadir}/gapi-2.0
  254. #mv %{buildroot}/%{_libdir}/libgda/gda-api.xml %{buildroot}/%{_datadir}/gapi-2.0
  255. #mkdir -p %{buildroot}/usr/lib/mono/gda-sharp-2.0
  256. #mv %{buildroot}/%{_libdir}/libgda/* %{buildroot}/usr/lib/mono/gda-sharp-2.0
  257. #rmdir %{buildroot}/%{_libdir}/libgda
  258. # Cleanup unnecessary, unpackaged files
  259. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  260. rm -f %{buildroot}/%{_sysconfdir}/libgda-%{libver}/sales_test.db
  261. %find_lang libgda-%{libver}
  262. %post -p /sbin/ldconfig
  263. %postun -p /sbin/ldconfig
  264. %clean
  265. rm -rf $RPM_BUILD_ROOT
  266. %files
  267. %defattr(-,root,root)
  268. %doc AUTHORS COPYING COPYING.LIB ChangeLog README NEWS
  269. %dir %{_sysconfdir}/libgda-%{libver}
  270. %config(noreplace) %{_sysconfdir}/libgda-%{libver}/config
  271. %{_bindir}/*
  272. %{_libdir}/*.so.*
  273. %{_libdir}/girepository-1.0/*.typelib
  274. %dir %{_libdir}/libgda-%{libver}
  275. %dir %{_libdir}/libgda-%{libver}/plugins
  276. %{_libdir}/libgda-%{libver}/plugins/*.xml
  277. %{_libdir}/libgda-%{libver}/plugins/libgda-ui-plugins.so
  278. %dir %{_libdir}/libgda-%{libver}/providers
  279. %{_libdir}/libgda-%{libver}/providers/libgda-bdb.so
  280. %{_libdir}/libgda-%{libver}/providers/libgda-sqlcipher.so
  281. %{_datadir}/applications/*.desktop
  282. %{_datadir}/icons/hicolor/*/*/*
  283. %{_datadir}/gnome/help/gda-sql/C/gda-sql-help.xml
  284. %{_datadir}/pixmaps/gda-browser-5.0.png
  285. %dir %{_datadir}/libgda-%{libver}
  286. %{_datadir}/libgda-%{libver}/demo
  287. %{_datadir}/libgda-%{libver}/dtd
  288. %{_datadir}/libgda-%{libver}/gda_trml2html
  289. %{_datadir}/libgda-%{libver}/gda_trml2pdf
  290. %{_datadir}/libgda-%{libver}/icons
  291. %{_datadir}/libgda-%{libver}/language-specs/gda-sql.lang
  292. %{_datadir}/libgda-%{libver}/pixmaps
  293. %{_datadir}/libgda-%{libver}/server_operation.glade
  294. %{_datadir}/libgda-%{libver}/ui
  295. %{_datadir}/libgda-%{libver}/*.xml
  296. %{_datadir}/libgda-%{libver}/web
  297. %{_mandir}/man1/*
  298. %{_datadir}/locale/*/LC_MESSAGES/*
  299. %files devel
  300. %defattr(-,root,root)
  301. %{_includedir}/libgda-%{libver}
  302. %{_libdir}/*.so
  303. %{_libdir}/pkgconfig/*
  304. %{_datadir}/gir-1.0/*.gir
  305. %{_datadir}/gtk-doc/html/*
  306. #files sharp
  307. #defattr(-,root,root)
  308. #{_datadir}/gapi-2.0
  309. #/usr/lib/mono/gda-sharp-2.0
  310. #{_libdir}/pkgconfig/gda-sharp-2.0.pc
  311. %if %{FREETDS}
  312. %files -n gda-freetds
  313. %{_libdir}/libgda-%{libver}/providers/libgda-freetds.so
  314. %endif
  315. %if %{IBMDB2}
  316. %files -n gda-ibmdb2
  317. %{_libdir}/libgda-%{libver}/providers/libgda-ibmdb2.so
  318. %endif
  319. %if %{MYSQL}
  320. %files -n gda-mysql
  321. %{_libdir}/libgda-%{libver}/providers/libgda-mysql.so
  322. %{_datadir}/libgda-%{libver}/mysql_*.xml
  323. %endif
  324. %if %{ODBC}
  325. %files -n gda-odbc
  326. %{_libdir}/libgda-%{libver}/providers/libgda-odbc.so
  327. %{_datadir}/libgda-%{libver}/odbc_*.xml
  328. %endif
  329. %if %{ORACLE}
  330. %files -n gda-oracle
  331. %{_libdir}/libgda-%{libver}/providers/libgda-oracle.so
  332. %endif
  333. %if %{POSTGRES}
  334. %files -n gda-postgres
  335. %{_libdir}/libgda-%{libver}/providers/libgda-postgres.so
  336. %{_datadir}/libgda-%{libver}/postgres_*.xml
  337. %endif
  338. %if %{SQLITE}
  339. %files -n gda-sqlite
  340. %{_libdir}/libgda-%{libver}/providers/libgda-sqlite.so
  341. %{_datadir}/libgda-%{libver}/sqlite_*.xml
  342. %endif
  343. %if %{SYBASE}
  344. %files -n gda-sybase
  345. %{_libdir}/libgda-%{libver}/providers/libgda-sybase.so
  346. %endif
  347. %if %{MDB}
  348. %files -n gda-mdb
  349. %{_libdir}/libgda-%{libver}/providers/libgda-mdb.so
  350. %endif
  351. %if %{LDAP}
  352. %files -n gda-ldap
  353. %{_libdir}/libgda-%{libver}/providers/libgda-ldap.so
  354. %{_datadir}/libgda-%{libver}/ldap_*.xml
  355. %endif
  356. %changelog
  357. * Tue Apr 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.0.3-1
  358. - new upstream release
  359. - add BuildRequires: gtk3-devel, gobject-introspection-devel, gcr-devel, iso-codes
  360. * Wed Dec 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.12-1
  361. - new upstream release
  362. * Mon Nov 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.11-1
  363. - new upstream release
  364. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.9-1
  365. - new upstream release
  366. * Tue Aug 16 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.8-1
  367. - new upstream release
  368. * Sat Oct 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.2.0-1
  369. - new upstream release
  370. - add Patch0 (libgda-4.2.0-disable-mdb.patch)
  371. - change %%{libver}
  372. * Sat Sep 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-2
  373. - rebuild with rpm-4.8.1 for pkg-config file
  374. * Mon Jun 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.9-1
  375. - new upstream release
  376. * Sun Mar 14 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 4.0.8-1
  377. - new upstream release
  378. * Mon Nov 02 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.5-1
  379. - new upstream release
  380. - remove gnome-vfs2-devel from BR.(use gio-2.0)
  381. - add Vendor, Distribution and Packager.
  382. - update summary and description.
  383. * Wed Jul 08 2009 Shu KONNO <owa@bg.wakwak.com> 4.0.2-3
  384. - rebuilt with postgresql-8.4.0
  385. * Fri May 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.2-2
  386. - added intltool to BuildRequires.
  387. - rebuilt with MySQL-5.1.34.
  388. * Wed Apr 29 2009 Yasumichi Akahoshi <yasumichi@vinelinux.org> 4.0.2-1
  389. - update from upstream.
  390. - update description and files.
  391. - ODBC,LDAP outdated
  392. * Sat Jul 05 2008 Shu KONNO <owa@bg.wakwak.com> 3.1.4-2
  393. - rebuilt with postgresql-8.3.3
  394. * Sun Jun 22 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.1.4-1
  395. - new upstream release
  396. - not build sharp subpackage
  397. - built with db4-4.6.21, MySQL-5.0.51a
  398. * Tue Jan 08 2008 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl8
  399. - rebuilt with postgresql-8.2.6
  400. * Wed Sep 19 2007 Shu KONNO <owa@bg.wakwak.com> 1.9.100-0vl7
  401. - rebuilt with postgresql-8.2.5
  402. * Sun May 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl6
  403. - rebuilt with new toolchain
  404. * Wed Nov 1 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl5
  405. - rebuilt with openldap 2.3.27, MySQL 5.0.27
  406. - added Patch0 from Fedora
  407. * Mon Aug 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl4
  408. - rebuilt with openldap-devel-2.3.24-0vl4
  409. * Sat Jun 17 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.100-0vl3
  410. - rebuilt with gamin-devel in place of fam-devel
  411. * Sun Apr 30 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl2
  412. - rebuilt with readline 5.1
  413. - added subpackage for Mono binding
  414. * Mon Jan 9 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.9.100-0vl1
  415. - new upstream release
  416. * Tue May 31 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-0vl1
  417. - new upstream release
  418. - rebuild with postgresql-devel-8.0.3-0vl2 and sqlite3-devel
  419. * Fri Feb 11 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.0-0vl1
  420. - new upstream release
  421. - fixed %files on devel package
  422. * Sun Aug 22 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.1.6-0vl1
  423. - new upstream release
  424. - re-define __libtoolize to compile shared object
  425. - updated summary
  426. - make sqlite package by default
  427. * Sun Mar 28 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.3-0vl1
  428. - new upstream release
  429. - build with new MySQL
  430. - make ldap package by default
  431. * Sat Dec 6 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.2-0vl1
  432. - new upstream release
  433. * Fri Oct 17 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.1-0vl1
  434. - new upstream release
  435. * Thu Sep 25 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.0.0-1vl1
  436. - updated to 1.0.0
  437. - based on original spec
  438. - disabled smp_flag at compile time
  439. * Sun Apr 20 2003 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.2.96-0vl3
  440. - added BuildPreReq: bonobo >= 1.0.9
  441. (0.2.96-0vl2 seems to be lost by accident, so putting again here)
  442. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.2.96-0vl1
  443. - New upstream release.
  444. - use gcc-2.95.3 and g++-2.95.3
  445. * Thu Jan 24 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.94-0vl1
  446. - New upstream release.
  447. * Fri Jan 4 2002 Akira TAGOH <tagoh@gnome.gr.jp> 0.2.93-0vl1
  448. - Rebuild for Vine.
  449. * Thu May 31 2001 Serge Pavlovsky <pal@re.com.ua>
  450. - Cleaned
  451. * Sat Sep 2 2000 Rodrigo Moya <rodrigo@linuxave.net>
  452. - Initial spec imported from old GNOME-DB spec