totem-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550
  1. # build browser plugins
  2. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  3. # define versions
  4. %define _glib_ver 2.30.0
  5. %define _gtk_ver 3.2.0
  6. %define _gnomeicon_ver 3.2.0
  7. %define _gnome_doc_utils_ver 0.20.0
  8. %define _dbus_ver 1.4.0
  9. %define _gst_ver 0.10.30
  10. %define _gstpb_ver 0.10.30
  11. %define _gstpg_ver 0.10.24
  12. %define _xulrunner_ver 1.9
  13. %define _nautilus_ver 3.2.0
  14. %define _shared_mime_info_ver 0.17
  15. %define _unique_ver 1.0
  16. %define _vala_ver 0.11.1
  17. %define _totem_pl_parser_ver 2.32.0
  18. %define _libgdata_ver 0.6.5
  19. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  20. %define mozplug_dir %{_libdir}/mozilla/plugins
  21. Summary: Movie player for GNOME 3
  22. Summary(ja): GNOME3 用動画プレイヤー
  23. Name: totem
  24. Version: 3.2.1
  25. Release: 1%{?_dist_release}
  26. License: GPL
  27. Group: Applications/Multimedia
  28. URL: http://www.gnome.org/projects/totem/
  29. Source0: http://ftp.gnome.org/pub/GNOME/sources/totem/3.2/totem-%{version}.tar.xz
  30. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  31. Vendor: Project Vine
  32. Distribution: Vine Linux
  33. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  34. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  35. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  36. BuildRequires: dbus-devel >= %{_dbus_ver}
  37. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  38. BuildRequires: gettext, scrollkeeper
  39. BuildRequires: perl-XML-Parser
  40. BuildRequires: iso-codes
  41. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  42. BuildRequires: bluez-libs-devel >= 4.15
  43. BuildRequires: lirc
  44. BuildRequires: unique-devel >= %{_unique_ver}
  45. BuildRequires: vala-devel >= %{_vala_ver}
  46. BuildRequires: python-devel
  47. BuildRequires: pygtk2-devel
  48. BuildRequires: pygobject3-devel
  49. BuildRequires: libgdata-devel >= %{_libgdata_ver}
  50. BuildRequires: libpeas-devel
  51. BuildRequires: libXtst-devel
  52. BuildRequires: gstreamer-devel >= %{_gst_ver}
  53. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb_ver}
  54. BuildRequires: gstreamer-plugins-good >= %{_gstpg_ver}
  55. BuildRequires: clutter-gtk-devel
  56. BuildRequires: clutter-gst-devel
  57. BuildRequires: libmx-devel
  58. %if %{build_plugin}
  59. BuildRequires: xulrunner-devel >= %{_xulrunner_ver}
  60. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  61. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  62. %endif
  63. Requires: gstreamer >= %{_gst_ver}
  64. Requires: gstreamer-plugins-base >= %{_gstpb_ver}
  65. Requires: gstreamer-plugins-good >= %{_gstpg_ver}
  66. Requires: iso-codes
  67. # for opensubtitles plugin
  68. Requires: pyxdg
  69. # for python plugins
  70. Requires: pygtk2
  71. # for coherence plugins
  72. # Requires: python-Coherence >= 0.6.6.2
  73. Obsoletes: nautilus-media
  74. Obsoletes: %{name}-gstreamer < 2.30.1-2
  75. Obsoletes: %{name}-xine < 2.30.1-2
  76. Obsoletes: %{name}-common < 2.30.1-3
  77. Provides: nautilus-media
  78. Provides: %{name}-common = %{version}-%{release}
  79. Requires(post): ldconfig, scrollkeeper, desktop-file-utils, GConf2
  80. Requires(postun): ldconfig, scrollkeeper, desktop-file-utils
  81. Requires(preun): GConf2
  82. %description
  83. Totem is simple movie player for the Gnome desktop. It features a
  84. simple playlist, a full-screen mode, seek and volume controls, as well as
  85. a pretty complete keyboard navigation.
  86. %if %{build_plugin}
  87. %package mozilla
  88. Summary: Totem movie plugin for Mozilla
  89. Summary(ja): Mozilla 用 Totem 動画プラグイン
  90. Group: Applications/Internet
  91. Requires: %{name} = %{version}-%{release}
  92. Obsoletes: %{name}-mozilla-common
  93. Obsoletes: %{name}-mozilla-gstreamer
  94. Obsoletes: %{name}-mozilla-xine
  95. %description mozilla
  96. Totem is simple movie player for the Gnome desktop. It features a
  97. simple playlist, a full-screen mode, seek and volume controls, as well as
  98. a pretty complete keyboard navigation.
  99. This package contains a Totem video plugin for Mozilla. It allows Totem
  100. movie player to be embedded into a web browser.
  101. %endif
  102. %package devel
  103. Summary: Plugin writer's documentation for totem
  104. Group: Development/Libraries
  105. Requires: %{name} = %{version}-%{release}
  106. %description devel
  107. The %{name}-devel package contains API documentation for
  108. developing developing plugins for %{name}.
  109. %prep
  110. %setup -q
  111. %build
  112. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
  113. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  114. %configure \
  115. --disable-scrollkeeper \
  116. --enable-python \
  117. --disable-vala \
  118. --enable-nautilus \
  119. --enable-gmp-plugin \
  120. --enable-narrowspace-plugin \
  121. --enable-mully-plugin \
  122. %if %{build_plugin}
  123. --enable-browser-plugins
  124. %else
  125. --disable-browser-plugins
  126. %endif
  127. make %{?_smp_mflags}
  128. %install
  129. rm -rf $RPM_BUILD_ROOT
  130. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  131. make install DESTDIR=$RPM_BUILD_ROOT
  132. # remove unneeded files
  133. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  134. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  135. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  136. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  137. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  138. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  139. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  140. # remove unused file
  141. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  142. %find_lang %{name} --with-gnome
  143. # save space by linking identical images in translated docs
  144. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  145. for f in $helpdir/C/figures/*.png; do
  146. b="$(basename $f)"
  147. for d in $helpdir/*; do
  148. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  149. g="$d/figures/$b"
  150. if [ -f "$g" ]; then
  151. if cmp -s $f $g; then
  152. rm "$g"; ln -s "../../C/figures/$b" "$g"
  153. fi
  154. fi
  155. fi
  156. done
  157. done
  158. %clean
  159. %__rm -rf %{buildroot}
  160. %post
  161. %{_bindir}/scrollkeeper-update -q
  162. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  163. touch %{_datadir}/icons/hicolor
  164. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  165. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  166. fi
  167. %postun
  168. %{_bindir}/scrollkeeper-update -q
  169. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  170. touch %{_datadir}/icons/hicolor
  171. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  172. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  173. fi
  174. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  175. %posttrans
  176. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  177. %files -f %{name}.lang
  178. %defattr(-,root,root,-)
  179. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  180. %{_bindir}/totem
  181. %{_bindir}/totem-audio-preview
  182. %{_bindir}/totem-video-thumbnailer
  183. %{_datadir}/GConf/gsettings/opensubtitles.convert
  184. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  185. %{_datadir}/GConf/gsettings/totem.convert
  186. %{_datadir}/applications/%{name}.desktop
  187. %{_datadir}/glib-2.0/schemas/*.xml
  188. %{_datadir}/icons/*/*/*/*
  189. %{_datadir}/thumbnailers/totem.thumbnailer
  190. %{_datadir}/%{name}
  191. %{_datadir}/gtk-doc/html/totem
  192. %{_libdir}/libtotem.so.*
  193. %{_libdir}/girepository-1.0/*.typelib
  194. %dir %{_libdir}/totem
  195. %dir %{_libdir}/totem/plugins
  196. %{_libdir}/totem/plugins/brasero-disc-recorder
  197. %{_libdir}/totem/plugins/chapters
  198. %{_libdir}/totem/plugins/dbus
  199. %{_libdir}/totem/plugins/gromit
  200. %{_libdir}/totem/plugins/iplayer
  201. %{_libdir}/totem/plugins/lirc
  202. %{_libdir}/totem/plugins/media-player-keys
  203. %{_libdir}/totem/plugins/ontop
  204. %{_libdir}/totem/plugins/opensubtitles
  205. %{_libdir}/totem/plugins/properties
  206. %{_libdir}/totem/plugins/pythonconsole
  207. %{_libdir}/totem/plugins/screensaver
  208. %{_libdir}/totem/plugins/screenshot
  209. %{_libdir}/totem/plugins/skipto
  210. %{_libdir}/totem/plugins/youtube
  211. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  212. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  213. %{_libdir}/totem/plugins/save-file/libsave-file.so
  214. %{_libdir}/totem/plugins/save-file/save-file.plugin
  215. %if %{build_plugin}
  216. %{_libdir}/nautilus/extensions-3.0/*.so*
  217. %endif
  218. %{_libexecdir}/%{name}/totem-bugreport.py
  219. %{_mandir}/man1/*
  220. %if %{build_plugin}
  221. %files mozilla
  222. %defattr(-,root,root,-)
  223. %{mozplug_dir}/*
  224. %{_libexecdir}/totem-plugin-viewer
  225. %endif
  226. %files devel
  227. %defattr(-, root, root,-)
  228. %{_includedir}/totem
  229. %{_libdir}/libtotem.so
  230. %{_libdir}/pkgconfig/totem.pc
  231. %{_datadir}/gir-1.0/Totem-1.0.gir
  232. %{_datadir}/gtk-doc/html/totem
  233. %changelog
  234. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  235. - new upstream release
  236. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  237. - new upstream release
  238. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  239. - new upstream release
  240. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  241. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  242. - new upstream release
  243. - change BuildRequires: gtk3-devel instead of gtk2-devel
  244. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  245. clutter-gst-devel, libmx-devel
  246. - change configure option (--disable-vala)
  247. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  248. - new upstream release
  249. - fix %files
  250. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  251. - new upstream release
  252. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  253. - clean up spec file
  254. - remove totem-common and merged to totem main package.
  255. - add Obsoletes: totem-common
  256. - remove unneeded BR: and R:
  257. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  258. - libmusicbrainz, alternatives
  259. - remove explicit dependency
  260. - gtk2, glib2, dbus
  261. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  262. - add R: gstreamer-plugins-good
  263. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  264. - rebuild with libgdata (add youtube plugin)
  265. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  266. - add Obsolete: totem-gstreamer, totem-xine)
  267. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  268. - new upstream release
  269. - chagnge _gst_ver from 0.10.19 to 0.10.29
  270. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  271. - new upstream release
  272. - drop totem-tracker package
  273. - add BuildRequires: unique-devel
  274. - remove BuildRequires: hal-devel
  275. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  276. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  277. - remove unneeded autoreconf
  278. - add BR: lirc
  279. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  280. - new upstream release
  281. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  282. - remove bemused plugin
  283. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  284. - new upstream release
  285. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  286. - added tracker video search sub-package
  287. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  288. - new upstream release
  289. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  290. - new upstream release
  291. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  292. - remove libxine dependency from totem-common
  293. - build xine backend with minimum dependency
  294. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  295. - add BR: bluez-libs-devel >= 4.15
  296. - fix typo in %%postun xine
  297. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  298. - rebuild with bluez-libs-devel-4.15
  299. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  300. - new upstream release
  301. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  302. - new upstream release
  303. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  304. - new upstream release
  305. - add patch1 to build with xulrunner-1.9
  306. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  307. - new upstream release
  308. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  309. - new upstream release
  310. - disabled devel package (replaced by totem-pl-parser-devel)
  311. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  312. - new upstream release
  313. - update version macros
  314. - enable browser plugins on x86_64
  315. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  316. - new upstream release
  317. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  318. - upstream release
  319. - drop obsolete ja.po.patch (patch0)
  320. - revert change of 1.4.4-0vl2
  321. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  322. - upstream release
  323. - enable browser plugins (exclude x86_64 arch)
  324. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  325. - upstream release
  326. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  327. - update configure options
  328. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  329. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  330. - fix mistranslation (patch0)
  331. - add icon symlink
  332. - add BuildRequires: gstreamer-plugins-good
  333. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  334. - upstream release
  335. - update %%_glib_ver, %%_xine_ver
  336. - add BuildRequires: hal
  337. - update %%configure options
  338. - update %%files
  339. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  340. - upstream release
  341. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  342. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  343. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  344. - upstream release
  345. - drop obsolete patch0
  346. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  347. - upstream release
  348. - add patch0 to build with intltool-0.35
  349. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  350. - upstream release
  351. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  352. - upstream release
  353. - update alternatives entry
  354. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  355. - upstream release
  356. - drop fix-sort-function.patch (was merged to upstream, #331426)
  357. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  358. - rebuild with gnome-2.14rc
  359. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  360. - upstream release
  361. - add macros
  362. - _gtk_ver, _glib_ver
  363. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  364. - _dbus_ver
  365. - _gst_ver, gstpb_ver, _xine_ver
  366. - add fix-sort-function.patch to build with glib < 2.9.1
  367. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  368. - upstream release
  369. - add BuildRequires:
  370. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  371. - gnome-vfs2-devel >= 2.9.92
  372. - dbus-devel >= 0.35
  373. - use gstreamer-0.10 as backend for totem-gstreamer
  374. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  375. - use gstreamer08 instead of gstreamer
  376. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  377. - upstream release
  378. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  379. - fix missing links
  380. - update file list
  381. - update update-alternatives scripts
  382. - fix totem-gstreamer's %%postun script
  383. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  384. - upstream release
  385. - add BuildRequires: iso-codes, libmusicbrainz-devel
  386. - add Requires: iso-codes, libmusicbrains to -common package
  387. - remove BuildRequires: nautilus-cd-burner
  388. - remove Requires: nautilus-cd-burner from -common package
  389. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  390. - totem-gstreamer obsoletes nautilus-media
  391. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  392. - upstream release
  393. - add Requires(post,postun): alternatives for gstreamer,xine
  394. - add Requires(postun,triggers): alternatives for common
  395. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  396. - upstream release
  397. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  398. - build xine backend
  399. - move common files to common package
  400. - move GStreamer related files to gstreamer package
  401. - install xine related files to xine package
  402. - fix scripts
  403. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  404. - upstream release
  405. - update URL
  406. - move *.{a,la} to devel package
  407. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  408. - fix %%{post,preun} script (video-thumbnail.schemas)
  409. - sync with Fedora Core's 1.0.1-1
  410. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  411. - Update to upstream version 1.0.1
  412. - Break out devel package
  413. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  414. - add %%{post,pre}un script
  415. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  416. - initial build for Vine Linux
  417. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  418. - fix %%post
  419. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  420. - Obsolete nautilus-media
  421. - Install property page and thumbnailer
  422. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  423. - Update to 0.101
  424. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  425. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  426. missing menu entry (144088)
  427. - Remove workaround for desktop file being misinstalled, fixed
  428. by above patch
  429. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  430. - New upstream version 0.100
  431. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  432. - update to 0.99.22
  433. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  434. - Add patch to remove removed items from package from help
  435. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  436. - New upstream 0.99.19
  437. - Fixes crasher with CD playback (see NEWS)
  438. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  439. - Call update-desktop-database in post
  440. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  441. - update to 0.99.18
  442. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  443. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>