hplip-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657
  1. # %define python_platlib %(python -c 'from distutils.sysconfig import get_python_lib; print get_python_lib(1)')
  2. Summary: HP printer drivers & utilities for Linux
  3. Summary(ja): HP プリンタの Linux 向けドライバとユーティリティ
  4. Name: hplip
  5. Version: 3.18.10
  6. Release: 1%{?_dist_release}
  7. License: GPLv2+, MIT and BSD
  8. Group: Applications/Publishing
  9. URL: http://hplip.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/sourceforge/hplip/hplip-%{version}.tar.gz
  11. #Source1: hpcups-update-ppds.sh
  12. Source2: copy-deviceids.py
  13. Source3: %{name}.appdata.xml
  14. Source1000: hplip.desktop.vine
  15. Patch1: hplip-pstotiff-is-rubbish.patch
  16. Patch2: hplip-strstr-const.patch
  17. Patch3: hplip-ui-optional.patch
  18. Patch4: hplip-no-asm.patch
  19. Patch5: hplip-deviceIDs-drv.patch
  20. Patch6: hplip-udev-rules.patch
  21. Patch7: hplip-retry-open.patch
  22. Patch8: hplip-snmp-quirks.patch
  23. Patch9: hplip-hpijs-marker-supply.patch
  24. Patch10: hplip-clear-old-state-reasons.patch
  25. Patch11: hplip-hpcups-sigpipe.patch
  26. Patch12: hplip-logdir.patch
  27. Patch13: hplip-bad-low-ink-warning.patch
  28. Patch14: hplip-deviceIDs-ppd.patch
  29. Patch15: hplip-ppd-ImageableArea.patch
  30. Patch16: hplip-scan-tmp.patch
  31. Patch17: hplip-log-stderr.patch
  32. Patch18: hplip-avahi-parsing.patch
  33. Patch20: hplip-dj990c-margin.patch
  34. Patch21: hplip-strncpy.patch
  35. Patch22: hplip-no-write-bytecode.patch
  36. Patch23: hplip-silence-ioerror.patch
  37. Patch24: hplip-3165-sourceoption.patch
  38. Patch25: hplip-noernie.patch
  39. Patch26: hplip-appdata.patch
  40. Patch27: hplip-check-cups.patch
  41. Patch30: hplip-typo.patch
  42. # python3 - recent HP release removed encoding/decoding to utf-8 in fax/pmlfax.py -
  43. # that results in text string going into translate function in base/utils.py, which
  44. # expects binary string because of parameters. Remove this patch if base/utils.py
  45. # code gets fixed.
  46. Patch31: hplip-use-binary-str.patch
  47. # m278-m281 doesn't work correctly again
  48. Patch32: hplip-colorlaserjet-mfp-m278-m281.patch
  49. Patch33: hplip-error-print.patch
  50. Patch34: hplip-hpfax-importerror-print.patch
  51. Patch35: hplip-wifisetup.patch
  52. # Vine Patches
  53. Patch70: hplip-3.11.5-gksu.patch
  54. Patch80: hplip-3.16.5-hpijs.patch
  55. # drop dependence on closed-source libImageProcessor.so
  56. Patch100: 0025-Remove-all-ImageProcessor-functionality-which-is-clo.patch
  57. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  58. Requires: cups
  59. Requires: dbus
  60. Requires: dbus-python
  61. Requires: foomatic
  62. Requires: ghostscript
  63. Requires: openssl
  64. Requires: python-imaging
  65. Requires: %{name}-libs = %{version}-%{release}
  66. Requires: gksu
  67. BuildRequires: cups-devel
  68. BuildRequires: dbus-devel
  69. BuildRequires: desktop-file-utils
  70. BuildRequires: libusb1-devel
  71. BuildRequires: libjpeg-devel
  72. BuildRequires: net-snmp-devel
  73. BuildRequires: openssl-devel
  74. BuildRequires: python-devel >= 2.3
  75. BuildRequires: python-cups, cups
  76. BuildRequires: sane-devel
  77. BuildRequires: PyQt4-devel
  78. # to force to use PyQt4
  79. BuildConflicts: PyQt
  80. Provides: hpijs = %{version}-%{release}
  81. Obsoletes: hpijs < %{version}-%{release}
  82. Vendor: Project Vine
  83. Distribution: Vine Linux
  84. Packager: kazutaka
  85. %description
  86. The Hewlett-Packard Linux Imaging and Printing Project provides
  87. drivers for HP printers and multi-function peripherals.
  88. It supports the DeskJet 350C, 600C, 600C Photo, 630C, Apollo 2000,
  89. Apollo 2100, Apollo 2560, DeskJet 800C, DeskJet 825, DeskJet 900,
  90. PhotoSmart, DeskJet 990C, and PhotoSmart 100 series.
  91. %description -l ja
  92. Hewlett-Packard Linux Imaging and Printing Project は HP 製プリンタ及びプリンタ複合機用のドライバを提供します。
  93. これには DeskJet 350C, 600C, 600C Photo, 630C, Apollo 2000, Apollo 2100, Apollo 2560, DeskJet 800C, DeskJet 825, DeskJet 900, PhotoSmart, DeskJet 990C, and PhotoSmart 100 シリーズ等が含まれます。
  94. #---------------------------------------------------------------------
  95. %package libs
  96. Summary: HPLIP libraries
  97. Summary(ja): HPLIP ライブラリ
  98. Group: System Environment/Libraries
  99. License: GPLv2+ and MIT
  100. Requires: python3
  101. %description libs
  102. Libraries needed by HPLIP.
  103. %description libs -l ja
  104. HPLIP 用のライブラリです。
  105. #---------------------------------------------------------------------
  106. %package gui
  107. Summary: HPLIP graphical tools
  108. Summary(ja): HPLIP 用 GUI ツール
  109. Group: Applications/System
  110. License: BSD
  111. Requires: %{name} = %{version}-%{release}
  112. Requires: PyQt4
  113. Requires: notify-python
  114. %description gui
  115. HP Device manager (toolbox) is a graphical utility including
  116. maintenance tools, supplies levels, and status information.
  117. %description gui -l ja
  118. HP デバイスマネージャ (toolbox) は、各種設定やインクや紙の残量確
  119. 認、ステータス情報の確認が行える HPLIP 用の GUI ユーティリティです。
  120. #---------------------------------------------------------------------
  121. %package -n libsane-hpaio
  122. Summary: SANE driver for scanners in HP's multi-function devices
  123. Summary(ja): HP 複合機のスキャナ用 SANE ドライバ
  124. Group: System Environment/Libraries
  125. License: GPLv2+
  126. Requires: %{name}-libs = %{version}-%{release}
  127. Requires: sane
  128. %description -n libsane-hpaio
  129. SANE driver for scanners in HP inkjet and laser based multi-function
  130. printers.
  131. %description -n libsane-hpaio -l ja
  132. HP インクジェット及びレーザープリンタ複合機のスキャナ機能を利用する
  133. 為の SANE ドライバです。
  134. #---------------------------------------------------------------------
  135. %prep
  136. %setup -q
  137. # The pstotiff filter is rubbish so replace it (launchpad #528394).
  138. %patch1 -p1 -b .pstotiff-is-rubbish
  139. # Fix compilation.
  140. %patch2 -p1 -b .strstr-const
  141. # Make utils.checkPyQtImport() look for the gui sub-package (bug #243273).
  142. %patch3 -p1 -b .ui-optional
  143. # Make sure to avoid handwritten asm.
  144. %patch4 -p1 -b .no-asm
  145. # Corrected several IEEE 1284 Device IDs using foomatic data.
  146. # Color LaserJet 2500 series (bug #659040)
  147. # LaserJet 4100 Series/2100 Series (bug #659039)
  148. %patch5 -p1 -b .deviceIDs-drv
  149. chmod +x %{SOURCE2}
  150. mv prnt/drv/hpijs.drv.in{,.deviceIDs-drv-hpijs}
  151. %{SOURCE2} prnt/drv/hpcups.drv.in \
  152. prnt/drv/hpijs.drv.in.deviceIDs-drv-hpijs \
  153. > prnt/drv/hpijs.drv.in
  154. # Move udev rules from /etc/ to /usr/lib/ (bug #748208).
  155. %patch6 -p1 -b .udev-rules
  156. # Retry when connecting to device fails (bug #532112).
  157. %patch7 -p1 -b .retry-open
  158. # Mark SNMP quirks in PPD for HP OfficeJet Pro 8500 (bug #581825).
  159. %patch8 -p1 -b .snmp-quirks
  160. # Fixed bogus low ink warnings from hpijs driver (bug #643643).
  161. %patch9 -p1 -b .hpijs-marker-supply
  162. # Clear old printer-state-reasons we used to manage (bug #510926).
  163. %patch10 -p1 -b .clear-old-state-reasons
  164. # Avoid busy loop in hpcups when backend has exited (bug #525944).
  165. %patch11 -p1 -b .hpcups-sigpipe
  166. # CUPS filters should use TMPDIR when available (bug #865603).
  167. %patch12 -p1 -b .logdir
  168. # Fixed Device ID parsing code in hpijs's dj9xxvip.c (bug #510926).
  169. %patch13 -p1 -b .bad-low-ink-warning
  170. # Add Device ID for
  171. # HP LaserJet Color M451dn (bug #1159380)
  172. for ppd_file in $(grep '^diff' %{PATCH14} | cut -d " " -f 4);
  173. do
  174. gunzip ${ppd_file#*/}.gz
  175. done
  176. %patch14 -p1 -b .deviceIDs-ppd
  177. for ppd_file in $(grep '^diff' %{PATCH14} | cut -d " " -f 4);
  178. do
  179. gzip -n ${ppd_file#*/}
  180. done
  181. # Fix ImageableArea for Laserjet 8150/9000 (bug #596298).
  182. for ppd_file in $(grep '^diff' %{PATCH15} | cut -d " " -f 4);
  183. do
  184. gunzip ${ppd_file#*/}.gz
  185. done
  186. %patch15 -p1 -b .ImageableArea
  187. for ppd_file in $(grep '^diff' %{PATCH15} | cut -d " " -f 4);
  188. do
  189. gzip -n ${ppd_file#*/}
  190. done
  191. # Scan to /var/tmp instead of /tmp (bug #1076954).
  192. %patch16 -p1 -b .scan-tmp
  193. # Treat logging before importing of logger module (bug #984699).
  194. %patch17 -p1 -b .log-stderr
  195. # Fix parsing of avahi-daemon output (bug #1096939).
  196. %patch18 -p1 -b .parsing
  197. # Fixed left/right margins for HP DeskJet 990C (LP #1405212).
  198. %patch20 -p1 -b .dj990c-margin
  199. # Fixed uses of strncpy throughout.
  200. %patch21 -p1 -b .strncpy
  201. # Don't try to write bytecode cache for hpfax backend (bug #1192761)
  202. # or hp-config_usb_printer (bug #1266903)
  203. # or hpps filter (bug #1241548).
  204. %patch22 -p1 -b .no-write-bytecode
  205. # Ignore IOError when logging output (bug #712537).
  206. %patch23 -p1 -b .silence-ioerror
  207. # [abrt] hplip: hp-scan:663:<module>:NameError: name 'source_option' is not defined (bug #1341304)
  208. %patch24 -p1 -b .sourceoption
  209. # hplip license problem (bug #1364711)
  210. %patch25 -p1 -b .no-ernie
  211. # hplip appdata
  212. %patch26 -p1 -b .appdata
  213. rm prnt/hpcups/ErnieFilter.{cpp,h} prnt/hpijs/ernieplatform.h
  214. # hp-check shows 'CUPS incompatible or not running' even if CUPS is running (bug #1456467)
  215. %patch27 -p1 -b .check-cups
  216. # hp-firmware:NameError: name 'INTERACTIVE_MODE4' is not defined (bug #1533869)
  217. %patch30 -p1 -b .typo
  218. %patch31 -p1 -b .use-binary-str
  219. %patch32 -p1 -b .colorlaserjet-mfp-m278-m281
  220. # TypeError: 'Error' object does not support indexing (bug #1564770)
  221. # upstream bug: https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/1718129
  222. # in python2 it was possible to acces Exception message by index [0].
  223. # in python3 this is no longer possible and it causes TypeError.
  224. %patch33 -p1 -b .error-print-fix
  225. # TypeError: not all arguments converted during string formatting (bug #1566938)
  226. # upstream bug: https://bugs.launchpad.net/ubuntu/+source/hplip/+bug/616450
  227. # bug caused by more arguments than argument specifiers in formatted string
  228. %patch34 -p1 -b .hpfax-import-error-print
  229. # 'WifiSetupDialog' object has no attribute 'wifiobj' (bug #1626877)
  230. # upstream bug: https://bugs.launchpad.net/hplip/+bug/1752060
  231. # bug caused by typo in wifisetupdialog wifiObj property call
  232. %patch35 -p1 -b .wifisetup-bad-call-fix
  233. # vine
  234. %patch70 -p1 -b .gksu
  235. %patch80 -p1 -b .hpijs
  236. %patch100 -p1 -b .libimageprocessor
  237. sed -i.duplex-constraints \
  238. -e 's,\(UIConstraints.* \*Duplex\),//\1,' \
  239. prnt/drv/hpcups.drv.in
  240. # Change shebang /usr/bin/env python -> /usr/bin/python3 (bug #618351).
  241. #find -name '*.py' -print0 | xargs -0 \
  242. # sed -i.env-python -e 's,^#!/usr/bin/env python,#!%{__python3},'
  243. rm locatedriver
  244. %build
  245. touch NEWS README AUTHORS ChangeLog
  246. autoreconf -f -i
  247. %configure \
  248. --enable-scan-build --enable-gui-build --enable-fax-build \
  249. --disable-foomatic-rip-hplip-install --enable-pp-build \
  250. --enable-qt4 \
  251. --enable-hpcups-install --enable-cups-drv-install \
  252. --enable-foomatic-drv-install --enable-dbus-build \
  253. --enable-hpijs-install \
  254. --disable-policykit \
  255. --with-mimedir=%{_datadir}/cups/mime \
  256. --with-cupsbackenddir=%{_libdir}/cups/backend \
  257. --with-cupsfilterdir=%{_libdir}/cups/filter \
  258. --with-hpppddir=%{_datadir}/foomatic/db/source/PPD/HP
  259. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  260. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  261. make
  262. %install
  263. rm -rf $RPM_BUILD_ROOT
  264. make install DESTDIR=$RPM_BUILD_ROOT rulesdir=/lib/udev/rules.d
  265. # Create /run/hplip & /var/lib/hp
  266. mkdir -p $RPM_BUILD_ROOT/run/hplip
  267. mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/lib/hp
  268. # install modified .desktop
  269. #{__install} -m 644 %{SOURCE1} ${RPM_BUILD_ROOT}/%{_datadir}/applications/hplip.desktop
  270. # install /usr/lib/tmpfiles.d/hplip.conf (bug #1015831)
  271. mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d
  272. cat > $RPM_BUILD_ROOT%{_prefix}/lib/tmpfiles.d/hplip.conf <<EOF
  273. # See tmpfiles.d(5) for details
  274. d /run/hplip 0775 root lp -
  275. EOF
  276. # remove unpacked files.
  277. rm -rf %{buildroot}%{_sysconfdir}/sane.d \
  278. %{buildroot}%{_docdir} \
  279. %{buildroot}%{_datadir}/hal/fdi \
  280. %{buildroot}%{_datadir}/hplip/pkservice.py \
  281. %{buildroot}%{_bindir}/hp-pkservice \
  282. %{buildroot}%{_datadir}/hplip/locatedriver* \
  283. %{buildroot}%{_datadir}/hplip/dat2drv*
  284. rm -f %{buildroot}%{_bindir}/hp-logcapture \
  285. %{buildroot}%{_bindir}/hp-doctor \
  286. %{buildroot}%{_bindir}/hp-pqdiag \
  287. %{buildroot}%{_datadir}/hplip/logcapture.py \
  288. %{buildroot}%{_datadir}/hplip/doctor.py \
  289. %{buildroot}%{_datadir}/hplip/pqdiag.py
  290. rm -f %{buildroot}%{_bindir}/foomatic-rip \
  291. %{buildroot}%{_libdir}/cups/filter/foomatic-rip \
  292. %{buildroot}%{_libdir}/*.la \
  293. %{buildroot}%{python3_sitearch}/*.la \
  294. %{buildroot}%{_libdir}/libhpip.so \
  295. %{buildroot}%{_libdir}/libhpipp.so \
  296. %{buildroot}%{_libdir}/libhpdiscovery.so \
  297. %{buildroot}%{_libdir}/sane/*.la \
  298. %{buildroot}%{_datadir}/cups/model/foomatic-ppds \
  299. %{buildroot}%{_datadir}/applications/hplip.desktop \
  300. %{buildroot}%{_datadir}/ppd/HP/*.ppd
  301. mkdir -p %{buildroot}%{_datadir}/appdata
  302. cp %{SOURCE3} %{buildroot}%{_datadir}/appdata/
  303. mkdir -p %{buildroot}%{_datadir}/icons/hicolor/{16x16,32x32,64x64}/apps
  304. install -p -m644 %{buildroot}%{_datadir}/hplip/data/images/16x16/hp_logo.png \
  305. %{buildroot}%{_datadir}/icons/hicolor/16x16/apps/hp_logo.png
  306. install -p -m644 %{buildroot}%{_datadir}/hplip/data/images/32x32/hp_logo.png \
  307. %{buildroot}%{_datadir}/icons/hicolor/32x32/apps/hp_logo.png
  308. install -p -m644 %{buildroot}%{_datadir}/hplip/data/images/64x64/hp_logo.png \
  309. %{buildroot}%{_datadir}/icons/hicolor/64x64/apps/hp_logo.png
  310. cp -p %{SOURCE1000} hplip.desktop
  311. mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
  312. sed -i -e '/^Categories=/d' hplip.desktop
  313. # Encoding key is deprecated
  314. sed -i -e '/^Encoding=/d' hplip.desktop
  315. desktop-file-install --vendor "HP" \
  316. --dir $RPM_BUILD_ROOT%{_datadir}/applications \
  317. --add-category System \
  318. --add-category Settings \
  319. --add-category HardwareSettings \
  320. hplip.desktop
  321. # Regenerate hpcups PPDs on upgrade if necessary (bug #579355).
  322. #install -p -m755 %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/hpcups-update-ppds
  323. %{__mkdir_p} $RPM_BUILD_ROOT%{_sysconfdir}/sane.d/dll.d
  324. echo hpaio > $RPM_BUILD_ROOT%{_sysconfdir}/sane.d/dll.d/hpaio
  325. # Images in docdir should not be executable (bug #440552).
  326. find doc/images -type f -exec chmod 644 {} \;
  327. # Create an empty plugins directory to make sure it gets the right
  328. # SELinux file context (bug #564551).
  329. %{__mkdir_p} $RPM_BUILD_ROOT%{_datadir}/hplip/prnt/plugins
  330. # Remove files we don't want to package.
  331. rm -f $RPM_BUILD_ROOT%{_datadir}/hplip/hpaio.desc
  332. rm -f $RPM_BUILD_ROOT%{_datadir}/hplip/hplip-install
  333. rm -rf $RPM_BUILD_ROOT%{_datadir}/hplip/install.*
  334. rm -f $RPM_BUILD_ROOT%{_datadir}/hplip/uninstall.*
  335. rm -f $RPM_BUILD_ROOT%{_bindir}/hp-uninstall
  336. rm -f $RPM_BUILD_ROOT%{_datadir}/hplip/upgrade.*
  337. rm -f $RPM_BUILD_ROOT%{_bindir}/hp-upgrade
  338. rm -f $RPM_BUILD_ROOT%{_bindir}/hp-config_usb_printer
  339. rm -f $RPM_BUILD_ROOT%{_unitdir}/hplip-printer@.service
  340. rm -f $RPM_BUILD_ROOT%{_datadir}/hplip/config_usb_printer.*
  341. rm -f $RPM_BUILD_ROOT%{_datadir}/hplip/hpijs.drv.in.template
  342. rm -f $RPM_BUILD_ROOT%{_datadir}/cups/mime/pstotiff.types
  343. rm -f $RPM_BUILD_ROOT%{_datadir}/hplip/fax/pstotiff*
  344. rm -rf $RPM_BUILD_ROOT%{_prefix}/lib/systemd
  345. # The systray applet doesn't work properly (displays icon as a
  346. # window), so don't ship the launcher yet.
  347. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/xdg/autostart/hplip-systray.desktop
  348. %clean
  349. rm -rf $RPM_BUILD_ROOT
  350. %post libs -p /sbin/ldconfig
  351. %postun libs -p /sbin/ldconfig
  352. %files
  353. %defattr(-,root,root)
  354. %doc COPYING doc/*
  355. #%doc %{_datadir}/doc/%{name}-%{version}
  356. %{_bindir}/hp-align
  357. %{_bindir}/hp-clean
  358. %{_bindir}/hp-colorcal
  359. %{_bindir}/hp-devicesettings
  360. %{_bindir}/hp-diagnose_plugin
  361. %{_bindir}/hp-diagnose_queues
  362. %{_bindir}/hp-fab
  363. %{_bindir}/hp-faxsetup
  364. %{_bindir}/hp-firmware
  365. %{_bindir}/hp-info
  366. %{_bindir}/hp-levels
  367. %{_bindir}/hp-linefeedcal
  368. %{_bindir}/hp-makecopies
  369. %{_bindir}/hp-makeuri
  370. %{_bindir}/hp-plugin
  371. %{_bindir}/hp-printsettings
  372. %{_bindir}/hp-probe
  373. %{_bindir}/hp-query
  374. %{_bindir}/hp-scan
  375. %{_bindir}/hp-sendfax
  376. %{_bindir}/hp-setup
  377. %{_bindir}/hp-testpage
  378. %{_bindir}/hp-timedate
  379. %{_bindir}/hp-unload
  380. %{_bindir}/hp-wificonfig
  381. %{_libdir}/cups/backend/hp
  382. %{_libdir}/cups/backend/hpfax
  383. %{_libdir}/cups/filter/hpcups
  384. %{_libdir}/cups/filter/hpcupsfax
  385. %{_libdir}/cups/filter/hpps
  386. %{_libdir}/cups/filter/pstotiff
  387. %{_datadir}/cups/mime/pstotiff.convs
  388. # Files
  389. %{_datadir}/hplip/align.py*
  390. %{_datadir}/hplip/check-plugin.py*
  391. %{_datadir}/hplip/clean.py*
  392. %{_datadir}/hplip/colorcal.py*
  393. %{_datadir}/hplip/devicesettings.py*
  394. %{_datadir}/hplip/diagnose_plugin.py*
  395. %{_datadir}/hplip/diagnose_queues.py*
  396. %{_datadir}/hplip/fab.py*
  397. %{_datadir}/hplip/fax
  398. %{_datadir}/hplip/faxsetup.py*
  399. %{_datadir}/hplip/firmware.py*
  400. %{_datadir}/hplip/hpdio.py*
  401. %{_datadir}/hplip/hplip_clean.sh
  402. %{_datadir}/hplip/hpssd*
  403. %{_datadir}/hplip/info.py*
  404. %{_datadir}/hplip/__init__.py*
  405. %{_datadir}/hplip/levels.py*
  406. %{_datadir}/hplip/linefeedcal.py*
  407. %{_datadir}/hplip/makecopies.py*
  408. %{_datadir}/hplip/makeuri.py*
  409. %{_datadir}/hplip/plugin.py*
  410. %{_datadir}/hplip/printsettings.py*
  411. %{_datadir}/hplip/probe.py*
  412. %{_datadir}/hplip/query.py*
  413. %{_datadir}/hplip/scan.py*
  414. %{_datadir}/hplip/sendfax.py*
  415. %{_datadir}/hplip/setup.py*
  416. %{_datadir}/hplip/testpage.py*
  417. %{_datadir}/hplip/timedate.py*
  418. %{_datadir}/hplip/unload.py*
  419. %{_datadir}/hplip/wificonfig.py*
  420. # Directories
  421. %{_datadir}/hplip/base
  422. %{_datadir}/hplip/copier
  423. %{_datadir}/hplip/data/ldl
  424. %{_datadir}/hplip/data/localization
  425. %{_datadir}/hplip/data/pcl
  426. %{_datadir}/hplip/data/ps
  427. %{_datadir}/hplip/installer
  428. %{_datadir}/hplip/pcard
  429. %{_datadir}/hplip/prnt
  430. %{_datadir}/hplip/scan
  431. %{_localstatedir}/lib/hp
  432. %dir %attr(0775,root,lp) /run/hplip
  433. %{_prefix}/lib/tmpfiles.d/hplip.conf
  434. %dir %{_sysconfdir}/hp
  435. %config(noreplace) %{_sysconfdir}/hp/hplip.conf
  436. /lib/udev/rules.d/56-hpmud.rules
  437. %dir %{_datadir}/hplip
  438. %dir %{_datadir}/hplip/data
  439. %{_datadir}/hplip/data/models
  440. %{_bindir}/hpijs
  441. #{_bindir}/hpcups-update-ppds
  442. %{_datadir}/cups/drv/*
  443. %dir %{_datadir}/foomatic/db/source/PPD/HP
  444. %{_datadir}/foomatic/db/source/PPD/HP/*
  445. %files libs
  446. %defattr(-,root,root)
  447. %{_libdir}/libhpip.so.*
  448. # The so symlink is required here (see bug #489059).
  449. %{_libdir}/libhpmud.so*
  450. %{_libdir}/libhpdiscovery.so*
  451. %{_libdir}/libhpipp.so*
  452. # Python extension
  453. %{python_sitearch}/*
  454. %files gui
  455. %defattr(-,root,root)
  456. %{_bindir}/hp-check
  457. %{_bindir}/hp-print
  458. %{_bindir}/hp-systray
  459. %{_bindir}/hp-toolbox
  460. %{_bindir}/hp-uiscan
  461. %{_datadir}/applications/*.desktop
  462. %{_datadir}/appdata/hplip.appdata.xml
  463. # Files
  464. %{_datadir}/icons/hicolor/*/apps/*
  465. %{_datadir}/hplip/check.py*
  466. %{_datadir}/hplip/print.py*
  467. %{_datadir}/hplip/systray.py*
  468. %{_datadir}/hplip/toolbox.py*
  469. %{_datadir}/hplip/uiscan.py*
  470. # Directories
  471. %{_datadir}/hplip/data/images
  472. %{_datadir}/hplip/ui4
  473. %{_datadir}/hplip/uiscan.py*
  474. %files -n libsane-hpaio
  475. %defattr(-,root,root)
  476. %{_libdir}/sane/libsane-hpaio*
  477. %config(noreplace) %{_sysconfdir}/sane.d/dll.d/hpaio
  478. %changelog
  479. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.18.10-1
  480. - new upstream release.
  481. - updated Patch12.
  482. - imported Patche24-35 from rawhide.
  483. * Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.16.5-1
  484. - new upstream release.
  485. - dropped all patches.
  486. - imported all patches from rawhide.
  487. - added Patch80 to fix error in building hpijs.
  488. * Sun May 15 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.15.2-2
  489. - rebuild with openssl-1.0.2
  490. * Thu Mar 19 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.15.2-1
  491. - updated to 3.15.2
  492. - updated Source1
  493. - renumbered former Patch 0 and 1 to Patch 70 and 6
  494. - built with libusb1
  495. - added BR: desktop-file-utils
  496. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.11.5-5
  497. - rebuild with net-snmp-5.7.1
  498. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.11.5-5
  499. - rebuild with net-snmp-5.7.1
  500. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.11.5-4
  501. - rebuild with python-2.7.2
  502. * Mon Jun 13 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-3
  503. - add Obsoletes: hpijs < 3.10
  504. * Sun Jun 12 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-2
  505. - change configure option to --enable-hpijs-install
  506. - add Provides: hpijs
  507. - change ppd installation path to %{_datadir}/foomatic/db/source/PPD/HP
  508. - update Source1 (hplip.desktop.vine)
  509. - update Patch0 (hplip-3.11.5-gksu.patch)
  510. - add Patch1 to fix udev old syntax (hplip-udev-rules.patch)
  511. * Tue Mar 15 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 3.11.5-1
  512. - new upstream release
  513. - change configure option: disable qt3 and enable qt4
  514. - add configure option: --enable-foomatic-drv-install
  515. - add BuildRequires: openssl-devel
  516. - add Requires: dbus-python
  517. - add Requires: notify-python (gui)
  518. - change Requires: PyQt to PyQt4 (gui)
  519. - add BuildConflicts: PyQt
  520. - add ppds below %{_datadir}/cups/model/foomatic/hp-*
  521. because foomatic (>= 4.0.3) drop PPDs for HP printers.
  522. * Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.9.4b-3
  523. - add Patch0 to require root privilege (via gksu) when adding printer
  524. - add Requires: gksu
  525. * Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 3.9.4b-2
  526. - added --with-cupsfilterdir to configure option
  527. - use python_sitearch macro instead of python_platlib
  528. * Sun Jun 07 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 3.9.4b-1
  529. - new upstream release
  530. - split libraries to -libs sub package
  531. - update configure option
  532. add --enable-dbus-build, --enable-qt3, --disable-qt4
  533. * Mon Jul 21 2008 Shu KONNO <owa@bg.wakwak.com> 2.7.12-1vl5
  534. - rebuilt with python-2.5.2
  535. - added python_platlib macro
  536. - applied new versioning policy and spec in utf-8
  537. * Sun Jan 6 2008 Shu KONNO <owa@bg.wakwak.com> 2.7.12-0vl2
  538. - added --with-cupsbackenddir=%%{_libdir}/cups/backend to configure
  539. * Thu Jan 3 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.7.12-0vl1
  540. - new upstream release
  541. - build with net-snmp-5.4.1
  542. * Thu Jun 28 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 2.7.6-0vl1
  543. - initial build for Vine Linux