libghc-build-pandoc-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173
  1. %define pkg_name build-pandoc
  2. %define pkg_version 2.2.1
  3. %define pkg_release 2%{?_dist_release}
  4. Summary: Haskell libraries: %{pkg_name} and dependent libraries
  5. Name: libghc-%{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD3
  9. Group: Applications/Text
  10. URL: http://hackage.haskell.org
  11. Source0: packages
  12. Source11: Glob-0.9.2.tar.gz
  13. Source12: Glob.cabal
  14. Source13: JuicyPixels-3.2.9.5.tar.gz
  15. Source14: JuicyPixels.cabal
  16. Source15: SHA-1.6.4.4.tar.gz
  17. Source16: SHA.cabal
  18. Source17: base64-bytestring-1.0.0.1.tar.gz
  19. Source18: base64-bytestring.cabal
  20. Source19: blaze-markup-0.8.2.1.tar.gz
  21. Source20: blaze-markup.cabal
  22. Source21: cmark-gfm-0.1.3.tar.gz
  23. Source22: cmark-gfm.cabal
  24. Source23: cmdargs-0.10.20.tar.gz
  25. Source24: cmdargs.cabal
  26. Source25: colour-2.3.4.tar.gz
  27. Source26: colour.cabal
  28. Source27: digest-0.0.1.2.tar.gz
  29. Source28: digest.cabal
  30. Source29: fail-4.9.0.0.tar.gz
  31. Source30: fail.cabal
  32. Source31: hxt-charproperties-9.2.0.1.tar.gz
  33. Source32: hxt-charproperties.cabal
  34. Source33: old-time-1.1.0.3.tar.gz
  35. Source34: old-time.cabal
  36. Source35: pandoc-types-1.17.4.2.tar.gz
  37. Source36: pandoc-types.cabal
  38. Source37: regex-pcre-builtin-0.94.4.8.8.35.tar.gz
  39. Source38: regex-pcre-builtin.cabal
  40. Source39: safe-0.3.17.tar.gz
  41. Source40: safe.cabal
  42. Source41: tagsoup-0.14.6.tar.gz
  43. Source42: tagsoup.cabal
  44. Source43: temporary-1.3.tar.gz
  45. Source44: temporary.cabal
  46. Source45: utf8-string-1.0.1.1.tar.gz
  47. Source46: utf8-string.cabal
  48. Source47: xml-1.3.14.tar.gz
  49. Source48: xml.cabal
  50. Source49: blaze-html-0.9.0.1.tar.gz
  51. Source50: blaze-html.cabal
  52. Source51: aeson-pretty-0.8.7.tar.gz
  53. Source52: aeson-pretty.cabal
  54. Source53: ansi-terminal-0.8.0.4.tar.gz
  55. Source54: ansi-terminal.cabal
  56. Source55: hslua-0.9.5.2.tar.gz
  57. Source56: hslua.cabal
  58. Source57: hxt-unicode-9.0.2.4.tar.gz
  59. Source58: hxt-unicode.cabal
  60. Source59: hxt-regex-xmlschema-9.2.0.3.tar.gz
  61. Source60: hxt-regex-xmlschema.cabal
  62. Source61: zip-archive-0.3.2.4.tar.gz
  63. Source62: zip-archive.cabal
  64. Source63: texmath-0.11.tar.gz
  65. Source64: texmath.cabal
  66. Source65: doctemplates-0.2.2.1.tar.gz
  67. Source66: doctemplates.cabal
  68. Source67: hslua-module-text-0.1.2.1.tar.gz
  69. Source68: hslua-module-text.cabal
  70. Source69: hxt-9.3.1.16.tar.gz
  71. Source70: hxt.cabal
  72. Source71: skylighting-core-0.7.1.tar.gz
  73. Source72: skylighting-core.cabal
  74. Source73: skylighting-0.7.1.tar.gz
  75. Source74: skylighting.cabal
  76. BuildRequires: ghc haskell-platform
  77. BuildRequires: libghc-data-default-class
  78. BuildRequires: libghc-dlist
  79. BuildRequires: libghc-old-locale
  80. BuildRequires: libghc-data-default
  81. BuildRequires: libghc-aeson
  82. BuildRequires: libghc-semigroups
  83. BuildRequires: yaml
  84. BuildRequires: libghc-http-client-tls
  85. BuildRequires: libghc-haddock-library
  86. BuildRequires: zlib-devel
  87. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  88. Requires: ghc haskell-platform
  89. Requires: haskell-platform-dep
  90. Requires: libghc-data-default-class
  91. Requires: libghc-dlist
  92. Requires: libghc-old-locale
  93. Requires: libghc-data-default
  94. Requires: libghc-aeson
  95. Requires: libghc-semigroups
  96. Requires: yaml
  97. Requires: libghc-http-client-tls
  98. Requires: libghc-haddock-library
  99. Vendor: Project Vine
  100. Distribution: Vine Linux
  101. Packager: ara_t
  102. %description
  103. Haskell libraries: %{pkg_name}
  104. %build
  105. %ghc_pkg_init
  106. cd %{_builddir}
  107. for pkg in `cat %{SOURCE0}`; do
  108. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  109. pushd ${pkg}
  110. %ghc_fix_dependencies ${pkg}
  111. %cabal_configure2 %{name} ${pkg}
  112. %cabal_build
  113. %cabal_haddock
  114. %cabal_copy_resister %{name}_${pkg}
  115. popd
  116. done
  117. %clean
  118. %{__rm} -rf ${RPM_BUILD_ROOT}
  119. %post
  120. %ghc_pkg_recache
  121. %postun
  122. %ghc_pkg_recache
  123. %files
  124. %defattr(-, root, root)
  125. %{_bindir}/
  126. %{_libdir}/ghc-%{ghc_version}/
  127. %{_libdir}/ghc-lib/
  128. %{_datadir}/%{name}/
  129. %{_docdir}/%{name}/
  130. %changelog
  131. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-2
  132. - correct BuildRequires and Requires (add libghc-data-default)
  133. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 2.2.1-1
  134. - update to 2.2.1
  135. - rebuild using ghc-8.4.2
  136. - rewrite using macro
  137. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 2.0.6-1
  138. - update to 2.0.6
  139. - build using ghc-8.2.2
  140. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 1.19.2.1-1
  141. - update to 1.19.2.1
  142. - build using ghc-8.0.2
  143. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 1.17.1-1
  144. - update to 1.17.1
  145. - build using ghc-8.0.1
  146. * Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 1.17.0.3-1
  147. - new package