123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149 |
- Summary: Validating XML Parser
- Name: xerces-c
- Version: 3.1.1
- Release: 1%{?_dist_release}
- License: ASL 2.0
- Group: System Environment/Libraries
- URL: http://xml.apache.org/xerces-c/
- Source0: http://www.apache.org/dist/xerces/c/3/sources/xerces-c-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: dos2unix
- %description
- Xerces-C is a validating XML parser written in a portable subset of
- C++. Xerces-C makes it easy to give your application the ability to
- read and write XML data. A shared library is provided for parsing,
- generating, manipulating, and validating XML documents. Xerces-C is
- faithful to the XML 1.0 recommendation and associated standards:
- XML 1.0 (Third Edition), XML 1.1 (First Edition), DOM Level 1, 2, 3
- Core, DOM Level 2.0 Traversal and Range, DOM Level 3.0 Load and Save,
- SAX 1.0 and SAX 2.0, Namespaces in XML, Namespaces in XML 1.1, XML
- Schema, XML Inclusions).
- %package devel
- Summary: Header files, libraries and development documentation for %{name}
- Summary(ja): %{name} のヘッダファイル、ライブラリ、開発用ドキュメント
- Group: Development/Libraries
- Requires: %{name} = %{version}-%{release}
- %description devel
- This package contains the header files, static libraries and development
- documentation for %{name}. If you like to develop programs using %{name},
- you will need to install %{name}-devel.
- %package doc
- Summary: Documentation for Xerces-C++ validating XML parser
- Group: Documentation
- BuildArch: noarch
- %description doc
- Documentation for Xerces-C++.
- Xerces-C++ is a validating XML parser written in a portable subset of C++.
- Xerces-C++ makes it easy to give your application the ability to read and
- write XML data. A shared library is provided for parsing, generating,
- manipulating, and validating XML documents.
- %prep
- %setup -q
- mkdir -p _docs
- cp -a samples/ _docs/
- %build
- export CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing"
- export CXXFLAGS="$CFLAGS"
- %configure --disable-static \
- --disable-pretty-make \
- --disable-sse2
- make %{?_smp_mflags}
- %install
- rm -rf $RPM_BUILD_ROOT
- make install DESTDIR="$RPM_BUILD_ROOT"
- iconv -f iso8859-1 -t utf-8 CREDITS > CREDITS.tmp && mv -f CREDITS.tmp CREDITS
- pushd doc; dos2unix -k *.xml; popd
- rm -rf $RPM_BUILD_ROOT%{_bindir}
- rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
- %post -p /sbin/ldconfig
- %postun -p /sbin/ldconfig
- %clean
- rm -rf $RPM_BUILD_ROOT
- %files
- %defattr(-,root,root,-)
- %doc LICENSE
- %{_libdir}/libxerces-c-3.*.so
- %files devel
- %defattr(-,root,root,-)
- %{_libdir}/libxerces-c.so
- %{_libdir}/pkgconfig/xerces-c.pc
- %{_includedir}/xercesc/
- %files doc
- %defattr(-,root,root,-)
- %doc README LICENSE NOTICE CREDITS doc _docs/*
- %changelog
- * Sat Jan 24 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 3.1.1-1
- - updated to 3.1.1
- * Sat Feb 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-3
- - rebuild with Vine6 environment
- * Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.0-2
- - rebuilt with new toolchain
- * Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.8.0-1
- - initial build for Vine Linux
- * Mon Jun 30 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-2
- - Spec cleanups ( https://bugzilla.redhat.com/show_bug.cgi?id=435132 )
- * Sun Feb 10 2008 Peter Lemenkov <lemenkov@gmail.com> 2.8.0-1
- - Ver. 2.8.0
- * Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-6
- - typo fix
- * Sat Nov 25 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-5
- - fixed some rpmlint warnings
- * Fri Nov 24 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-4
- - Added samples to docs-package
- * Sat Nov 18 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-3
- - improvements suggested by Aurelien Bompard
- * Sat Oct 14 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-2
- - Disabled package 'samples'
- * Fri Oct 13 2006 Peter Lemenkov <lemenkov@gmail.com> 2.7.0-1
- - initial build for FE
- * Fri Jan 06 2006 Dag Wieers <dag@wieers.com> - 2.7.0-1 - 3891/dag
- - Cleaned SPEC file.
- * Tue Jan 03 2006 Dries Verachtert <dries@ulyssis.org> - 2.7.0-1
- - Updated to release 2.7.0.
- * Thu Sep 22 2005 C.Lee Taylor <leet@leenx.co.za> 2.6.1-1
- - Update to 2.6.1
- - Build for FC4 32/64bit
- * Sat Aug 20 2005 Che
- - initial rpm release
|