openssl-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define soversion 6
  3. %define version 0.9.8p
  4. %define release 1%{_dist_release}
  5. Summary: Secure Sockets Layer Toolkit
  6. Name: openssl
  7. Version: %{version}
  8. Release: %{release}
  9. Source: openssl-%{version}.tar.gz
  10. Source2: Makefile.certificate
  11. Source3: ca-bundle.crt
  12. Source5: make-dummy-cert
  13. Source6: openssl-%{version}.pc
  14. Patch0: openssl-0.9.8b-soversion.patch
  15. Patch2: openssl-0.9.8e-rpm_opt.patch
  16. Patch4: openssl-0.9.8p-enginesdir.patch
  17. # security fix
  18. # Patch10: openssl-0.9.8k-dtls-dos.patch
  19. # Patch11: openssl-0.9.8-CVE-2009-4355.patch
  20. # Patch12: openssl-0.9.8k_CVE-2009-3555.patch
  21. License: BSDish
  22. Group: System Environment/Libraries
  23. URL: http://www.openssl.org/
  24. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  25. BuildPreReq: perl, sed
  26. Requires: mktemp
  27. Packager: Daisuke SUZUKI <daisuke@linux.or.jp>
  28. Vendor: Project Vine
  29. Distribution: Vine Linux
  30. %define solibbase %(echo %version | sed 's/[[:alpha:]]//g')
  31. %description
  32. The OpenSSL certificate management tool and the shared libraries that
  33. provide various cryptographic algorithms and protocols.
  34. %package devel
  35. Summary: OpenSSL libraries and development headers.
  36. Group: Development/Libraries
  37. Requires: %{name} = %{version}-%{release}
  38. %description devel
  39. The static libraries and include files needed to compile apps
  40. with support for various the cryptographic algorithms and protocols
  41. supported by OpenSSL.
  42. Patches for many networking apps can be found at:
  43. ftp://ftp.psy.uq.oz.au/pub/Crypto/SSLapps/
  44. %package perl
  45. Summary: OpenSSL scripts which require Perl.
  46. Group: Applications/Internet
  47. Requires: perl
  48. Requires: %{name} = %{version}-%{release}
  49. %description perl
  50. Perl scripts provided with OpenSSL for converting certificates and keys
  51. from other formats to those used by OpenSSL.
  52. ## to build compat32 for x86_64 architecture support
  53. %package -n compat32-%{name}
  54. Summary: Secure Sockets Layer Toolkit
  55. Group: System Environment/Libraries
  56. Requires: %{name} = %{version}-%{release}
  57. %description -n compat32-%{name}
  58. The OpenSSL certificate management tool and the shared libraries that
  59. provide various cryptographic algorithms and protocols.
  60. %package -n compat32-%{name}-devel
  61. Summary: OpenSSL libraries and development headers.
  62. Group: Development/Libraries
  63. Requires: compat32-%{name} = %{version}-%{release}
  64. %description -n compat32-%{name}-devel
  65. The static libraries and include files needed to compile apps
  66. with support for various the cryptographic algorithms and protocols
  67. supported by OpenSSL.
  68. %prep
  69. %setup -q -n openssl-%{version}
  70. %patch0 -p1 -b .soversion
  71. %patch2 -p1 -b .rpm_opt
  72. %patch4 -p1 -b .enginesdir
  73. # security fix
  74. # %patch10 -p1 -b .dtls-dos
  75. # %patch11 -p1 -b .CVE-2009-4355
  76. # %patch12 -p1 -b .CVE-2009-3555
  77. chmod 644 FAQ LICENSE CHANGES NEWS INSTALL README
  78. chmod 644 doc/README doc/c-indentation.el doc/openssl.txt
  79. chmod 644 doc/openssl_button.html doc/openssl_button.gif
  80. chmod 644 doc/ssleay.txt
  81. # Link the configuration header to the one we're going to make.
  82. ln -sf ../../crypto/opensslconf.h include/openssl/
  83. %build
  84. PATH=${PATH}:${PWD}/bin
  85. TOPDIR=${PWD}
  86. LD_LIBRARY_PATH=${TOPDIR}:${TOPDIR}/bin:${PATH} ; export LD_LIBRARY_PATH
  87. # Figure out which flags we want to use. Can't use assembler because it's
  88. # not lowest-common-denominator in most cases.
  89. perl util/perlpath.pl `dirname %{__perl}`
  90. %ifarch %ix86
  91. sslarch=linux-elf
  92. sslflags="no-asm 386"
  93. %endif
  94. %ifarch ppc
  95. sslarch=linux-ppc
  96. sslflags=no-asm
  97. %endif
  98. %ifarch sparc
  99. sslarch=linux-sparcv9
  100. sslflags=no-asm
  101. %endif
  102. %ifarch ia64
  103. sslarch=linux-ia64
  104. sslflags=no-asm
  105. %endif
  106. %ifarch alpha
  107. sslarch=linux-alpha-gcc
  108. sslflags=no-asm
  109. %endif
  110. %ifarch s390
  111. sslarch=linux-s390
  112. %endif
  113. %ifarch s390x
  114. sslarch=linux-s390x
  115. %endif
  116. %ifarch mipsel
  117. sslarch=linux-mips
  118. sslflags=no-asm
  119. %endif
  120. ## to build for x86_64 architecture support
  121. %ifarch x86_64
  122. sslarch=linux-x86_64
  123. sslflags=no-asm
  124. %endif
  125. # Configure the build tree. Override OpenSSL defaults with known-good defaults
  126. # usable on all platforms. The Configure script already knows to use -fPIC and
  127. # RPM_OPT_FLAGS, so we can skip specifiying them here.
  128. ./Configure \
  129. --prefix=%{_prefix} --openssldir=%{_datadir}/ssl ${sslflags} \
  130. --enginesdir=%{_libdir}/openssl/engines \
  131. shared ${sslarch}
  132. # Add -Wa,--noexecstack here so that libcrypto's assembler modules will be
  133. # marked as not requiring an executable stack.
  134. RPM_OPT_FLAGS="$RPM_OPT_FLAGS -Wa,--noexecstack"
  135. make depend
  136. make all build-shared
  137. # Generate hashes for the included certs.
  138. LD_LIBRARY_PATH=`pwd`${LD_LIBRARY_PATH:+:${LD_LIBRARY_PATH}}
  139. export LD_LIBRARY_PATH
  140. make rehash build-shared
  141. # Verify that what was compiled actually works.
  142. make -C test apps tests
  143. # Relink the main binary to get it dynamically linked.
  144. rm apps/openssl
  145. make all build-shared
  146. %install
  147. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  148. # Install OpenSSL.
  149. install -d $RPM_BUILD_ROOT/{%{_lib},%{_bindir},%{_includedir},%{_libdir},%{_mandir},%{_libdir}/openssl}
  150. make INSTALL_PREFIX=$RPM_BUILD_ROOT install build-shared
  151. install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir}
  152. # added for lib64
  153. mv $RPM_BUILD_ROOT/usr/lib/engines $RPM_BUILD_ROOT%{_libdir}/openssl || :
  154. mv $RPM_BUILD_ROOT/usr/lib/* $RPM_BUILD_ROOT%{_libdir}/ || :
  155. mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.%{soversion} $RPM_BUILD_ROOT/%{_lib}/
  156. mv $RPM_BUILD_ROOT%{_datadir}/ssl/man/* $RPM_BUILD_ROOT%{_mandir}
  157. rmdir $RPM_BUILD_ROOT%{_datadir}/ssl/man
  158. rename so.%{soversion} so.%{version} $RPM_BUILD_ROOT/%{_lib}/*.so.%{soversion}
  159. for lib in $RPM_BUILD_ROOT/%{_lib}/*.so.%{version} ; do
  160. chmod 755 ${lib}
  161. ln -s -f ../../%{_lib}/`basename ${lib}` $RPM_BUILD_ROOT%{_libdir}/`basename ${lib} .%{version}`
  162. ln -s -f `basename ${lib}` $RPM_BUILD_ROOT/%{_lib}/`basename ${lib} .%{version}`.%{soversion}
  163. done
  164. install -m644 -D %{SOURCE6} $RPM_BUILD_ROOT%{_libdir}/pkgconfig/openssl.pc
  165. # Install a makefile for generating keys and self-signed certs, and a script
  166. # for generating them on the fly.
  167. mkdir -p $RPM_BUILD_ROOT%{_datadir}/ssl/certs
  168. install -m644 $RPM_SOURCE_DIR/Makefile.certificate $RPM_BUILD_ROOT%{_datadir}/ssl/certs/Makefile
  169. install -m644 $RPM_SOURCE_DIR/make-dummy-cert $RPM_BUILD_ROOT%{_datadir}/ssl/certs/make-dummy-cert
  170. # Make sure we actually include the headers we built against.
  171. for header in $RPM_BUILD_ROOT%{_includedir}/openssl/* ; do
  172. if [ -f ${header} -a -f include/openssl/$(basename ${header}) ] ; then
  173. install -m644 include/openssl/`basename ${header}` ${header}
  174. fi
  175. done
  176. # Rename man pages so that they don't conflict with system man pages. We used
  177. # to change the file extensions, but that only prevents file conflicts. The
  178. # man viewer still can't select either of the two unless we physically change
  179. # the directory.
  180. for section in 1 2 3 4 5 6 7 8 ; do
  181. if test -d $RPM_BUILD_ROOT%{_mandir}/man${section} ; then
  182. mv $RPM_BUILD_ROOT%{_mandir}/man${section} \
  183. $RPM_BUILD_ROOT%{_mandir}/man${section}ssl
  184. fi
  185. done
  186. # Pick a CA script.
  187. pushd $RPM_BUILD_ROOT%{_datadir}/ssl/misc
  188. mv CA.sh CA
  189. popd
  190. # Install root CA stuffs.
  191. cat %{SOURCE3} > ca-bundle.crt
  192. install -m644 ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/certs/
  193. ln -s certs/ca-bundle.crt $RPM_BUILD_ROOT%{_datadir}/ssl/cert.pem
  194. # Fix libdir.
  195. #sed 's,^libdir=${exec_prefix}/lib,libdir=${exec_prefix}/%{_lib},g' \
  196. sed 's,^libdir=/usr/lib,libdir=%{_libdir},g' \
  197. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc > \
  198. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp && \
  199. cat $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp > \
  200. $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc && \
  201. rm -f $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/openssl.pc.tmp
  202. %clean
  203. [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
  204. %files
  205. %defattr(-,root,root)
  206. %doc FAQ LICENSE CHANGES NEWS INSTALL README
  207. %doc doc/README doc/c-indentation.el doc/openssl.txt
  208. %doc doc/openssl_button.html doc/openssl_button.gif
  209. %doc doc/ssleay.txt
  210. %dir %{_datadir}/ssl
  211. %{_datadir}/ssl/certs
  212. %{_datadir}/ssl/cert.pem
  213. %{_datadir}/ssl/misc/CA
  214. %{_datadir}/ssl/misc/c_*
  215. %{_datadir}/ssl/private
  216. %config(noreplace) %{_datadir}/ssl/openssl.cnf
  217. %attr(0755,root,root) %{_bindir}/openssl
  218. %attr(0755,root,root) /%{_lib}/*.so.*
  219. %attr(0755,root,root) %{_libdir}/openssl/engines/*.so
  220. %attr(0755,root,root) %dir %{_mandir}/man1*
  221. %attr(0644,root,root) %{_mandir}/man1*/*
  222. %attr(0755,root,root) %dir %{_mandir}/man5*
  223. %attr(0644,root,root) %{_mandir}/man5*/*
  224. %attr(0755,root,root) %dir %{_mandir}/man7*
  225. %attr(0644,root,root) %{_mandir}/man7*/*
  226. %files devel
  227. %defattr(-,root,root)
  228. %{_prefix}/include/openssl
  229. %exclude %{_libdir}/lib*.a
  230. %attr(0755,root,root) %{_libdir}/*.so
  231. %attr(0755,root,root) %dir %{_mandir}/man3*
  232. %attr(0644,root,root) %{_mandir}/man3*/*
  233. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  234. %files perl
  235. %defattr(-,root,root)
  236. %attr(0755,root,root) %{_bindir}/c_rehash
  237. %attr(0755,root,root) %dir %{_mandir}/man1*
  238. %attr(0644,root,root) %{_mandir}/man1*/*.pl*
  239. %{_datadir}/ssl/misc/*.pl
  240. ## to build compat32 for x86_64 architecture support
  241. %if %{build_compat32}
  242. %files -n compat32-%{name}
  243. %defattr(-,root,root)
  244. %attr(0755,root,root) /%{_lib}/*.so.*
  245. %files -n compat32-%{name}-devel
  246. %defattr(-,root,root)
  247. %exclude %{_libdir}/lib*.a
  248. %attr(0755,root,root) %{_libdir}/*.so
  249. %attr(0644,root,root) %{_libdir}/pkgconfig/*.pc
  250. %endif
  251. %post -p /sbin/ldconfig
  252. %postun -p /sbin/ldconfig
  253. %post -n compat32-%{name} -p /sbin/ldconfig
  254. %postun -n compat32-%{name} -p /sbin/ldconfig
  255. %changelog
  256. * Wed Nov 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8p-1
  257. - new upstream release with security fix (CVE-2010-3864)
  258. - drop patches included in new release
  259. - update patch4
  260. * Sun Jan 17 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-5
  261. - add patch12 for fix CVE-2009-3555 (renegotiation)
  262. * Fri Jan 15 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-4
  263. - add patch11 for fix CVE-2009-4355 (memory leak)
  264. * Tue Jun 23 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-3
  265. - add patch10 to fix CVE-2009-1377, 78, 79 (from fc11)
  266. * Mon Jun 22 2009 NAKAMURA Kenta <kenta@vinelinux.org> 0.9.8k-2
  267. - removed unnecessary %%if %{build_compat32} statements
  268. - removed lib*.a from devel package
  269. * Mon Mar 30 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8k-1
  270. - new upstream release with security fix (CVE-2000-0590,0591,0789)
  271. * Sun Jan 11 2009 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8j-1
  272. - new upstream release with security fix (CVE-2008-5077)
  273. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8i-1
  274. - new upstream release
  275. * Sat Jul 12 2008 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.8h-1
  276. - new upstream release
  277. - new versioning policy
  278. * Fri Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8g-0vl1
  279. - new upstream release
  280. - drop patch10,20 which is merged in upstream
  281. * Fri Sep 28 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl3
  282. - add security patch in advance for CVE-2007-5135
  283. http://www.securityfocus.com/archive/1/archive/1/480855/100/0/threaded
  284. http://marc.info/?l=openssl-cvs&m=119020417919619&w=2
  285. * Fri Aug 10 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.8e-0vl2
  286. - add security patch for CVE-2007-3108
  287. (http://openssl.org/news/patch-CVE-2007-3108.txt)
  288. * Tue May 15 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.8e-0vl1
  289. - new upstream release
  290. * Sat Dec 24 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl2
  291. - update (fix) openssl.pc <BTS:437>
  292. * Fri Sep 29 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7l-0vl1
  293. - new upstream release (with security fix)
  294. * Mon Sep 11 2006 Satosh IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.9.7k-0vl1
  295. - new upstream release
  296. - add patch2 to use RPM_OPT macro
  297. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl3
  298. - moved macros _lib to /usr/lib/rpm/rpmrc or macros files
  299. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.9.7i-0vl2
  300. - added compat32-* packages for x86_64 architecture support
  301. - added openssl-0.9.7i.Configure-compat32.patch
  302. - changed '/lib' to '/%{_lib}'
  303. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7i-0vl1
  304. - new upstream release
  305. * Mon Jan 31 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.7d-0vl4
  306. - rebuild on VineSeed
  307. * Sun Jan 09 2005 IKEDA Katsumi <ikeda@webmasters.gr.jp> 0.9.7d-0vl3.1
  308. - added a security patch from Gentoo.
  309. - Patch1: openssl-0.9.7c-tempfile.patch
  310. * Sun Mar 28 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.9.7d-0vl3
  311. - sslarch for ppc was missing... added.
  312. * Fri Mar 26 2004 Tomoya TAKA <taka@vinelinux.org> 0.9.7d-0vl2
  313. - use sslarch=linux-alpha-gcc instead of alpha-gcc
  314. * Mon Mar 22 2004 Satoshi MACHINO <machino@vinelinux.org> 0.9.7d-0vl1
  315. - new upstream version
  316. - clean up of spec file
  317. -- removed old patches
  318. * Sat Mar 20 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6m-0vl1
  319. - new upstream release
  320. - SECURITY fix.
  321. - http://www.openssl.org/news/secadv_20040317.txt
  322. * Wed Oct 1 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6k-0vl1
  323. - new upstream release
  324. - [Security fix]
  325. - Vulnerabilities in ASN.1 parsing
  326. http://www.openssl.org/news/secadv_20030930.txt
  327. - see %{_docdir}/%{name}-%{version}/CHANGES for other changes
  328. * Wed Jun 04 2003 HOTTA Michihide <hotta@net-newbie.com> 0.9.6j-0vl2
  329. - add openssl.pc for pkgconfig
  330. * Fri Mar 11 2003 Satoshi MACHINO <machino@vinelinux.org> 0.9.6j-0vl1
  331. - New upstream version
  332. - dropped patch10, 11
  333. -- merged upstream version
  334. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl1
  335. - rebuild for VineSeed
  336. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26.1
  337. - [Security Fix]
  338. - Timing-based attacks on RSA keys
  339. http://www.openssl.org/news/secadv_20030317.txt
  340. - Klima-Pokorny0Rosa attack on RSA in SSL/TLS
  341. http://www.openssl.org/news/secadv_20030317.txt
  342. * Sun Feb 23 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6i-0vl0.26
  343. - new upstream release 0.9.6i
  344. - [Security Fix]
  345. - build for Vine Linux 2.6 errata
  346. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6h-0vl1
  347. - new upstream release 0.9.6h
  348. * Mon Nov 18 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6g-0vl1
  349. - new upstream release 0.9.6g
  350. * Mon Oct 28 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl6
  351. - SECURITY: CAN-2002-0659 fixed
  352. - added Patch101 from RedHat 7.2 updates 0.9.6b-28
  353. * Fri Aug 02 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-28
  354. - update asn patch to fix accidental reversal of a logic check
  355. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-27
  356. - update asn patch to reduce chance that compiler optimization will remove
  357. one of the added tests
  358. * Thu Aug 01 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-26
  359. - rebuild
  360. * Tue Jul 30 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-25
  361. - add patch to fix ASN.1 vulnerabilities
  362. * Wed Jul 31 2002 IWAI Masaharu <iwai@alib.jp> 0.9.6b-1vl5
  363. - rename spec file name
  364. - SECURITY: CA-2002-23 fixed
  365. - added Patch100 from RedHat 7.2 updates 0.9.6b-24
  366. * Thu Jul 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.6b-24
  367. - add backport of Ben Laurie's patches for OpenSSL 0.9.6d
  368. * Mon Sep 10 2001 Satoshi MACHINO <machino@vinelinux.org> 0.9.6b-1vl4
  369. - added ${PATH} in LD_LIBRARY_PATH
  370. - added install -m 755 *.so.* $RPM_BUILD_ROOT%{_libdir} in %install
  371. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl3
  372. - remove --no-<cipher>
  373. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl2
  374. - add Patch10 for mipsel shared ( Configure )
  375. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.6b-1vl1
  376. - build for Vine Linux
  377. - use openssl-engine-0.9.6b.tar.gz
  378. * Wed Jul 11 2001 Nalin Dahyabhai <nalin@redhat.com>
  379. - update to 0.9.6b
  380. * Thu Jul 5 2001 Nalin Dahyabhai <nalin@redhat.com>
  381. - move .so symlinks back to %%{_libdir}
  382. * Tue Jul 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  383. - move shared libraries to /lib (#38410)
  384. * Mon Jun 25 2001 Nalin Dahyabhai <nalin@redhat.com>
  385. - switch to engine code base
  386. * Mon Jun 18 2001 Nalin Dahyabhai <nalin@redhat.com>
  387. - add a script for creating dummy certificates
  388. - move man pages from %%{_mandir}/man?/foo.?ssl to %%{_mandir}/man?ssl/foo.?
  389. * Thu Jun 07 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  390. - add s390x support
  391. * Fri Jun 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  392. - change two memcpy() calls to memmove()
  393. - don't define L_ENDIAN on alpha
  394. * Tue May 15 2001 Nalin Dahyabhai <nalin@redhat.com>
  395. - make subpackages depend on the main package
  396. * Tue May 1 2001 Nalin Dahyabhai <nalin@redhat.com>
  397. - adjust the hobble script to not disturb symlinks in include/ (fix from
  398. Joe Orton)
  399. * Fri Apr 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  400. - drop the m2crypo patch we weren't using
  401. * Tue Apr 24 2001 Nalin Dahyabhai <nalin@redhat.com>
  402. - configure using "shared" as well
  403. * Sun Apr 8 2001 Nalin Dahyabhai <nalin@redhat.com>
  404. - update to 0.9.6a
  405. - use the build-shared target to build shared libraries
  406. - bump the soversion to 2 because we're no longer compatible with
  407. our 0.9.5a packages or our 0.9.6 packages
  408. - drop the patch for making rsatest a no-op when rsa null support is used
  409. - put all man pages into <section>ssl instead of <section>
  410. - break the m2crypto modules into a separate package
  411. * Tue Mar 13 2001 Nalin Dahyabhai <nalin@redhat.com>
  412. - use BN_LLONG on s390
  413. * Mon Mar 12 2001 Nalin Dahyabhai <nalin@redhat.com>
  414. - fix the s390 changes for 0.9.6 (isn't supposed to be marked as 64-bit)
  415. * Sat Mar 3 2001 Nalin Dahyabhai <nalin@redhat.com>
  416. - move c_rehash to the perl subpackage, because it's a perl script now
  417. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  418. - update to 0.9.6
  419. - enable MD2
  420. - use the libcrypto.so and libssl.so targets to build shared libs with
  421. - bump the soversion to 1 because we're no longer compatible with any of
  422. the various 0.9.5a packages circulating around, which provide lib*.so.0
  423. * Wed Feb 28 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  424. - change hobble-openssl for disabling MD2 again
  425. * Tue Feb 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  426. - re-disable MD2 -- the EVP_MD_CTX structure would grow from 100 to 152
  427. bytes or so, causing EVP_DigestInit() to zero out stack variables in
  428. apps built against a version of the library without it
  429. * Mon Feb 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  430. - disable some inline assembly, which on x86 is Pentium-specific
  431. - re-enable MD2 (see http://www.ietf.org/ietf/IPR/RSA-MD-all)
  432. * Thu Feb 08 2001 Florian La Roche <Florian.LaRoche@redhat.de>
  433. - fix s390 patch
  434. * Fri Dec 8 2000 Than Ngo <than@redhat.com>
  435. - added support s390
  436. * Mon Nov 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  437. - remove -Wa,* and -m* compiler flags from the default Configure file (#20656)
  438. - add the CA.pl man page to the perl subpackage
  439. * Thu Nov 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  440. - always build with -mcpu=ev5 on alpha
  441. * Tue Oct 31 2000 Nalin Dahyabhai <nalin@redhat.com>
  442. - add a symlink from cert.pem to ca-bundle.crt
  443. * Wed Oct 25 2000 Nalin Dahyabhai <nalin@redhat.com>
  444. - add a ca-bundle file for packages like Samba to reference for CA certificates
  445. * Tue Oct 24 2000 Nalin Dahyabhai <nalin@redhat.com>
  446. - remove libcrypto's crypt(), which doesn't handle md5crypt (#19295)
  447. * Mon Oct 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  448. - add unzip as a buildprereq (#17662)
  449. - update m2crypto to 0.05-snap4
  450. * Tue Sep 26 2000 Bill Nottingham <notting@redhat.com>
  451. - fix some issues in building when it's not installed
  452. * Wed Sep 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  453. - make sure the headers we include are the ones we built with (aaaaarrgh!)
  454. * Fri Sep 1 2000 Nalin Dahyabhai <nalin@redhat.com>
  455. - add Richard Henderson's patch for BN on ia64
  456. - clean up the changelog
  457. * Tue Aug 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  458. - fix the building of python modules without openssl-devel already installed
  459. * Wed Aug 23 2000 Nalin Dahyabhai <nalin@redhat.com>
  460. - byte-compile python extensions without the build-root
  461. - adjust the makefile to not remove temporary files (like .key files when
  462. building .csr files) by marking them as .PRECIOUS
  463. * Sat Aug 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  464. - break out python extensions into a subpackage
  465. * Mon Jul 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  466. - tweak the makefile some more
  467. * Tue Jul 11 2000 Nalin Dahyabhai <nalin@redhat.com>
  468. - disable MD2 support
  469. * Thu Jul 6 2000 Nalin Dahyabhai <nalin@redhat.com>
  470. - disable MDC2 support
  471. * Sun Jul 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  472. - tweak the disabling of RC5, IDEA support
  473. - tweak the makefile
  474. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  475. - strip binaries and libraries
  476. - rework certificate makefile to have the right parts for Apache
  477. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  478. - use %%{_perl} instead of /usr/bin/perl
  479. - disable alpha until it passes its own test suite
  480. * Fri Jun 9 2000 Nalin Dahyabhai <nalin@redhat.com>
  481. - move the passwd.1 man page out of the passwd package's way
  482. * Fri Jun 2 2000 Nalin Dahyabhai <nalin@redhat.com>
  483. - update to 0.9.5a, modified for U.S.
  484. - add perl as a build-time requirement
  485. - move certificate makefile to another package
  486. - disable RC5, IDEA, RSA support
  487. - remove optimizations for now
  488. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  489. - Bero told me to move the Makefile into this package
  490. * Wed Mar 1 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  491. - add lib*.so symlinks to link dynamically against shared libs
  492. * Tue Feb 29 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  493. - update to 0.9.5
  494. - run ldconfig directly in post/postun
  495. - add FAQ
  496. * Sat Dec 18 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  497. - Fix build on non-x86 platforms
  498. * Fri Nov 12 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  499. - move /usr/share/ssl/* from -devel to main package
  500. * Tue Oct 26 1999 Bernhard Rosenkrdnzer <bero@redhat.de>
  501. - inital packaging
  502. - changes from base:
  503. - Move /usr/local/ssl to /usr/share/ssl for FHS compliance
  504. - handle RPM_OPT_FLAGS