stunnel-vl.spec 18 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606
  1. %bcond_with systemd
  2. %bcond_with crypto_policies
  3. Summary: An SSL-encrypting socket wrapper
  4. Name: stunnel
  5. Version: 5.72
  6. Release: 2%{?_dist_release}%{?with_systemd:.systemd}
  7. Group: internet
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: iwaim
  11. License: GPLv2
  12. URL: https://www.stunnel.org/
  13. Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
  14. Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
  15. Source2: Certificate-Creation
  16. Source3: sfinger.xinetd
  17. Source4: stunnel-sfinger.conf
  18. Source5: pop3-redirect.xinetd
  19. Source6: stunnel-pop3s-client.conf
  20. Source7: stunnel@.service
  21. Source10: stunnel-tmpfiles.conf
  22. Source100: stunnel.init
  23. Patch0: stunnel-5.50-authpriv.patch
  24. Patch1: stunnel-5.61-systemd-service.patch
  25. Patch3: stunnel-5.69-system-ciphers.patch
  26. Patch5: stunnel-5.72-default-tls-version.patch
  27. Patch6: stunnel-5.56-curves-doc-update.patch
  28. BuildRoot: %{_tmppath}/stunnel-root
  29. # util-linux is needed for rename
  30. BuildRequires: openssl-devel
  31. BuildRequires: pkgconfig
  32. BuildRequires: util-linux
  33. %if %{with systemd}
  34. %{?systemd_requires}
  35. %else
  36. Requires(post): chkconfig
  37. Requires(preun): chkconfig /sbin/service
  38. Requires(postun): /sbin/service
  39. %endif
  40. %global pidfile %{_rundir}/stunnel/stunnel.pid
  41. # Do not generate provides for private libraries
  42. %global __provides_exclude_from ^%{_libdir}/stunnel/.*$
  43. %description
  44. Stunnel is a socket wrapper which can provide SSL (Secure Sockets
  45. Layer) support to ordinary applications. For example, it can be used
  46. in conjunction with imapd to create an SSL secure IMAP server.
  47. %debug_package
  48. %prep
  49. %setup -q
  50. %patch0 -p1
  51. %patch1 -p1
  52. %if %{with crypto_policies}
  53. %patch3 -p1
  54. %endif
  55. %patch5 -p1
  56. %patch6 -p1
  57. # Fix the stack protector flag
  58. sed -i 's/-fstack-protector/-fstack-protector-strong/' configure
  59. # modify systemd service unit
  60. sed -i '/Type=forking/a \\PrivateTmp=true' tools/stunnel.service.in
  61. %build
  62. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  63. if pkg-config openssl ; then
  64. CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
  65. LDFLAGS="$LDFLAGS `pkg-config --libs-only-L openssl`"; export LDFLAGS
  66. fi
  67. %configure --disable-fips --enable-ipv6 --with-ssl=%{_prefix} \
  68. --with-bashcompdir=%{_datadir}/bash-completion/completions \
  69. CPPFLAGS="$CPPFLAGS -UPIDFILE -DPIDFILE='\"%{pidfile}\"'"
  70. make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
  71. %install
  72. rm -rf $RPM_BUILD_ROOT
  73. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
  74. touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
  75. make install DESTDIR=$RPM_BUILD_ROOT
  76. # Move the translated man pages to the right subdirectories, and strip off the
  77. # language suffixes.
  78. for lang in pl ; do
  79. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
  80. mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
  81. rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
  82. done
  83. mkdir -p srpm-docs
  84. cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
  85. %if %{with systemd}
  86. mkdir -p %{buildroot}%{_unitdir}
  87. cp %{buildroot}%{_datadir}/doc/stunnel/examples/%{name}.service %{buildroot}%{_unitdir}/%{name}.service
  88. cp %{SOURCE7} %{buildroot}%{_unitdir}/%{name}@.service
  89. install -Dpm644 %{SOURCE10} %{buildroot}%{_tmpfilesdir}/%{name}.conf
  90. %else
  91. install -d -m755 %{buildroot}%{_initdir}
  92. install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
  93. install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
  94. cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
  95. ENABLED=0
  96. EOF
  97. %endif
  98. %clean
  99. rm -rf $RPM_BUILD_ROOT
  100. %if %{without systemd}
  101. %pre
  102. if /sbin/service stunnel status >/dev/null; then
  103. touch /var/lib/rpm-state/stunnel
  104. /sbin/service stunnel stop
  105. fi
  106. %endif
  107. %post
  108. if [ -e /etc/stunnel/stunnel.conf ]; then
  109. sed -i -e 's|/var/run/|/run/stunnel/|' /etc/stunnel/stunnel.conf
  110. fi
  111. %if %{with systemd}
  112. %systemd_post %{name}.service
  113. %else
  114. /sbin/chkconfig --add stunnel
  115. %endif
  116. %preun
  117. %if %{with systemd}
  118. %systemd_preun %{name}.service
  119. %else
  120. if [ $1 -eq 0 -o -x /usr/bin/systemctl ]; then
  121. /sbin/service stunnel stop /dev/null 2>/dev/null ||:
  122. /sbin/chkconfig --del stunnel
  123. fi
  124. %endif
  125. %if %{with systemd}
  126. %postun
  127. %systemd_postun_with_restart %{name}.service
  128. %endif
  129. %if %{without systemd}
  130. %posttrans
  131. if [ -e /var/lib/rpm-state/stunnel -a ! -x /usr/bin/systemctl ]; then
  132. rm -f /var/lib/rpm-state/stunnel
  133. /sbin/service stunnel start
  134. fi
  135. %endif
  136. %files
  137. %defattr(-,root,root)
  138. %doc AUTHORS.md BUGS.md CREDITS.md PORTS.md README.md TODO.md
  139. %doc tools/stunnel.conf-sample
  140. %doc srpm-docs/*
  141. %license COPY*
  142. %lang(en) %doc doc/en/*
  143. %lang(po) %doc doc/pl/*
  144. %{_bindir}/stunnel
  145. %exclude %{_bindir}/stunnel3
  146. %exclude %{_datadir}/doc/stunnel
  147. %{_libdir}/stunnel
  148. %exclude %{_libdir}/stunnel/libstunnel.la
  149. %{_mandir}/man8/stunnel.8*
  150. %lang(pl) %{_mandir}/pl/man8/stunnel.8*
  151. %dir %{_sysconfdir}/%{name}
  152. %dir %{_sysconfdir}/%{name}/conf.d
  153. %exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
  154. %exclude %{_sysconfdir}/stunnel/stunnel.pem
  155. %if %{with systemd}
  156. %{_unitdir}/%{name}*.service
  157. %{_tmpfilesdir}/%{name}.conf
  158. %else
  159. %{_initdir}/stunnel
  160. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  161. %endif
  162. %dir %{_datadir}/bash-completion/completions
  163. %dir %{_datadir}/bash-completion
  164. %{_datadir}/bash-completion/completions/*
  165. %changelog
  166. * Thu Aug 15 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.72-2
  167. - added tmpfiles configuration.
  168. * Mon Jul 29 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.72-1
  169. - new upstream release.
  170. * Mon Oct 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.60-1
  171. - new upstream release.
  172. - built with openssl-3.0.0.
  173. - imported Patch100 from openmandriva.
  174. * Thu May 06 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.59-1
  175. - new upstream release.
  176. - diabled crypto-policies (not implemented for Vine Linux).
  177. * Sun Feb 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.58-1
  178. - new upstream release.
  179. - uodated patches.
  180. * Sat Apr 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.56-1
  181. - new upstream release.
  182. - replaced all patches.
  183. - added systemd support (disabled as default).
  184. * Sat Dec 01 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.49-1
  185. - new upstream release.
  186. - updated Patch0,1.
  187. * Mon Jun 05 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 5.32-2
  188. - rebuid with OpenSSL 1.0.2k
  189. * Tue May 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.32-1
  190. - new upstream release.
  191. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.31-1
  192. - new upstream release.
  193. * Fri Nov 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
  194. - new upstream release.
  195. - fixed dates in %%changelog.
  196. - updated all patches.
  197. * Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
  198. - initial build for Vine Linux
  199. *Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
  200. - 884183: support for full relro.
  201. *Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
  202. - New upstream realease 4.54
  203. - Updated local patches
  204. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
  205. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  206. * Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
  207. - New upstream realease 4.53
  208. - Updated local patches
  209. * Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
  210. - New upstream realease 4.52
  211. - Updated local patches
  212. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
  213. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  214. * Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
  215. - New upstream realease 4.50
  216. - Updated local patches
  217. * Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
  218. - New upstream realease 4.44
  219. - Updated local patches
  220. * Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
  221. - New upstream realease 4.42
  222. - Updated local patches
  223. - Fixes #732069
  224. * Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
  225. - New upstream realease 4.41
  226. - Updated local patches to match the new release
  227. * Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
  228. - New upstream realease 4.37
  229. - Updated local patches to match the new release
  230. * Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
  231. - New upstream realease 4.35
  232. - Updated authpriv and sample patches to match the new release
  233. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
  234. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  235. * Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
  236. - New upstream realease 4.34
  237. - Updated authpriv and sample patches to match the new release
  238. * Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
  239. - New upstream realease 4.33
  240. - Updated authpriv and sample patches to match the new release
  241. - Addresses bz 580117 (inted mode support issue)
  242. * Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
  243. - New upstream realease 4.32
  244. - Updated authpriv and sample patches to match the new release
  245. * Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
  246. - New upstream realease 4.31
  247. - Updated authpriv and sample patches to match the new release
  248. * Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
  249. - New upstream realease 4.30
  250. - Updated authpriv and sample patches for the new release
  251. * Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
  252. - New upstream realease 4.29
  253. - Updated authpriv and sample patches for the new release
  254. - Modified spec file to include dist tag
  255. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
  256. - rebuilt with new openssl
  257. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
  258. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  259. * Sun May 3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
  260. - Fix the previous patch.
  261. * Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
  262. - Avoid aliasing undefined by ISO C
  263. * Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
  264. - Update to stunnel-4.27.
  265. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
  266. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  267. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
  268. - disable openssl upstream fips mode
  269. * Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
  270. - Update to stunnel-4.26.
  271. * Sun Jun 8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
  272. - Use a clearer error message if the service name is unknown in "accept"
  273. Resolves: #450344
  274. * Mon Jun 2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
  275. - Update to stunnel-4.25
  276. * Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
  277. - Drop stunnel3
  278. Resolves: #442842
  279. * Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
  280. - Update to stunnel-4.24
  281. * Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
  282. - Update to stunnel-4.22
  283. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
  284. - Autorebuild for GCC 4.3
  285. * Tue Dec 4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
  286. - Rebuild with openssl-0.9.8g
  287. * Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
  288. - Revert the port to NSS, wait for NSS-based stunnel 5.x instead
  289. Resolves: #301971
  290. - Mark localized man pages with %%lang (patch by Ville Skyttä)
  291. Resolves: #322281
  292. * Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
  293. - Port to NSS
  294. * Mon Dec 4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
  295. - Update BuildRequires for the separate tcp_wrappers-devel package
  296. * Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
  297. - Update to stunnel-4.20
  298. * Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
  299. - Update to stunnel-4.19
  300. * Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
  301. - Update to stunnel-4.18
  302. - Remove unused stunnel.cnf from the src.rpm
  303. - Fix some rpmlint warnings
  304. * Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
  305. - rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
  306. (#203001)
  307. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
  308. - rebuild
  309. * Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
  310. - Update to stunnel-4.15
  311. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
  312. - bump again for double-long bug on ppc(64)
  313. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
  314. - rebuilt for new gcc4.1 snapshot and glibc changes
  315. * Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
  316. - Use pthread threading to fix crash on x86_64 (#179236)
  317. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  318. - rebuilt
  319. * Wed Nov 9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
  320. - Rebuild with newer openssl
  321. * Thu Nov 3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
  322. - Update to stunnel-4.14
  323. - Override changed default pid file location, keep it in %%{_localstatedir}/run
  324. * Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
  325. - Update to stunnel-4.13
  326. * Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
  327. - Update to stunnel-4.12
  328. * Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
  329. - Enable IPv6 (#169050, patch by Peter Bieringer)
  330. - Don't ship another copy of man pages in HTML
  331. * Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
  332. - Update to stunnel-4.11
  333. - Fix int/size_t mismatches in stack_info ()
  334. - Update Certificate-Creation for /etc/pki
  335. * Wed Jun 1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
  336. - Fix inetd mode
  337. - Remove unnecessary Requires: and BuildRequires:
  338. - Clean up the spec file
  339. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
  340. - update to 4.10
  341. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
  342. - add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
  343. coreutils (#133961)
  344. * Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
  345. - update to 4.08
  346. - build stunnel as a PIE binary
  347. * Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
  348. - Convert man pages to UTF-8
  349. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  350. - rebuilt
  351. * Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
  352. - move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
  353. * Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
  354. - update to 4.05
  355. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  356. - rebuilt
  357. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  358. - rebuilt
  359. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
  360. - Fix libtool
  361. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  362. - rebuilt
  363. * Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
  364. - fix xinetd configuration samples
  365. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
  366. - rebuild
  367. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  368. - rebuilt
  369. * Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
  370. - update to 4.04
  371. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
  372. - use pkgconfig for information about openssl, if available
  373. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  374. - update to 4.03
  375. * Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
  376. - update to 4.02
  377. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
  378. - don't create a dummy cert
  379. * Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
  380. - update to 4.00
  381. - remove textutils and fileutils as buildreqs, add automake/autoconf
  382. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  383. - automated rebuild
  384. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  385. - automated rebuild
  386. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
  387. - rebuild in new environment
  388. * Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
  389. - update to 3.22, correcting a format-string vulnerability
  390. * Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
  391. - update to 3.21a
  392. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
  393. - log using LOG_AUTHPRIV facility by default (#47289)
  394. - make permissions on stunnel binary 0755
  395. - implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
  396. * Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
  397. - update to 3.19 to avoid problems with stunnel being multithreaded, but
  398. tcp wrappers not being thrad-safe
  399. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  400. - update to 3.17
  401. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  402. - update to 3.16
  403. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  404. - update to 3.15
  405. - enable tcp-wrappers support
  406. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  407. - remove explicit requirement on openssl (specific version isn't enough,
  408. we have to depend on shared library version anyway)
  409. * Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  410. - update to 3.14
  411. * Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
  412. - depend on make (#33148)
  413. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  414. - rebuild in new environment
  415. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  416. - update to 3.13 to get pthread, OOB, 64-bit fixes
  417. - don't need sdf any more
  418. * Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  419. - pull in sdf to build the man page (#22892)
  420. * Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  421. - update to 3.11
  422. - chuck the SIGHUP patch (went upstream)
  423. - chuck parts of the 64-bit clean patch (went upstream)
  424. * Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  425. - update to 3.10
  426. - more 64-bit clean changes, hopefully the last bunch
  427. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  428. - change piddir from the default /var/stunnel to /var/run
  429. - clean out pid file on SIGHUP
  430. * Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
  431. - update to 3.9 to get a security fix
  432. * Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
  433. - change all unsigned longs to u_int32_t when dealing with network
  434. addresses
  435. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  436. - make stunnel.pem also be (missingok)
  437. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  438. - move to Applications/Internet group
  439. - clean up %%post script
  440. - make stunnel.pem %%ghost %%config(noreplace)
  441. - provide a sample file for use with xinetd
  442. * Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  443. - FHS compliance fixes
  444. - modify defaults
  445. * Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  446. - update to 3.8
  447. - do not create certificate if one already exists
  448. * Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  449. - update to 3.7
  450. - add patch to find /usr/share/ssl
  451. - change some perms
  452. * Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  453. - Modify spec file to match Red Hat standards
  454. * Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
  455. - Updated to 3.4a
  456. - Patched for OpenSSL 0.9.4
  457. - Cleaned up files section
  458. * Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
  459. - Updated to 3.3
  460. * Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
  461. - Initial RPMification