gpac-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363
  1. #% global svndate 20111217
  2. %define with_static 1
  3. Name: gpac
  4. Summary: MPEG-4 multimedia framework
  5. Version: 0.5.0
  6. Release: 3%{?svndate:.svn%svndate}%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://gpac.sourceforge.net/
  10. Source0: http://downloads.sourceforge.net/gpac/gpac-%{version}.tar.gz
  11. #Source0: gpac-%{svndate}.tar.bz2
  12. #Source9: gpac-snapshot-vine.sh
  13. Patch1: gpac-0.5.0-libdir.patch
  14. Patch2: gpac-0.4.6-amr.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. Obsoletes: %{name} < %{version}, %{name}-libs < %{version}
  17. Obsoletes: %{name}-devel < %{version}
  18. Obsoletes: %{name}-devel-static < %{version}
  19. Requires: %{name}-libs = %{version}-%{release}
  20. BuildRequires: ImageMagick
  21. BuildRequires: SDL-devel
  22. BuildRequires: librsvg2-devel >= 2.5.0
  23. BuildRequires: libGLU-devel
  24. BuildRequires: freeglut-devel
  25. BuildRequires: freetype2-devel >= 2.1.4
  26. BuildRequires: libjpeg-devel
  27. BuildRequires: libpng-devel >= 1.2.5
  28. BuildRequires: libxml2-devel
  29. BuildRequires: openssl-devel
  30. #BuildRequires: openjpeg-devel
  31. BuildRequires: pulseaudio-libs-devel
  32. BuildRequires: zlib-devel
  33. BuildRequires: libogg-devel libvorbis-devel libtheora-devel
  34. BuildRequires: libXt-devel
  35. BuildRequires: libXpm-devel
  36. BuildRequires: libXv-devel
  37. #BuildRequires: wxGTK-devel
  38. BuildRequires: xmlrpc-epi-devel
  39. %{?_with_mozilla:BuildRequires: gecko-devel}
  40. #BuildRequires: doxygen
  41. BuildRequires: desktop-file-utils
  42. %{?_with_amr:BuildRequires: amrnb-devel amrwb-devel}
  43. # *-devel packages provided by other self-build-* should only be listed
  44. # in self-build-%{name}.spec as PreReq.
  45. #BuildRequires: a52dec-devel
  46. #BuildRequires: faad2-devel
  47. #BuildRequires: libmad-devel
  48. #BuildRequires: xvidcore-devel >= 1.0.0
  49. ##BuildRequires: ffmpeg-devel
  50. %description
  51. GPAC is a multimedia framework based on the MPEG-4 Systems standard developed
  52. from scratch in ANSI C. The original development goal is to provide a clean,
  53. small and flexible alternative to the MPEG-4 Systems reference software.
  54. GPAC features the integration of recent multimedia standards (SVG/SMIL, VRML,
  55. X3D, SWF, 3GPP(2) tools and more) into a single framework. GPAC also features
  56. MPEG-4 Systems encoders/multiplexers, publishing tools for content distribution
  57. for MP4 and 3GPP(2) files and many tools for scene descriptions
  58. (MPEG4 <-> VRML <-> X3D converters, SWF -> MPEG-4, etc).
  59. %package libs
  60. Summary: Library for %{name}
  61. Group: System Environment/Libraries
  62. %description libs
  63. The %{name}-libs package contains library for %{name}.
  64. %package devel
  65. Summary: Development libraries and files for %{name}
  66. Group: Development/Libraries
  67. Requires: %{name}-libs = %{version}-%{release}
  68. %description devel
  69. Development libraries and files for gpac.
  70. %if %{with_static}
  71. %package devel-static
  72. Summary: Development libraries and files for %{name}
  73. Group: Development/Libraries
  74. Requires: %{name}-devel = %{version}-%{release}
  75. %description devel-static
  76. Static library for gpac.
  77. %endif
  78. %prep
  79. %setup -q -n gpac
  80. ## remove extra_libs directory
  81. %__rm -rf extra_libs
  82. %patch1 -p1 -b .libdir
  83. %patch2 -p1 -b .amr
  84. ## kwizart - enable dynamic mode - hardcoded with patch2
  85. # define SONAME number from the first number of gpac version.
  86. #define soname libgpac.so.0
  87. #sed -i.soname -e 's|EXTRALIBS+=$(GPAC_SH_FLAGS)|EXTRALIBS+=$(GPAC_SH_FLAGS)\nLDFLAGS+="-Wl,-soname,%{soname}"|' src/Makefile
  88. # Fix encoding warnings
  89. %__cp -p Changelog Changelog.origine
  90. iconv -f ISO-8859-1 -t UTF8 Changelog.origine > Changelog
  91. touch -r Changelog.origine Changelog
  92. %__rm -rf Changelog.origine
  93. %__cp -p doc/ipmpx_syntax.bt doc/ipmpx_syntax.bt.origine
  94. iconv -f ISO-8859-1 -t UTF8 doc/ipmpx_syntax.bt.origine > doc/ipmpx_syntax.bt
  95. touch -r doc/ipmpx_syntax.bt.origine doc/ipmpx_syntax.bt
  96. %__rm -rf doc/ipmpx_syntax.bt.origine
  97. # executable ./configure
  98. chmod +x configure
  99. %build
  100. %configure \
  101. --X11-path=%{_prefix} \
  102. --libdir=%{_lib} \
  103. %{?_with_mozilla:--mozdir=%{_libdir}/mozilla/plugins} \
  104. --enable-pic \
  105. --disable-static \
  106. --disable-wx \
  107. --extra-cflags="$RPM_OPT_FLAGS -D_FILE_OFFSET_BITS=64 -D_LARGE_FILES -D_LARGEFILE_SOURCE=1 -D_GNU_SOURCE=1" \
  108. --disable-oss-audio \
  109. %{?_with_amr:--enable-amr} \
  110. --use-js=no \
  111. ;
  112. #Avoid mess with setup.h
  113. cp -p config.h include/gpac
  114. # Parallele build will fail
  115. %__make all OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
  116. #{?_smp_mflags}
  117. %__make sggen OPTFLAGS="$RPM_OPT_FLAGS -fPIC -DPIC"
  118. #{?_smp_mflags}
  119. # ## kwizart - build doxygen doc for devel
  120. # pushd doc
  121. # doxygen
  122. # popd
  123. %install
  124. %__rm -rf $RPM_BUILD_ROOT
  125. %__make DESTDIR=$RPM_BUILD_ROOT install install-lib
  126. #Install generated sggen binaries
  127. #MPEG4 SVG X3D
  128. for b in MPEG4 X3D; do
  129. pushd applications/generators/${b}
  130. %__install -pm 0755 ${b}Gen $RPM_BUILD_ROOT%{_bindir} || exit 1
  131. popd
  132. done
  133. # #Fix doxygen timestamp
  134. # touch -r Changelog doc/html/*
  135. #config.h like but not only
  136. #Usual multilib bug https://bugzilla.rpmfusion.org/show_bug.cgi?id=270
  137. %__sed -i -e '/GPAC_CONFIGURATION/d' $RPM_BUILD_ROOT%{_includedir}/gpac/configuration.h || exit 1
  138. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/*.h || exit 1
  139. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/internal/*.h || exit 1
  140. touch -r Changelog $RPM_BUILD_ROOT%{_includedir}/gpac/modules/*.h || exit 1
  141. %__rm $RPM_BUILD_ROOT%{_includedir}/gpac/config.h || exit 1
  142. %clean
  143. %__rm -rf $RPM_BUILD_ROOT
  144. %post libs -p /sbin/ldconfig
  145. %postun libs -p /sbin/ldconfig
  146. %files
  147. %defattr(-,root,root,-)
  148. %doc AUTHORS BUGS Changelog COPYING README TODO
  149. %{_bindir}/MP4*
  150. %{_bindir}/*Gen
  151. %{_datadir}/gpac/
  152. %{_mandir}/man1/*.1.*
  153. %files libs
  154. %defattr(-,root,root)
  155. %{_libdir}/libgpac.so.*
  156. %{_libdir}/gpac/
  157. %files devel
  158. %doc doc/CODING_STYLE doc/ipmpx_syntax.bt
  159. %defattr(-,root,root)
  160. %{_includedir}/gpac/
  161. %{_libdir}/libgpac.so
  162. %if %{with_static}
  163. %files devel-static
  164. %defattr(-,root,root,-)
  165. %{_libdir}/libgpac_static.a
  166. %else
  167. %exclude %{_libdir}/libgpac_static.a
  168. %endif
  169. %changelog
  170. * Wed Oct 2 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-3
  171. - added Obsoletes: %{name} < %{version} and so on.
  172. * Sun Sep 29 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-2
  173. - rebuild
  174. * Sat Jan 19 2013 Munehiro Yamamoto <munepi@vinelinux.org> 0.5.0-1
  175. - new upstream release
  176. * Sat May 26 2012 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-2.svn20111217
  177. - rebuild
  178. * Sun Dec 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.6-1.svn20111217
  179. - update snapshot svn20111217
  180. - removed upstreamed/obsolated patches
  181. * Mon Apr 18 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-11
  182. - rebuilt with internal openjpeg
  183. - added --use-openjpeg=local in configure options
  184. - added --enable-pic in configure options
  185. * Sat Mar 26 2011 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-10
  186. - rebuild
  187. * Sat Jun 26 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-9
  188. - removed doxygen support
  189. * Sat Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-8
  190. - change release to sync with self-build-gpac
  191. * Thu Feb 18 2010 Munehiro Yamamoto <munepi@vinelinux.org> 0.4.5-7
  192. - rebuild
  193. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-6
  194. - added --use-js=no in configure
  195. - added devel-static subpackage
  196. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.7.4-5
  197. - change release to sync with self-build-gpac
  198. * Thu May 14 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-4
  199. - change release to sync with self-build-gpac
  200. * Thu Mar 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-3
  201. - applied gpac-0.4.5-ffmpeg.patch (RPM Fusion #454)
  202. - corrected default %%defattr
  203. * Thu Mar 12 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-2
  204. - dropped BuildRequires: ffmpeg-devel as self-build-ffmpeg
  205. - rebuilt with ffmpeg-devel by self-build-ffmpeg
  206. * Sun Mar 01 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.4.5-1
  207. - initial build based on RPM Fusion
  208. - without Osmo4 and its plugins for Mozilla browsers
  209. - added --disable-wx in configure options
  210. - included %%{_libdir}/libgpac_static.a in devel subpackage
  211. * Sun Dec 28 2008 kwizart < kwizart at gmail.com > - 0.4.5-3
  212. - Fix -devel doc timestamp which leads to multilib conflict
  213. ( RPM Fusion #270 )
  214. * Thu Dec 18 2008 kwizart < kwizart at gmail.com > - 0.4.5-2
  215. - Fix for ppc64
  216. * Wed Dec 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-1
  217. - Update to 0.4.5 (final)
  218. - Drop upstreamed patches - Rewrite some
  219. - Add More BR.
  220. - Conditionalize --with mozilla amr
  221. * Mon Sep 8 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.5.20080217cvs
  222. - Fix for Large File Support (was livna #2075 )
  223. * Mon Feb 25 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.3.20080217cvs
  224. - Enable devel-static
  225. - Conditionalize Osmo4 (buggy).
  226. - Clean the spec
  227. * Sun Feb 17 2008 kwizart < kwizart at gmail.com > - 0.4.5-0.2.20080217cvs
  228. - Update to 20080217.
  229. - Split libs.
  230. - Use the new amr nosrc scheme (need an end-users rebuilt to add support to it).
  231. - Add openjpeg-devel missing BR
  232. - Static patching instead of dyn patch when possible.
  233. - Disable %%{smp_mflags} (it tries to build the bin before the lib is ready)
  234. - Define soname as libgpac.so.0 (instead of libgpac.so.%%version )
  235. - Exclude static lib
  236. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.5-0.1.20080211cvs
  237. - Use %%{smp_mflags}
  238. - Oops, we're actually 0.4.5
  239. - Fix gpac so filenames
  240. - Only install nposmozilla when %%{with_firefox} is set
  241. * Mon Feb 11 2008 Stewart Adam < s.adam at diffingo.com > - 0.4.4-3.20080211cvs
  242. - Update to 20080211cvs
  243. - Disable osmozilla, doesn't build with xulrunner
  244. - Fix builds with gcc 4.3
  245. * Sat Dec 15 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-2
  246. - Rebuild for rawhide
  247. * Tue Oct 16 2007 Stewart Adam < s.adam at diffingo.com > - 0.4.4-1
  248. - Update to v4.4
  249. * Sat May 26 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070526
  250. - Update to cvs 20070526
  251. - Enable conditional build ( 3gpp firefox )
  252. * Wed Apr 11 2007 kwizart < kwizart at gmail.com > - 0.4.3-0.1cvs20070411
  253. - Update to cvs 20070411
  254. * Thu Dec 08 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061208.1.kwizart.fc6
  255. - Update to 20061208
  256. - Uses firefox-devel (since fc6!)
  257. - Drop tutorial
  258. - Use version-DEV-date with libgpac.so
  259. - Disabled osmozilla
  260. - Fix soname
  261. - Enabled gprof
  262. * Tue Oct 17 2006 kwizart < kwizart at gmail.com > - 0.4.3-cvs20061017.1_FC5
  263. - gpac snapshot.sh
  264. - Revert Patch osmozilla.cpp (v1.17 - build error from gpac/internal/terminal_dev.h)
  265. - TODO: - no-soname make option for libgpac.so
  266. - static lib in devel - needed ?
  267. - osmozilla - xpt link problem.
  268. - Osmo4: segmentation fault on exit.
  269. - MP4Client: segmentation fault on launch.
  270. - The program 'Osmo4' received an X Window System error:
  271. "The error was 'BadMatch (invalid parameter attributes)'.
  272. (Details: serial 37 error_code 8 request_code 42 minor_code 0)"
  273. - MP4Box -version display: GPAC version 0.4.3-DEV (try to display cvs )
  274. * Sat Oct 15 2006 kwizart < kwizart at gmail.com > - 0.4.2-rc2.1_FC5
  275. - Update to 0.4.2cvs20061017
  276. - Use DESTDIR=RPM_BUILD_ROOT in various Makefile.
  277. - Enable mozilla plugin: osmozilla.
  278. - Enable AMR_NB_FLOAT and AMR_WB_FLOAT / bundle AMR_NB_FIXED (but not used by default).
  279. - Provide documentation html in doc .
  280. - Provide tutorial from http://www.wildamerica.com/pages/Marty.html
  281. - Various corrections.
  282. * Fri Sep 01 2006 Anssi Hannula <anssi@zarb.org> 0.4.1-0.20060630.2plf2007.0
  283. - lib64 fixes
  284. * Fri Jan 30 2006 Austin Acton <austin@mandriva.org> 0.4.1-0.20060630.1plf2007.0
  285. - initial package