python-dns-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330
  1. Name: python-dns
  2. Version: 1.16.0
  3. Release: 1%{?_dist_release}
  4. Summary: DNS toolkit for Python
  5. Summary(ja): Python 用 DNS ツールキット
  6. Group: Development/Languages
  7. License: MIT
  8. URL: http://www.dnspython.org/
  9. Source0: http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz
  10. Source1: http://www.dnspython.org/kits/%{version}/dnspython-%{version}.tar.gz.asc
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  12. BuildArch: noarch
  13. BuildRequires: python-setuptools
  14. BuildRequires: python-devel
  15. BuildRequires: python-rpm-macros
  16. BuildRequires: python3-setuptools
  17. BuildRequires: python3-devel
  18. BuildRequires: python3-rpm-macros
  19. BuildRequires: python-crypto
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. %description
  23. dnspython is a DNS toolkit for Python. It supports almost all record
  24. types. It can be used for queries, zone transfers, and dynamic
  25. updates. It supports TSIG authenticated messages and EDNS0.
  26. dnspython provides both high and low level access to DNS. The high
  27. level classes perform queries for data of a given name, type, and
  28. class, and return an answer set. The low level classes allow direct
  29. manipulation of DNS zones, messages, names, and records.
  30. %package -n python3-dns
  31. Summary: DNS toolkit for Python 3
  32. %{?python_provide:%python_provide python3-dns}
  33. Requires: python3-crypto
  34. %description -n python3-dns
  35. dnspython3 is a DNS toolkit for Python 3. It supports almost all
  36. record types. It can be used for queries, zone transfers, and dynamic
  37. updates. It supports TSIG authenticated messages and EDNS0.
  38. dnspython3 provides both high and low level access to DNS. The high
  39. level classes perform queries for data of a given name, type, and
  40. class, and return an answer set. The low level classes allow direct
  41. manipulation of DNS zones, messages, names, and records.
  42. %prep
  43. %setup0 -q -n dnspython-%{version}
  44. # strip executable permissions so that we don't pick up dependencies
  45. # from documentation
  46. find examples -type f | xargs chmod a-x
  47. %build
  48. %py_build
  49. %py3_build
  50. %install
  51. rm -rf %{buildroot}
  52. %py_install
  53. %py3_install
  54. #%check
  55. #%{__python} setup.py test
  56. #%{__python3} setup.py test
  57. %clean
  58. rm -rf %{buildroot}
  59. %files
  60. %defattr(-,root,root,-)
  61. %license LICENSE
  62. %doc README* examples
  63. %{python_sitelib}/*egg-info
  64. %{python_sitelib}/dns
  65. %files -n python3-dns
  66. %defattr(-,root,root,-)
  67. %license LICENSE
  68. %doc README* examples
  69. %{python3_sitelib}/*egg-info
  70. %{python3_sitelib}/dns
  71. %changelog
  72. * Tue May 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  73. - new upstream release.
  74. - added python3 support.
  75. * Sun Jan 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3
  76. - rebuild with VineSeed environment
  77. * Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  78. - add BR: python-devel, python
  79. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  80. - new upstream release
  81. * Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
  82. - initial build for Vine Linux
  83. * Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
  84. -
  85. - dnspython 1.9.4 has been released and is available at
  86. - http://www.dnspython.org/kits/1.9.4/
  87. -
  88. - There is no new functionality in this release; just a few bug fixes
  89. - in RRSIG and SIG code.
  90. -
  91. - I will be eliminating legacy code for earlier versions of DNSSEC in a
  92. - future release of dnspython.
  93. * Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
  94. -
  95. - New since 1.9.2:
  96. -
  97. - A boolean parameter, 'raise_on_no_answer', has been added to
  98. - the query() methods. In no-error, no-data situations, this
  99. - parameter determines whether NoAnswer should be raised or not.
  100. - If True, NoAnswer is raised. If False, then an Answer()
  101. - object with a None rrset will be returned.
  102. -
  103. - Resolver Answer() objects now have a canonical_name field.
  104. -
  105. - Rdata now have a __hash__ method.
  106. -
  107. - Bugs fixed since 1.9.2:
  108. -
  109. - Dnspython was erroneously doing case-insensitive comparisons
  110. - of the names in NSEC and RRSIG RRs.
  111. -
  112. - We now use "is" and not "==" when testing what section an RR
  113. - is in.
  114. -
  115. - The resolver now disallows metaqueries.
  116. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
  117. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  118. * Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
  119. - It's brown paper bag time :) The fix for the import problems was
  120. - actually bad, but didn't show up in testing because the test suite's
  121. - conditional importing code hid the problem.
  122. -
  123. - Any, 1.9.2 is out.
  124. -
  125. - Sorry for the churn!
  126. * Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
  127. - New since 1.9.0:
  128. -
  129. - Nothing.
  130. -
  131. - Bugs fixed since 1.9.0
  132. -
  133. - The dns.dnssec module didn't work with DSA due to namespace
  134. - contamination from a "from"-style import.
  135. -
  136. - New since 1.8.0:
  137. -
  138. - dnspython now uses poll() instead of select() when available.
  139. -
  140. - Basic DNSSEC validation can be done using dns.dnsec.validate()
  141. - and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
  142. - later installed. Complete secure resolution is not yet
  143. - available.
  144. -
  145. - Added key_id() to the DNSSEC module, which computes the DNSSEC
  146. - key id of a DNSKEY rdata.
  147. -
  148. - Added make_ds() to the DNSSEC module, which returns the DS RR
  149. - for a given DNSKEY rdata.
  150. -
  151. - dnspython now raises an exception if HMAC-SHA284 or
  152. - HMAC-SHA512 are used with a Python older than 2.5.2. (Older
  153. - Pythons do not compute the correct value.)
  154. -
  155. - Symbolic constants are now available for TSIG algorithm names.
  156. -
  157. - Bugs fixed since 1.8.0
  158. -
  159. - dns.resolver.zone_for_name() didn't handle a query response
  160. - with a CNAME or DNAME correctly in some cases.
  161. -
  162. - When specifying rdata types and classes as text, Unicode
  163. - strings may now be used.
  164. -
  165. - Hashlib compatibility issues have been fixed.
  166. -
  167. - dns.message now imports dns.edns.
  168. -
  169. - The TSIG algorithm value was passed incorrectly to use_tsig()
  170. - in some cases.
  171. * Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
  172. - Add a patch from upstream to fix a Python 2.7 issue.
  173. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
  174. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  175. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
  176. - Fix error
  177. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
  178. - New since 1.7.1:
  179. -
  180. - Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
  181. - hmac-sha512 has been contributed by Kevin Chen.
  182. -
  183. - The tokenizer's tokens are now Token objects instead of (type,
  184. - value) tuples.
  185. -
  186. - Bugs fixed since 1.7.1:
  187. -
  188. - Escapes in masterfiles now work correctly. Previously they were
  189. - only working correctly when the text involved was part of a domain
  190. - name.
  191. -
  192. - When constructing a DDNS update, if the present() method was used
  193. - with a single rdata, a zero TTL was not added.
  194. -
  195. - The entropy pool needed locking to be thread safe.
  196. -
  197. - The entropy pool's reading of /dev/random could cause dnspython to
  198. - block.
  199. -
  200. - The entropy pool did buffered reads, potentially consuming more
  201. - randomness than we needed.
  202. -
  203. - The entropy pool did not seed with high quality randomness on
  204. - Windows.
  205. -
  206. - SRV records were compared incorrectly.
  207. -
  208. - In the e164 query function, the resolver parameter was not used.
  209. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
  210. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  211. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
  212. - New since 1.7.0:
  213. -
  214. - Nothing
  215. -
  216. - Bugs fixed since 1.7.0:
  217. -
  218. - The 1.7.0 kitting process inadventently omitted the code for the
  219. - DLV RR.
  220. -
  221. - Negative DDNS prerequisites are now handled correctly.
  222. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
  223. - New since 1.6.0:
  224. -
  225. - Rdatas now have a to_digestable() method, which returns the
  226. - DNSSEC canonical form of the rdata, suitable for use in
  227. - signature computations.
  228. -
  229. - The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
  230. -
  231. - An entropy module has been added and is used to randomize query ids.
  232. -
  233. - EDNS0 options are now supported.
  234. -
  235. - UDP IXFR is now supported.
  236. -
  237. - The wire format parser now has a 'one_rr_per_rrset' mode, which
  238. - suppresses the usual coalescing of all RRs of a given type into a
  239. - single RRset.
  240. -
  241. - Various helpful DNSSEC-related constants are now defined.
  242. -
  243. - The resolver's query() method now has an optional 'source' parameter,
  244. - allowing the source IP address to be specified.
  245. -
  246. - Bugs fixed since 1.6.0:
  247. -
  248. - On Windows, the resolver set the domain incorrectly.
  249. -
  250. - DS RR parsing only allowed one Base64 chunk.
  251. -
  252. - TSIG validation didn't always use absolute names.
  253. -
  254. - NSEC.to_text() only printed the last window.
  255. -
  256. - We did not canonicalize IPv6 addresses before comparing them; we
  257. - would thus treat equivalent but different textual forms, e.g.
  258. - "1:00::1" and "1::1" as being non-equivalent.
  259. -
  260. - If the peer set a TSIG error, we didn't raise an exception.
  261. -
  262. - Some EDNS bugs in the message code have been fixed (see the ChangeLog
  263. - for details).
  264. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
  265. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  266. * Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
  267. - Rebuild for Python 2.6
  268. * Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
  269. - fix license tag
  270. * Tue Dec 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
  271. - Update to 1.6.0
  272. * Tue Oct 9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
  273. - Follow new Python egg packaging specs
  274. * Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
  275. - Update to 1.5.0
  276. * Fri Dec 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
  277. - Bump release for rebuild with Python 2.5
  278. * Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
  279. - No longer ghost *.pyo files, thus further simplifying the files section.
  280. * Sat Aug 5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
  281. - Update to 1.4.0
  282. - Remove unneeded python-abi requires
  283. - Remove unneeded python_sitearch macro
  284. * Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
  285. - First version for Fedora Extras