123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240 |
- %{!?__python3:%global __python3 /usr/bin/python3}
- %{!?python3_inc:%global python3_inc %(%{__python3} -c "from distutils.sysconfig import get_python_inc; print(get_python_inc(1))")}
- %{!?python3_sitearch: %global python3_sitearch %(python3 -c "from distutils.sysconfig import get_python_lib; import sys; sys.stdout.write(get_python_lib(1))")}
- %{!?python3_sitelib: %global python3_sitelib %(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())")}
- %{!?python3_version: %global python3_version %(python3 -c "import sys; sys.stdout.write(sys.version[:3])")}
- %{!?__python2:%global __python2 %{__python}}
- %define py2_setup setup.py
- %define py2_shbang_opts -s
- %define py2_build() %{expand:\
- CFLAGS="%{optflags}" %{__python2} %{py2_setup} %{?py2_setup_args} build --executable="%{__python2} %{py2_shbang_opts}" %{?1}\
- }
- %define py2_install() %{expand:\
- CFLAGS="%{optflags}" %{__python2} %{py2_setup} %{?py2_setup_args} install -O1 --skip-build --root %{buildroot} %{?1}\
- }
- %define py3_setup setup.py
- %define py3_shbang_opts -s
- %define py3_build() %{expand:\
- CFLAGS="%{optflags}" %{__python3} %{py3_setup} %{?py3_setup_args} build --executable="%{__python3} %{py3_shbang_opts}" %{?1}\
- }
- %define py3_install() %{expand:\
- CFLAGS="%{optflags}" %{__python3} %{py3_setup} %{?py3_setup_args} install -O1 --skip-build --root %{buildroot} %{?1}\
- }
- %global srcname psutil
- %global sum A process and system utilities module for Python
- %global sum_ja Python用のプロセス・システムユーティリティ
- %global __provides_exclude_from ^(%{python_sitearch}|%{python3_sitearch})/.*\\.so$
- Name: python-%{srcname}
- Version: 4.3.0
- Release: 2%{?_dist_release}
- Summary: %{sum}
- Summary(ja): %{sum_ja}
- License: BSD
- URL: https://github.com/giampaolo/psutil
- Vendor: Project Vine
- Distribution: Vine Linux
- Source0: https://github.com/giampaolo/psutil/archive/release-%{version}.tar.gz#/%{srcname}-%{version}.tar.gz
- Provides: python2-%{srcname}
- BuildRequires: python-devel
- BuildRequires: python3-devel
- %description
- psutil is a module providing an interface for retrieving information on all
- running processes and system utilization (CPU, memory, disks, network, users) in
- a portable way by using Python, implementing many functionalities offered by
- command line tools such as: ps, top, df, kill, free, lsof, free, netstat,
- ifconfig, nice, ionice, iostat, iotop, uptime, pidof, tty, who, taskset, pmap.
- %package -n python3-psutil
- Summary: %{sum}
- Summary(ja): %{sum_ja}
- %{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
- %description -n python3-psutil
- psutil is a module providing an interface for retrieving information on all
- running processes and system utilization (CPU, memory, disks, network, users) in
- a portable way by using Python 3, implementing many functionalities offered by
- command line tools such as: ps, top, df, kill, free, lsof, free, netstat,
- ifconfig, nice, ionice, iostat, iotop, uptime, pidof, tty, who, taskset, pmap.
- %prep
- %autosetup -p1 -n %{srcname}-release-%{version}
- find psutil -name \*.py | while read file; do
- sed -i.orig -e '1{/^#!/d}' $file && \
- touch -r $file.orig $file && \
- rm $file.orig
- done
- %build
- %py2_build
- %py3_build
- %install
- %py2_install
- %py3_install
- %files
- %license LICENSE
- %doc CREDITS HISTORY.rst README.rst
- %{python_sitearch}/%{srcname}/
- %{python_sitearch}/*.egg-info
- %files -n python3-%{srcname}
- %license LICENSE
- %doc CREDITS HISTORY.rst README.rst
- %{python3_sitearch}/%{srcname}/
- %{python3_sitearch}/*.egg-info
- %changelog
- * Tue Jul 12 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.3.0-2
- - initial build for Vine Linux.
- * Tue Jun 21 2016 Orion Poplawski <orion@cora.nwra.com> - 4.3.0-1
- - Update to 4.3.0
- * Mon May 16 2016 Orion Poplawski <orion@cora.nwra.com> - 3.2.1-6
- - Use modern provides filter
- - Update URL
- - Use %%python3_pkgversion for EPEL7 compat
- * Fri Mar 11 2016 Than Ngo <than@redhat.com> - 3.2.1-5
- - fix endian issue on s390x/ppc64
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.1-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.1-3
- - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
- * Fri Sep 4 2015 Michel Alexandre Salim <salimma@fedoraproject.org> - 3.2.1-2
- - Add Obsoletes for old package
- * Fri Sep 4 2015 Michel Alexandre Salim <salimma@fedoraproject.org> - 3.2.1-1
- - Update to 3.2.1
- - Update to latest Python guidelines (https://fedorahosted.org/fpc/ticket/281)
- * Wed Jul 22 2015 Michel Alexandre Salim <salimma@fedoraproject.org> - 3.1.1-2
- - Restore *.so files
- - Enable tests
- * Tue Jul 21 2015 Michel Alexandre Salim <salimma@fedoraproject.org> - 3.1.1-1
- - Update to 3.1.1
- * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Wed Feb 18 2015 Ralph Bean <rbean@redhat.com> - 2.2.0-1
- - new version
- * Wed Dec 3 2014 Michel Alexandre Salim <salimma@fedoraproject.org> - 2.1.3-1
- - Update to 2.1.3
- * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
- * Thu Jul 31 2014 Tom Callaway <spot@fedoraproject.org> - 1.2.1-4
- - fix license handling
- * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.1-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
- * Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 1.2.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
- * Mon Jan 06 2014 Mohamed El Morabity <melmorabity@fedoraproject.org> - 1.2.1-1
- - Update to 1.2.1
- * Fri Aug 16 2013 Mohamed El Morabity <melmorabity@fedoraproject.org> - 1.0.1-1
- - Update to 1.0.1
- * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.7.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Sun May 12 2013 Mohamed El Morabity <melmorabity@fedoraproject.org> - 0.7.1-1
- - Update to 0.7.1
- * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
- * Sun Aug 19 2012 Mohamed El Morabity <melmorabity@fedorapeople.org> - 0.6.1-1
- - Update to 0.6.1
- * Sat Aug 04 2012 David Malcolm <dmalcolm@redhat.com> - 0.5.1-3
- - rebuild for https://fedoraproject.org/wiki/Features/Python_3.3
- * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Sun Jul 01 2012 Mohamed El Morabity <melmorabity@fedoraproject.org> - 0.5.1-1
- - Update to 0.5.1
- * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Fri Dec 16 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 0.4.1-1
- - Update to 0.4.1
- * Sun Nov 20 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 0.4.0-1
- - Update to 0.4.0
- * Mon Jul 18 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 0.3.0-1
- - Update to 0.3.0
- * Wed Mar 23 2011 Mohamed El Morabity <melmorabity@fedoraproject.org> - 0.2.1-1
- - Update to 0.2.1
- - Spec cleanup
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Mon Nov 22 2010 Mohamed El Morabity <melmorabity@fedoraproject.org> - 0.2.0-1
- - Update to 0.2.0
- * Wed Aug 25 2010 Thomas Spura <tomspur@fedoraproject.org> - 0.1.3-5
- - rebuild with python3.2
- http://lists.fedoraproject.org/pipermail/devel/2010-August/141368.html
- * Fri Jul 30 2010 Thomas Spura <tomspur@fedoraproject.org> - 0.1.3-4
- - bump, because previous build nvr already existed in F-14
- * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 0.1.3-3
- - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
- * Tue Apr 13 2010 ELMORABITY Mohamed <melmorabity@fedoraproject.org> 0.1.3-2
- - Add missing popd in %%build
- * Sat Mar 27 2010 ELMORABITY Mohamed <melmorabity@fedoraproject.org> 0.1.3-1
- - Update to 0.1.3
- - Remove useless call to 2to3 and corresponding BuildRequires
- python2-tools (this version supports Python 3)
- * Sat Feb 20 2010 ELMORABITY Mohamed <melmorabity@fedoraproject.org> 0.1.2-4
- - Change python-utils BuildRequires for python2-utils
- * Sat Feb 20 2010 ELMORABITY Mohamed <melmorabity@fedoraproject.org> 0.1.2-3
- - Add python3 subpackage
- * Thu Jan 14 2010 ELMORABITY Mohamed <melmorabity@fedoraproject.org> 0.1.2-2
- - Drop no-shebang patch for a sed command
- - Drop test suite from %%doc tag
- * Fri Jan 8 2010 ELMORABITY Mohamed <melmorabity@fedoraproject.org> 0.1.2-1
- - Initial RPM release
|