popt-vl.spec 8.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: C library for parsing command line parameters
  3. Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
  4. Name: popt
  5. Version: 1.16
  6. Release: 1%{?_dist_release}
  7. License: MIT
  8. Group: System Environment/Libraries
  9. URL: http://www.rpm5.org/
  10. Source0: http://www.rpm5.org/files/%{name}/%{name}-%{version}.tar.gz
  11. BuildRequires: gettext, doxygen, graphviz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  13. %description
  14. Popt is a C library for parsing command line parameters. Popt was
  15. heavily influenced by the getopt() and getopt_long() functions, but
  16. it improves on them by allowing more powerful argument expansion.
  17. Popt can parse arbitrary argv[] style arrays and automatically set
  18. variables based on command line arguments. Popt allows command line
  19. arguments to be aliased via configuration files and includes utility
  20. functions for parsing arbitrary strings into argv[] arrays using
  21. shell-like rules.
  22. %description -l ja
  23. Poptはコマンドパラメータを文法解析するためのCライブラリです。
  24. Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
  25. もっと強力な引数の拡張を施すことによって、それらをもっと進化
  26. させています。Poptは 任意の argv[]形式配列を解析して、コマンド
  27. ライン引数に基づいて変数を自動的に設定します。
  28. Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
  29. 許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
  30. てargv[]配列に変換したりするユーティリティ関数を含んでいます。
  31. %package devel
  32. Summary: Development files for the popt library
  33. Summary(ja): popt ライブラリの開発ファイル
  34. Group: Development/Libraries
  35. Requires: %{name} = %{version}-%{release}
  36. %description devel
  37. The popt-devel package includes header files and libraries necessary
  38. for developing programs which use the popt C library. It contains the
  39. API documentation of the popt library, too.
  40. %package static
  41. Summary: Static library for %{name}
  42. Summary(ja): %{name} のスタティックライブラリ
  43. Group: Development/Libraries
  44. Requires: %{name} = %{version}-%{release}
  45. %description static
  46. The %{name}-static package contains the static library for %{name}.
  47. %package -n compat32-%{name}
  48. Summary: A C library for parsing command line parameters.
  49. Summary(ja): コマンドラインパラメータを文法解析するためのCライブラリ
  50. Group: Development/Libraries
  51. Requires: %{name} = %{version}-%{release}
  52. %description -n compat32-%{name}
  53. Popt is a C library for parsing command line parameters. Popt was
  54. heavily influenced by the getopt() and getopt_long() functions, but it
  55. improves on them by allowing more powerful argument expansion. Popt
  56. can parse arbitrary argv[] style arrays and automatically set
  57. variables based on command line arguments. Popt allows command line
  58. arguments to be aliased via configuration files and includes utility
  59. functions for parsing arbitrary strings into argv[] arrays using
  60. shell-like rules.
  61. %description -n compat32-%{name} -l ja
  62. Poptはコマンドパラメータを文法解析するためのCライブラリです。
  63. Poptは getopt()やgetopt_long()関数の影響を強く受けていますが、
  64. もっと強力な引数の拡張を施すことによって、それらをもっと進化
  65. させています。Poptは 任意の argv[]形式配列を解析して、コマンド
  66. ライン引数に基づいて変数を自動的に設定します。
  67. Poptは、コマンドライン引数を設定ファイルによってエイリアス化を
  68. 許可したり、シェルライクな方針を用いた任意の文字列を文法解析し
  69. てargv[]配列に変換したりするユーティリティ関数を含んでいます。
  70. %package -n compat32-%{name}-devel
  71. Summary: Development files for the popt library
  72. Summary(ja): popt ライブラリの開発ファイル
  73. Group: Development/Libraries
  74. Requires: compat32-%{name} = %{version}-%{release}
  75. Requires: %{name}-devel = %{version}-%{release}
  76. %description -n compat32-%{name}-devel
  77. The popt-devel package includes header files and libraries necessary
  78. for developing programs which use the popt C library. It contains the
  79. API documentation of the popt library, too.
  80. %prep
  81. %setup -q
  82. sed -i "s|libdir=@libdir@|libdir=@prefix@@libdir@|" popt.pc.in
  83. %ifarch x86_64
  84. sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.am
  85. sed -i "s|/lib/pkgconfig|/lib64/pkgconfig|" Makefile.in
  86. %endif
  87. %build
  88. %configure --libdir=/%{_lib}
  89. make %{?_smp_mflags}
  90. doxygen
  91. %install
  92. rm -rf $RPM_BUILD_ROOT
  93. make DESTDIR=$RPM_BUILD_ROOT install
  94. # Move libpopt.{so,a} to %{_libdir}
  95. rm -f $RPM_BUILD_ROOT/%{_lib}/libpopt.{la,so}
  96. pushd $RPM_BUILD_ROOT/%{_lib}
  97. mkdir -p $RPM_BUILD_ROOT%{_libdir}
  98. ln -sf ../../%{_lib}/$(ls libpopt.so.?.?.?) $RPM_BUILD_ROOT%{_libdir}/libpopt.so
  99. popd
  100. mv -f $RPM_BUILD_ROOT/%{_lib}/libpopt.a $RPM_BUILD_ROOT%{_libdir}/libpopt.a
  101. # Multiple popt configurations are possible
  102. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/popt.d
  103. %find_lang %{name}
  104. %clean
  105. rm -rf $RPM_BUILD_ROOT
  106. %post -p /sbin/ldconfig
  107. %postun -p /sbin/ldconfig
  108. %post -n compat32-%{name} -p /sbin/ldconfig
  109. %postun -n compat32-%{name} -p /sbin/ldconfig
  110. %files -f %{name}.lang
  111. %defattr(-,root,root)
  112. %doc CHANGES COPYING
  113. %{_sysconfdir}/popt.d
  114. /%{_lib}/libpopt.so.*
  115. %files devel
  116. %defattr(-,root,root)
  117. %doc README doxygen/html
  118. %{_libdir}/libpopt.so
  119. %{_libdir}/pkgconfig/popt.pc
  120. %{_includedir}/popt.h
  121. %{_mandir}/man3/popt.3*
  122. %files static
  123. %defattr(-,root,root)
  124. %{_libdir}/libpopt.a
  125. %if %{build_compat32}
  126. %files -n compat32-%{name}
  127. %defattr(-,root,root)
  128. /%{_lib}/libpopt.so.*
  129. %files -n compat32-%{name}-devel
  130. %defattr(-,root,root)
  131. %{_libdir}/libpopt.so
  132. %endif
  133. %changelog
  134. * Sat Nov 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.16-1
  135. - update to 1.16
  136. - create %{name}-static sub package
  137. * Sun Apr 17 2011 Shu KONNO <owa@bg.wakwak.com> - 1.14-5
  138. - rebuilt with rpm-4.8.1-3
  139. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.14-4
  140. - rebuilt with new toolchain
  141. * Sun Jun 28 2009 NAKAMURA Kenta <kenta@vinelinux.org> 1.14-3
  142. - updated Requires: and %%files section on compat32 subpackages
  143. * Mon Jun 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.14-2
  144. - added %%define build_compat32
  145. - fixed compat32 directories
  146. * Mon Aug 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-1
  147. - initial build for Vine Linux
  148. - splitted out from rpm, based on rpm5.org source.
  149. - move libpopt to /lib[64] from /usr/lib[64]
  150. - initscripts-8 uses libpopt.
  151. * Sun May 25 2008 Robert Scheck <robert@fedoraproject.org> 1.13-4
  152. - Solved multilib problems at doxygen generated files (#342921)
  153. * Wed Feb 20 2008 Robert Scheck <robert@fedoraproject.org> 1.13-3
  154. - Revert the broken bind_textdomain_codeset() patch (#433324)
  155. * Thu Feb 14 2008 Robert Scheck <robert@fedoraproject.org> 1.13-2
  156. - Added patch to work around missing bind_textdomain_codeset()
  157. * Sun Dec 30 2007 Robert Scheck <robert@fedoraproject.org> 1.13-1
  158. - Upgrade to 1.13 (#290531, #332201, #425803)
  159. - Solved multilib problems at doxygen generated files (#342921)
  160. * Thu Aug 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-3
  161. - Added buildrequirement to graphviz (#249352)
  162. - Backported bugfixes from CVS (#102254, #135428 and #178413)
  163. * Sun Aug 12 2007 Robert Scheck <robert@fedoraproject.org> 1.12-2
  164. - Move libpopt to /lib[64] (#249814)
  165. - Generate API documentation, added buildrequirement to doxygen
  166. * Mon Jul 23 2007 Robert Scheck <robert@fedoraproject.org> 1.12-1
  167. - Changes to match with Fedora Packaging Guidelines (#249352)
  168. * Tue Jul 10 2007 Jeff Johnson <jbj@rpm5.org>
  169. - release popt-1.12 through rpm5.org.
  170. * Sat Jun 9 2007 Jeff Johnson <jbj@rpm5.org>
  171. - release popt-1.11 through rpm5.org.
  172. * Thu Dec 10 1998 Michael Johnson <johnsonm@redhat.com>
  173. - released 1.2.2; see CHANGES
  174. * Tue Nov 17 1998 Michael K. Johnson <johnsonm@redhat.com>
  175. - added man page to default install
  176. * Thu Oct 22 1998 Erik Troan <ewt@redhat.com>
  177. - see CHANGES file for 1.2
  178. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  179. - added ./configure step to spec file