webkitgtk4-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372
  1. %bcond_with systemd
  2. %bcond_with clang
  3. ## NOTE: Lots of files in various subdirectories have the same name (such as
  4. ## "LICENSE") so this short macro allows us to distinguish them by using their
  5. ## directory names (from the source tree) as prefixes for the files.
  6. %global add_to_license_files() \
  7. mkdir -p _license_files ; \
  8. cp -p %1 _license_files/$(echo '%1' | sed -e 's!/!.!g')
  9. Summary: GTK+ Web content engine library
  10. Name: webkitgtk4
  11. Version: 2.32.0
  12. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  13. Group: system
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: LGPLv2
  17. URL: http://www.webkitgtk.org/
  18. Source0: https://webkitgtk.org/releases/webkitgtk-%{version}.tar.xz
  19. %if %{with clang}
  20. BuildRequires: clang
  21. BuildRequires: lld
  22. %endif
  23. BuildRequires: at-spi2-core-devel
  24. BuildRequires: bison
  25. BuildRequires: bubblewrap
  26. BuildRequires: cairo-devel
  27. BuildRequires: cmake
  28. BuildRequires: enchant2-devel
  29. BuildRequires: flex
  30. BuildRequires: fontconfig-devel
  31. BuildRequires: freetype-devel
  32. BuildRequires: geoclue2-devel
  33. BuildRequires: gettext
  34. BuildRequires: glib2-devel
  35. BuildRequires: gobject-introspection-devel
  36. BuildRequires: gperf
  37. BuildRequires: gstreamer1-devel
  38. BuildRequires: gstreamer1-plugins-base-devel
  39. BuildRequires: gtk2-devel
  40. BuildRequires: gtk3-devel
  41. BuildRequires: harfbuzz-icu-devel
  42. BuildRequires: libicu-devel
  43. BuildRequires: libjpeg-turbo-devel
  44. BuildRequires: libpng-devel
  45. BuildRequires: libseccomp-devel
  46. BuildRequires: libsecret-devel
  47. BuildRequires: libsoup-devel
  48. BuildRequires: libwebp-devel
  49. BuildRequires: libxslt-devel
  50. BuildRequires: libXt-devel
  51. BuildRequires: ninja
  52. BuildRequires: mesa-libGL-devel
  53. BuildRequires: pcre-devel
  54. BuildRequires: python3-devel
  55. BuildRequires: ruby
  56. BuildRequires: sqlite3-devel
  57. BuildRequires: libnotify-devel
  58. BuildRequires: hyphen-devel
  59. BuildRequires: woff2-devel
  60. BuildRequires: xdg-dbus-proxy
  61. %if %{with systemd}
  62. BuildRequires: systemd-devel
  63. %endif
  64. Requires: geoclue2
  65. # for sandbox
  66. Requires: bubblewrap
  67. Requires: xdg-dbus-proxy
  68. # Require the jsc subpackage
  69. Requires: %{name}-jsc = %{version}-%{release}
  70. # Obsolete libwebkit2gtk from the webkitgtk3 package
  71. Obsoletes: libwebkit2gtk < 2.4.5-3
  72. Provides: libwebkit2gtk = %{version}-%{release}
  73. # Filter out provides for private libraries
  74. %global __provides_exclude_from ^%{_libdir}/webkit2gtk-4\\.0/.*\\.so$
  75. %description
  76. WebKitGTK+ is the port of the portable web rendering engine WebKit to the
  77. GTK+ platform.
  78. This package contains WebKitGTK+ for GTK+ 3.
  79. %package devel
  80. Summary: Development files for %{name}
  81. Group: programming
  82. Requires: %{name} = %{version}-%{release}
  83. Requires: %{name}-jsc-devel = %{version}-%{release}
  84. %description devel
  85. The %{name}-devel package contains libraries, build data, and header
  86. files for developing applications that use %{name}.
  87. %package jsc
  88. Summary: JavaScript engine from %{name}
  89. Group: system
  90. %description jsc
  91. This package contains JavaScript engine from %{name}.
  92. %package jsc-devel
  93. Summary: Development files for JavaScript engine from %{name}
  94. Group: programming
  95. Requires: %{name}-jsc = %{version}-%{release}
  96. %description jsc-devel
  97. The %{name}-jsc-devel package contains libraries, build data, and header
  98. files for developing applications that use JavaScript engine from %{name}.
  99. %debug_package
  100. %prep
  101. %setup -q -n webkitgtk-%{version}
  102. # Remove bundled libraries
  103. rm -rf Source/ThirdParty/leveldb/
  104. rm -rf Source/ThirdParty/gtest/
  105. rm -rf Source/ThirdParty/qunit/
  106. %build
  107. %ifnarch x86_64
  108. %define cflags_add --rtlib=compiler-rt
  109. %endif
  110. %if %{with clang}
  111. export CC=clang
  112. export CXX=clang++
  113. export LD=ld.lld
  114. %ifnarch x86_64
  115. %define cflags_add --rtlib=compiler-rt
  116. %endif
  117. %global optflags %(echo %{optflags} -DENABLE_YARR_JIT=0 | sed -e 's/-fno-schedule-insns2//') -fuse-ld=lld %{?cflags_add}
  118. %global build_ldflags %{build_ldflags}
  119. %else
  120. %global optflags %(echo %{optflags} | sed 's/-g /-g1 /')
  121. %endif
  122. %cmake \
  123. -GNinja \
  124. %if %{with clang}
  125. -DCOMPILER_IS_CLANG=ON \
  126. -DCMAKE_CXX_COMPILER=clang++ \
  127. %endif
  128. -DPORT=GTK \
  129. -DCMAKE_BUILD_TYPE=Release \
  130. -DUSER_AGENT_BRANDING="Vine Linux" \
  131. -DENABLE_JIT=OFF \
  132. -DENABLE_LLINT_C_LOOP=ON \
  133. -DUSE_GSTREAMER_GL=OFF \
  134. -DUSE_OPENJPEG=OFF \
  135. -DENABLE_GTKDOC=OFF \
  136. -DUSE_WPE_RENDERER=OFF \
  137. -DENABLE_GAMEPAD=NO \
  138. %if %{with systemd}
  139. -DUSE_SYSTEMD=ON \
  140. %else
  141. -DUSE_SYSTEMD=OFF \
  142. %endif
  143. # Show the build time in the status
  144. export NINJA_STATUS="[%f/%t][%e] "
  145. %cmake_build
  146. %install
  147. %cmake_install
  148. %find_lang WebKit2GTK-4.0
  149. # Finally, copy over and rename various files for %%license inclusion
  150. %add_to_license_files Source/JavaScriptCore/COPYING.LIB
  151. %add_to_license_files Source/ThirdParty/ANGLE/LICENSE
  152. %add_to_license_files Source/ThirdParty/ANGLE/src/third_party/compiler/LICENSE
  153. %add_to_license_files Source/WebCore/LICENSE-APPLE
  154. %add_to_license_files Source/WebCore/LICENSE-LGPL-2
  155. %add_to_license_files Source/WebCore/LICENSE-LGPL-2.1
  156. %add_to_license_files Source/WebInspectorUI/UserInterface/External/CodeMirror/LICENSE
  157. %add_to_license_files Source/WebInspectorUI/UserInterface/External/Esprima/LICENSE
  158. %add_to_license_files Source/WTF/icu/LICENSE
  159. %add_to_license_files Source/WTF/wtf/dtoa/COPYING
  160. %add_to_license_files Source/WTF/wtf/dtoa/LICENSE
  161. %files -f WebKit2GTK-4.0.lang
  162. %license _license_files/*
  163. %{_libdir}/libwebkit2gtk-4.0.so.*
  164. %{_libdir}/girepository-1.0/WebKit2-4.0.typelib
  165. %{_libdir}/girepository-1.0/WebKit2WebExtension-4.0.typelib
  166. %{_libdir}/webkit2gtk-4.0/
  167. %{_libexecdir}/webkit2gtk-4.0/*
  168. %exclude %{_libexecdir}/webkit2gtk-4.0/jsc
  169. %{_bindir}/WebKitWebDriver
  170. %files jsc
  171. %license _license_files/*JavaScriptCore*
  172. %dir %{_libexecdir}/webkit2gtk-4.0/
  173. %{_libexecdir}/webkit2gtk-4.0/jsc
  174. %{_libdir}/libjavascriptcoregtk-4.0.so.*
  175. %{_libdir}/girepository-1.0/JavaScriptCore-4.0.typelib
  176. %files devel
  177. %{_includedir}/webkitgtk-4.0/*
  178. %exclude %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  179. %{_libdir}/libwebkit2gtk-4.0.so
  180. %{_libdir}/pkgconfig/webkit2gtk-4.0.pc
  181. %{_libdir}/pkgconfig/webkit2gtk-web-extension-4.0.pc
  182. %{_datadir}/gir-1.0/WebKit2-4.0.gir
  183. %{_datadir}/gir-1.0/WebKit2WebExtension-4.0.gir
  184. %files jsc-devel
  185. %dir %{_includedir}/webkitgtk-4.0
  186. %{_includedir}/webkitgtk-4.0/JavaScriptCore/
  187. %{_libdir}/libjavascriptcoregtk-4.0.so
  188. %{_libdir}/pkgconfig/javascriptcoregtk-4.0.pc
  189. %{_datadir}/gir-1.0/JavaScriptCore-4.0.gir
  190. %changelog
  191. * Thu Apr 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.32.0-1
  192. - new upstream release.
  193. - dropped ldconfig scriptlets.
  194. * Tue Mar 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.30.5-1
  195. - new upstream release.
  196. * Tue Dec 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.30.3-1
  197. - new upstream release.
  198. - added systemd support (disabled as default).
  199. * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.4-1
  200. - new upstream release.
  201. * Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.3-1
  202. - new upstream release.
  203. * Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.2-1
  204. - new upstream release.
  205. * Fri Apr 24 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.1-1
  206. - new upstream release.
  207. - rebuilt with libicu67.
  208. * Fri Mar 20 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-2
  209. - rebuilt with libicu66.
  210. * Sun Mar 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.28.0-1
  211. - new upstream release.
  212. - dropped Patch1: fixed in upstream.
  213. * Sun Oct 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.1-1
  214. - new upstream release.
  215. - built with icu-65.
  216. * Fri Sep 20 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.26.0-1
  217. - new upstream release.
  218. - switched build-system to ninja.
  219. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.24.3-1
  220. - new upstream release.
  221. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.22.5-1
  222. - new upstream release.
  223. * Thu Jan 11 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.5-1
  224. - new upstream release.
  225. - added subpackages webkitgtk4-jsc{,-devel}.
  226. * Mon Jan 08 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.18.4-1
  227. - new upstream release.
  228. * Wed Jun 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.12.3-2
  229. - rebuilt with new toolchain.
  230. * Sun Jun 12 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.3-1
  231. - new upstream release
  232. (including security fix for CVE-2016-1856,1857)
  233. * Sun May 08 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.2-1
  234. - new upstream release
  235. - remove Patch0
  236. - add BuildRequires: libnotify-devel, hyphen-devel
  237. * Wed Dec 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-3
  238. - rebuild with gnutls-3.4.7
  239. * Sat Oct 31 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-2
  240. - rebuild with icu-56.1
  241. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.5-1
  242. - new upstream release
  243. * Sun Jul 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.4-1
  244. - new upstream release
  245. * Fri May 22 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.3-1
  246. - new upstream release
  247. * Fri May 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-1
  248. - new upstream release
  249. * Wed Apr 15 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.1-1
  250. - new upstream release
  251. * Sun Mar 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.0-1
  252. - new upstream release
  253. - update Patch0
  254. * Sun Mar 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-1
  255. - new upstream release
  256. * Sat Nov 29 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-2
  257. - add Group tag
  258. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.4-1
  259. - new upstream release
  260. * Tue Nov 18 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.3-1
  261. - new upstream release
  262. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.2-1
  263. - initial build for Vine Linux
  264. * Thu Sep 25 2014 Tomas Popela <tpopela@redhat.com> - 2.6.0-1
  265. - Add the wrongly removed CLoop patch and remove the one that was upstreamed
  266. * Wed Sep 24 2014 Kalev Lember <kalevlember@gmail.com> - 2.6.0-1
  267. - Update to 2.6.0
  268. * Mon Sep 22 2014 Tomas Popela <tpopela@redhat.com> - 2.5.90-1
  269. - Update to 2.5.90
  270. * Tue Aug 26 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-7
  271. - Obsolete libwebkit2gtk from the webkitgtk3 package
  272. * Tue Aug 26 2014 David Tardon <dtardon@redhat.com> - 2.5.3-6
  273. - rebuild for ICU 53.1
  274. * Mon Aug 25 2014 Tomas Popela <tpopela@redhat.com> - 2.5.3-5
  275. - Add support for secondary arches
  276. * Fri Aug 22 2014 Michael Catanzaro <mcatanzaro@gnome.org> - 2.5.3-4
  277. - Add webkitgtk-2.5.3-toggle-buttons.patch
  278. * Thu Aug 21 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-3
  279. - More package review fixes (#1131284)
  280. - Correct the license tag to read LGPLv2
  281. - Filter out provides for private libraries
  282. * Tue Aug 19 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-2
  283. - Remove bundled leveldb, gtest, qunit in %%prep (#1131284)
  284. * Fri Aug 15 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.3-1
  285. - Update to 2.5.3
  286. * Fri Aug 01 2014 Kalev Lember <kalevlember@gmail.com> - 2.5.1-1
  287. - Initial Fedora packaging, based on the webkitgtk3 package