123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305 |
- %global with_python3 1
- %{!?__python2: %global __python2 /usr/bin/python}
- %{!?python2_sitearch: %global python2_sitearch %(%{__python2} -c "from distutils.sysconfig import get_python_lib; print(get_python_lib(1))")}
- %{!?python3_pkgversion:%global python3_pkgversion 3}
- %global srcname cryptography
- Name: python-%{srcname}
- Version: 2.4.1
- Release: 1%{?_dist_release}
- Summary: PyCA's cryptography library
- Group: Development/Libraries
- License: ASL 2.0 or BSD
- URL: https://cryptography.io/en/latest/
- Vendor: Project Vine
- Distribution: Vine Linux
- Source0: https://pypi.io/packages/source/c/%{srcname}/%{srcname}-%{version}.tar.gz
- Requires: openssl
- Requires: python-idna >= 2.1
- Requires: python-asn1crypto >= 0.21
- Requires: python-six >= 1.4.1
- Requires: python-cffi >= 1.7
- Requires: python-enum34
- Requires: python-ipaddress
- BuildRequires: openssl-devel
- BuildRequires: gcc
- BuildRequires: python-rpm-macros
- BuildRequires: python-devel
- BuildRequires: python-setuptools
- BuildRequires: python-asn1crypto >= 0.21
- BuildRequires: python-idna >= 2.1
- BuildRequires: python-six >= 1.4.1
- BuildRequires: python-cffi >= 1.7
- BuildRequires: python-enum34
- BuildRequires: python-ipaddress
- %if 0%{?with_python3}
- BuildRequires: python%{python3_pkgversion}-rpm-macros
- BuildRequires: python%{python3_pkgversion}-devel
- BuildRequires: python%{python3_pkgversion}-setuptools
- BuildRequires: python%{python3_pkgversion}-asn1crypto >= 0.21
- BuildRequires: python%{python3_pkgversion}-idna >= 2.1
- BuildRequires: python%{python3_pkgversion}-six >= 1.4.1
- BuildRequires: python%{python3_pkgversion}-cffi >= 1.7
- %endif
- %description
- cryptography is a package designed to expose cryptographic primitives and
- recipes to Python developers.
- %if 0%{?with_python3}
- %{?python_provide:%python_provide python2-%{srcname}}
- %else
- Provides: python-%{srcname}
- %endif
- %if 0%{?with_python3}
- %package -n python%{python3_pkgversion}-%{srcname}
- Group: Development/Libraries
- Summary: PyCA's cryptography library
- %{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
- Requires: openssl
- Requires: python%{python3_pkgversion}-idna >= 2.1
- Requires: python%{python3_pkgversion}-asn1crypto >= 0.21
- Requires: python%{python3_pkgversion}-six >= 1.4.1
- Requires: python%{python3_pkgversion}-cffi >= 1.7
- %description -n python%{python3_pkgversion}-%{srcname}
- cryptography is a package designed to expose cryptographic primitives and
- recipes to Python developers.
- %endif
- %prep
- %autosetup -p1 -n %{srcname}-%{version}
- %if 0%{?with_python3}
- rm -rf %{py3dir}
- cp -a . %{py3dir}
- find %{py3dir} -name '*.py' | xargs sed -i '1s|^#!/usr/bin/python|#!%{__python3}|'
- %endif
- %build
- %if 0%{?with_python3}
- %py_build
- pushd %{py3dir}
- %py3_build
- popd
- %else
- %{__python} setup.py build
- %endif
- %install
- find . -name .keep -print -delete
- %if 0%{?with_python3}
- %py_install
- pushd %{py3dir}
- %py3_install
- popd
- %else
- %{__python} setup.py install --skip-build --prefix=%{_prefix} --root %{buildroot}
- %endif
- %check
- rm -f tests/hazmat/primitives/test_padding.py
- %if 0%{?with_python3}
- pushd %{py3dir}
- rm -f tests/hazmat/primitives/test_padding.py
- popd
- %endif
- %files
- %doc LICENSE LICENSE.APACHE LICENSE.BSD README.rst docs
- %{python2_sitearch}/%{srcname}
- %{python2_sitearch}/%{srcname}-%{version}-py*.egg-info
- %if 0%{?with_python3}
- %files -n python%{python3_pkgversion}-%{srcname}
- %doc README.rst docs
- %license LICENSE LICENSE.APACHE LICENSE.BSD
- %{python3_sitearch}/*
- %{python3_sitearch}/%{srcname}-%{version}-py*.egg-info
- %endif
- %changelog
- * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.4.1-1
- - initial build for Vine Linux.
- - new upstream release.
- * Mon Aug 13 2018 Christian Heimes <cheimes@redhat.com> - 2.3-2
- - Use TLSv1.2 in test as workaround for RHBZ#1615143
- * Wed Jul 18 2018 Christian Heimes <cheimes@redhat.com> - 2.3-1
- - New upstream release 2.3
- - Fix AEAD tag truncation bug, RHBZ#1602752
- * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.2.1-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 2.2.1-2
- - Rebuilt for Python 3.7
- * Wed Mar 21 2018 Christian Heimes <cheimes@redhat.com> - 2.2.1-1
- - New upstream release 2.2.1
- * Sun Feb 18 2018 Christian Heimes <cheimes@redhat.com> - 2.1.4-1
- - New upstream release 2.1.4
- * Sun Feb 18 2018 Christian Heimes <cheimes@redhat.com> - 2.1.3-4
- - Build requires gcc
- * Mon Feb 12 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.1.3-3
- - Update Python 2 dependency declarations to new packaging standards
- (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
- * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.1.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Thu Nov 23 2017 Haïkel Guémar <hguemar@fedoraproject.org> - 2.1.3-1
- - Upstream 2.1.3
- * Tue Oct 24 2017 Christian Heimes <cheimes@redhat.com> - 2.1-2
- - Change Requires to openssl-libs
- * Thu Oct 12 2017 Christian Heimes <cheimes@redhat.com> - 2.1-1
- - New upstream release 2.1
- * Wed Sep 27 2017 Troy Dawson <tdawson@redhat.com> - 2.0.2-3
- - Cleanup spec file conditionals
- * Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 2.0.2-2
- - Add workaround for pytest bug
- * Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 2.0.2-1
- - New upstream release 2.0.2
- - Modernize spec
- * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
- * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.9-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 1.9-1
- - Upstream release 1.9
- * Wed Feb 15 2017 Christian Heimes <cheimes@redhat.com> - 1.7.2-1
- - Update to latest upstream
- * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.7.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- * Thu Jan 05 2017 Matěj Cepl <mcepl@redhat.com> - 1.7.1-1
- - Update to the latest upstream.
- - Add a patch from https://github.com/pyca/cryptography/pull/3328
- * Tue Dec 13 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.3-5
- - Enable tests
- * Mon Dec 12 2016 Charalampos Stratakis <cstratak@redhat.com> - 1.5.3-4
- - Rebuild for Python 3.6
- - Disable python3 tests for now
- * Thu Nov 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-3
- - Revert previous change
- * Thu Nov 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-2
- - Disable tests on releases earlier than 24
- * Mon Nov 07 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.5.3-1
- - Update to v1.5.3
- - Update source URL
- - Add BR for pytz
- * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.3.1-4
- - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
- * Tue May 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-3
- - Remove versioned setuptools dependency
- * Tue May 10 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-2
- - Make it easier to build on EL7
- * Tue May 03 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.3.1-1
- - Update to v1.3.1
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.1-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Mon Jan 11 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.2.1-2
- - Move python-cryptograph => python2-cryptography
- * Sat Jan 09 2016 Nathaniel McCallum <npmccallum@redhat.com> - 1.2.1-1
- - Update to v1.2.1
- * Wed Nov 11 2015 Robert Kuska <rkuska@redhat.com> - 1.1-1
- - Update to v1.1
- * Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 1.0.2-2
- - Rebuilt for Python3.5 rebuild
- * Wed Sep 30 2015 Matěj Cepl <mcepl@redhat.com> - 1.0.2-1
- - New upstream release (fix
- * Wed Aug 12 2015 Nathaniel McCallum <npmccallum@redhat.com> - 1.0-1
- - New upstream release
- * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.9-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Thu May 14 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.9-1
- - New upstream release
- - Run tests on RHEL
- - New deps: python-idna, python-ipaddress
- * Fri Apr 17 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.8.2-1
- - New upstream release
- - Add python3-pyasn1 Requires (#1211073)
- * Tue Apr 14 2015 Matej Cepl <mcepl@redhat.com> - 0.8-2
- - Add python-pyasn1 Requires (#1211073)
- * Fri Mar 13 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.8-1
- - New upstream release
- - Remove upstreamed patch
- * Wed Mar 04 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.7.2-2
- - Add python3-cryptography-vectors build requires
- - Add python-enum34 requires
- * Tue Feb 03 2015 Nathaniel McCallum <npmccallum@redhat.com> - 0.7.2-1
- - New upstream release. BSD is now an optional license.
- - Fix test running on python3
- - Add upstream patch to fix test paths
- * Fri Nov 07 2014 Matej Cepl <mcepl@redhat.com> - 0.6.1-2
- - Fix requires, for reasons why other development files were not
- eliminated see https://github.com/pyca/cryptography/issues/1463.
- * Wed Nov 05 2014 Matej Cepl <mcepl@redhat.com> - 0.6.1-1
- - New upstream release.
- * Sun Jun 29 2014 Terry Chia <terrycwk1994@gmail.com> 0.4-1
- - initial version
|