inkscape-vl.spec 8.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305
  1. %define filever A6N0YOn
  2. Name: inkscape
  3. Summary: A Vector Drawing Application
  4. Summary(ja): ベクター描画アプリケーション
  5. Version: 0.92.4
  6. Release: 1%{?_dist_release}
  7. Group: Applications/Graphics
  8. License: GPLv2+
  9. URL: https://launchpad.net/inkscape
  10. Source0: https://launchpad.net/inkscape/%{version}.x/%{version}/+download/inkscape-%{version}_%{filever}.tar.bz2
  11. # # to fix compile error with poppler>=0.58
  12. # Patch1000: poppler-0.58.x.patch
  13. # Patch1001: poppler-0.58.x-autotools.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gtk2-devel >= 2.8.0
  16. BuildRequires: gnome-vfs2-devel >= 2.0
  17. BuildRequires: libxml2-devel >= 2.6.11
  18. BuildRequires: libxslt-devel >= 1.0.15
  19. BuildRequires: gc-devel >= 6.4
  20. BuildRequires: dbus-glib-devel
  21. BuildRequires: libsigc++-devel >= 2.0.12
  22. BuildRequires: gtkmm2-devel >= 2.8.0
  23. BuildRequires: libpng-devel >= 1.2.0
  24. BuildRequires: libwpg-devel
  25. BuildRequires: libexif-devel
  26. BuildRequires: libjpeg-turbo-devel
  27. BuildRequires: perl-XML-Parser
  28. BuildRequires: lcms2-devel
  29. BuildRequires: poppler-devel >= 0.14.2
  30. BuildRequires: pango-devel, cairo-devel
  31. BuildRequires: gsl-devel
  32. BuildRequires: libboost-devel
  33. BuildRequires: popt-devel
  34. BuildRequires: ImageMagick-c++-devel
  35. BuildRequires: dos2unix
  36. BuildRequires: automake autoconf
  37. Requires: python-lxml
  38. Requires: perl-XML-RegExp
  39. Requires: perl-XML-DOM
  40. Requires: perl-XML-XQL
  41. # the package requires libperl.so, so it also has to require this:
  42. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  43. # Filter out perl requires and provides
  44. # XXX: For now _all_
  45. %global __perl_provides %{nil}
  46. %global __perl_requires %{nil}
  47. Vendor: Project Vine
  48. Distribution: Vine Linux
  49. %description
  50. Inkscape is a SVG based generic vector-drawing program for
  51. Linux/Unix/Windows/Mac.
  52. %description -l ja
  53. Inkscape SVG ベースの汎用ベクトル描画プログラムです。
  54. Linux/Unix/Windows/Mac で動作します。
  55. %prep
  56. %setup -q -n %{name}-%{version}
  57. # %patch1000 -p1
  58. # %patch1001 -p1
  59. # https://bugs.launchpad.net/inkscape/+bug/314381
  60. # A couple of files have executable bits set,
  61. # despite not being executable
  62. find . -name '*.cpp' | xargs chmod -x
  63. find . -name '*.h' | xargs chmod -x
  64. find share/extensions -name '*.py' | xargs chmod -x
  65. # Fix end of line encodings
  66. dos2unix -k -q share/extensions/*.py
  67. %build
  68. ./autogen.sh
  69. export CXXFLAGS="$RPM_OPT_FLAGS -std=c++11"
  70. %configure \
  71. --with-gnome-vfs \
  72. --with-inkjar \
  73. --enable-poppler-cairo \
  74. --disable-strict-build
  75. make %{?_smp_mflags}
  76. %install
  77. rm -rf %{buildroot}
  78. make install DESTDIR=$RPM_BUILD_ROOT
  79. rm -f $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/icon-theme.cache
  80. %find_lang %{name}
  81. %clean
  82. rm -rf %{buildroot}
  83. %post
  84. /sbin/ldconfig
  85. touch --no-create %{_datadir}/icons/hicolor &> /dev/null || :
  86. %postun
  87. if [ $1 -eq 0 ] ; then
  88. update-desktop-database -q &> /dev/null
  89. touch --no-create %{_iconsdir}/icons/hicolor &> /dev/null
  90. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  91. fi
  92. %posttrans
  93. update-desktop-database -q &> /dev/null
  94. gtk-update-icon-cache %{_iconsdir}/icons/hicolor &> /dev/null || :
  95. %files -f %{name}.lang
  96. %defattr(-, root, root)
  97. %doc AUTHORS COPYING ChangeLog NEWS README
  98. %{_bindir}/inkscape
  99. %{_bindir}/inkview
  100. %{_datadir}/appdata/inkscape.appdata.xml
  101. %{_datadir}/applications/*.desktop
  102. %{_datadir}/icons/hicolor/*
  103. %{_datadir}/inkscape
  104. %{_mandir}/man1/*
  105. %{_mandir}/*/man1/*
  106. %changelog
  107. * Mon May 20 2019 Toshiaki Ara <ara_t@384.jp> 0.92.3-2
  108. - update to 0.92.4
  109. - drop unrecognized options: --with-python, --enable-lcms2
  110. * Sun Jun 03 2018 Toshiaki Ara <ara_t@384.jp> 0.92.3-1
  111. - updated to 0.92.3
  112. - drop Patch1000,1001
  113. * Wed Jan 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.92.2-1
  114. - updated to 0.92.2
  115. * Tue Jun 28 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-3
  116. - rebuild with gcc-5.4.0
  117. * Mon May 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-2
  118. - rebuild with poppler-0.43.0
  119. * Tue Nov 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.91-1
  120. - update to 0.91
  121. - remove old patches
  122. - add BuildRequires: dbus-glib-devel, libexif-devel, libjpeg-turbo-devel
  123. * Tue Apr 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-4
  124. - rebuild with ImageMagick-6.9.1.1
  125. * Tue Jan 13 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.48.5-3
  126. - rebuilt with libwpd 0.3.0
  127. - added Patch14 to build with libwpd 0.3.0
  128. * Tue Jul 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-2
  129. - rebuild with poppler-0.26.2
  130. * Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.5-1
  131. - new upstream release
  132. - add BuildRequires: libwpg-devel
  133. - remove Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  134. * Sat May 03 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-5
  135. - rebuild with poppler-0.24.5
  136. - add Patch0 (inkscape-0.48.4-freetype-2.5.x.patch)
  137. * Sun Nov 10 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-4
  138. - rebuild with ImageMagick-6.8.7.5
  139. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-3
  140. - rebuild with poppler-0.24.2
  141. * Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-2
  142. - rebuild with ImageMagick-6.8.6.8
  143. * Mon Jul 15 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.4-1
  144. - new upstream release
  145. - remove Patch0 (inkscape-0.48.2-poppler_020.patch)
  146. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-2
  147. - rebuild with poppler-0.20.4
  148. - add Patch0 (inkscape-0.48.2-poppler_020.patch) from fedora
  149. - change BuildRequires: lcms2-devel instead of lcms-devel
  150. * Thu Apr 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.3.1-1
  151. - new upstream release
  152. * Sat Mar 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.2-2
  153. - rebuild with ImageMagick-6.7.5.10
  154. * Sat Feb 4 2012 TANAKA hiroaki <mosaicist@par.odn.ne.jp> 0.48.2-1
  155. - new upstream release
  156. * Sat May 28 2011 TANAKA hiroaki <mosaicist@par.odn.ne.jp>
  157. - add Requires: python-lxml,perl-XML-RegExp,perl-XML-DOM
  158. * Sat Mar 12 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48.1-1
  159. - new upstream release
  160. - built with poppler-0.16.3
  161. * Wed Oct 06 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.48.0-2
  162. - rebuild with poppler-0.14.2
  163. - add BuildRequires: popt-devel, ImageMagick-c++-devel
  164. * Sun Oct 3 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.48-1
  165. - new upstream release
  166. - rebuilt with ImageMagick-6.6.4.8
  167. * Thu Apr 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.47-3
  168. - added Patch0 for building with poppler-0.12.2+
  169. - rebuilt with new toolchain and ImageMagick-6.6.1.5
  170. - removed BR: libgnomeprint-devel, libgnomeprintui-devel
  171. * Fri Nov 27 2009 Shu KONNO <owa@bg.wakwak.com> 0.47-2
  172. - rebuild with poppler-0.12.1
  173. * Mon Nov 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-1
  174. - new upstream release
  175. - add BR: libboost-devel
  176. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0.1.pre2
  177. - update to 0.47pre2
  178. - drop obsolete patches
  179. - add BR: gsl-devel
  180. * Sat Dec 13 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.46-4
  181. - rebuild with poppler-0.10.2
  182. * Sun Oct 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-3
  183. - add Patch[1-6]
  184. * Sat Aug 23 2008 Shu KONNO <owa@bg.wakwak.com> 0.46-2vl5
  185. - added inkscape-0.46-poppler-0.8.3.patch
  186. - spec in utf-8
  187. - added option %%{?_smp_mflags} at make
  188. * Sun Apr 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.46-1vl5
  189. - new upstream release
  190. * Fri May 11 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45.1-0vl2
  191. - rebuild with new environment/toolchain
  192. * Mon Apr 30 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45.1-0vl1
  193. - new upstream release
  194. * Sun Mar 11 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.45-0vl2
  195. - add BuildRequires: lcms-devel >= 1.13, libxslt-devel >= 1.0.15
  196. - update required version of gtk2-devel
  197. * Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.45-0vl1
  198. - new upstream release
  199. * Sun Sep 24 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.44.1-0vl1
  200. - new upstream release
  201. * Wed Nov 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.43-0vl1
  202. - new upstream release
  203. * Tue Aug 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.2-0vl1
  204. - new upstream release
  205. * Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42.1-0vl1
  206. - new upstream release
  207. * Thu Aug 18 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.42-0vl1
  208. - new upstream release
  209. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.40-0vl1
  210. - new upstream release
  211. - add Japanese summary and description
  212. - fixed dependancy of libsigc++12 to libsigc++ >= 2.0
  213. * Tue Nov 16 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl2
  214. - fixed dependancy of libsigc++ to libsigc++12
  215. - fixed %files section
  216. * Wed Aug 25 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.39-1vl1
  217. - rebuild for Vine Linux
  218. - s/Copyright/License/
  219. - added Requires and BuildRequires
  220. * Sat Jul 17 2004 Bryce W. Harrington <bryce@bryceharrington.com>
  221. - Removing _libdir and TODO, updating description
  222. * Thu May 01 2003 Christian Schaller <uraeus@gnome.org>
  223. - Fix up the spec file for current release
  224. * Mon Sep 23 2002 Dag Wieers <dag@wieers.com>
  225. - Update to 0.2.6
  226. * Thu Sep 12 2002 Dag Wieers <dag@wieers.com>
  227. - Update to 0.2.5
  228. - Changed SPEC to benefit from macros