python-pillow-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577
  1. %global with_python3 1
  2. %global py3_incdir %(python3 -c 'import distutils.sysconfig; print(distutils.sysconfig.get_python_inc())')
  3. %global py3_libbuilddir %(python3 -c 'import sys; import sysconfig; print("lib.{p}-{v[0]}.{v[1]}".format(p=sysconfig.get_platform(), v=sys.version_info))')
  4. %global srcname pillow
  5. # bootstrap building docs (pillow is required by docutils, docutils are
  6. # required by sphinx; pillow build-requires sphinx)
  7. %global with_docs 0
  8. Name: python-%{srcname}
  9. Version: 7.2.0
  10. Release: 1%{?_dist_release}
  11. Summary: Python image processing library
  12. Group: Development/Libraries
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. # License: see http://www.pythonware.com/products/pil/license.htm
  16. License: MIT
  17. URL: http://python-pillow.github.io/
  18. Source0: https://github.com/python-pillow/Pillow/archive/%{version}/Pillow-%{version}.tar.gz
  19. BuildRequires: freetype2-devel
  20. BuildRequires: gcc
  21. BuildRequires: ghostscript
  22. BuildRequires: lcms2-devel
  23. #BuildRequires: libimagequant-devel
  24. BuildRequires: libjpeg-devel
  25. #BuildRequires: libraqm-devel
  26. BuildRequires: libtiff-devel
  27. BuildRequires: libwebp-devel
  28. BuildRequires: openjpeg2-devel
  29. BuildRequires: tk-devel
  30. BuildRequires: zlib-devel
  31. BuildRequires: python-devel
  32. BuildRequires: numpy
  33. #BuildRequires: python-olefile
  34. BuildRequires: python-setuptools
  35. %if 0%{?with_python3}
  36. BuildRequires: python3-rpm-macros
  37. BuildRequires: python3-cffi
  38. BuildRequires: python3-devel
  39. BuildRequires: python3-numpy
  40. #BuildRequires: python3-olefile
  41. BuildRequires: python3-qt5
  42. BuildRequires: python3-setuptools
  43. %if 0%{?with_docs}
  44. BuildRequires: python3-sphinx
  45. BuildRequires: python3-sphinx_rtd_theme
  46. %endif
  47. BuildRequires: python3-tkinter
  48. %endif
  49. %global __provides_exclude_from ^%{python3_sitearch}/PIL/.*\\.so$
  50. %description
  51. Python image processing library, fork of the Python Imaging Library (PIL)
  52. This library provides extensive file format support, an efficient
  53. internal representation, and powerful image processing capabilities.
  54. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  55. devel (development) and doc (documentation).
  56. %if 0%{?with_python3}
  57. %package -n python3-%{srcname}
  58. Summary: Python 3 image processing library
  59. Requires: ghostscript
  60. %{?python_provide:%python_provide python3-%{srcname}}
  61. Provides: python3-imaging = %{version}-%{release}
  62. %description -n python3-%{srcname}
  63. Python image processing library, fork of the Python Imaging Library (PIL)
  64. This library provides extensive file format support, an efficient
  65. internal representation, and powerful image processing capabilities.
  66. There are four subpackages: tk (tk interface), qt (PIL image wrapper for Qt),
  67. devel (development) and doc (documentation).
  68. %package -n python3-%{srcname}-devel
  69. Summary: Development files for %{srcname}
  70. Requires: python3-devel, libjpeg-devel, zlib-devel
  71. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  72. %{?python_provide:%python_provide python3-%{srcname}-devel}
  73. Provides: python3-imaging-devel = %{version}-%{release}
  74. %description -n python3-%{srcname}-devel
  75. Development files for %{srcname}.
  76. %package -n python3-%{srcname}-doc
  77. Summary: Documentation for %{srcname}
  78. BuildArch: noarch
  79. Requires: python3-%{srcname} = %{version}-%{release}
  80. %{?python_provide:%python_provide python3-%{srcname}-doc}
  81. Provides: python3-imaging-doc = %{version}-%{release}
  82. Obsoletes: python-%{srcname}-doc < 5.4.1-4
  83. %description -n python3-%{srcname}-doc
  84. Documentation for %{srcname}.
  85. %package -n python3-%{srcname}-tk
  86. Summary: Tk interface for %{srcname}
  87. Requires: python3-tkinter
  88. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  89. %{?python_provide:%python_provide python3-%{srcname}-tk}
  90. Provides: python3-imaging-tk = %{version}-%{release}
  91. %description -n python3-%{srcname}-tk
  92. Tk interface for %{name}.
  93. %package -n python3-%{srcname}-qt
  94. Summary: Qt %{srcname} image wrapper
  95. Requires: python3-qt5
  96. Requires: python3-%{srcname}%{?_isa} = %{version}-%{release}
  97. %{?python_provide:%python_provide python3-%{srcname}-qt}
  98. Provides: python3-imaging-qt = %{version}-%{release}
  99. %description -n python3-%{srcname}-qt
  100. Qt %{srcname} image wrapper.
  101. %endif
  102. %prep
  103. %autosetup -p1 -n Pillow-%{version}
  104. %build
  105. %if 0%{?with_python3}
  106. # Build Python 3 modules
  107. %py3_build
  108. %if 0%{?with_docs}
  109. PYTHONPATH=$PWD/build/%py3_libbuilddir make -C docs html BUILDDIR=_build_py3 SPHINXBUILD=sphinx-build-%python3_version
  110. rm -f docs/_build_py3/html/.buildinfo
  111. %endif
  112. %endif
  113. %install
  114. %if 0%{?with_python3}
  115. # Install Python 3 modules
  116. install -d %{buildroot}/%{py3_incdir}/Imaging
  117. install -m 644 src/libImaging/*.h %{buildroot}/%{py3_incdir}/Imaging
  118. %py3_install
  119. %endif
  120. %check
  121. %if 0%{?with_python3}
  122. # Check Python 3 modules
  123. ln -s $PWD/Images $PWD/build/%py3_libbuilddir/Images
  124. cp -R $PWD/Tests $PWD/build/%py3_libbuilddir/Tests
  125. cp -R $PWD/selftest.py $PWD/build/%py3_libbuilddir/selftest.py
  126. pushd build/%py3_libbuilddir
  127. PYTHONPATH=$PWD %{__python3} selftest.py
  128. popd
  129. %endif
  130. %if 0%{?with_python3}
  131. %files -n python3-%{srcname}
  132. %doc README.rst CHANGES.rst
  133. %license docs/COPYING
  134. %{python3_sitearch}/*
  135. # These are in subpackages
  136. %exclude %{python3_sitearch}/PIL/_imagingtk*
  137. %exclude %{python3_sitearch}/PIL/ImageTk*
  138. %exclude %{python3_sitearch}/PIL/SpiderImagePlugin*
  139. %exclude %{python3_sitearch}/PIL/ImageQt*
  140. %exclude %{python3_sitearch}/PIL/__pycache__/ImageTk*
  141. %exclude %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  142. %exclude %{python3_sitearch}/PIL/__pycache__/ImageQt*
  143. %files -n python3-%{srcname}-devel
  144. %{py3_incdir}/Imaging/
  145. %files -n python3-%{srcname}-doc
  146. %if 0%{?with_docs}
  147. %doc docs/_build_py3/html
  148. %endif
  149. %files -n python3-%{srcname}-tk
  150. %{python3_sitearch}/PIL/_imagingtk*
  151. %{python3_sitearch}/PIL/ImageTk*
  152. %{python3_sitearch}/PIL/SpiderImagePlugin*
  153. %{python3_sitearch}/PIL/__pycache__/ImageTk*
  154. %{python3_sitearch}/PIL/__pycache__/SpiderImagePlugin*
  155. %files -n python3-%{srcname}-qt
  156. %{python3_sitearch}/PIL/ImageQt*
  157. %{python3_sitearch}/PIL/__pycache__/ImageQt*
  158. %endif
  159. %changelog
  160. * Fri Jul 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 7.2.0-1
  161. - new upstream release.
  162. - dropped python2 support.
  163. * Wed Jan 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.2-1
  164. - new upstream release.
  165. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 6.2.0-3
  166. - initial build for Vine Linux.
  167. * Mon Oct 07 2019 Petr Viktorin <pviktori@redhat.com> - 6.2.0-2
  168. - Remove optional build dependency on python2-cffi
  169. * Tue Oct 01 2019 Sandro Mani <manisandro@gmail.com> - 6.2.0-1
  170. - Update to 6.2.0
  171. * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 6.1.0-4
  172. - Rebuilt for Python 3.8
  173. * Mon Aug 12 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-3
  174. - Drop python2-pillow-qt, python2-pillow-tk
  175. * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 6.1.0-2
  176. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  177. * Mon Jul 01 2019 Sandro Mani <manisandro@gmail.com> - 6.1.0-1
  178. - Update to 6.1.0
  179. * Fri May 31 2019 Elliott Sales de Andrade <quantum.analyst@gmail.com> - 6.0.0-2
  180. - Fix broken Python/C interop on s390x
  181. * Tue Apr 02 2019 Sandro Mani <manisandro@gmail.com> - 6.0.0-1
  182. - Update to 6.0.0
  183. * Sun Mar 10 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-4
  184. - Drop python2-pillow-doc
  185. * Mon Mar 04 2019 Yatin Karel <ykarel@redhat.com> - 5.4.1-3
  186. - Fix python3 conditional
  187. * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 5.4.1-2
  188. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  189. * Mon Jan 07 2019 Sandro Mani <manisandro@gmail.com> - 5.4.1-1
  190. - Update to 5.4.1
  191. * Mon Oct 01 2018 Sandro Mani <manisandro@gmail.com> - 5.3.0-1
  192. - Update to 5.3.0
  193. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.0-3
  194. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  195. * Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 5.2.0-2
  196. - Rebuilt for Python 3.7
  197. * Mon Jul 02 2018 Sandro Mani <manisandro@gmail.com> - 5.2.0-1
  198. - Update to 5.2.0
  199. * Wed Jun 27 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-3
  200. - Fix the tkinter dependency
  201. * Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 5.1.1-2
  202. - Rebuilt for Python 3.7
  203. * Wed Apr 25 2018 Sandro Mani <manisandro@gmail.com> - 5.1.1-1
  204. - Update to 5.1.1
  205. * Thu Apr 05 2018 Sandro Mani <manisandro@gmail.com> - 5.1.0-1
  206. - Update to 5.1.0
  207. * Wed Mar 07 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-3
  208. - Add missing BR: gcc
  209. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 5.0.0-2
  210. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  211. * Wed Jan 03 2018 Sandro Mani <manisandro@gmail.com> - 5.0.0-1
  212. - Update to 5.0.0
  213. * Tue Oct 03 2017 Sandro Mani <manisandro@gmail.com> - 4.3.0-1
  214. - Update to 4.3.0
  215. * Tue Sep 05 2017 Troy Dawson <tdawson@redhat.com> - 4.2.1-5
  216. - Cleanup spec file conditionals
  217. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-4
  218. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  219. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 4.2.1-3
  220. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  221. * Fri Jul 07 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.2.1-2
  222. - Rebuild due to bug in RPM (RHBZ #1468476)
  223. * Thu Jul 06 2017 Sandro Mani <manisandro@gmail.com> - 4.2.1-1
  224. - Update to 4.2.1
  225. * Sat Jul 01 2017 Sandro Mani <manisandro@gmail.com> - 4.2.0-1
  226. - Update to 4.2.0
  227. * Fri Apr 28 2017 Sandro Mani <manisandro@gmail.com> - 4.1.1-1
  228. - Update to 4.1.1
  229. * Wed Apr 05 2017 Sandro Mani <manisandro@gmail.com> - 4.1.0-1
  230. - Update to 4.1.0
  231. * Wed Feb 15 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-3
  232. - Fix some __pycache__ files in wrong subpackage (#1422606)
  233. * Wed Feb 01 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-2
  234. - Rebuild (libwebp)
  235. * Tue Jan 03 2017 Sandro Mani <manisandro@gmail.com> - 4.0.0-1
  236. - Update to 4.0.0
  237. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-3
  238. - Enable docs build
  239. * Mon Dec 12 2016 Miro Hrončok <mhroncok@redhat.com> - 3.4.2-2
  240. - Rebuild for Python 3.6
  241. * Wed Oct 19 2016 Sandro Mani <manisandro@gmail.com> - 3.4.2-1
  242. - Update to 3.4.2
  243. * Tue Oct 04 2016 Sandro Mani <manisandro@gmail.com> - 3.4.1-1
  244. - Update to 3.4.1
  245. * Mon Oct 03 2016 Sandro Mani <manisandro@gmail.com> - 3.4.0-1
  246. - Update to 3.4.0
  247. * Thu Aug 18 2016 Sandro Mani <manisandro@gmail.com> - 3.3.1-1
  248. - Update to 3.3.1
  249. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.3.0-2
  250. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  251. * Sat Jul 02 2016 Sandro Mani <manisandro@gmail.com> - 3.3.0-1
  252. - Update to 3.3.0
  253. - Modernize spec
  254. * Fri Apr 01 2016 Sandro Mani <manisandro@gmail.com> - 3.2.0-1
  255. - Update to 3.2.0
  256. * Wed Feb 10 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-3
  257. - Fix broken python3-pillow package description
  258. * Sun Feb 07 2016 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.1.1-2
  259. - Fix provides
  260. * Thu Feb 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.1-1
  261. - Update to 3.1.1
  262. - Fixes CVE-2016-0740, CVE-2016-0775
  263. * Mon Jan 11 2016 Toshio Kuratomi <toshio@fedoraproject.org> - 3.1.0-2
  264. - Fix executable files in doc package bringing in python 2 for the python3 doc
  265. packages
  266. * Mon Jan 04 2016 Sandro Mani <manisandro@gmail.com> - 3.1.0-1
  267. - Update to 3.1.0
  268. * Tue Dec 29 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-5
  269. - Build with docs
  270. * Mon Dec 28 2015 Igor Gnatenko <i.gnatenko.brain@gmail.com> - 3.0.0-4
  271. - Rebuilt for libwebp soname bump
  272. * Wed Oct 14 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-3
  273. - Rebuilt for Python3.5 rebuild with docs
  274. * Tue Oct 13 2015 Robert Kuska <rkuska@redhat.com> - 3.0.0-2
  275. - Rebuilt for Python3.5 rebuild without docs
  276. * Fri Oct 02 2015 Sandro Mani <manisandro@gmail.com> - 3.0.0-1
  277. - Update to 3.0.0
  278. * Wed Jul 29 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-2
  279. - Fix python3-pillow-tk Requires: tkinter -> python3-tkinter (#1248085)
  280. * Thu Jul 02 2015 Sandro Mani <manisandro@gmail.com> - 2.9.0-1
  281. - Update to 2.9.0
  282. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.8.2-2
  283. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  284. * Mon Jun 08 2015 Sandro Mani <manisandro@gmail.com> - 2.8.2-1
  285. - Update to 2.8.2
  286. * Thu Apr 02 2015 Sandro Mani <manisandro@gmail.com> - 2.8.1-1
  287. - Update to 2.8.1
  288. * Wed Apr 01 2015 Sandro Mani <manisandro@gmail.com> - 2.8.0-1
  289. - Update to 2.8.0
  290. * Mon Jan 12 2015 Sandro Mani <manisandro@gmail.com> - 2.7.0-1
  291. - Update to 2.7.0
  292. - Drop sane subpackage, is in python-sane now
  293. - Fix python3 headers directory
  294. - Drop Obsoletes: python3-pillow on python3-pillow-qt
  295. * Mon Oct 13 2014 Sandro Mani <manisandro@gmail.com> - 2.6.1-1
  296. - Update to 2.6.1
  297. * Thu Oct 02 2014 Sandro Mani <manisandro@gmail.com> - 2.6.0-1
  298. - Update to 2.6.0
  299. * Wed Aug 20 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-3
  300. - Rebuilding again to resolve transient build error that caused BZ#1131723
  301. * Tue Aug 19 2014 Stephen Gallagher <sgallagh@redhat.com> - 2.5.3-2
  302. - Rebuilding to resolve transient build error that caused BZ#1131723
  303. * Tue Aug 19 2014 Sandro Mani <manisandro@gmail.com> - 2.5.3-1
  304. - Update to 2.5.3 (Fix CVE-2014-3598, a DOS in the Jpeg2KImagePlugin)
  305. * Sun Aug 17 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.5.2-2
  306. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
  307. * Wed Aug 13 2014 Sandro Mani <manisandro@gmail.com> - 2.5.2-1
  308. - Update to 2.5.2 (Fix CVE-2014-3589, a DOS in the IcnsImagePlugin)
  309. * Sat Jul 26 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-2
  310. - Reenable jpeg2k tests on big endian arches
  311. * Tue Jul 15 2014 Sandro Mani <manisandro@gmail.com> - 2.5.1-1
  312. - Update to 2.5.1
  313. * Wed Jul 02 2014 Sandro Mani <manisandro@gmail.com> - 2.5.0-1
  314. - Update to 2.5.0
  315. * Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-11
  316. - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
  317. * Wed May 28 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-10
  318. - Rebuild with docs enabled
  319. - Update python-pillow_openjpeg-2.1.0.patch
  320. * Tue May 27 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-9
  321. - Rebuild against openjpeg-2.1.0
  322. * Fri May 23 2014 Dan Horák <dan[at]danny.cz> - 2.4.0-8
  323. - skip jpeg2k tests on big endian arches (#1100762)
  324. * Wed May 21 2014 Jaroslav Škarvada <jskarvad@redhat.com> - 2.4.0-7
  325. - Rebuilt for https://fedoraproject.org/wiki/Changes/f21tcl86
  326. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-6
  327. - Set with_docs to 1 to build docs.
  328. * Tue May 13 2014 Bohuslav Kabrda <bkabrda@redhat.com> - 2.4.0-5
  329. - Bootstrap building sphinx docs because of circular dependency with sphinx.
  330. * Fri May 9 2014 Orion Poplawski <orion@cora.nwra.com> - 2.4.0-4
  331. - Rebuild for Python 3.4
  332. * Tue Apr 22 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-3
  333. - Add patch: Have the tempfile use a suffix with a dot
  334. * Thu Apr 17 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-2
  335. - Enable Jpeg2000 support
  336. - Enable webp support also on s390* archs, bug #962091 is now fixed
  337. - Add upstream patch for ghostscript detection
  338. * Wed Apr 02 2014 Sandro Mani <manisandro@gmail.com> - 2.4.0-1
  339. - Update to 2.4.0
  340. * Wed Mar 19 2014 Sandro Mani <manisandro@gmail.com> - 2.3.1-1
  341. - Update to 2.3.1 (Fix insecure use of tempfile.mktemp (CVE-2014-1932 CVE-2014-1933))
  342. * Thu Mar 13 2014 Jakub Dorňák <jdornak@redhat.com> - 2.3.0-5
  343. - python-pillow does not provide python3-imaging
  344. (python3-pillow does)
  345. * Tue Jan 07 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-4
  346. - Add missing ghostscript Requires and BuildRequires
  347. * Mon Jan 06 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-3
  348. - Remove python-pillow_help-theme.patch, add python-sphinx-theme-better BR
  349. * Sun Jan 05 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-2
  350. - Rebuild with docs enabled
  351. - Change lcms BR to lcms2
  352. * Thu Jan 02 2014 Sandro Mani <manisandro@gmail.com> - 2.3.0-1
  353. - Update to 2.3.0
  354. - Build with doc disabled to break circular python-pillow -> python-sphinx -> python pillow dependency
  355. * Wed Oct 23 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-2
  356. - Backport fix for decoding tiffs with correct byteorder, fixes rhbz#1019656
  357. * Wed Oct 02 2013 Sandro Mani <manisandro@gmail.com> - 2.2.1-1
  358. - Update to 2.2.1
  359. - Really enable webp on ppc, but leave disabled on s390
  360. * Thu Aug 29 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-4
  361. - Add patch to fix incorrect PyArg_ParseTuple tuple signature, fixes rhbz#962091 and rhbz#988767.
  362. - Renable webp support on bigendian arches
  363. * Wed Aug 28 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-3
  364. - Add patch to fix memory corruption caused by invalid palette size, see rhbz#1001122
  365. * Tue Jul 30 2013 Karsten Hopp <karsten@redhat.com> 2.1.0-2
  366. - Build without webp support on ppc* archs (#988767)
  367. * Wed Jul 03 2013 Sandro Mani <manisandro@gmail.com> - 2.1.0-1
  368. - Update to 2.1.0
  369. - Run tests in builddir, not installroot
  370. - Build python3-pillow docs with python3
  371. - python-pillow_endian.patch upstreamed
  372. * Mon May 13 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-10
  373. - Build without webp support on s390* archs
  374. Resolves: rhbz#962059
  375. * Sat May 11 2013 Roman Rakus <rrakus@redhat.com> - 2.0.0-9.gitd1c6db8
  376. - Conditionaly disable build of python3 parts on RHEL system
  377. * Wed May 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-8.gitd1c6db8
  378. - Add patch to fix test failure on big-endian
  379. * Thu Apr 25 2013 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.0-7.gitd1c6db8
  380. - Remove Obsoletes in the python-pillow-qt subpackage. Obsoletes isn't
  381. appropriate since qt support didn't exist in the previous python-pillow
  382. package so there's no reason to drag in python-pillow-qt when updating
  383. python-pillow.
  384. * Fri Apr 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-6.gitd1c6db8
  385. - Update to latest git
  386. - python-pillow_quantization.patch now upstream
  387. - python-pillow_endianness.patch now upstream
  388. - Add subpackage for ImageQt module, with correct dependencies
  389. - Add PyQt4 and numpy BR (for generating docs / running tests)
  390. * Mon Apr 08 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-5.git93a488e
  391. - Reenable tests on bigendian, add patches for #928927
  392. * Sun Apr 07 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-4.git93a488e
  393. - Update to latest git
  394. - disable tests on bigendian (PPC*, S390*) until rhbz#928927 is fixed
  395. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-3.gitde210a2
  396. - python-pillow_tempfile.patch now upstream
  397. - Add python3-imaging provides (bug #924867)
  398. * Fri Mar 22 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-2.git2e88848
  399. - Update to latest git
  400. - Remove python-pillow-disable-test.patch, gcc is now fixed
  401. - Add python-pillow_tempfile.patch to prevent a temporary file from getting packaged
  402. * Tue Mar 19 2013 Sandro Mani <manisandro@gmail.com> - 2.0.0-1.git2f4207c
  403. - Update to 2.0.0 git snapshot
  404. - Enable python3 packages
  405. - Add libwebp-devel BR for Pillow 2.0.0
  406. * Wed Mar 13 2013 Peter Robinson <pbrobinson@fedoraproject.org> 1.7.8-6.20130305git
  407. - Add ARM support
  408. * Tue Mar 12 2013 Karsten Hopp <karsten@redhat.com> 1.7.8-5.20130305git
  409. - add s390* and ppc* to arch detection
  410. * Tue Mar 05 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-4.20130305git7866759
  411. - Update to latest git snapshot
  412. - 0001-Cast-hash-table-values-to-unsigned-long.patch now upstream
  413. - Pillow-1.7.8-selftest.patch now upstream
  414. * Mon Feb 25 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-3.20130210gite09ff61
  415. - Really remove -fno-strict-aliasing
  416. - Place comment on how to retreive source just above the Source0 line
  417. * Mon Feb 18 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-2.20130210gite09ff61
  418. - Rebuild without -fno-strict-aliasing
  419. - Add patch for upstream issue #52
  420. * Sun Feb 10 2013 Sandro Mani <manisandro@gmail.com> - 1.7.8-1.20130210gite09ff61
  421. - Initial RPM package