123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293 |
- Name: perl-Test-Refcount
- Version: 0.07
- Release: 1%{?_dist_release}
- Summary: Assert reference counts on objects
- Group: Development/Libraries
- License: GPL+ or Artistic
- URL: http://search.cpan.org/dist/Test-Refcount/
- Source0: http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Test-Refcount-%{version}.tar.gz
- BuildArch: noarch
- BuildRequires: perl(ExtUtils::MakeMaker)
- BuildRequires: perl(Devel::Refcount)
- BuildRequires: perl(Devel::FindRef)
- BuildRequires: perl(Test::Builder)
- BuildRequires: perl(Test::Builder::Tester)
- BuildRequires: perl(Test::More)
- BuildRequires: perl(Test::Pod)
- Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
- %description
- The Perl garbage collector uses simple reference counting during the normal
- execution of a program. This means that cycles or unweakened references in
- other parts of code can keep an object around for longer than intended. To
- help avoid this problem, the reference count of a new object from its class
- constructor ought to be 1. This way, the caller can know the object will be
- properly DESTROYed when it drops all of its references to it.
- %prep
- %setup -q -n Test-Refcount-%{version}
- %build
- %{__perl} Makefile.PL INSTALLDIRS=vendor
- make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- make pure_install PERL_INSTALL_ROOT=%{buildroot}
- find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
- %{_fixperms} %{buildroot}/*
- %check
- make test
- %clean
- rm -rf %{buildroot}
- %files
- %doc Changes LICENSE README
- %{perl_vendorlib}/Test
- %{_mandir}/man3/Test*.3*
- %changelog
- * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.07-1
- - initial build for Vine Linux
- * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.07-1
- - update to 0.07
- * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
- - Perl mass rebuild
- * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-3
- - 661697 rebuild for fixing problems with vendorach/lib
- * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-2
- - Mass rebuild with perl-5.12.0
- * Sun Dec 27 2009 Nicolas Chauvet <kwizart@fedoraproject.org> - 0.06-1
- - Update to 0.06
- - Remove workaround at make test for perl with debug - rhbz#514942
- * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.05-3
- - rebuild against perl 5.10.1
- * Fri Jul 31 2009 kwizart < kwizart at gmail.com > - 0.05-2
- - Add missing BR
- - Use %%{_fixperms}
- - Fix %%files section
- - Add comment about why it fails
- * Thu Jul 9 2009 kwizart < kwizart at gmail.com > - 0.05-1
- - Initial spec
|