perl-Test-Refcount-vl.spec 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293
  1. Name: perl-Test-Refcount
  2. Version: 0.07
  3. Release: 1%{?_dist_release}
  4. Summary: Assert reference counts on objects
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/Test-Refcount/
  8. Source0: http://search.cpan.org/CPAN/authors/id/P/PE/PEVANS/Test-Refcount-%{version}.tar.gz
  9. BuildArch: noarch
  10. BuildRequires: perl(ExtUtils::MakeMaker)
  11. BuildRequires: perl(Devel::Refcount)
  12. BuildRequires: perl(Devel::FindRef)
  13. BuildRequires: perl(Test::Builder)
  14. BuildRequires: perl(Test::Builder::Tester)
  15. BuildRequires: perl(Test::More)
  16. BuildRequires: perl(Test::Pod)
  17. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  18. %description
  19. The Perl garbage collector uses simple reference counting during the normal
  20. execution of a program. This means that cycles or unweakened references in
  21. other parts of code can keep an object around for longer than intended. To
  22. help avoid this problem, the reference count of a new object from its class
  23. constructor ought to be 1. This way, the caller can know the object will be
  24. properly DESTROYed when it drops all of its references to it.
  25. %prep
  26. %setup -q -n Test-Refcount-%{version}
  27. %build
  28. %{__perl} Makefile.PL INSTALLDIRS=vendor
  29. make %{?_smp_mflags}
  30. %install
  31. rm -rf %{buildroot}
  32. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  33. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  34. %{_fixperms} %{buildroot}/*
  35. %check
  36. make test
  37. %clean
  38. rm -rf %{buildroot}
  39. %files
  40. %doc Changes LICENSE README
  41. %{perl_vendorlib}/Test
  42. %{_mandir}/man3/Test*.3*
  43. %changelog
  44. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.07-1
  45. - initial build for Vine Linux
  46. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.07-1
  47. - update to 0.07
  48. * Tue Jun 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.06-5
  49. - Perl mass rebuild
  50. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.06-4
  51. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  52. * Wed Dec 22 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-3
  53. - 661697 rebuild for fixing problems with vendorach/lib
  54. * Fri May 07 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.06-2
  55. - Mass rebuild with perl-5.12.0
  56. * Sun Dec 27 2009 Nicolas Chauvet <kwizart@fedoraproject.org> - 0.06-1
  57. - Update to 0.06
  58. - Remove workaround at make test for perl with debug - rhbz#514942
  59. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.05-3
  60. - rebuild against perl 5.10.1
  61. * Fri Jul 31 2009 kwizart < kwizart at gmail.com > - 0.05-2
  62. - Add missing BR
  63. - Use %%{_fixperms}
  64. - Fix %%files section
  65. - Add comment about why it fails
  66. * Thu Jul 9 2009 kwizart < kwizart at gmail.com > - 0.05-1
  67. - Initial spec