pandoc-crossref-vl.spec 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140
  1. %define pkg_name pandoc-crossref
  2. %define pkg_version 0.3.2.1
  3. %define pkg_release 1%{?_dist_release}
  4. %define pandoc_version 2.2.2
  5. Summary: Library and executable for using citeproc with pandoc
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: BSD3
  10. Group: Applications/Text
  11. URL: http://hackage.haskell.org
  12. Source0: packages
  13. Source11: ansi-wl-pprint-0.6.8.2.tar.gz
  14. Source12: ansi-wl-pprint.cabal
  15. Source13: base-unicode-symbols-0.2.2.4.tar.gz
  16. Source14: base-unicode-symbols.cabal
  17. Source15: data-accessor-0.2.2.7.tar.gz
  18. Source16: data-accessor.cabal
  19. Source17: open-browser-0.2.1.0.tar.gz
  20. Source18: open-browser.cabal
  21. Source19: utility-ht-0.0.14.tar.gz
  22. Source20: utility-ht.cabal
  23. Source21: optparse-applicative-0.14.2.0.tar.gz
  24. Source22: optparse-applicative.cabal
  25. Source23: roman-numerals-0.5.1.5.tar.gz
  26. Source24: roman-numerals.cabal
  27. Source25: data-accessor-transformers-0.2.1.7.tar.gz
  28. Source26: data-accessor-transformers.cabal
  29. Source27: data-accessor-template-0.2.1.15.tar.gz
  30. Source28: data-accessor-template.cabal
  31. Source29: pandoc-crossref-0.3.2.1.tar.gz
  32. Source30: pandoc-crossref.cabal
  33. BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
  34. BuildRequires: libffi-devel gmp-devel zlib-devel
  35. BuildRequires: ghc haskell-platform
  36. BuildRequires: pandoc-libs = %{pandoc_version}
  37. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  38. Requires: pandoc = %{pandoc_version}
  39. Vendor: Project Vine
  40. Distribution: Vine Linux
  41. Packager: ara_t
  42. %description
  43. pandoc-crossref is a pandoc filter for numbering figures, equations, tables
  44. and cross-references to them. Input file (like demo.md) can be converted into
  45. html, latex, pdf, md or other formats.
  46. Optionally, you can use cleveref for latex/pdf output,
  47. e.g. cleveref pdf, cleveref latex, and listings package,
  48. e.g. listings pdf, listings latex.
  49. You can also enable per-chapter numbering (as with --chapters for latex output).
  50. You need to specify -M chapters for non-latex/pdf output however.
  51. Examples: html, markdown, latex, pdf.
  52. %prep
  53. %{__rm} -rf ${RPM_BUILD_ROOT}
  54. %build
  55. %ghc_pkg_init
  56. cd %{_builddir}
  57. for pkg in `sed '$d' %{SOURCE0}`; do
  58. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  59. pushd ${pkg}
  60. %ghc_fix_dependencies ${pkg}
  61. %{__cabal} configure
  62. %{__cabal} build
  63. %{__cabal} copy
  64. %{__cabal} register --inplace
  65. popd
  66. done
  67. for pkg in `tail -n 1 %{SOURCE0}`; do
  68. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  69. pushd ${pkg}
  70. %ghc_fix_dependencies ${pkg}
  71. %cabal_configure1 ${pkg}
  72. %cabal_build
  73. %cabal_haddock
  74. %cabal_copy_resister ${pkg}
  75. popd
  76. done
  77. %install
  78. %{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}
  79. %clean
  80. %{__rm} -rf ${RPM_BUILD_ROOT}
  81. %files
  82. %defattr(-, root, root)
  83. %{_bindir}/pandoc-crossref
  84. %{_datadir}/%{name}-%{version}/
  85. %{_docdir}/%{name}-%{version}/
  86. %changelog
  87. * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 0.3.2.1-1
  88. - update to 0.3.2.1
  89. - build using ghc-8.4.3 and pandoc-2.2.2
  90. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.3.2.0-1
  91. - update to 0.3.2.0
  92. - rebuild using ghc-8.4.2 and pandoc-2.2.1
  93. - rewrite using macro
  94. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.3.0.0-1
  95. - update to 0.3.0.0
  96. - build using ghc-8.2.2
  97. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.2.4.2-2
  98. - rebuild using ghc-8.0.2
  99. * Thu Feb 02 2017 Toshiaki Ara <ara_t@384.jp> 0.2.4.2-1
  100. - update to 0.2.4.2
  101. - rebuild using ghc-8.0.1
  102. * Sun Jun 19 2016 Toshiaki Ara <ara_t@384.jp> 0.2.1.3-2
  103. - rebuild under pandoc-1.17.1
  104. * Sun Jun 05 2016 Toshiaki Ara <ara_t@384.jp> 0.2.1.3-1
  105. - update to 0.2.1.3
  106. * Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 0.2.1.1-1
  107. - new package (devide from pandoc)