mariadb-vl.spec 27 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793
  1. %define mysqld_user mysql
  2. %define mysqld_group mysql
  3. %define mysqldatadir /var/lib/mysql
  4. # Working around perl dependency problem
  5. %global __perl_requires %{SOURCE998}
  6. %global __perllib_requires %{SOURCE998}
  7. %define _unpackaged_files_terminate_build 1
  8. %define mariadb_base_version 10.0
  9. %define mariadb_version 10.0.11
  10. %define client_version 18
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: tomop
  14. Name: mariadb
  15. Summary: MariaDB: a very fast and robust SQL database server
  16. Version: %{mariadb_version}
  17. Release: 1%{_dist_release}
  18. Group: Applications/Databases
  19. License: GPL2
  20. URL: http://www.mariadb.org/
  21. Source: mariadb-%{version}.tar.gz
  22. # Don't depend on lib::mtr*
  23. Source998: perl-requires.sh
  24. Source1000: macros.mariadb.in
  25. Patch0: mysql-5.5.15-jp-all.patch
  26. Patch100: mysql-srv_buf_size.patch
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  28. BuildRequires: bison, cmake, gcc-c++, groff
  29. BuildRequires: libaio-devel, libboost-devel, libevent-devel, libxml2-devel
  30. BuildRequires: ncurses-devel, perl, openssl-devel, readline-devel
  31. BuildRequires: zlib-devel
  32. Requires: fileutils sh-utils
  33. Provides: msqlormysql MySQL mysql
  34. Obsoletes: mysql MySQL5
  35. # From the manual
  36. %description
  37. MariaDB: a very fast and robust SQL database server
  38. It is GPL v2 licensed, which means you can use the it free of charge under the
  39. conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
  40. MariaDB documentation can be found at http://kb.askmonty.org/
  41. MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
  42. %package server
  43. Release: %{release}
  44. Summary: MariaDB: a very fast and robust SQL database server
  45. Group: Applications/Databases
  46. Requires: fileutils sh-utils net-tools mariadb-common
  47. Requires(post): mariadb-common
  48. Provides: mysql-server mysql MySQL MySQL-server mariadbserver-%{mariadb_base_version}
  49. Obsoletes: MySQL mysql mysql-server
  50. Obsoletes: MySQL-server < 5.6.0
  51. %description server
  52. MariaDB: a very fast and robust SQL database server
  53. It is GPL v2 licensed, which means you can use the it free of charge under the
  54. conditions of the GNU General Public License Version 2 (http://www.gnu.org/licenses/).
  55. MariaDB documentation can be found at http://kb.askmonty.org/
  56. MariaDB bug reports should be submitted through https://mariadb.atlassian.net/
  57. %package client
  58. Summary: MariaDB - Client
  59. Group: Applications/Databases
  60. Obsoletes: mysql-client MySQL-client < 5.6.0
  61. Provides: mysql-client MySQL-client mariadbclient-%{mariadb_base_version}
  62. %description client
  63. This package contains the standard MariaDB clients and administration tools.
  64. %package devel
  65. Summary: MariaDB - Development libraries and headers
  66. Group: Development/Libraries
  67. Requires: %{name}-static, openssl-devel, zlib-devel
  68. Conflicts: MySQL-devel < 5.6.0
  69. Conflicts: libmysqlclient-devel
  70. %description devel
  71. This package contains the development libraries and headers to develop
  72. MariaDB server components (e.g. plugins or embedded applications).
  73. %package static
  74. Summary: MariaDB - static libraries
  75. Group: Development/Libraries
  76. Requires: %{name}-devel
  77. %description static
  78. This package provides static libraries of MariaDB.
  79. %package source
  80. Summary: MariaDB - Source
  81. Group: Development/Libraries
  82. Requires: mariadb-devel = %{version}-%{release}
  83. Obsoletes: MySQL-source < 5.6.0
  84. AutoReqProv: no
  85. %description source
  86. This package contains the sources files of MariaDB.
  87. %package test
  88. Requires: %{name}-client = %{version}-%{release} perl-DBI perl
  89. Summary: MariaDB - Test suite
  90. Group: Applications/Databases
  91. Obsoletes: mysql-bench MySQL5-bench MySQL-bench MySQL-test < 5.6.0
  92. Provides: perl(mtr_misc.pl)
  93. %description test
  94. This package contains the MariaDB regression test suite.
  95. %package embedded
  96. Summary: MariaDB as an embeddable library
  97. Group: System Environment/Libraries
  98. Obsoletes: mysql-embedded MySQL-embedded
  99. Provides: mysql-embedded MySQL-embedded
  100. %description embedded
  101. This package contains a version of the MariaDB server that can be embedded
  102. into a client application instead of running as a separate process.
  103. %prep
  104. %setup -q
  105. #%patch0 -p1 -b .jp
  106. %patch100 -p1 -b .srv_buf_size
  107. %build
  108. # Be strict about variables, bail at earliest opportunity, etc.
  109. set -eu
  110. # Optional package files
  111. touch optional-files-devel
  112. export CFLAGS=${MYSQL_BUILD_CFLAGS:-${CFLAGS:-$RPM_OPT_FLAGS}}
  113. export CXXFLAGS=${MYSQL_BUILD_CXXFLAGS:-${CXXFLAGS:-$RPM_OPT_FLAGS -felide-constructors -fno-exceptions -fno-rtti}}
  114. # Build full release
  115. mkdir release
  116. (
  117. cd release
  118. cmake ../ \
  119. -DINSTALL_LAYOUT=RPM \
  120. -DBUILD_CONFIG=mysql_release \
  121. -DCMAKE_BUILD_TYPE=Release \
  122. -DINSTALL_UNIX_ADDRDIR="/var/lib/mysql/mysql.sock" \
  123. -DMANUFACTURER="Vine Linux" \
  124. -DCOMPILATION_COMMENT="Vine Linux MariaDB RPM" \
  125. -DWITH_PIC="ON" \
  126. -DWITH_EMBEDDED_SERVER="ON" \
  127. -DWITH_ZLIB="system" \
  128. -DWITH_LIBEVENT="system" \
  129. -DWITH_LOCALES="yes" \
  130. -DWITH_UNIT_TESTS="no" \
  131. -DWITH_CONNECT_STORAGE_ENGINE="ON" \
  132. -DWITH_SEQUENCE_STORAGE_ENGINE="ON" \
  133. -DWITH_XTRADB_STORAGE_ENGINE="ON" \
  134. -DWITHOUT_TOKUDB=1
  135. # -DWITH_PCRE="system"
  136. echo BEGIN_NORMAL_CONFIG ; egrep '^#define' include/config.h ; echo END_NORMAL_CONFIG
  137. make %{?_smp_mflags} VERBOSE=1
  138. )
  139. %install
  140. rm -rf %{buildroot}
  141. install -d %{buildroot}%{mysqldatadir}/mysql
  142. install -d %{buildroot}%{_infodir}
  143. # Install all binaries
  144. (
  145. cd release
  146. make DESTDIR=%{buildroot} install
  147. )
  148. install -m 0644 Docs/mysql.info %{buildroot}%{_infodir}
  149. rm -rf ./doc
  150. mv -f %{buildroot}%{_docdir} ./
  151. mkdir -p %{buildroot}%{_datadir}/%{name}-source
  152. pushd %{buildroot}%{_datadir}/%{name}-source
  153. tar zxf %{SOURCE0}
  154. find %{buildroot}%{_datadir}/%{name}-source -type f -exec chmod ugo-x {} \;
  155. popd
  156. install -d %{buildroot}%{_sysconfdir}/rpm
  157. sed -e 's/@BASEVERSION@/%{mariadb_base_version}/' -e 's/@VERSION@/%{version}/' -e 's/@RELEASE@/%{release}/' < %{SOURCE1000} > %{buildroot}%{_sysconfdir}/rpm/macros.mariadb
  158. rm -f %{buildroot}%{_mandir}/man1/mysql_fix_privilege_tables.1*
  159. rm -f %{buildroot}%{_mandir}/man8/mysqlmanager.8*
  160. rm -f %{buildroot}%{_sysconfdir}/my.cnf
  161. rm -f %{buildroot}%{_sysconfdir}/my.cnf.d/client.cnf
  162. rm -f %{buildroot}%{_libdir}/libmysqlclient*.so*
  163. rm -f %{buildroot}%{_libdir}/mysql/plugin/daemon_example.ini
  164. # force linking statically.
  165. perl -pi -e 's,-lmysqlclient_r,%{_libdir}/libmysqlclient_r.a,' %{buildroot}%{_bindir}/mysql_config
  166. perl -pi -e 's,-lmysqlclient,%{_libdir}/libmysqlclient.a,' %{buildroot}%{_bindir}/mysql_config
  167. ##############################################################################
  168. %pre server
  169. # Create a MySQL user and group. Do not report any problems if it already
  170. # exists.
  171. datadir=/var/lib/mysql
  172. groupadd -r mysql 2> /dev/null || true
  173. useradd -M -r -d $datadir -s /bin/bash -c "MySQL server" -g mysql mysql 2> /dev/null || true
  174. # The user may already exist, make sure it has the proper group nevertheless (BUG#12823)
  175. usermod -g mysql mysql 2> /dev/null || true
  176. %post server
  177. # Make MySQL start/shutdown automatically when the machine does it.
  178. if [ $1 = 1 ] ; then
  179. if [ -x /sbin/chkconfig ] ; then
  180. /sbin/chkconfig --add mysql
  181. fi
  182. basedir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--basedir=//p'|tail -1`
  183. if [ -z "$basedir" ] ; then
  184. basedir=/usr
  185. fi
  186. datadir=`/usr/bin/my_print_defaults --mysqld|sed -ne 's/^--datadir=//p'|tail -1`
  187. if [ -z "$datadir" ] ; then
  188. datadir=/var/lib/mysql
  189. else
  190. # datadir may be relative to a basedir!
  191. if ! expr $datadir : / > /dev/null; then
  192. datadir=$basedir/$datadir
  193. fi
  194. fi
  195. # Change permissions so that the user that will run the MySQL daemon
  196. # owns all database files.
  197. chown -R mysql:mysql $datadir
  198. if [ ! -e $datadir/mysql ]; then
  199. # Create data directory
  200. mkdir -p $datadir/{mysql,test}
  201. # Initiate databases
  202. /usr/bin/mysql_install_db --rpm --user=mysql
  203. fi
  204. # Change permissions again to fix any new files.
  205. chown -R mysql:mysql $datadir
  206. # Fix permissions for the permission database so that only the user
  207. # can read them.
  208. chmod -R og-rw $datadir/mysql
  209. fi
  210. %preun server
  211. if [ $1 = 0 ] ; then
  212. # Stop MySQL before uninstalling it
  213. if [ -x /etc/init.d/mysql ] ; then
  214. /etc/init.d/mysql stop > /dev/null
  215. fi
  216. # Don't start it automatically anymore
  217. if [ -x /sbin/chkconfig ] ; then
  218. /sbin/chkconfig --del mysql
  219. fi
  220. fi
  221. %postun server
  222. if [ $1 -ge 1 ]; then
  223. if [ -x /etc/init.d/mysql ] ; then
  224. # only restart the server if it was alredy running
  225. /etc/init.d/mysql status > /dev/null 2>&1 && \
  226. /etc/init.d/mysql restart
  227. fi
  228. fi
  229. # Clean up the BuildRoot
  230. %clean
  231. [ "$RPM_BUILD_ROOT" != "/" ] && [ -d $RPM_BUILD_ROOT ] && rm -rf $RPM_BUILD_ROOT;
  232. %files server
  233. %defattr(-,root,root)
  234. %doc doc/*
  235. %doc release/support-files/my-*.cnf
  236. %doc %{_infodir}/mysql.info*
  237. %doc %{_mandir}/man1/innochecksum.1*
  238. %doc %{_mandir}/man1/my_print_defaults.1*
  239. %doc %{_mandir}/man1/myisam_ftdump.1*
  240. %doc %{_mandir}/man1/myisamchk.1*
  241. %doc %{_mandir}/man1/myisamlog.1*
  242. %doc %{_mandir}/man1/myisampack.1*
  243. %doc %{_mandir}/man1/mysql_convert_table_format.1*
  244. %doc %{_mandir}/man1/mysql_fix_extensions.1*
  245. %doc %{_mandir}/man8/mysqld.8*
  246. %doc %{_mandir}/man1/mysqld_multi.1*
  247. %doc %{_mandir}/man1/mysqld_safe.1*
  248. %doc %{_mandir}/man1/mysqldumpslow.1*
  249. %doc %{_mandir}/man1/mysql_install_db.1*
  250. %doc %{_mandir}/man1/mysql_plugin.1*
  251. %doc %{_mandir}/man1/mysql_secure_installation.1*
  252. %doc %{_mandir}/man1/mysql_setpermission.1*
  253. %doc %{_mandir}/man1/mysql_upgrade.1*
  254. %doc %{_mandir}/man1/mysqlhotcopy.1*
  255. %doc %{_mandir}/man1/mysqlman.1*
  256. %doc %{_mandir}/man1/mysql.server.1*
  257. %doc %{_mandir}/man1/mysqltest.1*
  258. %doc %{_mandir}/man1/mysql_tzinfo_to_sql.1*
  259. %doc %{_mandir}/man1/mysql_zap.1*
  260. %doc %{_mandir}/man1/mysqlbug.1*
  261. %doc %{_mandir}/man1/perror.1*
  262. %doc %{_mandir}/man1/replace.1*
  263. %doc %{_mandir}/man1/resolve_stack_dump.1*
  264. %doc %{_mandir}/man1/resolveip.1*
  265. %{_bindir}/aria_*
  266. %{_bindir}/innochecksum
  267. %{_bindir}/my_print_defaults
  268. %{_bindir}/myisam_ftdump
  269. %{_bindir}/myisamchk
  270. %{_bindir}/myisamlog
  271. %{_bindir}/myisampack
  272. %{_bindir}/mysql_convert_table_format
  273. %{_bindir}/mysql_fix_extensions
  274. %{_bindir}/mysql_install_db
  275. %{_bindir}/mysql_plugin
  276. %{_bindir}/mysql_secure_installation
  277. %{_bindir}/mysql_setpermission
  278. %{_bindir}/mysql_tzinfo_to_sql
  279. %{_bindir}/mysql_upgrade
  280. %{_bindir}/mysql_zap
  281. %{_bindir}/mysqlbug
  282. %{_bindir}/mysqld_multi
  283. %{_bindir}/mysqld_safe
  284. %{_bindir}/mysqldumpslow
  285. %{_bindir}/mysqlhotcopy
  286. %{_bindir}/mysqltest
  287. %{_bindir}/perror
  288. %{_bindir}/replace
  289. %{_bindir}/resolve_stack_dump
  290. %{_bindir}/resolveip
  291. #%{_bindir}/tokuftdump
  292. %{_sbindir}/mysqld
  293. %{_libdir}/mysql
  294. %config(noreplace) %{_sysconfdir}/my.cnf.d/server.cnf
  295. #%config(noreplace) %{_sysconfdir}/my.cnf.d/tokudb.cnf
  296. %config(noreplace,missingok) %{_sysconfdir}/logrotate.d/mysql
  297. %{_sysconfdir}/init.d/mysql
  298. %{_datadir}/mysql
  299. %attr(755, mysql, mysql) %dir %{mysqldatadir}
  300. %files client
  301. %defattr(-, root, root)
  302. %config(noreplace) %{_sysconfdir}/my.cnf.d/mysql-clients.cnf
  303. %{_bindir}/msql2mysql
  304. %{_bindir}/mysql
  305. %{_bindir}/mysql_find_rows
  306. %{_bindir}/mysql_waitpid
  307. %{_bindir}/mysqlaccess
  308. %{_bindir}/mysqladmin
  309. %{_bindir}/mysqlbinlog
  310. %{_bindir}/mysqlcheck
  311. %{_bindir}/mysqldump
  312. %{_bindir}/mysqlimport
  313. %{_bindir}/mysqlshow
  314. %{_bindir}/mysqlslap
  315. %{_bindir}/mytop
  316. %doc %{_mandir}/man1/msql2mysql.1*
  317. %doc %{_mandir}/man1/mysql.1*
  318. %doc %{_mandir}/man1/mysql_find_rows.1*
  319. %doc %{_mandir}/man1/mysql_waitpid.1*
  320. %doc %{_mandir}/man1/mysqlaccess.1*
  321. %doc %{_mandir}/man1/mysqladmin.1*
  322. %doc %{_mandir}/man1/mysqlbinlog.1*
  323. %doc %{_mandir}/man1/mysqlcheck.1*
  324. %doc %{_mandir}/man1/mysqldump.1*
  325. %doc %{_mandir}/man1/mysqlimport.1*
  326. %doc %{_mandir}/man1/mysqlshow.1*
  327. %doc %{_mandir}/man1/mysqlslap.1*
  328. %files devel -f optional-files-devel
  329. %defattr(-, root, root)
  330. %doc %{_mandir}/man1/mysql_config.1*
  331. %{_bindir}/mysql_config
  332. %{_includedir}/mysql
  333. %{_datadir}/aclocal/mysql.m4
  334. %{_libdir}/*.so
  335. %{_sysconfdir}/rpm/*
  336. %{_bindir}/mysql_embedded
  337. %files static
  338. %defattr(-,root,root)
  339. %{_libdir}/lib*.a
  340. %files source
  341. %defattr(-, root, root)
  342. %{_datadir}/mariadb-source
  343. %files test
  344. %defattr(-, root, root)
  345. %attr(-, root, root) %{_datadir}/mysql-test
  346. %{_bindir}/mysql_client_test
  347. %{_bindir}/mysql_client_test_embedded
  348. %{_bindir}/mysqltest_embedded
  349. %doc %{_mandir}/man1/mysql_client_test.1*
  350. %doc %{_mandir}/man1/mysql-stress-test.pl.1*
  351. %doc %{_mandir}/man1/mysql-test-run.pl.1*
  352. %doc %{_mandir}/man1/mysql_client_test_embedded.1*
  353. %doc %{_mandir}/man1/mysqltest_embedded.1*
  354. %files embedded
  355. %defattr(-,root,root)
  356. %{_libdir}/libmysqld.so.*
  357. %changelog
  358. * Sat May 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.11-1
  359. - new upstream release.
  360. * Sun Apr 13 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-2
  361. - fixed Conflicts: and Obsoletes:.
  362. * Mon Mar 31 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.10-1
  363. - new upstream release.
  364. * Mon Mar 24 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.9-1
  365. - new upstream release.
  366. * Tue Feb 11 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.8-1
  367. - new upstream release.
  368. * Sat Dec 07 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-2
  369. - removed duplicated files.
  370. * Wed Dec 04 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 10.0.6-1
  371. - switched to MariaDB.
  372. * Wed Feb 20 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.30-1
  373. - new upstream release.
  374. * Fri Nov 16 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.28-1
  375. - new upstream release.
  376. * Sat Sep 15 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.27-1
  377. - new upstream release.
  378. - added a sub-package 'MySQL-source".
  379. - added some macros for rpm.
  380. * Thu Jun 21 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.25-1
  381. - new upstream release.
  382. * Thu May 10 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.24-1
  383. - new upstream release.
  384. * Tue May 01 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.23-1
  385. - new upstream release.
  386. - added "Vendor:" and "Distribution:" tag.
  387. * Tue Aug 23 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.5.15-1
  388. - new upstream release.
  389. - removed NDB cluster support.
  390. * Mon Apr 18 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-3
  391. - Added "BR: zlib-devel" to MySQL-devel.
  392. * Sun Apr 03 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-2
  393. - Added "BR: openssl-devel" to MySQL-devel.
  394. * Fri Mar 11 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.56-1
  395. - new upstream release.
  396. * Mon Jan 10 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.54-1
  397. - new upstream release.
  398. - updated jp-patch.
  399. - added ssl support.
  400. * Sat Nov 06 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.52-1
  401. - new upstream release.
  402. - replaced '%%__find_requires' to '%%__perl_requires'.
  403. - updated jp-patch.
  404. * Fri Oct 29 2010 Shu KONNO <owa@bg.wakwak.com> 5.1.44-3
  405. - added mysql-5.1.44-lib64.patch (on x86_64)
  406. - added -fPIC (on x86_64)
  407. * Sun Oct 17 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.1.44-2
  408. - made embedded package again
  409. * Fri Mar 05 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.44-1
  410. - new upstream release.
  411. - updated jp-patch.
  412. * Thu Feb 04 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-2
  413. - VineSeed: rebuilt with new toolchain.
  414. * Wed Feb 03 2010 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.43-1
  415. - new upstream release.
  416. - fixed CVE-2009-4484.
  417. * Fri Nov 20 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.41-1
  418. - new upstream release.
  419. * Thu Nov 19 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-2
  420. - added net-tools to 'Requires'.
  421. - added groff to 'BuildRequires'.
  422. - renamed subpackage 'MySQL-shared' to 'libmysqlclient16' (VineSeed only).
  423. * Tue Nov 10 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.40-1
  424. - new upstream release.
  425. * Sat Sep 26 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.39-1
  426. - new upstream release.
  427. * Sun Jul 5 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.36-1
  428. - new upstream release.
  429. - dropped %%Patch100 (fixed in upstream).
  430. * Sat Jun 6 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.35-1
  431. - new upstream release.
  432. - add %%Patch100 (no longer needed for MySQL-5.1.36 or later).
  433. * Thu May 21 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.1.34-1
  434. - new upstream release.
  435. - rename 'MySQL-bench' to 'MySQL-test'.
  436. - update Patch0.
  437. - change default charset to 'utf8'.
  438. * Sat Apr 12 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.51a-1
  439. - new upstream release.
  440. - update Patch0.
  441. - add "--with-client-charset=ujis".
  442. - sync %%files to official RPM.
  443. - remove MySQL-Max.
  444. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl7
  445. - for VineSeed
  446. * Thu Dec 13 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.0.27-0vl6
  447. - move shared library from /usr/lib/ to /usr/lib/mysql/
  448. - add /etc/ld.so.conf.d/*.conf
  449. - fix broken libmysqlcient*.la files (or should we remove them permanently?)
  450. * Sat Jun 16 2007 IWAI, Masaharu <iwai@alib.jp> 5.0.27-0vl5
  451. - rebuild <BTS:VineLinux:534>
  452. * Mon Nov 13 2006 NAKAMURA Kenta <kenta@vinelinux.org> 5.0.27-0vl4
  453. - added -fPIC
  454. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl3
  455. - fixed dependency. <BTS:338>
  456. * Mon Oct 30 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl2
  457. - add %%Patch1. <BTS:320>
  458. * Sat Oct 28 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.27-0vl1
  459. - new upstream release.
  460. * Fri Oct 27 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.26-0vl1
  461. - new upstream release.
  462. * Sat Jun 3 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.22-0vl1
  463. - new upstream release.
  464. * Sat May 13 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl1
  465. - release++.
  466. * Wed May 10 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 5.0.21-0vl0
  467. - new upstream release.
  468. - for VineSeed.
  469. * Wed Feb 8 2006 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.16-0vl0
  470. - new upstream release.
  471. - replace Patch0 for MySQL-4.1.16.
  472. * Thu Oct 6 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 4.1.14-0vl0
  473. - new upstream release.
  474. - add Patch0.
  475. * Tue Sep 6 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.25-0vl0
  476. - new upstream version
  477. -- mysql-4.0.25
  478. * Fri Jan 21 2005 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.23-0vl0
  479. - new upstream version
  480. -- mysql-4.0.23
  481. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.22-0vl0
  482. - new upstream version
  483. -- mysql-4.0.22
  484. * Tue Sep 28 2004 Takeyuki FUJIOKA <fuji@ftserve.net> 4.0.21-0vl1
  485. - new upstream version
  486. -- mysql-4.0.21
  487. * Fri May 21 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.20-0vl1
  488. - new upstream version
  489. -- mysql-4.0.20
  490. * Tue May 04 2004 Tomoya TAKA <taka@vinelinux.org> 4.0.18-0vl2
  491. - modify CFLAGS, CXXFLAGS and configure options for alpha
  492. * Tue Mar 23 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.18-0vl1
  493. - Upgraded to MySQL-4
  494. - added "with-charset=ujis" and "without-readline" to configure (vineseed-plus-02150)
  495. - merged to MySQL Official packages
  496. -- renamed package "MySQL" to "MySQL-server"
  497. -- when using gcc, _always_ use CXX=gcc
  498. -- replaced Copyright with License field (Copyright is obsolete)
  499. -- added myisam_ftdump to the Server package
  500. -- marked /etc/logrotate.d/mysql as a config file (BUG 2156)
  501. -- fixed file permissions (BUG 1672)
  502. -- removed dependency on MySQL-client from the MySQL-devel subpackage
  503. -- as it is not really required. (BUG 1610)
  504. -- Fixed BUG 1162 (removed macro names from the changelog)
  505. -- Really fixed BUG 998 (disable the checking for installed but
  506. -- unpackaged files)
  507. -- Fixed BUG 959 (libmysqld not being compiled properly)
  508. -- Fixed BUG 998 (RPM build errors): added missing files to the
  509. -- distribution (mysql_fix_extensions, mysql_tableinfo, mysqldumpslow,
  510. -- mysql_fix_privilege_tables.1), removed "-n" from install section.
  511. -- removed the GIF Icon (file was not included in the sources anyway)
  512. -- removed unused variable shared_lib_version
  513. -- do not run automake before building the standard binary
  514. -- (should not be necessary)
  515. -- add server suffix '-standard' to standard binary (to be in line
  516. -- with the binary tarball distributions)
  517. -- allow overriding CC and CXX (required when building
  518. -- with other compilers)
  519. * Mon Apr 14 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.23.56-0vl5
  520. - added BuildRequires: automake16
  521. * Thu Apr 03 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl3
  522. - add '-fPIC -DPIC' to CFLAGS on alpha
  523. - little fix of spec file
  524. * Thu Mar 27 2003 Tomoya TAKA <taka@vinelinux.org> 3.23.56-0vl2
  525. - enable MySQL-shared subpackage for alpha
  526. - delete 'BuildPrereq: kernel24-headers' for alpha
  527. - fix shared %files (exclude sparc)
  528. * Tue Mar 18 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.56-0vl1
  529. - new upstream version
  530. * Sun Mar 9 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.23.55-0vl2
  531. - fixed devel %files (dropped *.la files)
  532. * Tue Jan 28 2003 Satoshi MACHINO <machino@vinelinux.org> 3.23.55-0vl1
  533. - new upstream version
  534. - fixed document permission
  535. * Sat Dec 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.54a-0vl1
  536. - new upstream version
  537. * Sat Oct 19 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl2
  538. - dropped MySQL-Max sub-pakage for sparc/sparc64/alpha
  539. -- don't work
  540. * Wed Oct 16 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.53-0vl1
  541. - new upstream version
  542. - diseble-assembler in configure on sparc,sparc64,alpha
  543. * Wed Aug 21 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.52-0vl1
  544. - new upstream version
  545. - moved some man files to main package
  546. - added enable-local-infile in configure
  547. - changed --with-extra-charsets=all in configure
  548. * Fri Jun 14 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl2
  549. - fixed changelog
  550. * Thu Jun 13 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.51-0vl1
  551. - updated to mysql-3.23.51
  552. * Fri Mar 15 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl2
  553. - rebuild on zlib-1.1.4(security fix.)
  554. * Mon Feb 18 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.49-0vl1
  555. - updated to mysql-2.23.49
  556. * Tue Feb 12 2002 Tomoya TAKA <taka@vinelinux.org> 3.23.48-0vl2
  557. - add 'BuildPrereq: kernel24-headers' on alpha
  558. - remove shared library and max on alpha
  559. * Tue Feb 12 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.48-0vl1
  560. - updated to mysql-3.23.48
  561. * Thu Jan 03 2002 Satoshi MACHINO <machino@vinelinux.org> 3.23.47-0vl1
  562. - updated to mysql-3.23.47
  563. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.46-0vl1
  564. - updated to mysql-3.23.46
  565. * Thu Nov 29 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.45-0vl1
  566. - updated to mysql-3.23.45
  567. * Mon Nov 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.44-0vl1
  568. - updated to mysql-3.23.44
  569. * Sat Oct 13 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.43-0vl1
  570. - updated to mysql-3.23.43
  571. - removed shared library and max on sparc
  572. * Wed Sep 12 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.42-0vl1
  573. - updated to mysql-3.23.42
  574. - changed MYSQL_BUILD_CC: and MYSQL_BUILD_XCC: to -gcc
  575. * Thu Aug 30 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.41-0vl1
  576. - updated to mysql-3.23.41
  577. * Wed Aug 22 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.40-0vl1
  578. - updated to mysql-3.23.40
  579. * Tue Jul 10 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.39-0vl1
  580. - updated to mysql-3.23.39
  581. * Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  582. - added configure --with-charset=ujis
  583. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl2
  584. - used some rpmmacro
  585. * Fri May 25 2001 Satoshi MACHINO <machino@vinelinux.org> 3.23.38-1vl1
  586. - updated to MySQL-3.23.38
  587. * Thu Dec 07 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl2
  588. - removed Bench pakages
  589. * Tue Dec 05 2000 Satoshi MACHINO <machino@vinelinux.org> 3.23.28-1vl1
  590. - removed pt_BR locale
  591. - build on Vine Linux
  592. - partially used rpmmacros
  593. - added %clean tag
  594. * Fri Aug 18 2000 Tim Smith <tim@mysql.com>
  595. - Added separate libmysql_r directory; now both a threaded
  596. and non-threaded library is shipped.
  597. * Tue Sep 28 1999 David Axmark <davida@mysql.com>
  598. - Added the support-files/my-example.cnf to the docs directory.
  599. - Removed devel dependency on base since it is about client
  600. development.
  601. * Wed Sep 8 1999 David Axmark <davida@mysql.com>
  602. - Cleaned up some for 3.23.
  603. * Thu Jul 1 1999 David Axmark <davida@mysql.com>
  604. - Added support for shared libraries in a separate sub
  605. package. Original fix by David Fox (dsfox@cogsci.ucsd.edu)
  606. - The --enable-assembler switch is now automatically disables on
  607. platforms there assembler code is unavailable. This should allow
  608. building this RPM on non i386 systems.
  609. * Mon Feb 22 1999 David Axmark <david@detron.se>
  610. - Removed unportable cc switches from the spec file. The defaults can
  611. now be overridden with environment variables. This feature is used
  612. to compile the official RPM with optimal (but compiler version
  613. specific) switches.
  614. - Removed the repetitive description parts for the sub rpms. Maybe add
  615. again if RPM gets a multiline macro capability.
  616. - Added support for a pt_BR translation. Translation contributed by
  617. Jorge Godoy <jorge@bestway.com.br>.
  618. * Wed Nov 4 1998 David Axmark <david@detron.se>
  619. - A lot of changes in all the rpm and install scripts. This may even
  620. be a working RPM :-)
  621. * Sun Aug 16 1998 David Axmark <david@detron.se>
  622. - A developers changelog for MySQL is available in the source RPM. And
  623. there is a history of major user visible changed in the Reference
  624. Manual. Only RPM specific changes will be documented here.