1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374 |
- %define pkgname HTML-Scrubber
- # Basic Information
- Name: perl-%{pkgname}
- Version: 0.09
- Release: 1%{?_dist_release}
- License: Artistic or GPL
- Group: Development/Libraries
- Source0: http://search.cpan.org/CPAN/authors/id/N/NI/NIGELM/%{pkgname}-%{version}.tar.gz
- BuildRoot: %{_tmppath}/%{name}-%{version}-root
- BuildArch: noarch
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: yasumichi
- Summary: HTML::Scrubber - Perl extension for scrubbing/sanitizing html
- Summary(ja): HTML::Scrubber - html の除去/サニタイジングのための Perl 拡張
- # Dependency
- Requires: perl
- Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
- BuildRequires: perl
- %description
- If you wanna "scrub" or "sanitize" html input in a reliable and flexible
- fashion, then this module is for you.
- I wasn't satisfied with HTML::Sanitizer because it is based on
- HTML::TreeBuilder, so I thought I'd write something similar that works
- directly with HTML::Parser.
- #%%description -l ja
- %prep
- %setup -q -n HTML-Scrubber-0.09
- %build
- %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
- %{__make} %{?_smp_mflags}
- %install
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %{__make} pure_install DESTDIR=${RPM_BUILD_ROOT}
- # remove unnecessary files.
- find ${RPM_BUILD_ROOT} -type f -name perllocal.pod -exec %{__rm} -f {} ';'
- find ${RPM_BUILD_ROOT} -type f -name .packlist -exec %{__rm} -f {} ';'
- find ${RPM_BUILD_ROOT}%{_mandir} -type f -exec %{__rm} -f {} ';'
- find %{buildroot} -depth -type d -exec rmdir {} 2>/dev/null \;
- # generate file list
- find $RPM_BUILD_ROOT%{_prefix} -type f -print |
- sed "s@^$RPM_BUILD_ROOT@@g" > %{name}.files
- if [ "$(cat %{name}.files)X" = "X" ] ; then
- echo "ERROR: EMPTY FILE LIST"
- exit -1
- fi
- %clean
- %{__rm} -rf ${RPM_BUILD_ROOT}
- %files -f %{name}.files
- %defattr(-,root,root)
- %doc Changes LICENSE README
- %changelog
- * Thu Oct 04 2012 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.09-1
- - initial build for Vine Linux
|