curl-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %if %{?_dist_release} != "vl6"
  3. %global with_http2 1
  4. %endif
  5. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  6. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  7. Name: curl
  8. Version: 7.75.0
  9. Release: 1%{?_dist_release}
  10. Group: internet
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: daisuke
  14. License: MIT
  15. URL: https://curl.haxx.se/
  16. Source: https://curl.haxx.se/download/%{name}-%{version}.tar.xz
  17. # avoid reporting spurious error in the HTTP2 framing layer (#1690971)
  18. Patch2: 0002-curl-7.65.3-h2-framing-layer-error.patch
  19. # patch making libcurl multilib ready
  20. Patch101: 0101-curl-7.73.0-multilib.patch
  21. # prevent configure script from discarding -g in CFLAGS (#496778)
  22. Patch102: 0102-curl-7.36.0-debug.patch
  23. # migrate tests/http_pipe.py to Python 3
  24. Patch103: 0103-curl-7.59.0-python3.patch
  25. # use localhost6 instead of ip6-localhost in the curl test-suite
  26. Patch104: 0104-curl-7.73.0-localhost6.patch
  27. # prevent valgrind from reporting false positives on x86_64
  28. Patch105: 0105-curl-7.63.0-lib1560-valgrind.patch
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. BuildRequires: openssl-devel
  31. BuildRequires: gnutls-devel
  32. BuildRequires: libidn-devel zlib-devel
  33. BuildRequires: openldap-devel
  34. BuildRequires: openssh-server
  35. BuildRequires: openssh-clients
  36. BuildRequires: pkgconfig
  37. %if "%{?_dist_release}" != "vl6"
  38. BuildRequires: libssh2-devel
  39. %endif
  40. %if 0%{?with_http2}
  41. BuildRequires: libnghttp2-devel
  42. %endif
  43. Requires: ca-certificates
  44. %description
  45. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  46. Dict servers, using any of the supported protocols. cURL is designed
  47. to work without user interaction or any kind of interactivity. cURL
  48. offers many useful capabilities, like proxy support, user
  49. authentication, FTP upload, HTTP post, and file transfer resume.
  50. %package devel
  51. Summary: Files needed for building applications with libcurl.
  52. Group: programming
  53. Requires: %{name} = %{version}-%{release}
  54. Requires: openssl-devel libidn-devel zlib-devel
  55. %description devel
  56. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  57. Dict servers, using any of the supported protocols. The curl-devel
  58. package includes files needed for developing applications which can
  59. use cURL's capabilities internally.
  60. #'
  61. ## to build compat32 for x86_64 architecture support
  62. %package -n compat32-%{name}
  63. Summary: A utility for getting files from remote servers (FTP, HTTP, and others).
  64. Summary(ja): リモートサーバ(FTP,HTTPなど)からファイルを取得するためのユーティリティ
  65. Group: system
  66. %description -n compat32-%{name}
  67. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  68. Dict servers, using any of the supported protocols. cURL is designed
  69. to work without user interaction or any kind of interactivity. cURL
  70. offers many useful capabilities, like proxy support, user
  71. authentication, FTP upload, HTTP post, and file transfer resume.
  72. %package -n compat32-%{name}-devel
  73. Summary: Files needed for building applications with libcurl.
  74. Group: programming
  75. %description -n compat32-%{name}-devel
  76. cURL is a tool for getting files from FTP, HTTP, Gopher, Telnet, and
  77. Dict servers, using any of the supported protocols. The curl-devel
  78. package includes files needed for developing applications which can
  79. use cURL's capabilities internally.
  80. #'
  81. %debug_package
  82. %prep
  83. %setup -q
  84. # upstream patches
  85. # Fedora patches
  86. %patch101 -p1
  87. %patch102 -p1
  88. #patch103 -p1
  89. %patch104 -p1
  90. %patch105 -p1
  91. # make tests/*.py use Python 3
  92. sed -e '1 s|^#!/.*python|&3|' -i tests/*.py
  93. # regenerate Makefile.in files
  94. aclocal -I m4
  95. automake
  96. # disable test 1112 (#565305), test 1455 (occasionally fails with 'bind failed
  97. # with errno 98: Address already in use' in Koji environment), and test 1801
  98. # <https://github.com/bagder/curl/commit/21e82bd6#commitcomment-12226582>
  99. # and test 1900, which is flaky and covers a deprecated feature of libcurl
  100. # <https://github.com/curl/curl/pull/2705>
  101. printf "1112\n1455\n1801\n1900\n" >> tests/data/DISABLED
  102. # disable test 1319 on ppc64 (server times out)
  103. %ifarch ppc64
  104. echo "1319" >> tests/data/DISABLED
  105. %endif
  106. # temporarily disable test 582 on s390x (client times out)
  107. %ifarch s390x
  108. echo "582" >> tests/data/DISABLED
  109. %endif
  110. # adapt test 323 for updated OpenSSL
  111. sed -e 's/^35$/35,52/' -i tests/data/test323
  112. %build
  113. %configure \
  114. --with-ssl=%{_prefix} \
  115. --with-libidn \
  116. --enable-ipv6 \
  117. --enable-threaded-resolver \
  118. --with-ssl --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt \
  119. %if "%{?_dist_release}" != "vl6"
  120. --with-libssh2 \
  121. %endif
  122. %if 0%{?with_http2}
  123. --with-nghttp2 \
  124. %endif
  125. --enable-ldaps \
  126. --disable-static \
  127. --enable-hidden-symbols
  128. make %{?_smp_mflags}
  129. %install
  130. rm -rf $RPM_BUILD_ROOT
  131. make DESTDIR=$RPM_BUILD_ROOT install
  132. rm -rf $RPM_BUILD_ROOT%{_libdir}/lib*.{a,la}
  133. %clean
  134. rm -rf $RPM_BUILD_ROOT
  135. %post -p /sbin/ldconfig
  136. %postun -p /sbin/ldconfig
  137. %files
  138. %defattr(-,root,root)
  139. %{!?_licensedir:%global license %%doc}
  140. %license COPYING
  141. %doc CHANGES README
  142. %doc docs/BUGS docs/CONTRIBUTE docs/examples docs/FAQ docs/FEATURES
  143. %doc docs/INSTALL docs/INTERNALS docs/MANUAL docs/RESOURCES
  144. %doc docs/TheArtOfHttpScripting docs/TODO
  145. %{_bindir}/curl
  146. #{_datadir}/curl/*
  147. %{_libdir}/*.so.*
  148. %{_mandir}/man1/*.1*
  149. %files devel
  150. %defattr(-,root,root)
  151. %{_bindir}/curl-config
  152. %{_includedir}/curl
  153. %{_libdir}/*.so
  154. %{_libdir}/pkgconfig/*.pc
  155. %{_mandir}/man1/curl-config.1*
  156. %{_mandir}/man3/*
  157. %{_datadir}/aclocal/libcurl.m4
  158. ## to build compat32 for x86_64 architecture support
  159. %if %{build_compat32}
  160. %files -n compat32-%{name}
  161. %defattr(-,root,root)
  162. %{_libdir}/*.so.*
  163. %files -n compat32-%{name}-devel
  164. %defattr(-,root,root)
  165. %{_libdir}/*.so
  166. %endif
  167. %changelog
  168. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.75.0-1
  169. - new upstream release.
  170. * Wed Dec 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.74.0-1
  171. - new upstream release.
  172. * Tue Nov 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.73.0-1
  173. - new upstream release.
  174. - updated Patch0101 and Patch0104.
  175. * Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.71.1-1
  176. - new upstream release.
  177. * Tue Jun 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.70.0-1
  178. - new upstream release.
  179. * Sun Feb 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.68.0-1
  180. - new upstream release.
  181. * Sat Sep 21 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.66.0-1
  182. - new upstream release.
  183. - dropped Patch1 and 2: fixed in upstream.
  184. * Thu Aug 29 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.65.3-1
  185. - new upstream release.
  186. - updated patches.
  187. - imported Patch1, 2 and 105 from rawhide.
  188. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.62.0-1
  189. - new upstream release.
  190. - imported patches from rawhide.
  191. * Fri Apr 13 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.59.0-1
  192. - new upstream release.
  193. - imported Patch1 and 103 from rawhide.
  194. * Wed Feb 7 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.58.0-1
  195. - new upstream release with security fix
  196. - update patch101
  197. * Thu Jan 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.57.0-1
  198. - new upstream release.
  199. - updated Patch101-104.
  200. - dropped Patch107.
  201. * Mon May 1 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.54.0-1
  202. - new upstream release.
  203. * Thu Mar 16 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.53.1-1
  204. - new upstream release.
  205. * Wed Dec 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.51.0-1
  206. - new upstream release.
  207. * Fri Jul 29 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.50.0-1
  208. - new upstream release.
  209. - disabled HTTP/2 on Vine6.
  210. * Sat Jul 16 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-2
  211. - added HTTP/2 support.
  212. * Tue Jun 28 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.1-1
  213. - new upstream release with security fix.
  214. * Sat May 21 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.49.0-1
  215. - new upstream release.
  216. * Sat Mar 12 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.47.1-1
  217. - new upstream release
  218. - built with openssl 1.0.2g
  219. * Fri Jun 26 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.43.0-1
  220. - new upstream release with security fix .
  221. - removed Patch108 (fixed in upstream).
  222. * Sun Nov 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.39.0-1
  223. - new upstream release with security fix
  224. * Sun Jan 19 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 7.34.0-1
  225. - new upstream release
  226. - add libcurl.m4 to -devel package
  227. * Wed Sep 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 7.32.0-1
  228. - new upstream release
  229. - import upstream/fedora patches
  230. - disable libssh2 on Vine Linux 6
  231. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.1-1
  232. - new upstream reelase
  233. * Sun Oct 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 7.28.0-1
  234. - update to 7.28.0
  235. - add configure options
  236. - --enable-ssh2, --enable-threaded-resolver, --enable-ldaps
  237. - add BR: libssh2-devel, openssh-clients, openssh-server, pkgconfig
  238. - use ca-certificates package
  239. - --with-ca-bundle=%{_sysconfdir}/pki/tls/certs/ca-bundle.crt
  240. - R: ca-certificates
  241. * Tue Feb 21 2012 NAKAMURA Kenta <kenta@vinelinux.org> 7.24.0-1
  242. - new upstream release
  243. * Sun Jul 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.20.1-4
  244. - add patch100 for fix CVE-2011-2192 (gssapi)
  245. - add Vendor/Distri tags
  246. * Tue Jan 11 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.20.1-3
  247. - rebuild with openssl-1.0.0c
  248. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 7.20.1-2
  249. - rebuilt with rpm-4.8.1 for pkg-config
  250. * Sun Apr 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.20.1-1
  251. - new upstream release
  252. * Thu Aug 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.6-1
  253. - new upstream release with security fix
  254. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 7.19.5-2
  255. - added compat32 subpackages
  256. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.5-1
  257. - new upstream release
  258. - use "_smp_mflags" flag
  259. * Sat Apr 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.19.4-2
  260. - rebuild with openldap-2.4.11
  261. - add BR: openldap-devel
  262. - remove static library
  263. * Sat Mar 07 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 7.19.4-1
  264. - new upstream release with security fix (CVE-2009-0037)
  265. * Sun Jul 6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.2-1
  266. - new upstream release
  267. * Tue Apr 15 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.1-1vl5
  268. - new upstream release
  269. * Wed Mar 26 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.18.0-1vl5
  270. - new upstream release
  271. * Thu Dec 13 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.17.1-0vl1
  272. - new upstream release
  273. * Wed Jul 11 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.4-0vl1
  274. - new upstream release
  275. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.16.2-0vl2
  276. - rebuilt with openssl-0.9.8e
  277. * Sun May 13 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.16.2-0vl1
  278. - new upstream release
  279. * Wed Mar 22 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.3-0vl1
  280. - new upstream release
  281. * Tue Feb 28 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.2-0vl1
  282. - new upstream release
  283. - add pkgconfig file to devel package
  284. * Wed Dec 7 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.1-0vl1
  285. - new upstream release
  286. * Tue Oct 18 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.15.0-0vl1
  287. - new upstream release
  288. * Fri Sep 2 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.14.1-0vl1
  289. - new upstream release
  290. * Mon Feb 14 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl3
  291. - added libidn, zlib in Requires
  292. - added libidn-devel, zlib-devel in BuildPrereq
  293. - added zlib-devel in curl-devel's Requires
  294. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl2
  295. - added openssl-devel, libidn-devel in curl-devel's Requires
  296. * Sun Feb 13 2005 Satoshi MACHINO <machino@vinelinux.org> 7.13.0-0vl1
  297. - new upstream release
  298. * Tue Mar 30 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.11.1-0vl1
  299. - new upstream release
  300. - rebuild with openssl-0.9.7d
  301. * Sun Sep 14 2003 HOTTA Michihide <hotta@net-newbie.com> 7.10.7-0vl1
  302. - upstream release
  303. * Sat Feb 15 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl2
  304. - add %%{_datadir}/curl/* to %%files section
  305. * Sun Jan 19 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.10.3-0vl1
  306. - source upgrade
  307. * Wed Jul 24 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 7.9.8-0vl1
  308. - source upgrade
  309. - add PreReq: ldconfig
  310. - add %%{_libdir}/*.la to %%files devel section
  311. * Sat Jan 12 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 7.9.2-2vl1
  312. - build for VineSeed
  313. - add Requires: openssl
  314. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  315. - automated rebuild
  316. * Wed Jan 9 2002 Trond Eivind Glomsr.A綬d <teg@redhat.com> 7.9.2-1
  317. - 7.9.2
  318. * Fri Aug 17 2001 Nalin Dahyabhai <nalin@redhat.com>
  319. - include curl-config in curl-devel
  320. - update to 7.8 to fix memory leak and strlcat() symbol pollution from libcurl
  321. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com>
  322. - added openssl-devel build req
  323. * Mon May 21 2001 Tim Powers <timp@redhat.com>
  324. - built for the distro
  325. * Tue Apr 24 2001 Jeff Johnson <jbj@redhat.com>
  326. - upgrade to curl-7.7.2.
  327. - enable IPv6.
  328. * Fri Mar 2 2001 Tim Powers <timp@redhat.com>
  329. - rebuilt against openssl-0.9.6-1
  330. * Thu Jan 4 2001 Tim Powers <timp@redhat.com>
  331. - fixed mising ldconfigs
  332. - updated to 7.5.2, bug fixes
  333. * Mon Dec 11 2000 Tim Powers <timp@redhat.com>
  334. - updated to 7.5.1
  335. * Mon Nov 6 2000 Tim Powers <timp@redhat.com>
  336. - update to 7.4.1 to fix bug #20337, problems with curl -c
  337. - not using patch anymore, it's included in the new source. Keeping
  338. for reference
  339. * Fri Oct 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  340. - fix bogus req in -devel package
  341. * Fri Oct 20 2000 Tim Powers <timp@redhat.com>
  342. - devel package needed defattr so that root owns the files
  343. * Mon Oct 16 2000 Nalin Dahyabhai <nalin@redhat.com>
  344. - update to 7.3
  345. - apply vsprintf/vsnprintf patch from Colin Phipps via Debian
  346. * Mon Aug 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  347. - enable SSL support
  348. - fix packager tag
  349. - move buildroot to %%{_tmppath}
  350. * Tue Aug 1 2000 Tim Powers <timp@redhat.com>
  351. - fixed vendor tag for bug #15028
  352. * Mon Jul 24 2000 Prospector <prospector@redhat.com>
  353. - rebuilt
  354. * Tue Jul 11 2000 Tim Powers <timp@redhat.com>
  355. - workaround alpha build problems with optimizations
  356. * Mon Jul 10 2000 Tim Powers <timp@redhat.com>
  357. - rebuilt
  358. * Mon Jun 5 2000 Tim Powers <timp@redhat.com>
  359. - put man pages in correct place
  360. - use %%makeinstall
  361. * Mon Apr 24 2000 Tim Powers <timp@redhat.com>
  362. - updated to 6.5.2
  363. * Wed Nov 3 1999 Tim Powers <timp@redhat.com>
  364. - updated sources to 6.2
  365. - gzip man page
  366. * Mon Aug 30 1999 Tim Powers <timp@redhat.com>
  367. - changed group
  368. * Thu Aug 26 1999 Tim Powers <timp@redhat.com>
  369. - changelog started
  370. - general cleanups, changed prefix to /usr, added manpage to files section
  371. - including in Powertools