gnuplot-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345
  1. %global major 5
  2. %global minor 0
  3. %global patchlevel 0
  4. %global x11_app_defaults_dir %{_datadir}/X11/app-defaults
  5. Summary: A program for plotting mathematical expressions and data.
  6. Summary(ja): 数学系の関数やデータのプロット・プログラム
  7. Name: gnuplot
  8. Version: %{major}.%{minor}.%{patchlevel}
  9. Release: 1%{?_dist_release}
  10. # MIT .. term/PostScript/aglfn.txt
  11. License: gnuplot and MIT
  12. Group: Applications/Engineering
  13. URL: http://www.gnuplot.info/
  14. Source: http://downloads.sourceforge.net/%{name}/%{name}-%{version}.tar.gz
  15. Patch0: gnuplot-4.2.0-refers_to.patch
  16. #Patch1: gnuplot-4.2.0-fonts.patch
  17. # resolves: #812225
  18. # submitted upstream: http://sourceforge.net/tracker/?func=detail&aid=3558973&group_id=2055&atid=302055
  19. Patch3: gnuplot-4.6.1-plot-sigsegv.patch
  20. Patch4: gnuplot-4.6.4-singlethread.patch
  21. Patch5: gnuplot-5.0.0-lua_checkint.patch
  22. # Vine Patches (replaces Patch1)
  23. Patch70: gnuplot-5.0.0-fonts.patch
  24. BuildRoot: %{_tmppath}/%{name}-root
  25. #libedit-devel can not handle utf8, readline-devel is not legal with gnuplot, stick to builtin
  26. BuildRequires: cairo-devel
  27. BuildRequires: gd-devel >= 2.0.27
  28. BuildRequires: giflib-devel
  29. BuildRequires: libX11-devel
  30. BuildRequires: libXt-devel
  31. BuildRequires: libXpm-devel
  32. BuildRequires: libjpeg-turbo-devel
  33. BuildRequires: libpng-devel
  34. BuildRequires: lua-devel
  35. BuildRequires: m17n-lib
  36. BuildRequires: pango-devel
  37. BuildRequires: wxGTK-devel
  38. BuildRequires: zlib-devel
  39. BuildRequires: texlive
  40. BuildRequires: texlive-common
  41. BuildRequires: texlive-collection-latexextra
  42. BuildRequires: texlive-collection-htmlxml
  43. BuildRequires: texinfo
  44. BuildRequires: latex2html
  45. BuildRequires: emacs
  46. Requires: TrueType-dejavu
  47. Requires(post): install-info
  48. Requires(preun): install-info
  49. Vendor: Project Vine
  50. Distribution: Vine Linux
  51. Packager: daisuke, inagaki, shaolin
  52. %description
  53. Gnuplot is a command-line driven, interactive function plotting
  54. program especially suited for scientific data representation. Gnuplot
  55. can be used to plot functions and data points in both two and three
  56. dimensions and in many different formats.
  57. Install gnuplot if you need a graphics package for scientific data
  58. representation.
  59. %description -l ja
  60. Gnuplotはとりわけ科学データ・プレゼンテーションに適した、コマンド
  61. 操作によるインタラクティブな関数プロット・プログラムです。
  62. Gnuplotは関数や座標データを同時にプロットしたり、3次元化やさまざ
  63. まな形式で表現するのに利用することができます。
  64. 科学データプレゼンテーション用のグラフィック・パッケージが必要な
  65. 場合、gnuplotをインストールしてください。
  66. %package doc
  67. Summary: Documentation for the gnuplot main application
  68. Group: Applications/Documentation
  69. BuildArch: noarch
  70. Requires: %{name} = %{version}-%{release}
  71. %description doc
  72. The gnuplot-doc package contains the documentation related to gnuplot
  73. plotting tool
  74. %package latex
  75. Summary: Configuration for LaTeX typesetting using gnuplot
  76. Group: Applications/Engineering
  77. BuildArch: noarch
  78. Requires: %{name} = %{version}-%{release}
  79. Requires: texlive-collection-latexextra
  80. Requires: texlive-collection-fontsrecommended
  81. %description latex
  82. The gnuplot-latex package contains LaTeX configuration file related to gnuplot
  83. plotting tool.
  84. %prep
  85. %setup -q
  86. %patch0 -p1 -b .refto
  87. #patch1 -p1 -b .font
  88. %patch3 -p1 -b .plot-sigsegv
  89. %patch4 -p1 -b .isinglethread
  90. %patch5 -p1 -b .checkint
  91. sed -i -e 's:"/usr/lib/X11/app-defaults":"%{x11_app_defaults_dir}":' src/gplt_x11.c
  92. iconv -f windows-1252 -t utf-8 ChangeLog > ChangeLog.aux
  93. mv ChangeLog.aux ChangeLog
  94. chmod 644 src/getcolor.h
  95. chmod 644 demo/html/webify.pl
  96. chmod 644 demo/html/webify_svg.pl
  97. chmod 644 demo/html/webify_canvas.pl
  98. %patch70 -p1 -b .font
  99. %build
  100. #remove binaries from source tarball
  101. rm -rf demo/plugin/*.so demo/plugin/*.o
  102. rm -rf docs_to_include
  103. mkdir -p docs_to_include
  104. cp -pr demo docs_to_include
  105. %configure --with-readline=builtin --without-linux-vga --enable-history-file --with-tutorial --without-qt
  106. make %{?_smp_mflags}
  107. make -C docs html info
  108. export GNUPLOT_PS_DIR=../../term/PostScript
  109. make -C docs/psdoc ps_symbols.ps ps_fontfile_doc.pdf
  110. rm -rf docs/htmldocs/images.idx
  111. make -C tutorial
  112. %install
  113. rm -rf %{buildroot}
  114. make install DESTDIR=%{buildroot}
  115. make -C docs install-info DESTDIR=%{buildroot} INSTALL='install -p'
  116. #rm -f demo/Makefile* tutorial/Makefile*
  117. #packaged by info package, updated by post-installation script, do not package here
  118. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  119. mkdir -p $RPM_BUILD_ROOT%{x11_app_defaults_dir}
  120. mv $RPM_BUILD_ROOT%{_datadir}/gnuplot/%{major}.%{minor}/app-defaults/Gnuplot $RPM_BUILD_ROOT%{x11_app_defaults_dir}/Gnuplot
  121. rm -rf $RPM_BUILD_ROOT%{_libdir}/
  122. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/ja/man1
  123. mv $RPM_BUILD_ROOT%{_mandir}/man1/gnuplot-ja.1 $RPM_BUILD_ROOT/%{_mandir}/ja/man1/gnuplot.1
  124. %clean
  125. rm -rf %{buildroot}
  126. %post
  127. if [ -f %{_infodir}/gnuplot.info* ]; then
  128. /sbin/install-info %{_infodir}/gnuplot.info %{_infodir}/dir || :
  129. fi
  130. %preun
  131. if [ $1 = 0 ] ; then
  132. if [ -f %{_infodir}/gnuplot.info* ]; then
  133. /sbin/install-info --delete %{_infodir}/gnuplot.info %{_infodir}/dir || :
  134. fi
  135. fi
  136. %files
  137. %defattr(-,root,root)
  138. %doc BUGS ChangeLog Copyright NEWS README
  139. %{_bindir}/gnuplot
  140. %dir %{_libexecdir}/gnuplot/%{major}.%{minor}
  141. %{_libexecdir}/gnuplot/%{major}.%{minor}/gnuplot_x11
  142. %dir %{_datadir}/gnuplot/%{major}.%{minor}
  143. %dir %{_datadir}/gnuplot/%{major}.%{minor}/PostScript
  144. %dir %{_datadir}/gnuplot/%{major}.%{minor}/js
  145. %dir %{_datadir}/gnuplot/%{major}.%{minor}/lua
  146. %{_datadir}/gnuplot/%{major}.%{minor}/PostScript/*.ps
  147. %{_datadir}/gnuplot/%{major}.%{minor}/PostScript/aglfn.txt
  148. %{_datadir}/gnuplot/%{major}.%{minor}/js/*
  149. %{_datadir}/gnuplot/%{major}.%{minor}/lua/gnuplot-tikz.lua
  150. %{_datadir}/gnuplot/%{major}.%{minor}/colors_*
  151. %{_datadir}/gnuplot/%{major}.%{minor}/gnuplot.gih
  152. %{_datadir}/gnuplot/%{major}.%{minor}/gnuplotrc
  153. %{x11_app_defaults_dir}/Gnuplot
  154. %{_infodir}/gnuplot.info.gz
  155. %{_mandir}/man1/gnuplot.*
  156. %{_mandir}/ja/man1/gnuplot.*
  157. %files doc
  158. %defattr(-,root,root)
  159. %doc ChangeLog Copyright
  160. %doc docs/psdoc/ps_guide.ps docs/psdoc/ps_symbols.ps
  161. %doc tutorial/tutorial.dvi docs/psdoc/ps_file.doc
  162. %doc docs/psdoc/ps_fontfile_doc.pdf docs/htmldocs tutorial/eg7.eps
  163. %doc docs_to_include/demo
  164. %files latex
  165. %defattr(-,root,root)
  166. %doc ChangeLog Copyright
  167. %{_datadir}/texmf/tex/latex/gnuplot/
  168. %changelog
  169. * Thu May 7 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 5.0.0-1
  170. - new upstream release
  171. - libedit-devel can not handle utf8, readline-devel is not legal with gnuplot, stick to builtin
  172. https://bugzilla.redhat.com/show_bug.cgi?id=1039102
  173. - split documents and latex-related files into subpackages
  174. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 4.6.6-1
  175. - update to 4.6.6
  176. * Thu Jan 16 2014 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.6.4-1
  177. - new upstream release
  178. - add Patch0, Patch1 and Patch2 (font paths, upstream fixes)
  179. - modify spec to build/install docs correctly
  180. * Wed Jul 11 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 4.4.3-2
  181. - changed BuildRequires: wx-gtk2-devel >= 2.8.12 to wxGTK-devel >= 2.8.12
  182. - added BuildRequires: libXpm-devel libjpeg-turbo-devel texlive-common
  183. * Sat Apr 16 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.4.3-1
  184. - update to gnuplot-4.4.3
  185. - use BR: texlive instead of tetex
  186. * Sun May 31 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.2.5-1
  187. - update to gnuplot-4.2.5
  188. - drop plus patch (merged in upstream)
  189. - update URL: to new upstream homepage
  190. - fix License:
  191. - build with wxGTK
  192. - add BR: libX11-devel, libXt-devel, wx-gtk2-devel
  193. * Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.0-1vl5
  194. - applied new versioning policy, spec in utf-8
  195. * Tue Aug 22 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl6
  196. - add BuildRequires: texinfo, emacsen
  197. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 4.0.0-0vl5
  198. - rebuild with readline-5.1
  199. * Wed Jun 15 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.0-0vl4
  200. - update Patch0 to fix 'Invalid char in eps file'
  201. (thanks to HANAWA Toshihiro)
  202. - add BuildRequires: autoconf, automake
  203. * Sat Nov 20 2004 Satoshi MACHINO <machino@vinelinux.org> 4.0.0-0vl2
  204. - enabled history-file
  205. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.0-0vl1
  206. - source update
  207. * Wed Jul 14 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.8k.3-0vl1
  208. - source update
  209. - patch update and modified
  210. - add info
  211. * Wed Mar 10 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl3
  212. - rebuild
  213. - fix license
  214. - remove -DUSE_SYSTEM_TIME ([VinePlus:01805])
  215. * Wed Apr 02 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl2
  216. - rebuild with readline-4.3
  217. * Thu Feb 20 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.7.3-2vl1
  218. - syncd with RH 3.7.3-2
  219. - modified Yamaga-san's gnuplot3.7.2+1.2.0rc2.patch for 3.7.3
  220. * Fri Jan 25 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 16vl1
  221. - added pathes (patch1,2) from RH
  222. * Sat Aug 25 2001 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 12vl1
  223. - syncd rawhide
  224. - updated to 3.7.1-1.2.0
  225. * Mon Jun 5 2000 Yasuyuki Furukawa <furukawa@vinelinux.org>
  226. - updated to 3.7.1
  227. - updated gnuplot+ patch to 1.1.9 for gnuplot 3.7.1.
  228. - remake SPEC from rawhide.
  229. * Fri May 19 2000 Nalin Dahyabhai <nalin@redhat.com>
  230. - rebuild with new gd, changing gif terminal to jpeg terminal (release 7)
  231. * Mon May 08 2000 Preston Brown <pbrown@redhat.com>
  232. - build for 7.0
  233. * Thu Apr 6 2000 Bill Nottingham <notting@redhat.com>
  234. - use gnu readline, not built-in version
  235. * Mon Apr 3 2000 Bill Nottingham <notting@redhat.com>
  236. - add latex tutorial, demo files, other docs (#10508)
  237. * Wed Mar 1 2000 Bill Nottingham <notting@redhat.com>
  238. - update to 3.7.1. Oops.
  239. * Thu Feb 3 2000 Bill Nottingham <notting@redhat.com>
  240. - handle compressed man pages
  241. * Thu Nov 4 1999 Bill Nottingham <notting@redhat.com>
  242. - update to 3.7.1
  243. * Mon Oct 11 1999 Bill Nottingham <notting@redhat.com>
  244. - ship some docs.
  245. * Wed Aug 18 1999 Bill Nottingham <notting@redhat.com>
  246. - add a patch to fix postscript output from Bernd Kischnick
  247. (kisch@die-herrmanns.de)
  248. * Fri Jul 30 1999 Bill Nottingham <notting@redhat.com>
  249. - fix license
  250. * Thu Jul 15 1999 Bill Nottingham <notting@redhat.com>
  251. - rebuild without svgalib
  252. * Tue Jun 15 1999 Bill Nottingham <notting@redhat.com>
  253. - update to 3.7.0.1
  254. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  255. - auto rebuild in the new build environment (release 2)
  256. * Tue Feb 2 1999 Jeff Johnson <jbj@redhat.com>
  257. - update to 3.7.
  258. * Thu Dec 17 1998 Michael Maher <mike@redhat.com>
  259. - built package for 6.0
  260. * Fri Sep 11 1998 Jeff Johnson <jbj@redhat.com>
  261. - update to 2.6beta347
  262. * Sat Aug 15 1998 Jeff Johnson <jbj@redhat.com>
  263. - build root
  264. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  265. - translations modified for de, fr, tr
  266. * Mon Oct 20 1997 Donnie Barnes <djb@redhat.com>
  267. - spec file cleanups
  268. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  269. - built against glibc