totem-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643
  1. # select backend (GStreamer, xine)
  2. #define build_gst 1
  3. %define build_xine 1
  4. # build browser plugins
  5. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  6. # define versions
  7. %define _glib_ver 2.20.0
  8. %define _gtk_ver 2.16.0
  9. %define _gnomevfs_ver 2.24.0
  10. %define _gnomeui_ver 2.24.0
  11. %define _gnomeicon_ver 2.26.0
  12. %define _gnome_desktop_ver 2.26.0
  13. %define _libgnome_ver 2.26.0
  14. %define _gnome_doc_utils_ver 0.16.0
  15. %define _dbus_ver 1.0
  16. %define _hal_ver 0.5
  17. %define _gst_ver 0.10.19
  18. %define _gstpb_ver 0.10.7
  19. %define _xine_ver 1.1.11.1
  20. %define _gecko_ver 1.9
  21. %define _nautilus_ver 2.26.0
  22. %define _shared_mime_info_ver 0.17
  23. %define nautilus_extdir %{_libdir}/nautilus/extensions-2.0
  24. %define mozplug_dir %{_libdir}/mozilla/plugins
  25. Summary: Movie player for GNOME 2
  26. Summary(ja): GNOME2 用動画プレイヤー
  27. Name: totem
  28. Version: 2.26.3
  29. Release: 2%{?_dist_release}
  30. License: GPL
  31. Group: Applications/Multimedia
  32. URL: http://www.gnome.org/projects/totem/
  33. Source0: http://ftp.gnome.org/pub/GNOME/sources/totem/2.26/totem-%{version}.tar.bz2
  34. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  35. Vendor: Project Vine
  36. Distribution: Vine Linux
  37. BuildRequires: gtk2-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  38. BuildRequires: gnome-desktop-devel >= %{_gnome_desktop_ver}
  39. BuildRequires: gnome-vfs2-devel >= %{_gnomevfs_ver}
  40. BuildRequires: libgnomeui-devel >= %{_gnomeui_ver}
  41. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  42. BuildRequires: libgnome-devel >= %{_libgnome_ver}
  43. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  44. BuildRequires: dbus-devel >= %{_dbus_ver}
  45. BuildRequires: hal-devel >= %{_hal_ver}
  46. BuildRequires: libmusicbrainz-devel
  47. BuildRequires: nautilus >= %{_nautilus_ver}
  48. BuildRequires: gettext, scrollkeeper
  49. BuildRequires: perl-XML-Parser
  50. BuildRequires: iso-codes
  51. BuildRequires: totem-pl-parser-devel
  52. BuildRequires: bluez-libs-devel >= 4.15
  53. BuildRequires: lirc
  54. Requires: %{name}-common = %{version}-%{release}
  55. Requires: %{name}-gstreamer = %{version}-%{release}
  56. %if %{build_plugin}
  57. BuildRequires: gecko-devel >= %{_gecko_ver}
  58. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  59. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  60. %endif
  61. %description
  62. Totem is simple movie player for the Gnome desktop. It features a
  63. simple playlist, a full-screen mode, seek and volume controls, as well as
  64. a pretty complete keyboard navigation.
  65. This is virtual package to install totem common package and totem backend
  66. package.
  67. %package gstreamer
  68. Summary: GStramer backend for Totem
  69. Summary(ja): Totem 用 GStreamer バックエンド
  70. Group: Applications/Multimedia
  71. Requires: %{name}-common = %{version}-%{release}
  72. Requires: gstreamer >= %{_gst_ver}
  73. Requires: gstreamer-plugins-base >= %{_gstpb_ver}
  74. BuildRequires: gstreamer-devel >= %{_gst_ver}
  75. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb_ver}
  76. BuildRequires: gstreamer-plugins-good
  77. Obsoletes: %{name} < 1.0.2-0vl2, nautilus-media
  78. Provides: %{name} = %{version}-%{release}
  79. Requires(post): alternatives
  80. Requires(postun): alternatives
  81. %description gstreamer
  82. Totem is simple movie player for the Gnome desktop. It features a
  83. simple playlist, a full-screen mode, seek and volume controls, as well as
  84. a pretty complete keyboard navigation.
  85. %if %{build_xine}
  86. %package xine
  87. Summary: Xine backend for Totem
  88. Summary(ja): Totem 用 Xine バックエンド
  89. Group: Applications/Multimedia
  90. Requires: %{name}-common = %{version}-%{release}
  91. Requires: xine-lib >= %{_xine_ver}
  92. BuildRequires: xine-lib-devel >= %{_xine_ver}
  93. Obsoletes: %{name} < 1.0.2-0vl2
  94. Provides: %{name} = %{version}-%{release}
  95. Requires(post): alternatives
  96. Requires(postun): alternatives
  97. %description xine
  98. Totem is simple movie player for the Gnome desktop. It features a
  99. simple playlist, a full-screen mode, seek and volume controls, as well as
  100. a pretty complete keyboard navigation.
  101. %endif
  102. %package common
  103. Summary: common files for Totem
  104. Summary(ja): Totem の共通ファイル
  105. Group: Applications/Multimedia
  106. Requires: gtk2 >= %{_gtk_ver}, glib2 >= %{_glib_ver}
  107. Requires: gnome-desktop-libs >= %{_gnome_desktop_ver}
  108. Requires: gnome-vfs2 >= %{_gnomevfs_ver}
  109. Requires: libgnomeui >= %{_gnomeui_ver}
  110. Requires: libgnome >= %{_libgnome_ver}
  111. Requires: dbus >= %{_dbus_ver}
  112. Requires: hal >= %{_hal_ver}
  113. Requires: iso-codes, libmusicbrainz
  114. Conflicts: %{name} < 1.0.2-0vl2
  115. Requires(post): ldconfig, scrollkeeper, desktop-file-utils, GConf2
  116. Requires(postun): ldconfig, scrollkeeper, desktop-file-utils, alternatives
  117. Requires(preun): GConf2
  118. Requires(triggers): alternatives
  119. %description common
  120. Totem is simple movie player for the Gnome desktop. It features a
  121. simple playlist, a full-screen mode, seek and volume controls, as well as
  122. a pretty complete keyboard navigation.
  123. This package contains common files for Totem (GStreamer/xine backend).
  124. %if %{build_plugin}
  125. %package mozilla
  126. Summary: Totem movie plugin for Mozilla
  127. Summary(ja): Mozilla 用 Totem 動画プラグイン
  128. Group: Applications/Internet
  129. Requires: %{name}-common = %{version}-%{release}
  130. Obsoletes: %{name}-mozilla-common
  131. Obsoletes: %{name}-mozilla-gstreamer
  132. Obsoletes: %{name}-mozilla-xine
  133. Requires(post): alternatives
  134. Requires(postun): alternatives
  135. %description mozilla
  136. Totem is simple movie player for the Gnome desktop. It features a
  137. simple playlist, a full-screen mode, seek and volume controls, as well as
  138. a pretty complete keyboard navigation.
  139. This package contains a Totem video plugin for Mozilla. It allows Totem
  140. movie player to be embedded into a web browser.
  141. %package tracker
  142. Summary: Tracker-based video search plugin for Totem
  143. Summary(ja): Tracker を使った Totem 用動画検索プラグイン
  144. Group: Applications/Multimedia
  145. Requires: %{name}-common = %{version}-%{release}
  146. BuildRequires: tracker-devel
  147. %description tracker
  148. A plugin to allow searching local videos, based on their tags, metadata,
  149. or filenames, as indexing by the Tracker indexer.
  150. %endif
  151. %prep
  152. %setup -q -c
  153. # Whatever needs to be changed in both copies do here
  154. ## remember to update me when changing %doc
  155. for i in AUTHORS COPYING ChangeLog NEWS README TODO;do
  156. cp totem-%{version}/$i .
  157. done
  158. # duplicate sources
  159. cp -a totem-%{version} xine
  160. mv totem-%{version} gstreamer
  161. %build
  162. # build Totem (GStreamer backend)
  163. pushd gstreamer
  164. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
  165. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  166. %configure \
  167. --disable-lirc \
  168. --disable-vanity \
  169. --disable-nvtv \
  170. --disable-schemas-install \
  171. --disable-scrollkeeper \
  172. --disable-xine \
  173. --enable-gstreamer \
  174. %if %{build_plugin}
  175. --enable-browser-plugins \
  176. --enable-nautilus \
  177. --enable-mozilla \
  178. --with-mozilla=libxul \
  179. --enable-basic-plugin \
  180. --enable-gmp-plugin \
  181. --enable-complex-plugin \
  182. --enable-narrowspace-plugin \
  183. --enable-mully-plugin
  184. %else
  185. --disable-browser-plugins
  186. %endif
  187. make %{?_smp_mflags}
  188. popd
  189. # build Totem (xine backend)
  190. %if %{build_xine}
  191. pushd xine
  192. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  193. %configure \
  194. --disable-lirc \
  195. --disable-vanity \
  196. --disable-nvtv \
  197. --disable-schemas-install \
  198. --disable-scrollkeeper \
  199. --disable-gstreamer \
  200. --enable-xine \
  201. --disable-nautilus \
  202. --disable-mozilla \
  203. --disable-browser-plugins
  204. cd src/backend/
  205. make %{?_smp_mflags}
  206. popd
  207. %endif
  208. %install
  209. rm -rf $RPM_BUILD_ROOT
  210. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  211. # install Totem (GStreamer backend)
  212. pushd gstreamer/
  213. make install DESTDIR=$RPM_BUILD_ROOT
  214. mv $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget.so.0.0.0 \
  215. $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
  216. # language hack
  217. %find_lang %{name} --with-gnome
  218. mv %{name}.lang ../
  219. popd
  220. # install Totem (xine backend)
  221. %if %{build_xine}
  222. pushd xine/src/backend/
  223. make install DESTDIR=$RPM_BUILD_ROOT
  224. mv $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget.so.0.0.0 \
  225. $RPM_BUILD_ROOT/%{_libdir}/libbaconvideowidget-xine.so.0.0.0
  226. popd
  227. %endif
  228. # remove unneeded files
  229. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  230. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  231. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  232. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  233. %__rm -f %{buildroot}%{_libdir}/libbaconvideowidget*.{a,la}
  234. %__rm -f %{buildroot}%{_libdir}/libbaconvideowidget.so
  235. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  236. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  237. %find_lang %{name} --with-gnome
  238. %clean
  239. %__rm -rf %{buildroot}
  240. %post gstreamer
  241. %{_syssbindir}/update-alternatives --install \
  242. %{_libdir}/libbaconvideowidget.so.0.0.0 totem \
  243. %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0 10
  244. /sbin/ldconfig
  245. %postun gstreamer
  246. [ "$1" = "1" ] && exit
  247. %{_syssbindir}/update-alternatives --remove \
  248. totem %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
  249. [ -f "%{_libdir}/libbaconvideowidget.so.0.0.0" ] || %{_syssbindir}/update-alternatives --auto totem
  250. /sbin/ldconfig
  251. %if %{build_xine}
  252. %post xine
  253. %{_syssbindir}/update-alternatives --install \
  254. %{_libdir}/libbaconvideowidget.so.0.0.0 totem \
  255. %{_libdir}/libbaconvideowidget-xine.so.0.0.0 15
  256. /sbin/ldconfig
  257. %postun xine
  258. [ "$1" = "1" ] && exit
  259. %{_syssbindir}/update-alternatives --remove \
  260. totem %{_libdir}/libbaconvideowidget-xine.so.0.0.0
  261. [ -f "%{_libdir}/libbaconvideowidget.so.0.0.0" ] || %{_syssbindir}/update-alternatives --auto totem
  262. /sbin/ldconfig
  263. %endif
  264. %post common
  265. %{_bindir}/scrollkeeper-update -q
  266. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  267. export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
  268. gconftool-2 --makefile-install-rule \
  269. %{_sysconfdir}/gconf/schemas/totem.schemas \
  270. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  271. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  272. >& /dev/null || :
  273. touch %{_datadir}/icons/hicolor
  274. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  275. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  276. fi
  277. %pre common
  278. if [ "$1" -gt 1 ]; then
  279. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  280. gconftool-2 --makefile-uninstall-rule \
  281. %{_sysconfdir}/gconf/schemas/totem.schemas \
  282. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  283. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  284. >& /dev/null || :
  285. fi
  286. %preun common
  287. if [ "$1" -eq 0 ]; then
  288. export GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source`
  289. gconftool-2 --makefile-uninstall-rule \
  290. %{_sysconfdir}/gconf/schemas/totem.schemas \
  291. %{_sysconfdir}/gconf/schemas/totem-handlers.schemas \
  292. %{_sysconfdir}/gconf/schemas/totem-video-thumbnail.schemas \
  293. >& /dev/null || :
  294. fi
  295. %postun common
  296. %{_bindir}/scrollkeeper-update -q
  297. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  298. touch %{_datadir}/icons/hicolor
  299. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  300. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  301. fi
  302. [ -f "%{_bindir}/totem" ] || %{_syssbindir}/update-alternatives --auto totem
  303. %triggerpostun common -- %{name} < 1.0.2-0vl2
  304. export GCONF_CONFIG_SOURCE=`%{_bindir}/gconftool-2 --get-default-source`
  305. for schema in totem totem-video-thumbnail totem-handlers ; do
  306. %{_bindir}/gconftool-2 --makefile-install-rule \
  307. %{_sysconfdir}/gconf/schemas/${schema}.schemas > /dev/null ||:
  308. done
  309. [ -f "%{_bindir}/totem" ] || %{_syssbindir}/update-alternatives --auto totem
  310. %files
  311. %files gstreamer
  312. %defattr(-,root,root,-)
  313. %{_libdir}/libbaconvideowidget-gstreamer.so.0.0.0
  314. %if %{build_xine}
  315. %files xine
  316. %defattr(-,root,root,-)
  317. %{_libdir}/libbaconvideowidget-xine.so.0.0.0
  318. %endif
  319. %files common -f %{name}.lang
  320. %defattr(-,root,root,-)
  321. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  322. %config %{_sysconfdir}/gconf/schemas/*.schemas
  323. %{_bindir}/totem
  324. %{_bindir}/totem-audio-preview
  325. %{_bindir}/totem-video-indexer
  326. %{_bindir}/totem-video-thumbnailer
  327. %{_datadir}/applications/%{name}.desktop
  328. %{_datadir}/icons/*/*/apps/*
  329. %{_datadir}/icons/*/*/devices/*
  330. %{_datadir}/%{name}
  331. %{_datadir}/gtk-doc/html/totem
  332. %dir %{_libdir}/totem
  333. %dir %{_libdir}/totem/plugins
  334. %{_libdir}/totem/plugins/brasero-disc-recorder
  335. %{_libdir}/totem/plugins/coherence_upnp
  336. %{_libdir}/totem/plugins/gromit
  337. %{_libdir}/totem/plugins/jamendo
  338. %{_libdir}/totem/plugins/lirc
  339. %{_libdir}/totem/plugins/media-player-keys
  340. %{_libdir}/totem/plugins/ontop
  341. %{_libdir}/totem/plugins/opensubtitles
  342. %{_libdir}/totem/plugins/properties
  343. %{_libdir}/totem/plugins/pythonconsole
  344. %{_libdir}/totem/plugins/screensaver
  345. %{_libdir}/totem/plugins/screenshot
  346. %{_libdir}/totem/plugins/skipto
  347. %{_libdir}/totem/plugins/thumbnail
  348. %{_libdir}/totem/plugins/youtube
  349. %{_libdir}/totem/plugins/totem
  350. %if %{build_plugin}
  351. %{_libdir}/nautilus/extensions-2.0/*.so*
  352. %endif
  353. %{_libdir}/libbaconvideowidget.so*
  354. %{_libexecdir}/%{name}/totem-bugreport.py
  355. %{_mandir}/man1/*
  356. %if %{build_plugin}
  357. %files mozilla
  358. %defattr(-,root,root,-)
  359. %{mozplug_dir}/*
  360. %{_libexecdir}/totem-plugin-viewer
  361. %files tracker
  362. %defattr(-, root, root)
  363. %{_libdir}/totem/plugins/tracker
  364. %endif
  365. %changelog
  366. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  367. - remove unneeded autoreconf
  368. - add BR: lirc
  369. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  370. - new upstream release
  371. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  372. - remove bemused plugin
  373. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  374. - new upstream release
  375. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  376. - added tracker video search sub-package
  377. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  378. - new upstream release
  379. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  380. - new upstream release
  381. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  382. - remove libxine dependency from totem-common
  383. - build xine backend with minimum dependency
  384. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  385. - add BR: bluez-libs-devel >= 4.15
  386. - fix typo in %%postun xine
  387. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  388. - rebuild with bluez-libs-devel-4.15
  389. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  390. - new upstream release
  391. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  392. - new upstream release
  393. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  394. - new upstream release
  395. - add patch1 to build with xulrunner-1.9
  396. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  397. - new upstream release
  398. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  399. - new upstream release
  400. - disabled devel package (replaced by totem-pl-parser-devel)
  401. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  402. - new upstream release
  403. - update version macros
  404. - enable browser plugins on x86_64
  405. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  406. - new upstream release
  407. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  408. - upstream release
  409. - drop obsolete ja.po.patch (patch0)
  410. - revert change of 1.4.4-0vl2
  411. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  412. - upstream release
  413. - enable browser plugins (exclude x86_64 arch)
  414. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  415. - upstream release
  416. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  417. - update configure options
  418. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  419. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  420. - fix mistranslation (patch0)
  421. - add icon symlink
  422. - add BuildRequires: gstreamer-plugins-good
  423. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  424. - upstream release
  425. - update %%_glib_ver, %%_xine_ver
  426. - add BuildRequires: hal
  427. - update %%configure options
  428. - update %%files
  429. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  430. - upstream release
  431. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  432. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  433. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  434. - upstream release
  435. - drop obsolete patch0
  436. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  437. - upstream release
  438. - add patch0 to build with intltool-0.35
  439. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  440. - upstream release
  441. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  442. - upstream release
  443. - update alternatives entry
  444. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  445. - upstream release
  446. - drop fix-sort-function.patch (was merged to upstream, #331426)
  447. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  448. - rebuild with gnome-2.14rc
  449. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  450. - upstream release
  451. - add macros
  452. - _gtk_ver, _glib_ver
  453. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  454. - _dbus_ver
  455. - _gst_ver, gstpb_ver, _xine_ver
  456. - add fix-sort-function.patch to build with glib < 2.9.1
  457. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  458. - upstream release
  459. - add BuildRequires:
  460. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  461. - gnome-vfs2-devel >= 2.9.92
  462. - dbus-devel >= 0.35
  463. - use gstreamer-0.10 as backend for totem-gstreamer
  464. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  465. - use gstreamer08 instead of gstreamer
  466. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  467. - upstream release
  468. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  469. - fix missing links
  470. - update file list
  471. - update update-alternatives scripts
  472. - fix totem-gstreamer's %%postun script
  473. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  474. - upstream release
  475. - add BuildRequires: iso-codes, libmusicbrainz-devel
  476. - add Requires: iso-codes, libmusicbrains to -common package
  477. - remove BuildRequires: nautilus-cd-burner
  478. - remove Requires: nautilus-cd-burner from -common package
  479. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  480. - totem-gstreamer obsoletes nautilus-media
  481. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  482. - upstream release
  483. - add Requires(post,postun): alternatives for gstreamer,xine
  484. - add Requires(postun,triggers): alternatives for common
  485. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  486. - upstream release
  487. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  488. - build xine backend
  489. - move common files to common package
  490. - move GStreamer related files to gstreamer package
  491. - install xine related files to xine package
  492. - fix scripts
  493. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  494. - upstream release
  495. - update URL
  496. - move *.{a,la} to devel package
  497. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  498. - fix %%{post,preun} script (video-thumbnail.schemas)
  499. - sync with Fedora Core's 1.0.1-1
  500. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  501. - Update to upstream version 1.0.1
  502. - Break out devel package
  503. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  504. - add %%{post,pre}un script
  505. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  506. - initial build for Vine Linux
  507. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  508. - fix %%post
  509. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  510. - Obsolete nautilus-media
  511. - Install property page and thumbnailer
  512. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  513. - Update to 0.101
  514. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  515. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  516. missing menu entry (144088)
  517. - Remove workaround for desktop file being misinstalled, fixed
  518. by above patch
  519. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  520. - New upstream version 0.100
  521. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  522. - update to 0.99.22
  523. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  524. - Add patch to remove removed items from package from help
  525. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  526. - New upstream 0.99.19
  527. - Fixes crasher with CD playback (see NEWS)
  528. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  529. - Call update-desktop-database in post
  530. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  531. - update to 0.99.18
  532. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  533. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>