pandoc-citeproc-vl.spec 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158
  1. %define pkg_name pandoc-citeproc
  2. %define pkg_version 0.14.3.1
  3. %define pkg_release 3%{?_dist_release}
  4. %define pandoc_version 2.2.3.2
  5. Summary: Library and executable for using citeproc with pandoc
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: BSD3
  10. Group: Applications/Text
  11. URL: http://hackage.haskell.org
  12. Source0: packages
  13. Source11: base-orphans-0.8.tar.gz
  14. Source12: base-orphans.cabal
  15. Source13: hs-bibutils-6.6.0.0.tar.gz
  16. Source14: hs-bibutils.cabal
  17. Source15: rfc5051-0.1.0.3.tar.gz
  18. Source16: rfc5051.cabal
  19. Source17: setenv-0.1.1.3.tar.gz
  20. Source18: setenv.cabal
  21. Source19: typed-process-0.2.2.0.tar.gz
  22. Source20: typed-process.cabal
  23. Source21: unliftio-core-0.1.1.0.tar.gz
  24. Source22: unliftio-core.cabal
  25. Source23: vector-algorithms-0.7.0.1.tar.gz
  26. Source24: vector-algorithms.cabal
  27. Source25: xml-types-0.3.6.tar.gz
  28. Source26: xml-types.cabal
  29. Source27: transformers-base-0.4.5.2.tar.gz
  30. Source28: transformers-base.cabal
  31. Source29: resourcet-1.2.1.tar.gz
  32. Source30: resourcet.cabal
  33. Source31: mono-traversable-1.0.9.0.tar.gz
  34. Source32: mono-traversable.cabal
  35. Source33: monad-control-1.0.2.3.tar.gz
  36. Source34: monad-control.cabal
  37. Source35: conduit-1.3.0.3.tar.gz
  38. Source36: conduit.cabal
  39. Source37: yaml-0.9.0.tar.gz
  40. Source38: yaml.cabal
  41. Source39: conduit-extra-1.3.0.tar.gz
  42. Source40: conduit-extra.cabal
  43. Source41: xml-conduit-1.8.0.tar.gz
  44. Source42: xml-conduit.cabal
  45. Source43: pandoc-citeproc-0.14.3.1.tar.gz
  46. Source44: pandoc-citeproc.cabal
  47. BuildRoot: %{_tmppath}/%{pkg_name}-%{version}-root
  48. BuildRequires: ghc haskell-platform
  49. BuildRequires: libffi-devel gmp-devel zlib-devel
  50. BuildRequires: libghc-build-pandoc
  51. BuildRequires: pandoc-libs = %{pandoc_version}
  52. BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
  53. Requires: pandoc = %{pandoc_version}
  54. Vendor: Project Vine
  55. Distribution: Vine Linux
  56. Packager: ara_t
  57. %description
  58. The pandoc-citeproc library exports functions for using the citeproc system
  59. with pandoc. It relies on citeproc-hs, a library for rendering bibliographic
  60. reference citations into a variety of styles using a macro language called
  61. Citation Style Language (CSL).
  62. More details on CSL can be found here: http://citationstyles.org/.
  63. %prep
  64. %{__rm} -rf ${RPM_BUILD_ROOT}
  65. %build
  66. %ghc_pkg_init
  67. cd %{_builddir}
  68. for pkg in `sed '$d' %{SOURCE0}`; do
  69. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  70. pushd ${pkg}
  71. %ghc_fix_dependencies ${pkg}
  72. %{__cabal} configure
  73. %{__cabal} build
  74. %{__cabal} copy
  75. %{__cabal} register --inplace
  76. popd
  77. done
  78. for pkg in `tail -n 1 %{SOURCE0}`; do
  79. %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
  80. pushd ${pkg}
  81. %ghc_fix_dependencies ${pkg}
  82. %cabal_configure1 ${pkg}
  83. %cabal_build
  84. %cabal_haddock
  85. %cabal_copy_resister ${pkg}
  86. popd
  87. done
  88. %install
  89. %{__rm} -rf ${RPM_BUILD_ROOT}%{_libdir}
  90. %{__mv} \
  91. ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/{changelog,README.md} \
  92. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
  93. %{__mv} \
  94. ${RPM_BUILD_ROOT}%{_datadir}/%{name}-%{version}/man \
  95. ${RPM_BUILD_ROOT}%{_datadir}/
  96. %clean
  97. %{__rm} -rf ${RPM_BUILD_ROOT}
  98. %files
  99. %defattr(-, root, root)
  100. %{_bindir}/pandoc-citeproc
  101. %{_datadir}/%{name}-%{version}/
  102. %{_docdir}/%{name}-%{version}/
  103. %{_mandir}/man1/
  104. %changelog
  105. * Thu Aug 09 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-3
  106. - build using ghc-8.4.3-2 and pandoc-2.2.3.2
  107. * Sat Jul 21 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-2
  108. - build using ghc-8.4.3 and pandoc-2.2.2
  109. * Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.14.3.1-1
  110. - update to 0.14.3.1
  111. - rebuild using ghc-8.4.2 and pandoc-2.2.1
  112. - rewrite using macro
  113. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.12.2.5-1
  114. - update to 0.12.2.5
  115. - build using ghc-8.2.2
  116. * Tue Feb 21 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4.1-1
  117. - update to 0.10.4.1
  118. - build using ghc-8.0.2
  119. * Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.10.4-1
  120. - update to 0.10.4
  121. - build using ghc-8.0.1
  122. * Sat Jun 18 2016 Toshiaki Ara <ara_t@384.jp> 0.10-1
  123. - update to 0.10
  124. * Fri May 06 2016 Toshiaki Ara <ara_t@384.jp> 0.9.1.1-1
  125. - new package (devide from pandoc)