cmake-vl.spec 6.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239
  1. # Set to bcond_without or use --with bootstrap if bootstrapping a new release
  2. # or architecture
  3. %bcond_with bootstrap
  4. # Set to bcond_with or use --without gui to disable qt4 gui build
  5. %bcond_without gui
  6. Name: cmake
  7. Summary: Cross-platform make system
  8. Summary(ja): クロスプラットフォームな Make システム
  9. Version: 3.5.2
  10. Release: 1%{?_dist_release}
  11. Group: Development/Tools
  12. License: BSD
  13. URL: http://www.cmake.org/
  14. Source0: http://www.cmake.org/files/v3.5/%{name}-%{version}.tar.gz
  15. Source1: macros.cmake
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: curl-devel
  18. BuildRequires: expat-devel
  19. BuildRequires: gcc-gfortran
  20. BuildRequires: libarchive-devel
  21. BuildRequires: libidn-devel
  22. BuildRequires: ncurses-devel
  23. BuildRequires: openssl-devel
  24. BuildRequires: zlib-devel
  25. BuildRequires: xz-devel
  26. BuildRequires: jsoncpp-devel
  27. %if %{with gui}
  28. BuildRequires: qt4-devel, desktop-file-utils
  29. %define qt_gui --qt-gui
  30. %else
  31. %define qt_gui --no-qt-gui
  32. %endif
  33. Vendor: Project Vine
  34. Distribution: Vine Linux
  35. %description
  36. CMake is used to control the software compilation process using simple
  37. platform and compiler independent configuration files. CMake generates
  38. native makefiles and workspaces that can be used in the compiler
  39. environment of your choice. CMake is quite sophisticated: it is possible
  40. to support complex environments requiring system configuration, pre-processor
  41. generation, code generation, and template instantiation.
  42. %package gui
  43. Summary: Qt GUI for %{name}
  44. Group: Development/Tools
  45. Requires: %{name} = %{version}-%{release}
  46. Requires(post): desktop-file-utils, shared-mime-info
  47. Requires(postun): desktop-file-utils, shared-mime-info
  48. %description gui
  49. The %{name}-gui package contains the Qt based GUI for CMake.
  50. %prep
  51. %setup -q
  52. # Fixup permissions
  53. #find -name \*.h -o -name \*.cxx -print0 | xargs -0 chmod -x
  54. #fix desktop file warning
  55. sed -i 's:\(Icon=\)\(CMakeSetup32.png\):\1/usr/share/pixmaps/\2:' Source/QtDialog/CMake.desktop
  56. %build
  57. ./bootstrap \
  58. --prefix=%{_prefix} \
  59. --datadir=/share/%{name} \
  60. --mandir=/share/man \
  61. --%{?with_bootstrap:no-}system-libs \
  62. %{?qt_gui}
  63. sed -i 's/-lcurses/-lcurses -ltinfo/' Source/CMakeFiles/ccmake.dir/link.txt
  64. %if %{?_dist_release} == "vl5"
  65. sed -i 's/HAVE_SYS_WAIT_H:INTERNAL=/HAVE_SYS_WAIT_H:INTERNAL=1/' CMakeCache.txt
  66. %endif
  67. make VERBOSE=1 %{?_smp_mflags}
  68. %install
  69. rm -rf $RPM_BUILD_ROOT
  70. make install DESTDIR=$RPM_BUILD_ROOT
  71. find $RPM_BUILD_ROOT/%{_datadir}/%{name}/Modules -type f | xargs chmod -x
  72. rm -rf $RPM_BUILD_ROOT/usr/doc
  73. # RPM macros
  74. install -p -m0644 -D %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  75. sed -i -e "s|@@CMAKE_VERSION@@|%{version}|" $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  76. touch -r %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.cmake
  77. %if %{with gui}
  78. # Desktop file
  79. desktop-file-install --delete-original \
  80. --dir=$RPM_BUILD_ROOT%{_datadir}/applications \
  81. $RPM_BUILD_ROOT/%{_datadir}/applications/CMake.desktop
  82. %endif
  83. %clean
  84. rm -rf $RPM_BUILD_ROOT
  85. %if %{with gui}
  86. %post gui
  87. update-desktop-database &> /dev/null || :
  88. update-mime-database %{_datadir}/mime &> /dev/null || :
  89. %postun gui
  90. update-desktop-database &> /dev/null || :
  91. update-mime-database %{_datadir}/mime &> /dev/null || :
  92. %endif
  93. %files
  94. %defattr(-,root,root)
  95. %doc CMakeLogo.gif ChangeLog.* Copyright.txt
  96. %doc Docs/*
  97. %doc Example/
  98. %config(noreplace) %{_sysconfdir}/rpm/macros.cmake
  99. %{_bindir}/ccmake
  100. %{_bindir}/cmake
  101. %{_bindir}/cpack
  102. %{_bindir}/ctest
  103. %{_datadir}/%{name}/
  104. %{_datadir}/aclocal/cmake.m4
  105. %if %{with gui}
  106. %files gui
  107. %defattr(-,root,root,-)
  108. %{_bindir}/cmake-gui
  109. %{_datadir}/applications/CMake.desktop
  110. %{_datadir}/mime/packages/cmakecache.xml
  111. %{_datadir}/icons/hicolor/*/*/*
  112. %endif
  113. %changelog
  114. * Sat May 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.5.2-1
  115. - update to 3.5.2
  116. - add BuildRequires: xz-devel, jsoncpp-devel
  117. - remove old patches
  118. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  119. - update to 2.8.12.2
  120. * Sat Sep 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.2-1
  121. - update to 2.8.12.2
  122. - add Patch2 (cmake-2.8.12.2-ruby-2.2.x.patch)
  123. * Sun Jul 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-2
  124. - rebuild with libarchive-3.1.2
  125. * Mon Dec 23 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.12.1-1
  126. - new upstream release
  127. - add Patch1 (cmake-2.8.12.1-FindFreetype.patch)
  128. * Sun Jul 07 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11.2-1
  129. - new upstream release
  130. * Wed Jun 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.11-1
  131. - new upstream release
  132. * Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.8.10.2-1
  133. - new upstream release
  134. - fixed desktop file warning
  135. * Sun Jun 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.6-2
  136. - rebuild with libarchive-3.0.4
  137. * Sat Nov 19 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.6-1
  138. - new upstream release
  139. - forced to link with libtinfo.so (ccmake)
  140. - used --system-libs again
  141. * Sat Jan 8 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.3-1
  142. - new upstream release
  143. - used --no-system-libs, removed BR: curl-devel, expat-devel, zlib-devel
  144. * Sun Sep 5 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-4
  145. - fixed typo (not --with-system-libs, but --system-libs)
  146. - added BR: curl-devel, expat-devel, zlib-devel
  147. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.8.2-3
  148. - add BuildRequires: ncurses-devel
  149. * Sun Aug 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-2
  150. - generate gui package
  151. - renamed module directory
  152. * Sun Jul 25 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.8.2-1
  153. - new upstream release
  154. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-3
  155. - rebuilt with new toolchain
  156. * Sun Aug 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.6.4-2
  157. - imported RPM macros from Fedora (cmake-2.6.4-3.fc12)
  158. * Tue Aug 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.6.4-1
  159. - new upstream release
  160. - added Vendor/Distribution tag
  161. * Wed Mar 25 2009 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.3-1
  162. - new upstream release
  163. * Tue Oct 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.6.2-1
  164. - new upstream release
  165. * Sat Mar 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.8-1
  166. - new upstream release
  167. * Wed Aug 15 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.7-0vl1
  168. - new upstream release
  169. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.6-0vl1
  170. - new upstream release
  171. - drop Patch100
  172. - use bootstrap script instead of configure
  173. - delete caches from %%doc
  174. * Sat May 12 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.4.3-0vl2
  175. - rebuilt with new toolchain
  176. * Tue Oct 31 2006 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 2.4.3-0vl1
  177. - new upstream release
  178. - delete duped docs
  179. * Fri Oct 13 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.2.3-0vl2
  180. - added Patch100 (especially for ppc to solve ppc/powerpc issue)
  181. * Mon Feb 06 2006 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.2.3-0vl1
  182. - source version up
  183. * Sun Mar 20 2005 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp> 2.0.5-0vl1
  184. - initial build for Vine Linux