perl-XML-DOM-vl.spec 2.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. Name: perl-XML-DOM
  2. Version: 1.44
  3. Release: 8%{?_dist_release}
  4. Summary: DOM extension to XML::Parser
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/XML-DOM/
  8. Source0: http://www.cpan.org/authors/id/T/TJ/TJMATHER/XML-DOM-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  10. BuildArch: noarch
  11. # perl(XML::Parser::PerlSAX)
  12. BuildRequires: perl-libxml-perl
  13. BuildRequires: perl-XML-RegExp
  14. # for testing perl(LWP::UserAgent)
  15. BuildRequires: perl-libwww-perl
  16. Requires: perl-XML-Parser
  17. Requires: perl-libwww-perl
  18. Requires: perl >= %(eval "`%{__perl} -V:version`"; echo $version)
  19. #Obsoletes: perl-libxml-enno <= 1.02
  20. Conflicts: perl-libxml-enno <= 1.02
  21. %description
  22. This is a Perl extension to XML::Parser. It adds a new 'Style' to
  23. XML::Parser, called 'Dom', that allows XML::Parser to build an Object
  24. Oriented datastructure with a DOM Level 1 compliant interface. For a
  25. description of the DOM (Document Object Model), see
  26. http://www.w3.org/DOM/
  27. %prep
  28. %setup -q -n XML-DOM-%{version}
  29. cat <<EOF > %{name}-prov
  30. #!/bin/sh
  31. %{__perl_provides} \$* | grep -v 'perl(XML::XQL::Node)'
  32. EOF
  33. %define __perl_provides %{_builddir}/XML-DOM-%{version}/%{name}-prov
  34. chmod +x %{__perl_provides}
  35. %build
  36. %{__perl} Makefile.PL INSTALLDIRS=vendor
  37. make %{?_smp_mflags}
  38. %install
  39. rm -rf $RPM_BUILD_ROOT
  40. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  41. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  42. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  43. chmod -R u+w $RPM_BUILD_ROOT/*
  44. %check
  45. make test
  46. %clean
  47. rm -rf $RPM_BUILD_ROOT
  48. %files
  49. %defattr(-,root,root,-)
  50. %doc BUGS Changes README
  51. %{perl_vendorlib}/XML/
  52. %{_mandir}/man3/XML::*.3*
  53. %changelog
  54. * Sat May 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-8
  55. - s/Obsoletes/Conflicts/
  56. * Sat Aug 22 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.44-7
  57. - Initial build for Vine Linux
  58. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-6
  59. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  60. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.44-5
  61. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  62. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-4
  63. - Rebuild for perl 5.10 (again)
  64. * Thu Jan 24 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-3
  65. - rebuild for new perl
  66. * Wed Oct 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> - 1.44-2.1
  67. - correct license tag
  68. - add BR: perl(ExtUtils::MakeMaker)
  69. * Thu Jun 29 2006 Orion Poplawski <orion@cora.nwra.com> - 1.44-2
  70. - Bump for new perl version (#196667)
  71. * Sat Nov 5 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-1
  72. - First Fedora Extras release (#172331).
  73. * Thu Oct 27 2005 Ville Skyttä <ville.skytta at iki.fi> - 1.44-0.1
  74. - First build (#128879).