bind-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828829830831832833834835836837838839840841842843844845846847848849850851852853854855856857858859860
  1. %bcond_with systemd
  2. %bcond_with python
  3. %define python_executable %{__python}
  4. %define _localstatedir /var
  5. %define _unpackaged_files_terminate_build 1
  6. %define sname bind
  7. %define pname bind
  8. # example: 9.9.13.P1
  9. %define pversion 9.18.24
  10. # example: 9.9.13-P1
  11. %define sversion 9.18.24
  12. %define bind_epoch 1
  13. # fixed <BTS:VineLinux:1139>
  14. %define old_bind_version 1:9.9.2p2-1vl7
  15. %define bind_uid 25
  16. %define bind_gid 25
  17. %bcond_with readline
  18. Summary: A DNS (Domain Name System) server.
  19. Summary(ja): DNS (Domain Name System) サーバ
  20. Name: %{pname}
  21. Epoch: %{bind_epoch}
  22. Version: %{pversion}
  23. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  24. Group: servers
  25. Vendor: Project Vine
  26. Distribution: Vine Linux
  27. Packager: daisuke
  28. License: ISC and BSD and Public Domain
  29. URL: https://www.isc.org/bind/
  30. Source: https://downloads.isc.org/isc/bind9/%{sversion}/bind-%{sversion}.tar.xz
  31. Source1: bind-manpages.tar.bz2
  32. Source2: named.sysconfig
  33. Source3: named.init
  34. Source4: named.logrotate
  35. Source5: keygen.c
  36. Source42: generate-rndc-key.sh
  37. Source100: named.service
  38. Source101: named-setup-rndc.service
  39. Source102: named.sysconfig.systemd
  40. Source103: bind.tmpfiles.d
  41. Source104: named.conf
  42. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  43. %if %{with python}
  44. BuildRequires: python
  45. BuildRequires: python-rpm-macros
  46. BuildRequires: python-ply
  47. %endif
  48. BuildRequires: openssl-devel glibc-devel libtool
  49. BuildRequires: libxml2-devel
  50. BuildRequires: libcap-devel
  51. %if %{with readline}
  52. BuildRequires: readline-devel
  53. %endif
  54. BuildRequires: libuv-devel
  55. BuildRequires: libnghttp2-devel
  56. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  57. Requires(pre): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  58. Requires(pre): shadow-utils
  59. Requires(post): %{pname}-utils = %{bind_epoch}:%{version}-%{release}
  60. Requires(post): coreutils
  61. %if %{with systemd}
  62. %{?systemd_requires}
  63. %else
  64. Requires(post): chkconfig
  65. Requires(preun): chkconfig
  66. %endif
  67. Conflicts: bind9 <= 9.2.1-0vl5, bind-current
  68. Obsoletes: bind9 <= 9.2.1-0vl5
  69. Obsoletes: bind-current < 1:9.9.4-1
  70. %description
  71. BIND (Berkeley Internet Name Domain) is an implementation of the DNS
  72. (Domain Name System) protocols. BIND includes a DNS server (named),
  73. which resolves host names to IP addresses, and a resolver library
  74. (routines for applications to use when interfacing with DNS). A DNS
  75. server allows clients to name resources or objects and share the
  76. information with other network machines. The named DNS server can be
  77. used on workstations as a caching name server, but is generally only
  78. needed on one machine for an entire network. Note that the
  79. configuration files for making BIND act as a simple caching nameserver
  80. are included in the caching-nameserver package.
  81. Install the bind package if you need a DNS server for your network. If
  82. you want bind to act a caching name server, you will also need to install
  83. the caching-nameserver package.
  84. %package libs
  85. Summary: Libraries used by various DNS packages
  86. Summary(ja): さまざまな DNS パッケージで使用されるライブラリ
  87. Group: system
  88. Obsoletes: bind-current-libs <= %{old_bind_version}
  89. %description libs
  90. Contains libraries used by both the bind server package as well as the utils packages.
  91. %package utils
  92. Summary: Utilities for querying DNS name servers.
  93. Summary(ja): DNS ネームサーバに問い合わせをするユーティリティ
  94. Group: admin-tools
  95. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  96. Conflicts: bind9-utils <= 9.2.1-0vl5
  97. Conflicts: bind-current-utils
  98. Obsoletes: bind9-utils <= 9.2.1-0vl5
  99. Obsoletes: bind-current-utils <= %{old_bind_version}
  100. %description utils
  101. Bind-utils contains a collection of utilities for querying DNS (Domain
  102. Name Service) name servers to find out information about Internet hosts.
  103. These tools will provide you with the IP addresses for given host names,
  104. as well as other information about registered domains and network
  105. addresses.
  106. You should install bind-utils if you need to get information from DNS name
  107. servers.
  108. %package devel
  109. Summary: Include files and libraries needed for bind DNS development.
  110. Summary(ja): bind DNS 開発に必要なインクルードファイルとライブラリ
  111. Group: programming
  112. Requires: %{pname} = %{bind_epoch}:%{version}-%{release}
  113. Requires: %{pname}-libs = %{bind_epoch}:%{version}-%{release}
  114. Conflicts: bind9-devel <= 9.2.1-0vl5
  115. Conflicts: bind-current-devel
  116. Obsoletes: bind9-devel <= 9.2.1-0vl5
  117. Obsoletes: bind-current-devel <= %{old_bind_version}
  118. %description devel
  119. The bind-devel package contains all the include files and the
  120. library required for DNS (Domain Name Service) development for
  121. BIND versions 9.x.x.
  122. You should install bind-devel if you want to develop bind DNS
  123. applications. If you install bind-devel, you'll also need to install
  124. bind.
  125. #'
  126. %debug_package
  127. %prep
  128. %setup -n bind-%{sversion} -q
  129. perl -pi -e 's/^(SUBDIRS =.+)dlzexternal(.+)$/\1\2/' bin/tests/system/Makefile.in
  130. %build
  131. CFLAGS="$CFLAGS $RPM_OPT_FLAGS"
  132. CPPFLAGS="$CPPFLAGS -DOPENSSL_API_COMPAT=10100"
  133. export CFLAGS CPPFLAGS
  134. export STD_CDEFINES="$CPPFLAGS"
  135. autoreconf -vif
  136. %configure \
  137. --with-libtool \
  138. --with-openssl=/usr \
  139. %if %{without readline}
  140. --without-readline \
  141. %endif
  142. --disable-openssl-version-ceck \
  143. --enable-threads \
  144. --enable-ipv6 \
  145. --with-pic \
  146. --with-dlz-dlopen \
  147. %if %{with python}
  148. --with-python=%{python_executable} \
  149. %else
  150. --with-python=no \
  151. %endif
  152. --enable-filter-aaaa \
  153. --enable-fixed-rrset
  154. make %{?_smp_mflags}
  155. %install
  156. rm -rf %{buildroot}
  157. # Build directory hierarchy
  158. mkdir -p %{buildroot}%{_sysconfdir}/{logrotate.d,sysconfig}
  159. mkdir -p %{buildroot}%{_libdir}/{bind,named}
  160. mkdir -p %{buildroot}%{_localstatedir}/named/{slaves,data,dynamic}
  161. mkdir -p %{buildroot}%{_mandir}/{man1,man5,man8}
  162. mkdir -p %{buildroot}/var/run/named
  163. mkdir -p %{buildroot}/run/named
  164. mkdir -p %{buildroot}%{_localstatedir}/log
  165. make DESTDIR=%{buildroot} install
  166. install -c -m 644 %SOURCE4 %{buildroot}%{_sysconfdir}/logrotate.d/named
  167. touch %{buildroot}%{_sysconfdir}/rndc.{key,conf}
  168. gcc %{optflags} -o %{buildroot}/usr/sbin/dns-keygen %{SOURCE5}
  169. cd %{buildroot}%{_mandir}
  170. tar xjf %{SOURCE1}
  171. # newer version is contained in source
  172. rm -f man5/named.conf.5.gz
  173. install -m 644 %{SOURCE104} %{buildroot}%{_sysconfdir}/named.conf
  174. %if %{with systemd}
  175. # Systemd unit files
  176. mkdir -p %{buildroot}%{_unitdir}
  177. install -m 644 %{SOURCE100} %{buildroot}%{_unitdir}
  178. install -m 644 %{SOURCE101} %{buildroot}%{_unitdir}
  179. install -m 644 %{SOURCE102} %{buildroot}%{_sysconfdir}/sysconfig/named
  180. mkdir -p %{buildroot}%{_tmpfilesdir}
  181. install -m 644 %{SOURCE103} %{buildroot}%{_tmpfilesdir}/named.conf
  182. mkdir -p %{buildroot}%{_libexecdir}
  183. install -m 755 %{SOURCE42} %{buildroot}%{_libexecdir}/generate-rndc-key.sh
  184. %else
  185. mkdir -p %{buildroot}%{_sysconfdir}/rc.d/init.d
  186. install -c -m 755 %SOURCE3 %{buildroot}%{_sysconfdir}/rc.d/init.d/named
  187. cp %{SOURCE2} %{buildroot}%{_sysconfdir}/sysconfig/named
  188. %endif
  189. pushd ${RPM_BUILD_ROOT}%{_sbindir}
  190. # Compatibility with previous major versions, only for selected binaries
  191. for BIN in named-checkconf named-checkzone named-compilezone
  192. do
  193. ln -s ../bin/$BIN $BIN
  194. done
  195. popd
  196. rm -f %{buildroot}%{_libdir}/*.la
  197. %clean
  198. rm -rf %{buildroot} ${RPM_BUILD_DIR}/%{name}-%{version}
  199. %pre
  200. if [ "$1" -eq 1 ]; then
  201. /usr/sbin/groupadd -g %{bind_gid} -f -r named >/dev/null 2>&1 || :;
  202. /usr/sbin/useradd -u %{bind_uid} -r -N -M -g named -s /sbin/nologin -d /var/named -c Named named >/dev/null 2>&1 || :;
  203. fi;
  204. :;
  205. %post
  206. /sbin/ldconfig
  207. if [ "$1" -eq 1 ]; then
  208. if [ ! -e /etc/rndc.key ]; then
  209. /usr/sbin/rndc-confgen -a > /dev/null 2>&1
  210. fi
  211. [ -x /sbin/restorecon ] && /sbin/restorecon /etc/rndc.* /etc/named.* >/dev/null 2>&1 ;
  212. # rndc.key has to have correct perms and ownership, CVE-2007-6283
  213. [ -e /etc/rndc.key ] && chown root:named /etc/rndc.key
  214. [ -e /etc/rndc.key ] && chmod 0640 /etc/rndc.key
  215. # Check DNSSEC settings if this is a fresh install
  216. if [ -r /etc/sysconfig/dnssec ]; then
  217. . /etc/sysconfig/dnssec
  218. [ -x /usr/sbin/dnssec-configure ] && \
  219. dnssec-configure -b --norestart --dnssec="$DNSSEC" --dlv="$DLV" > \
  220. /dev/null 2>&1
  221. fi;
  222. fi
  223. %if %{with systemd}
  224. %systemd_post named.service
  225. %else
  226. if [ "$1" -eq 1 ]; then
  227. /sbin/chkconfig --add named
  228. fi
  229. %endif
  230. :;
  231. %preun
  232. %if %{with systemd}
  233. # Package removal, not upgrade
  234. %systemd_preun named.service
  235. %else
  236. if [ "$1" -eq 0 -o -x /sbin/systemctl ]; then
  237. /sbin/service named stop >/dev/null 2>&1 || :
  238. /sbin/chkconfig --del named ||:
  239. fi
  240. %endif
  241. exit 0
  242. %postun
  243. %if %{with systemd}
  244. # Package upgrade, not uninstall
  245. %systemd_postun_with_restart named.service
  246. %else
  247. if [ "$1" -ge 1 ]; then
  248. %{_sysconfdir}/rc.d/init.d/named condrestart >/dev/null 2>&1 || :
  249. fi
  250. %endif
  251. exit 0
  252. %triggerpostun -- bind < 8.2.2_P5-15
  253. /sbin/chkconfig --add named
  254. %triggerpostun -- bind-current < 1:9.9.4-1
  255. /sbin/chkconfig --add named
  256. %files
  257. %defattr(-,root,root)
  258. %license COPYRIGHT
  259. %doc CHANGES README*
  260. %doc doc/arm doc/misc
  261. %config(noreplace) %{_sysconfdir}/named.conf
  262. %config(noreplace) %{_sysconfdir}/logrotate.d/named
  263. %if %{with systemd}
  264. %{_unitdir}/named.service
  265. %{_unitdir}/named-setup-rndc.service
  266. %{_libexecdir}/generate-rndc-key.sh
  267. %{_tmpfilesdir}/named.conf
  268. %else
  269. %config %{_sysconfdir}/rc.d/init.d/named
  270. %attr(-,named,named) %dir %{_var}/run/named
  271. %endif
  272. %config(noreplace) %{_sysconfdir}/sysconfig/named
  273. %ghost %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.conf
  274. %ghost %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/rndc.key
  275. %config(noreplace) %attr(0640,root,named) %{_sysconfdir}/bind.keys
  276. %attr(-,named,named) %dir %{_var}/named
  277. %attr(-,named,named) %dir %{_var}/named/data
  278. %{_bindir}/dnssec-*
  279. %{_bindir}/named-journalprint
  280. %{_bindir}/named-checkconf
  281. %{_bindir}/named-checkzone
  282. %{_bindir}/named-compilezone
  283. %{_bindir}/nsec3hash
  284. %{_sbindir}/ddns-confgen
  285. %{_sbindir}/dns-keygen
  286. %{_sbindir}/named
  287. %{_sbindir}/rndc*
  288. %{_sbindir}/named-checkconf
  289. %{_sbindir}/named-checkzone
  290. %{_sbindir}/named-compilezone
  291. %{_sbindir}/tsig-keygen
  292. %dir %{_libdir}/named
  293. %dir %{_libdir}/bind
  294. %{_libdir}/bind/filter*.so
  295. %exclude %{_libdir}/bind/filter*.la
  296. %if %{with python}
  297. %{python_sitelib}/*
  298. %endif
  299. %{_mandir}/man1/dnssec-*.1*
  300. %{_mandir}/man1/named-checkconf.1*
  301. %{_mandir}/man1/named-checkzone.1*
  302. %{_mandir}/man1/named-compilezone.1*
  303. %{_mandir}/man1/named-journalprint.1*
  304. %{_mandir}/man1/nsec3hash.1*
  305. %{_mandir}/man5/resolv.conf.5*
  306. %{_mandir}/man5/named.conf.5*
  307. %{_mandir}/man5/rndc.conf.5*
  308. %{_mandir}/man8/rndc.8*
  309. %{_mandir}/man8/named.8*
  310. %{_mandir}/man8/filter-*.8*
  311. %{_mandir}/man8/rndc-confgen.8*
  312. %{_mandir}/man8/ddns-confgen.8*
  313. %{_mandir}/man8/tsig-keygen.8*
  314. %files libs
  315. %defattr(-,root,root)
  316. %{_libdir}/*-%{version}.so
  317. %files utils
  318. %defattr(-,root,root)
  319. %{_bindir}/arpaname
  320. %{_bindir}/delv
  321. %{_bindir}/dig
  322. %{_bindir}/host
  323. %{_bindir}/mdig
  324. %{_bindir}/named-rrchecker
  325. %{_bindir}/nslookup
  326. %{_bindir}/nsupdate
  327. %{_mandir}/man1/arpaname.1*
  328. %{_mandir}/man1/delv.1*
  329. %{_mandir}/man1/dig.1*
  330. %{_mandir}/man1/host.1*
  331. %{_mandir}/man1/mdig.1*
  332. %{_mandir}/man1/named-rrchecker.1*
  333. %{_mandir}/man1/nslookup.1*
  334. %{_mandir}/man1/nsupdate.1*
  335. %{_mandir}/man5/resolver.5*
  336. %{_mandir}/man8/nslookup.8*
  337. %files devel
  338. %defattr(-,root,root)
  339. %{_libdir}/*.so
  340. %exclude %{_libdir}/*-%{version}.so
  341. %{_includedir}/*
  342. %changelog
  343. * Mon Feb 19 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.18.24-1
  344. - updated to 9.18.24.
  345. * Sat Sep 23 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.16.44-1
  346. - updated to 9.16.44.
  347. * Sat Sep 24 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.16.33-1
  348. - updated to 9.16.33.
  349. * Thu Nov 04 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.16.22-1
  350. - updated to 9.16.22.
  351. * Sat Oct 16 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.16.21-1
  352. - updated to 9.16.21.
  353. - built with openssl-3.0.0.
  354. * Tue Aug 31 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.16.20-1
  355. - updated to 9.16.20.
  356. * Fri May 14 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.31-1
  357. - updated to 9.11.31.
  358. * Sat Feb 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.28-1
  359. - updated to 9.11.28.
  360. * Thu Sep 03 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.22-1
  361. - updated to 9.11.22.
  362. * Fri Jul 10 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-2
  363. - added systemd support (disabled as default).
  364. * Thu Jul 02 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.20-1
  365. - updated to 9.11.20.
  366. * Sat Nov 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.12-1
  367. - updated to 9.11.12.
  368. * Wed Oct 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.11-1
  369. - updated to 9.11.11.
  370. * Sun Dec 02 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.11.5-1
  371. - updated to 9.11.5 (new ESV).
  372. - updated Patch1.
  373. * Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.13.P1-1
  374. - updated to 9.9.13.P1.
  375. - updated Patch1.
  376. * Thu Apr 13 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P8-1
  377. - update to 9.9.9.P8
  378. * Sun Feb 19 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 9.9.9.P6-1
  379. - new upstream release.
  380. * Thu Nov 03 2016 Daisuke SUZUKI <daisuke@vinelinux.org> 9.9.9.P4-1
  381. - new upstream release.
  382. * Mon Aug 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.9.9.P2-1
  383. - new upstream release.
  384. * Mon Mar 14 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P4-1
  385. - new upstream release with secrity fix (CVE-2016-1285,1286)
  386. - built with openssl 1.0.2g
  387. * Wed Jan 20 2016 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.8.P3-1
  388. - new upstream release with secrity fix (CVE-2015-4620)
  389. * Thu Jul 9 2015 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.9.7.P1-1
  390. - new upstream release with secrity fix (CVE-2015-4620)
  391. * Mon Mar 23 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-2
  392. - rebuilt without readline to avoid GPL infection
  393. * Fri Feb 27 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P2-1
  394. - new upstream release with secrity fix (CVE-2015-1349)
  395. - added BR: readline-devel
  396. * Fri Feb 6 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 9.9.6.P1-3
  397. - new upstream release with secrity fix (CVE-2014-8500)
  398. - used "3" as release number because of being newer than Vine Linux/6 updates
  399. * Tue Oct 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.4-1
  400. - update to 9.9.4(ESV)
  401. * Thu Mar 28 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 9.9.2p2-1
  402. - update to 9.9.2-P2
  403. - remove .la
  404. - remove Conflicts/Obsoletes from libs subpackage.
  405. - add configure options
  406. --enable-ipv6 --with-pic --enable-filter-aaaa --enable-fixed-rrset
  407. * Tue Dec 18 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 9.8.4p1-1
  408. - new upstream release.
  409. - added an option "--with-dlz-dlopen".
  410. * Tue May 31 2011 IWAI, Masaharu <iwai@alib.jp> 9.8.0p2-2
  411. - Obosoletes: bind.* < 1:9.6.ESV.R1
  412. - fixed <BTS:VineLinux:1139>
  413. * Sun May 29 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p2-1
  414. - new upstream release with security fix (CVE-2011-1910)
  415. * Tue May 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.8.0p1-2
  416. - add BuildRequires: libxml2-devel, libcap-devel
  417. * Mon May 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.8.0p1-1
  418. - new upstream release with security fix (CVE-2011-1907)
  419. - fix changelog typo
  420. * Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-2
  421. - Obosoletes: bind.* < 1:9.6.ESV.R1
  422. * Thu Apr 07 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 9.8.0-1
  423. - update to 9.8.0
  424. - remove Provides: bind.* = %%{bind_epoch}:%{version}-%{release}
  425. * Mon Jan 10 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 9.7.2P2-3
  426. - rebuild with openssl-1.0.0c
  427. * Sun Oct 24 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-2
  428. - fix Req: in bind package
  429. * Wed Oct 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.7.2P2-1
  430. - change package name bind -> bind-current
  431. - add epoch 1
  432. - new upstream release
  433. * Sat Jul 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 9.7.1P2-1
  434. - new upstream release
  435. * Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 9.6.1P3-4
  436. - rebuilt with gcc-4.4.3-3 on ppc
  437. * Sat Feb 6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 9.6.1P3-3
  438. - rebuilt with new toolchains (for VineSeed)
  439. - s/BuildPrereq/BuildRequires/
  440. * Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-2
  441. - add man1/isc-config.sh.1 into devel file list
  442. * Wed Jan 20 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P3-1
  443. - new upstream release with security fix (CVE-2009-4022, 2010-0097)
  444. * Sat Dec 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P2-1
  445. - new upstream release with security fix (CVE-2009-4022)
  446. * Wed Jul 29 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.6.1P1-1
  447. - new upstream release with security fix
  448. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.1-1
  449. - new upstream release
  450. - clean up %%post/%%pre scriptlet
  451. - create named user and group in %%pre
  452. - don't remove named user/group in %%preun
  453. - use rndc-confgen to create rndc.key
  454. * Thu Apr 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 9.6.0P1-1
  455. - new upstream release
  456. - drop patch0 and patch14, merged in upstream
  457. * Sun Jan 11 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.5.1P1-1
  458. - new upstream release with security fix
  459. * Wed Jul 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 9.5.0P1-1
  460. - new upstream release with security fix
  461. - new versioning policy
  462. * Sun Sep 30 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1P1-0vl1
  463. - new upstream release with security fix
  464. * Fri May 18 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 9.4.1-0vl1
  465. - new upstream release
  466. - build with new openssl/toolchain
  467. * Tue Jan 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.4-0vl1
  468. - new upstream release with security fix
  469. * Fri Nov 03 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2P2-0vl1
  470. - new upstream release
  471. * Fri Sep 08 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl2
  472. - add Prereq sed
  473. * Wed Sep 06 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 9.3.2P1-0vl1
  474. - new upstream release for security fix (CVE-2006-4095,4096)
  475. * Wed Feb 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 9.3.2-0vl3
  476. - separate -libs package
  477. - remove old named.conf.5.gz
  478. - newer version is contained in source
  479. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl2
  480. - add bsdcompat patch (Patch4)
  481. - add fix_h_errno patch from FC
  482. - h_errno not being accessed / set correctly in libbind
  483. * Thu Feb 09 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 9.3.2-0vl1
  484. - new upstream release
  485. * Sun Nov 7 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 9.2.4-0vl2
  486. - added PreReq to bind-utils (see: [VineSeed:09555])
  487. * Thu Oct 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.4-0vl1
  488. - new upstream release
  489. * Wed Nov 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl3
  490. - fix /etc/init.d/named to use rndc
  491. * Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl2
  492. - rebuild to remove unneeded dependancy
  493. * Mon Nov 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.3-0vl1
  494. - new upstream release
  495. * Tue Mar 4 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.2-0vl1
  496. - new upstream release
  497. * Thu Nov 28 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl7
  498. - fix dependancies.
  499. * Wed Nov 27 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl6
  500. - add obsoletes: and conflicts: to bind9, bind9-utils, bind9-devel <= 9.2.1-0vl5
  501. - change package name to bind for VineSeed.
  502. - use more macros.
  503. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl5
  504. - fixed some macros
  505. - add conflicts: to bind-* in bind9-devel and bind9-utils
  506. - add provides: bind = %%{version}
  507. * Sat Oct 19 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 9.2.1-0vl4
  508. - use %%configure macros
  509. * Sat Oct 19 2002 Michihide Hotta <hotta@net-newbie.com> 9.2.1-0vl3
  510. - fixed inconsistent dependency
  511. * Wed Aug 14 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl2
  512. - updated to 9.2.2rc1
  513. * Thu May 02 2002 Satoshi MACHINO <machino@vinelinux.org> 9.2.1-0vl0
  514. - updated to bind9(9.2.1), test packages ;)
  515. -- based on Rawhide's bind-9.2.0-8
  516. -- changed name bind9
  517. -- added Conflicts: bind
  518. * Sun Feb 03 2002 Toru Sagami <sagami@vinelinux.org> 8.3.1-0vl1
  519. - release 8.3.1 includes security fixes
  520. * Mon Jan 14 2002 Toru Sagami <sagami@vinelinux.org> 8.3.0-0vl1
  521. - Upgraded to current stable release 8.3.0
  522. * Mon Oct 8 2001 <zn@mbf.nifty.com>
  523. - 8.2.5-0vl0: Upgraded to new upstream version.
  524. * Thu May 24 2001 <sagami@vinelinux.org>
  525. - 8.2.4-0vl1: eliminate CVS related files from %%doc
  526. * Thu May 17 2001 <sagami@vinelinux.org>
  527. - 8.2.4-0vl0
  528. * Fri Feb 02 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  529. - 8.2.3-1vl2
  530. - built on VineSeed
  531. * Tue Jan 30 2001 KAJIKI Yoshihiro <kajiki@ylug.org>
  532. - add doc/old
  533. - build for Vine 2.1
  534. * Sat Jan 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  535. - 8.2.3, fixes several security problems
  536. * Tue Nov 14 2000 Bill Nottingham <notting@redhat.com>
  537. - static libraries may be used in shared objects. Build with -fPIC on ia64
  538. * Fri Nov 10 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  539. - 8.2.2-P7 (fixes Bug #20546)
  540. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  541. - condrestart fixes
  542. * Tue Jul 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  543. - change the init script to take condrestart, not cond-restart
  544. - add sh-utils, /bin/cat, perl, /bin/chmod, /usr/sbin/useradd as prereqs for
  545. the %pre and %post scripts
  546. * Sun Jul 16 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  547. - Don't prereq /etc/init.d
  548. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  549. - move initscript back
  550. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  551. - automatic rebuild
  552. * Sun Jul 9 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  553. - add "exit 0" for uninstall case
  554. * Fri Jul 7 2000 Florian La Roche <Florian.LaRoche@redhat.de>
  555. - add prereq init.d and cleanup install section
  556. * Fri Jun 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  557. - fix the init script
  558. * Wed Jun 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  559. - make libbind.a and nslookup.help readable again by setting INSTALL_LIB to ""
  560. * Mon Jun 26 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  561. - Fix up the initscript (Bug #13033)
  562. - Fix build with current glibc (Bug #12755)
  563. - /etc/rc.d/init.d -> /etc/init.d
  564. - use %%{_mandir} rather than /usr/share/man
  565. * Mon Jun 19 2000 Bill Nottingham <notting@redhat.com>
  566. - fix conflict with man-pages
  567. - remove compatibilty chkconfig links
  568. - initscript munging
  569. * Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
  570. - modify logrotate setup to use PID file
  571. - temporarily disable optimization by unsetting $RPM_OPT_FLAGS at build-time
  572. - actually bump the release this time
  573. * Sun Jun 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  574. - FHS compliance
  575. * Mon Apr 17 2000 Nalin Dahyabhai <nalin@redhat.com>
  576. - clean up restart patch
  577. * Mon Apr 10 2000 Nalin Dahyabhai <nalin@redhat.com>
  578. - provide /var/named (fix for bugs #9847, #10205)
  579. - preserve args when restarted via ndc(8) (bug #10227)
  580. - make resolv.conf(5) a link to resolver(5) (bug #10245)
  581. - fix SYSTYPE bug in all makefiles
  582. - move creation of named user from %%post into %%pre
  583. * Mon Feb 28 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  584. - Fix TTL (patch from ISC, Bug #9820)
  585. * Wed Feb 16 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
  586. - fix typo in spec (it's %post, without a leading blank) introduced in -6
  587. - change SYSTYPE to linux
  588. * Fri Feb 11 2000 Bill Nottingham <notting@redhat.com>
  589. - pick a standard < 100 uid/gid for named
  590. * Fri Feb 04 2000 Elliot Lee <sopwith@redhat.com>
  591. - Pass named a '-u named' parameter by default, and add/remove user.
  592. * Thu Feb 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  593. - fix host mx bug (Bug #9021)
  594. * Mon Jan 31 2000 Cristian Gafton <gafton@redhat.com>
  595. - rebuild to fix dependencies
  596. - man pages are compressed
  597. * Wed Jan 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  598. - It's /usr/bin/killall, not /usr/sbin/killall (Bug #8063)
  599. * Mon Jan 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  600. - Fix up location of named-bootconf.pl and make it executable
  601. (Bug #8028)
  602. - bind-devel requires bind
  603. * Mon Nov 15 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  604. - update to 8.2.2-P5
  605. * Wed Nov 10 1999 Bill Nottingham <notting@redhat.com>
  606. - update to 8.2.2-P3
  607. * Tue Oct 12 1999 Cristian Gafton <gafton@redhat.com>
  608. - add patch to stop a cache only server from complaining about lame servers
  609. on every request.
  610. * Fri Sep 24 1999 Preston Brown <pbrown@redhat.com>
  611. - use real stop and start in named.init for restart, not ndc restart, it has
  612. problems when named has changed during a package update... (# 4890)
  613. * Fri Sep 10 1999 Bill Nottingham <notting@redhat.com>
  614. - chkconfig --del in %preun, not %postun
  615. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  616. - initscript munging
  617. * Mon Jul 26 1999 Bill Nottingham <notting@redhat.com>
  618. - fix installed chkconfig links to match init file
  619. * Sat Jul 3 1999 Jeff Johnson <jbj@redhat.com>
  620. - conflict with new (in man-1.24) man pages (#3876,#3877).
  621. * Tue Jun 29 1999 Bill Nottingham <notting@redhat.com>
  622. - fix named.logrotate (wrong %SOURCE)
  623. * Fri Jun 25 1999 Jeff Johnson <jbj@redhat.com>
  624. - update to 8.2.1.
  625. - add named.logrotate (#3571).
  626. - hack around egcs-1.1.2 -m486 bug (#3413, #3485).
  627. - vet file list.
  628. * Fri Jun 18 1999 Bill Nottingham <notting@redhat.com>
  629. - don't run by default
  630. * Sun May 30 1999 Jeff Johnson <jbj@redhat.com>
  631. - nslookup fixes (#2463).
  632. - missing files (#3152).
  633. * Sat May 1 1999 Stepan Kasal <kasal@math.cas.cz>
  634. - nslookup patched:
  635. to count numRecords properly
  636. to fix subsequent calls to ls -d
  637. to parse "view" and "finger" commands properly
  638. the view hack updated for bind-8 (using sed)
  639. * Wed Mar 31 1999 Bill Nottingham <notting@redhat.com>
  640. - add ISC patch
  641. - add quick hack to make host not crash
  642. - add more docs
  643. * Fri Mar 26 1999 Cristian Gafton <gafton@redhat.com>
  644. - add probing information in the init file to keep linuxconf happy
  645. - dont strip libbind
  646. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  647. - auto rebuild in the new build environment (release 3)
  648. * Wed Mar 17 1999 Preston Brown <pbrown@redhat.com>
  649. - removed 'done' output at named shutdown.
  650. * Tue Mar 16 1999 Cristian Gafton <gafton@redhat.com>
  651. - version 8.2
  652. * Wed Dec 30 1998 Cristian Gafton <gafton@redhat.com>
  653. - patch to use the __FDS_BITS macro
  654. - build for glibc 2.1
  655. * Wed Sep 23 1998 Jeff Johnson <jbj@redhat.com>
  656. - change named.restart to /usr/sbin/ndc restart
  657. * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
  658. - install man pages correctly.
  659. - change K10named to K45named.
  660. * Wed Aug 12 1998 Jeff Johnson <jbj@redhat.com>
  661. - don't start if /etc/named.conf doesn't exist.
  662. * Sat Aug 8 1998 Jeff Johnson <jbj@redhat.com>
  663. - autmagically create /etc/named.conf from /etc/named.boot in %post
  664. - remove echo in %post
  665. * Wed Jun 10 1998 Jeff Johnson <jbj@redhat.com>
  666. - merge in 5.1 mods
  667. * Sun Apr 12 1998 Manuel J. Galan <manolow@step.es>
  668. - Several essential modifications to build and install correctly.
  669. - Modified 'ndc' to avoid deprecated use of '-'
  670. * Mon Dec 22 1997 Scott Lampert <fortunato@heavymetal.org>
  671. - Used buildroot
  672. - patched bin/named/ns_udp.c to use <libelf/nlist.h> for include
  673. on Redhat 5.0 instead of <nlist.h>